Bug 230222 - Plasma crashes after Kopete crashes
Summary: Plasma crashes after Kopete crashes
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-10 17:53 UTC by Alexis Kauffmann
Modified: 2010-03-10 18:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexis Kauffmann 2010-03-10 17:53:04 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
There are many reports of this bug, I don't know which one is the duplicate as the human descriptions do not really match what happened here. Kopete crashes, then Plasma, no other program stops responding. Google Desktop Search icon is undocked from the desktop panel. When I close the little floating box with Google Desktop's icon, it reappears where it was meant to.

 -- Backtrace:
Application: Espaço de trabalho do Plasma (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x00eff266 in QString (this=0x15, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#7  KIconEffect::fingerprint (this=0x15, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#8  0x00f0c724 in KIconLoader::loadIcon (this=0x9afd5b0, _name=..., group=KIconLoader::Desktop, size=21, state=0, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#9  0x00f03bb8 in KIconEngine::actualSize (this=0xa941270, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:80
#10 0x072c3ea6 in QIcon::actualSize (this=0xa894c1c, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:700
#11 0x06115c43 in Plasma::IconWidgetPrivate::decoration (this=0xa894ba0, option=0x9541e28, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#12 0x06117877 in Plasma::IconWidget::paint (this=0xa895c50, painter=0xbfb50cac, option=0x9541e28, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1013
#13 0x0789702c in _q_paintItem (item=<value optimized out>, painter=<value optimized out>, option=0x9541e28, widget=0x0, useWindowOpacity=false, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4243
#14 0x07899c1a in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x9541e28, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4281
#15 0x078b36c0 in QGraphicsScenePrivate::drawItemHelper (this=0x9541cc8, item=0xa895c58, painter=0xbfb52ad4, option=0x9541e28, widget=0xa2571f0, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4574
#16 0x078b40e4 in QGraphicsScenePrivate::draw (this=0x9541cc8, item=0xa895c58, painter=0xbfb52ad4, viewTransform=0xbfb5290c, transformPtr=0xbfb51690, exposedRegion=0x9fa8744, widget=0xa2571f0, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4827
#17 0x078b4d6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9541cc8, item=0xa895c58, painter=0xbfb52ad4, viewTransform=0xbfb5290c, exposedRegion=0x9fa8744, widget=0xa2571f0, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#18 0x078b4174 in QGraphicsScenePrivate::draw (this=0x9541cc8, item=0x99c5650, painter=0xbfb52ad4, viewTransform=0xbfb5290c, transformPtr=0xbfb51b90, exposedRegion=0x9fa8744, widget=0xa2571f0, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#19 0x078b4d6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9541cc8, item=0x99c5650, painter=0xbfb52ad4, viewTransform=0xbfb5290c, exposedRegion=0x9fa8744, widget=0xa2571f0, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#20 0x078b4174 in QGraphicsScenePrivate::draw (this=0x9541cc8, item=0x99c0418, painter=0xbfb52ad4, viewTransform=0xbfb5290c, transformPtr=0xbfb52090, exposedRegion=0x9fa8744, widget=0xa2571f0, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#21 0x078b4d6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9541cc8, item=0x99c0418, painter=0xbfb52ad4, viewTransform=0xbfb5290c, exposedRegion=0x9fa8744, widget=0xa2571f0, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#22 0x078b4174 in QGraphicsScenePrivate::draw (this=0x9541cc8, item=0x996e678, painter=0xbfb52ad4, viewTransform=0xbfb5290c, transformPtr=0xbfb52590, exposedRegion=0x9fa8744, widget=0xa2571f0, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#23 0x078b4d6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9541cc8, item=0x996e678, painter=0xbfb52ad4, viewTransform=0xbfb5290c, exposedRegion=0x9fa8744, widget=0xa2571f0, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#24 0x078b573e in QGraphicsScenePrivate::drawItems (this=0x9541cc8, painter=0xbfb52ad4, viewTransform=0xbfb5290c, exposedRegion=0x9fa8744, widget=0xa2571f0) at graphicsview/qgraphicsscene.cpp:4619
#25 0x078cfcab in QGraphicsView::paintEvent (this=0xa252280, event=0xbfb531f4) at graphicsview/qgraphicsview.cpp:3393
#26 0x02245d99 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#27 0x072605d6 in QWidget::event (this=0xa252280, event=0xbfb531f4) at kernel/qwidget.cpp:8144
#28 0x0765c733 in QFrame::event (this=0xa252280, e=0xbfb531f4) at widgets/qframe.cpp:557
#29 0x076f69b2 in QAbstractScrollArea::viewportEvent (this=0x0, e=0x15) at widgets/qabstractscrollarea.cpp:1036
#30 0x078cc12b in QGraphicsView::viewportEvent (this=0xa252280, event=0xbfb531f4) at graphicsview/qgraphicsview.cpp:2787
#31 0x076f92a5 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9b039d0, o=0xa2571f0, e=0xbfb531f4) at widgets/qabstractscrollarea_p.h:100
#32 QAbstractScrollAreaFilter::eventFilter (this=0x9b039d0, o=0xa2571f0, e=0xbfb531f4) at widgets/qabstractscrollarea_p.h:116
#33 0x02585e8a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x94b2978, receiver=0xa2571f0, event=0xbfb531f4) at kernel/qcoreapplication.cpp:819
#34 0x072023a9 in QApplicationPrivate::notify_helper (this=0x94b2978, receiver=0xa2571f0, e=0xbfb531f4) at kernel/qapplication.cpp:4296
#35 0x072090b9 in QApplication::notify (this=0x94c1af0, receiver=0xa2571f0, e=0xbfb531f4) at kernel/qapplication.cpp:4265
#36 0x00f4942a in KApplication::notify (this=0x94c1af0, receiver=0xa2571f0, event=0xbfb531f4) at ../../kdeui/kernel/kapplication.cpp:302
#37 0x02586beb in QCoreApplication::notifyInternal (this=0x94c1af0, receiver=0xa2571f0, event=0xbfb531f4) at kernel/qcoreapplication.cpp:704
#38 0x072698e6 in QCoreApplication::sendSpontaneousEvent (this=0x9fbaed0, pdev=0xa190774, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9fbb778)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#39 QWidgetPrivate::drawWidget (this=0x9fbaed0, pdev=0xa190774, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9fbb778) at kernel/qwidget.cpp:5339
#40 0x0726a725 in QWidgetPrivate::paintSiblingsRecursive (this=0x9fa83e0, pdev=0xa190774, siblings=..., index=7, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9fbb778)
    at kernel/qwidget.cpp:5452
#41 0x0726a55e in QWidgetPrivate::paintSiblingsRecursive (this=0x9fa83e0, pdev=0xa190774, siblings=..., index=8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9fbb778)
    at kernel/qwidget.cpp:5439
#42 0x0726a55e in QWidgetPrivate::paintSiblingsRecursive (this=0x9fa83e0, pdev=0xa190774, siblings=..., index=9, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9fbb778)
    at kernel/qwidget.cpp:5439
#43 0x0726a55e in QWidgetPrivate::paintSiblingsRecursive (this=0x9fa83e0, pdev=0xa190774, siblings=..., index=10, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9fbb778)
    at kernel/qwidget.cpp:5439
#44 0x0726a55e in QWidgetPrivate::paintSiblingsRecursive (this=0x9fa83e0, pdev=0xa190774, siblings=..., index=11, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9fbb778)
    at kernel/qwidget.cpp:5439
#45 0x07269635 in QWidgetPrivate::drawWidget (this=0x9fa83e0, pdev=0xa190774, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9fbb778) at kernel/qwidget.cpp:5388
#46 0x0743ff00 in QWidgetBackingStore::sync (this=0x9fbb778) at painting/qbackingstore.cpp:1291
#47 0x07259a93 in QWidgetPrivate::syncBackingStore (this=0x9fa83e0) at kernel/qwidget.cpp:1672
#48 0x07260d96 in QWidget::event (this=0xa252280, event=0xa91f210) at kernel/qwidget.cpp:8291
#49 0x0765c733 in QFrame::event (this=0xa252280, e=0xa91f210) at widgets/qframe.cpp:557
#50 0x076f73c7 in QAbstractScrollArea::event (this=0xa252280, e=0xa91f210) at widgets/qabstractscrollarea.cpp:989
#51 0x078ce2d6 in QGraphicsView::event (this=0xa252280, event=0xa91f210) at graphicsview/qgraphicsview.cpp:2666
#52 0x02246583 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#53 0x072023cc in QApplicationPrivate::notify_helper (this=0x94b2978, receiver=0xa91f210, e=0xa252280) at kernel/qapplication.cpp:4300
#54 0x072090b9 in QApplication::notify (this=0x94c1af0, receiver=0xa252280, e=0xa91f210) at kernel/qapplication.cpp:4265
#55 0x00f4942a in KApplication::notify (this=0x94c1af0, receiver=0xa252280, event=0xa91f210) at ../../kdeui/kernel/kapplication.cpp:302
#56 0x02586beb in QCoreApplication::notifyInternal (this=0x94c1af0, receiver=0xa252280, event=0xa91f210) at kernel/qcoreapplication.cpp:704
#57 0x02589623 in QCoreApplication::sendEvent (receiver=0xa252280, event_type=77, data=0x947c658) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#58 QCoreApplicationPrivate::sendPostedEvents (receiver=0xa252280, event_type=77, data=0x947c658) at kernel/qcoreapplication.cpp:1345
#59 0x0258978d in QCoreApplication::sendPostedEvents (receiver=0xa252280, event_type=77) at kernel/qcoreapplication.cpp:1238
#60 0x078b13c6 in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x9541cc8) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#61 QGraphicsScenePrivate::_q_processDirtyItems (this=0x9541cc8) at graphicsview/qgraphicsscene.cpp:509
#62 0x078b1916 in QGraphicsScene::qt_metacall (this=0x9595708, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x9fb9270) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#63 0x06054c6a in Plasma::Corona::qt_metacall (this=0x9595708, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x9fb9270) at ./corona.moc:107
#64 0x022361ad in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#65 0x0258be5a in QMetaObject::metacall (object=0x9595708, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x0) at kernel/qmetaobject.cpp:237
#66 0x02596516 in QMetaCallEvent::placeMetaCall (this=0xa8ed1e8, object=0x9595708) at kernel/qobject.cpp:561
#67 0x0259763e in QObject::event (this=0x9595708, e=0xa8ed1e8) at kernel/qobject.cpp:1248
#68 0x078ad5f4 in QGraphicsScene::event (this=0x9595708, event=0xa8ed1e8) at graphicsview/qgraphicsscene.cpp:3500
#69 0x072023cc in QApplicationPrivate::notify_helper (this=0x94b2978, receiver=0x9595708, e=0xa8ed1e8) at kernel/qapplication.cpp:4300
#70 0x0720901e in QApplication::notify (this=0x94c1af0, receiver=0x9595708, e=0xa8ed1e8) at kernel/qapplication.cpp:3704
#71 0x00f4942a in KApplication::notify (this=0x94c1af0, receiver=0x9595708, event=0xa8ed1e8) at ../../kdeui/kernel/kapplication.cpp:302
#72 0x02586beb in QCoreApplication::notifyInternal (this=0x94c1af0, receiver=0x9595708, event=0xa8ed1e8) at kernel/qcoreapplication.cpp:704
#73 0x02589623 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x947c658) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#74 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x947c658) at kernel/qcoreapplication.cpp:1345
#75 0x0258978d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#76 0x025b2d0f in QCoreApplication::sendPostedEvents (s=0x94b4210) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#77 postEventSourceDispatch (s=0x94b4210) at kernel/qeventdispatcher_glib.cpp:276
#78 0x050b9e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#79 0x050bd730 in ?? () from /lib/libglib-2.0.so.0
#80 0x050bd863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#81 0x025b2805 in QEventDispatcherGlib::processEvents (this=0x94b2648, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#82 0x072c1b35 in QGuiEventDispatcherGlib::processEvents (this=0x94b2648, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#83 0x02585209 in QEventLoop::processEvents (this=0xbfb55034, flags=) at kernel/qeventloop.cpp:149
#84 0x0258565a in QEventLoop::exec (this=0xbfb55034, flags=...) at kernel/qeventloop.cpp:201
#85 0x0258984f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#86 0x07202467 in QApplication::exec () at kernel/qapplication.cpp:3579
#87 0x0223e17e in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#88 0x0804dff7 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x949aa20 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051405 "0") at ../../kinit/kinit.cpp:717
#89 0x0804ec15 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#90 0x0804f08c in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#91 0x0804fe2f in main (argc=4, argv=0xbfb55ae4, envp=0xbfb55af8) at ../../kinit/kinit.cpp:1841

This bug may be a duplicate of or related to bug 226596.

Possible duplicates by query: bug 229461, bug 229429, bug 229302, bug 228923, bug 226596.

Reported using DrKonqi
Comment 1 Pino Toscano 2010-03-10 18:00:35 UTC

*** This bug has been marked as a duplicate of bug 226596 ***