Bug 230313 - Plasma crash when quiting Kopete
Summary: Plasma crash when quiting Kopete
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-11 12:39 UTC by Mitja
Modified: 2010-03-11 20:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mitja 2010-03-11 12:39:13 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
I made right click on Kopete icon and then left click on quit. At that moment plasma crash.

Before this my firefox freeze while i opening a pdf file. So i tried to get some memory if i'd close Kopete, but that made this problem.

 -- Backtrace:
Application: Delovno okolje Plasma (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  QBasicAtomicInt::ref (this=0x961bbb0, group=0, state=0) at /usr/include/qt4/QtCore/qatomic_i386.h:120
#7  QString (this=0x961bbb0, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:715
#8  KIconEffect::fingerprint (this=0x961bbb0, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#9  0x0096a724 in KIconLoader::loadIcon (this=0x9d12b98, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#10 0x00961bb8 in KIconEngine::actualSize (this=0xa274808, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:80
#11 0x02e57ea6 in QIcon::actualSize (this=0xa56ad5c, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:700
#12 0x06c92c43 in Plasma::IconWidgetPrivate::decoration (this=0xa56ace0, option=0x9691e28, useHoverEffect=true, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#13 0x06c94877 in Plasma::IconWidget::paint (this=0xa56b710, painter=0xbfb6869c, option=0x9691e28, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1013
#14 0x0342b02c in _q_paintItem (item=<value optimized out>, painter=<value optimized out>, option=0x9691e28, widget=0x0, useWindowOpacity=false, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4243
#15 0x0342dc1a in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x9691e28, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4281
#16 0x034476c0 in QGraphicsScenePrivate::drawItemHelper (this=0x9691cc8, item=0xa56b718, painter=0xbfb6a4c4, option=0x9691e28, widget=0x9f58ae8, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4574
#17 0x034480e4 in QGraphicsScenePrivate::draw (this=0x9691cc8, item=0xa56b718, painter=0xbfb6a4c4, viewTransform=0xbfb6a2fc, transformPtr=0xbfb69080, exposedRegion=0x9f44dfc, widget=0x9f58ae8, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4827
#18 0x03448d6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9691cc8, item=0xa56b718, painter=0xbfb6a4c4, viewTransform=0xbfb6a2fc, exposedRegion=0x9f44dfc, widget=0x9f58ae8, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#19 0x03448174 in QGraphicsScenePrivate::draw (this=0x9691cc8, item=0x9934cb8, painter=0xbfb6a4c4, viewTransform=0xbfb6a2fc, transformPtr=0xbfb69580, exposedRegion=0x9f44dfc, widget=0x9f58ae8, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#20 0x03448d6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9691cc8, item=0x9934cb8, painter=0xbfb6a4c4, viewTransform=0xbfb6a2fc, exposedRegion=0x9f44dfc, widget=0x9f58ae8, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#21 0x03448174 in QGraphicsScenePrivate::draw (this=0x9691cc8, item=0x99384f0, painter=0xbfb6a4c4, viewTransform=0xbfb6a2fc, transformPtr=0xbfb69a80, exposedRegion=0x9f44dfc, widget=0x9f58ae8, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#22 0x03448d6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9691cc8, item=0x99384f0, painter=0xbfb6a4c4, viewTransform=0xbfb6a2fc, exposedRegion=0x9f44dfc, widget=0x9f58ae8, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#23 0x03448174 in QGraphicsScenePrivate::draw (this=0x9691cc8, item=0x97555a0, painter=0xbfb6a4c4, viewTransform=0xbfb6a2fc, transformPtr=0xbfb69f80, exposedRegion=0x9f44dfc, widget=0x9f58ae8, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#24 0x03448d6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9691cc8, item=0x97555a0, painter=0xbfb6a4c4, viewTransform=0xbfb6a2fc, exposedRegion=0x9f44dfc, widget=0x9f58ae8, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#25 0x0344973e in QGraphicsScenePrivate::drawItems (this=0x9691cc8, painter=0xbfb6a4c4, viewTransform=0xbfb6a2fc, exposedRegion=0x9f44dfc, widget=0x9f58ae8) at graphicsview/qgraphicsscene.cpp:4619
#26 0x03463cab in QGraphicsView::paintEvent (this=0x9f6e360, event=0xbfb6abe4) at graphicsview/qgraphicsview.cpp:3393
#27 0x01681d99 in PanelView::paintEvent (this=0x9f6e360, event=0xbfb6abe4) at ../../../../plasma/desktop/shell/panelview.cpp:1310
#28 0x02df45d6 in QWidget::event (this=0x9f6e360, event=0xbfb6abe4) at kernel/qwidget.cpp:8144
#29 0x031f0733 in QFrame::event (this=0x9f6e360, e=0xbfb6abe4) at widgets/qframe.cpp:557
#30 0x0328a9b2 in QAbstractScrollArea::viewportEvent (this=0x0, e=0x9611a70) at widgets/qabstractscrollarea.cpp:1036
#31 0x0346012b in QGraphicsView::viewportEvent (this=0x9f6e360, event=0xbfb6abe4) at graphicsview/qgraphicsview.cpp:2787
#32 0x0328d2a5 in QAbstractScrollAreaPrivate::viewportEvent (this=0x99036d0, o=0x9f58ae8, e=0xbfb6abe4) at widgets/qabstractscrollarea_p.h:100
#33 QAbstractScrollAreaFilter::eventFilter (this=0x99036d0, o=0x9f58ae8, e=0xbfb6abe4) at widgets/qabstractscrollarea_p.h:116
#34 0x01049e8a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x96206d0, receiver=0x9f58ae8, event=0xbfb6abe4) at kernel/qcoreapplication.cpp:819
#35 0x02d963a9 in QApplicationPrivate::notify_helper (this=0x96206d0, receiver=0x9f58ae8, e=0xbfb6abe4) at kernel/qapplication.cpp:4296
#36 0x02d9d0b9 in QApplication::notify (this=0x961a978, receiver=0x9f58ae8, e=0xbfb6abe4) at kernel/qapplication.cpp:4265
#37 0x009a742a in KApplication::notify (this=0x961a978, receiver=0x9f58ae8, event=0xbfb6abe4) at ../../kdeui/kernel/kapplication.cpp:302
#38 0x0104abeb in QCoreApplication::notifyInternal (this=0x961a978, receiver=0x9f58ae8, event=0xbfb6abe4) at kernel/qcoreapplication.cpp:704
#39 0x02dfd8e6 in QCoreApplication::sendSpontaneousEvent (this=0x9f58b00, pdev=0x9f592a4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9f58d08)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#40 QWidgetPrivate::drawWidget (this=0x9f58b00, pdev=0x9f592a4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9f58d08) at kernel/qwidget.cpp:5339
#41 0x02dfe725 in QWidgetPrivate::paintSiblingsRecursive (this=0x9f44a98, pdev=0x9f592a4, siblings=..., index=5, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9f58d08)
    at kernel/qwidget.cpp:5452
#42 0x02dfd635 in QWidgetPrivate::drawWidget (this=0x9f44a98, pdev=0x9f592a4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9f58d08) at kernel/qwidget.cpp:5388
#43 0x02fd3f00 in QWidgetBackingStore::sync (this=0x9f58d08) at painting/qbackingstore.cpp:1291
#44 0x02deda93 in QWidgetPrivate::syncBackingStore (this=0x9f44a98) at kernel/qwidget.cpp:1672
#45 0x02df4d96 in QWidget::event (this=0x9f6e360, event=0x9cd3148) at kernel/qwidget.cpp:8291
#46 0x031f0733 in QFrame::event (this=0x9f6e360, e=0x9cd3148) at widgets/qframe.cpp:557
#47 0x0328b3c7 in QAbstractScrollArea::event (this=0x9f6e360, e=0x9cd3148) at widgets/qabstractscrollarea.cpp:989
#48 0x034622d6 in QGraphicsView::event (this=0x9f6e360, event=0x9cd3148) at graphicsview/qgraphicsview.cpp:2666
#49 0x01682583 in PanelView::event (this=0x9f6e360, event=0x9cd3148) at ../../../../plasma/desktop/shell/panelview.cpp:1324
#50 0x02d963cc in QApplicationPrivate::notify_helper (this=0x96206d0, receiver=0x9f6e360, e=0x9cd3148) at kernel/qapplication.cpp:4300
#51 0x02d9d0b9 in QApplication::notify (this=0x961a978, receiver=0x9f6e360, e=0x9cd3148) at kernel/qapplication.cpp:4265
#52 0x009a742a in KApplication::notify (this=0x961a978, receiver=0x9f6e360, event=0x9cd3148) at ../../kdeui/kernel/kapplication.cpp:302
#53 0x0104abeb in QCoreApplication::notifyInternal (this=0x961a978, receiver=0x9f6e360, event=0x9cd3148) at kernel/qcoreapplication.cpp:704
#54 0x0104d623 in QCoreApplication::sendEvent (receiver=0x9f6e360, event_type=77, data=0x95d3658) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#55 QCoreApplicationPrivate::sendPostedEvents (receiver=0x9f6e360, event_type=77, data=0x95d3658) at kernel/qcoreapplication.cpp:1345
#56 0x0104d78d in QCoreApplication::sendPostedEvents (receiver=0x9f6e360, event_type=77) at kernel/qcoreapplication.cpp:1238
#57 0x034453c6 in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x9691cc8) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#58 QGraphicsScenePrivate::_q_processDirtyItems (this=0x9691cc8) at graphicsview/qgraphicsscene.cpp:509
#59 0x03445916 in QGraphicsScene::qt_metacall (this=0x96fb6b0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x9e7e260) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#60 0x06bd1c6a in Plasma::Corona::qt_metacall (this=0x96fb6b0, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x9e7e260) at ./corona.moc:107
#61 0x016721ad in DesktopCorona::qt_metacall (this=0x96fb6b0, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x9e7e260) at ./desktopcorona.moc:86
#62 0x0104fe5a in QMetaObject::metacall (object=0x96fb6b0, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x9e7e260) at kernel/qmetaobject.cpp:237
#63 0x0105a516 in QMetaCallEvent::placeMetaCall (this=0xa83cd90, object=0x96fb6b0) at kernel/qobject.cpp:561
#64 0x0105b63e in QObject::event (this=0x96fb6b0, e=0xa83cd90) at kernel/qobject.cpp:1248
#65 0x034415f4 in QGraphicsScene::event (this=0x96fb6b0, event=0xa83cd90) at graphicsview/qgraphicsscene.cpp:3500
#66 0x02d963cc in QApplicationPrivate::notify_helper (this=0x96206d0, receiver=0x96fb6b0, e=0xa83cd90) at kernel/qapplication.cpp:4300
#67 0x02d9d01e in QApplication::notify (this=0x961a978, receiver=0x96fb6b0, e=0xa83cd90) at kernel/qapplication.cpp:3704
#68 0x009a742a in KApplication::notify (this=0x961a978, receiver=0x96fb6b0, event=0xa83cd90) at ../../kdeui/kernel/kapplication.cpp:302
#69 0x0104abeb in QCoreApplication::notifyInternal (this=0x961a978, receiver=0x96fb6b0, event=0xa83cd90) at kernel/qcoreapplication.cpp:704
#70 0x0104d623 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x95d3658) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#71 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x95d3658) at kernel/qcoreapplication.cpp:1345
#72 0x0104d78d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#73 0x01076d0f in QCoreApplication::sendPostedEvents (s=0x9622710) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#74 postEventSourceDispatch (s=0x9622710) at kernel/qeventdispatcher_glib.cpp:276
#75 0x03f84e88 in g_main_dispatch (context=0x9622690) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#76 IA__g_main_context_dispatch (context=0x9622690) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#77 0x03f88730 in g_main_context_iterate (context=0x9622690, block=<value optimized out>, dispatch=1, self=0x96201e0) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#78 0x03f88863 in IA__g_main_context_iteration (context=0x9622690, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#79 0x01076805 in QEventDispatcherGlib::processEvents (this=0x9620578, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#80 0x02e55b35 in QGuiEventDispatcherGlib::processEvents (this=0x9620578, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#81 0x01049209 in QEventLoop::processEvents (this=0xbfb6c4a4, flags=) at kernel/qeventloop.cpp:149
#82 0x0104965a in QEventLoop::exec (this=0xbfb6c4a4, flags=...) at kernel/qeventloop.cpp:201
#83 0x0104d84f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#84 0x02d96467 in QApplication::exec () at kernel/qapplication.cpp:3579
#85 0x0167a17e in kdemain (argc=1, argv=0x9612258) at ../../../../plasma/desktop/shell/main.cpp:112
#86 0x0804dff7 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x95f1848 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051405 "0") at ../../kinit/kinit.cpp:717
#87 0x0804ec15 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#88 0x0804f08c in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#89 0x0804fe2f in main (argc=4, argv=0xbfb6cf54, envp=0xbfb6cf68) at ../../kinit/kinit.cpp:1841

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2010-03-11 20:03:16 UTC

*** This bug has been marked as a duplicate of bug 226596 ***