Bug 229461 - Plasma Desktop Crash after Kopete Crash
Summary: Plasma Desktop Crash after Kopete Crash
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-04 23:00 UTC by Joshua L. Blocher
Modified: 2010-03-05 18:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua L. Blocher 2010-03-04 23:00:21 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-15-generic-pae i686
Distribution: Ubuntu lucid (development branch)

-- Information about the crash:
Started Kopete up it crashed and then Plasma Desktop crashed almost immedaitely Firefox Frozen as well. Crashs everytime I try to start kopete.

The crash can be reproduced every time.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb545b760 (LWP 1394))]

Thread 2 (Thread 0xa5ec9b70 (LWP 1399)):
#0  0xb599db2e in g_poll () from /lib/libglib-2.0.so.0
#1  0xb599093f in ?? () from /lib/libglib-2.0.so.0
#2  0xb5990cc8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0xb6d104cf in QEventDispatcherGlib::processEvents (this=0x9d49328, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#4  0xb6ce2ef9 in QEventLoop::processEvents (this=0xa5ec9240, flags=) at kernel/qeventloop.cpp:149
#5  0xb6ce334a in QEventLoop::exec (this=0xa5ec9240, flags=...) at kernel/qeventloop.cpp:201
#6  0xb6bdf5a8 in QThread::exec (this=0x9d2e130) at thread/qthread.cpp:487
#7  0xb6cc2b1b in QInotifyFileSystemWatcherEngine::run (this=0x9d2e130) at io/qfilesystemwatcher_inotify.cpp:248
#8  0xb6be232e in QThreadPrivate::start (arg=0x9d2e130) at thread/qthread_unix.cpp:248
#9  0xb6b4f96e in start_thread (arg=0xa5ec9b70) at pthread_create.c:300
#10 0xb5f5192e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb545b760 (LWP 1394)):
[KCrash Handler]
#6  0xb6f900d6 in QString (this=0x24, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#7  KIconEffect::fingerprint (this=0x24, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#8  0xb6f9c864 in KIconLoader::loadIcon (this=0xa460208, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#9  0xb6f94a08 in KIconEngine::actualSize (this=0xa397560, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:80
#10 0xb62c5236 in QIcon::actualSize (this=0xa4e7784, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:700
#11 0xb5210a73 in Plasma::IconWidgetPrivate::decoration (this=0xa4e7708, option=0x9785b48, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#12 0xb5212687 in Plasma::IconWidget::paint (this=0xa0caae8, painter=0xbfafaecc, option=0x9785b48, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1013
#13 0xb6898e4c in _q_paintItem (item=<value optimized out>, painter=<value optimized out>, option=0x9785b48, widget=0x0, useWindowOpacity=false, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4243
#14 0xb689ba3a in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x9785b48, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4281
#15 0xb68b5520 in QGraphicsScenePrivate::drawItemHelper (this=0x97859e8, item=0xa0caaf0, painter=0xbfafccf4, option=0x9785b48, widget=0x9dcf568, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4574
#16 0xb68b5f44 in QGraphicsScenePrivate::draw (this=0x97859e8, item=0xa0caaf0, painter=0xbfafccf4, viewTransform=0xbfafcb2c, transformPtr=0xbfafb8b0, exposedRegion=0x9c98a3c, widget=0x9dcf568, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4827
#17 0xb68b6bd3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x97859e8, item=0xa0caaf0, painter=0xbfafccf4, viewTransform=0xbfafcb2c, exposedRegion=0x9c98a3c, widget=0x9dcf568, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#18 0xb68b5fe4 in QGraphicsScenePrivate::draw (this=0x97859e8, item=0x9a19448, painter=0xbfafccf4, viewTransform=0xbfafcb2c, transformPtr=0xbfafbdb0, exposedRegion=0x9c98a3c, widget=0x9dcf568, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#19 0xb68b6bd3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x97859e8, item=0x9a19448, painter=0xbfafccf4, viewTransform=0xbfafcb2c, exposedRegion=0x9c98a3c, widget=0x9dcf568, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#20 0xb68b5fe4 in QGraphicsScenePrivate::draw (this=0x97859e8, item=0x9a91288, painter=0xbfafccf4, viewTransform=0xbfafcb2c, transformPtr=0xbfafc2b0, exposedRegion=0x9c98a3c, widget=0x9dcf568, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#21 0xb68b6bd3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x97859e8, item=0x9a91288, painter=0xbfafccf4, viewTransform=0xbfafcb2c, exposedRegion=0x9c98a3c, widget=0x9dcf568, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#22 0xb68b5fe4 in QGraphicsScenePrivate::draw (this=0x97859e8, item=0x99baec8, painter=0xbfafccf4, viewTransform=0xbfafcb2c, transformPtr=0xbfafc7b0, exposedRegion=0x9c98a3c, widget=0x9dcf568, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#23 0xb68b6bd3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x97859e8, item=0x99baec8, painter=0xbfafccf4, viewTransform=0xbfafcb2c, exposedRegion=0x9c98a3c, widget=0x9dcf568, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#24 0xb68b75de in QGraphicsScenePrivate::drawItems (this=0x97859e8, painter=0xbfafccf4, viewTransform=0xbfafcb2c, exposedRegion=0x9c98a3c, widget=0x9dcf568) at graphicsview/qgraphicsscene.cpp:4619
#25 0xb68d1b3b in QGraphicsView::paintEvent (this=0x9c218c0, event=0xbfafd414) at graphicsview/qgraphicsview.cpp:3393
#26 0xb380ddb9 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#27 0xb62615e6 in QWidget::event (this=0x9c218c0, event=0xbfafd414) at kernel/qwidget.cpp:8144
#28 0xb665df23 in QFrame::event (this=0x9c218c0, e=0xbfafd414) at widgets/qframe.cpp:557
#29 0xb66f8262 in QAbstractScrollArea::viewportEvent (this=0x0, e=0x24) at widgets/qabstractscrollarea.cpp:1036
#30 0xb68cdfbb in QGraphicsView::viewportEvent (this=0x9c218c0, event=0xbfafd414) at graphicsview/qgraphicsview.cpp:2787
#31 0xb66fab45 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9d76f90, o=0x9dcf568, e=0xbfafd414) at widgets/qabstractscrollarea_p.h:100
#32 QAbstractScrollAreaFilter::eventFilter (this=0x9d76f90, o=0x9dcf568, e=0xbfafd414) at widgets/qabstractscrollarea_p.h:116
#33 0xb6ce3b7a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x963f980, receiver=0x9dcf568, event=0xbfafd414) at kernel/qcoreapplication.cpp:819
#34 0xb62034b9 in QApplicationPrivate::notify_helper (this=0x963f980, receiver=0x9dcf568, e=0xbfafd414) at kernel/qapplication.cpp:4296
#35 0xb620a0d9 in QApplication::notify (this=0x9639b38, receiver=0x9dcf568, e=0xbfafd414) at kernel/qapplication.cpp:4265
#36 0xb6fd9d4a in KApplication::notify (this=0x9639b38, receiver=0x9dcf568, event=0xbfafd414) at ../../kdeui/kernel/kapplication.cpp:302
#37 0xb6ce48db in QCoreApplication::notifyInternal (this=0x9639b38, receiver=0x9dcf568, event=0xbfafd414) at kernel/qcoreapplication.cpp:704
#38 0xb626a8f6 in QCoreApplication::sendSpontaneousEvent (this=0x9cb6c48, pdev=0x9fe81d4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9ca6a10)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#39 QWidgetPrivate::drawWidget (this=0x9cb6c48, pdev=0x9fe81d4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9ca6a10) at kernel/qwidget.cpp:5339
#40 0xb626b735 in QWidgetPrivate::paintSiblingsRecursive (this=0x9c986d8, pdev=0x9fe81d4, siblings=..., index=5, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9ca6a10)
    at kernel/qwidget.cpp:5452
#41 0xb626a645 in QWidgetPrivate::drawWidget (this=0x9c986d8, pdev=0x9fe81d4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9ca6a10) at kernel/qwidget.cpp:5388
#42 0xb64417e0 in QWidgetBackingStore::sync (this=0x9ca6a10) at painting/qbackingstore.cpp:1291
#43 0xb625aa83 in QWidgetPrivate::syncBackingStore (this=0x9c986d8) at kernel/qwidget.cpp:1672
#44 0xb6261da6 in QWidget::event (this=0x9c218c0, event=0xa43fcc0) at kernel/qwidget.cpp:8291
#45 0xb665df23 in QFrame::event (this=0x9c218c0, e=0xa43fcc0) at widgets/qframe.cpp:557
#46 0xb66f8c77 in QAbstractScrollArea::event (this=0x9c218c0, e=0xa43fcc0) at widgets/qabstractscrollarea.cpp:989
#47 0xb68d0166 in QGraphicsView::event (this=0x9c218c0, event=0xa43fcc0) at graphicsview/qgraphicsview.cpp:2666
#48 0xb3810c83 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#49 0xb62034dc in QApplicationPrivate::notify_helper (this=0x963f980, receiver=0xa43fcc0, e=0x9c218c0) at kernel/qapplication.cpp:4300
#50 0xb620a0d9 in QApplication::notify (this=0x9639b38, receiver=0x9c218c0, e=0xa43fcc0) at kernel/qapplication.cpp:4265
#51 0xb6fd9d4a in KApplication::notify (this=0x9639b38, receiver=0x9c218c0, event=0xa43fcc0) at ../../kdeui/kernel/kapplication.cpp:302
#52 0xb6ce48db in QCoreApplication::notifyInternal (this=0x9639b38, receiver=0x9c218c0, event=0xa43fcc0) at kernel/qcoreapplication.cpp:704
#53 0xb6ce7313 in QCoreApplication::sendEvent (receiver=0x9c218c0, event_type=77, data=0x95f0048) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#54 QCoreApplicationPrivate::sendPostedEvents (receiver=0x9c218c0, event_type=77, data=0x95f0048) at kernel/qcoreapplication.cpp:1345
#55 0xb6ce747d in QCoreApplication::sendPostedEvents (receiver=0x9c218c0, event_type=77) at kernel/qcoreapplication.cpp:1238
#56 0xb68b3226 in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x97859e8) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#57 QGraphicsScenePrivate::_q_processDirtyItems (this=0x97859e8) at graphicsview/qgraphicsscene.cpp:509
#58 0xb68b3776 in QGraphicsScene::qt_metacall (this=0x97858a0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xa009130) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#59 0xb514fb0a in Plasma::Corona::qt_metacall (this=0x97858a0, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xa009130) at ./corona.moc:107
#60 0xb37fe0ed in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#61 0xb6ce9b3a in QMetaObject::metacall (object=0x97858a0, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x0) at kernel/qmetaobject.cpp:237
#62 0xb6cf41e6 in QMetaCallEvent::placeMetaCall (this=0xa0deca0, object=0x97858a0) at kernel/qobject.cpp:561
#63 0xb6cf52ae in QObject::event (this=0x97858a0, e=0xa0deca0) at kernel/qobject.cpp:1248
#64 0xb68af454 in QGraphicsScene::event (this=0x97858a0, event=0xa0deca0) at graphicsview/qgraphicsscene.cpp:3500
#65 0xb62034dc in QApplicationPrivate::notify_helper (this=0x963f980, receiver=0x97858a0, e=0xa0deca0) at kernel/qapplication.cpp:4300
#66 0xb620a03e in QApplication::notify (this=0x9639b38, receiver=0x97858a0, e=0xa0deca0) at kernel/qapplication.cpp:3704
#67 0xb6fd9d4a in KApplication::notify (this=0x9639b38, receiver=0x97858a0, event=0xa0deca0) at ../../kdeui/kernel/kapplication.cpp:302
#68 0xb6ce48db in QCoreApplication::notifyInternal (this=0x9639b38, receiver=0x97858a0, event=0xa0deca0) at kernel/qcoreapplication.cpp:704
#69 0xb6ce7313 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x95f0048) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#70 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x95f0048) at kernel/qcoreapplication.cpp:1345
#71 0xb6ce747d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#72 0xb6d1099f in QCoreApplication::sendPostedEvents (s=0x9641b10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#73 postEventSourceDispatch (s=0x9641b10) at kernel/qeventdispatcher_glib.cpp:276
#74 0xb598ce05 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#75 0xb5990b08 in ?? () from /lib/libglib-2.0.so.0
#76 0xb5990cc8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#77 0xb6d10495 in QEventDispatcherGlib::processEvents (this=0x963f650, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#78 0xb62c2eb5 in QGuiEventDispatcherGlib::processEvents (this=0x963f650, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#79 0xb6ce2ef9 in QEventLoop::processEvents (this=0xbfafecd4, flags=) at kernel/qeventloop.cpp:149
#80 0xb6ce334a in QEventLoop::exec (this=0xbfafecd4, flags=...) at kernel/qeventloop.cpp:201
#81 0xb6ce753f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#82 0xb6203577 in QApplication::exec () at kernel/qapplication.cpp:3579
#83 0xb380619e in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#84 0x0804e037 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x9610970 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051465 "0") at ../../kinit/kinit.cpp:717
#85 0x0804ec55 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#86 0x0804f193 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#87 0x0804fe7f in main (argc=4, argv=0xbfaff784, envp=0xbfaff798) at ../../kinit/kinit.cpp:1841

This bug may be a duplicate of or related to bug 228923, bug 226596.

Possible duplicates by query: bug 229429, bug 229302, bug 228923, bug 226596.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-03-05 18:11:56 UTC

*** This bug has been marked as a duplicate of bug 226596 ***