Bug 229429 - Kopete crashes after Quit (possibly after login in Yahoo from Pidgin)
Summary: Kopete crashes after Quit (possibly after login in Yahoo from Pidgin)
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-04 19:15 UTC by Andrei Sebastian Cimpean
Modified: 2010-03-05 18:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Sebastian Cimpean 2010-03-04 19:15:17 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-19-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
I had previous similar problems but where fixed after reinstall and system update.
I wanted to close Kopete because im in yahoo doesn't work right(it doesn't send what i type) and pressed Ctrl+Q. It has a 1-3 seconds lag and then the window dissappears. I launched pidgin, and plasma crashed. I suspect it is because Kopete losses the connection from Yahoo!, but of course i don't really know.
It happened before, but i didn't send any bug reports. 
Sorry for my bad english.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7853760 (LWP 1485))]

Thread 2 (Thread 0xa855db70 (LWP 1505)):
#0  0x00e5a422 in __kernel_vsyscall ()
#1  0x00b1fe15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x023fe887 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x24d71a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#3  0x023fe8d1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x24d71a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#4  0x00b1b80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x00d388de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb7853760 (LWP 1485)):
[KCrash Handler]
#6  0x00ff1266 in QString (this=0x24, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#7  KIconEffect::fingerprint (this=0x24, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#8  0x00ffe724 in KIconLoader::loadIcon (this=0x9db38c8, _name=..., group=KIconLoader::Desktop, size=23, state=0, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#9  0x00ff5bb8 in KIconEngine::actualSize (this=0x9ffb4a8, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:80
#10 0x01409ea6 in QIcon::actualSize (this=0xa10ed34, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:700
#11 0x0893bc43 in Plasma::IconWidgetPrivate::decoration (this=0xa10ecb8, option=0x8cede70, useHoverEffect=true, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#12 0x0893d877 in Plasma::IconWidget::paint (this=0xa1d18b8, painter=0xbfe26b5c, option=0x8cede70, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1013
#13 0x019dd02c in _q_paintItem (item=<value optimized out>, painter=<value optimized out>, option=0x8cede70, widget=0x0, useWindowOpacity=false, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4243
#14 0x019dfc1a in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x8cede70, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4281
#15 0x019f96c0 in QGraphicsScenePrivate::drawItemHelper (this=0x8cedd10, item=0xa1d18c0, painter=0xbfe28984, option=0x8cede70, widget=0x994a580, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4574
#16 0x019fa0e4 in QGraphicsScenePrivate::draw (this=0x8cedd10, item=0xa1d18c0, painter=0xbfe28984, viewTransform=0xbfe287bc, transformPtr=0xbfe27540, exposedRegion=0x9bd5a34, widget=0x994a580, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4827
#17 0x019fad6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8cedd10, item=0xa1d18c0, painter=0xbfe28984, viewTransform=0xbfe287bc, exposedRegion=0x9bd5a34, widget=0x994a580, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#18 0x019fa174 in QGraphicsScenePrivate::draw (this=0x8cedd10, item=0x90ccf48, painter=0xbfe28984, viewTransform=0xbfe287bc, transformPtr=0xbfe27a40, exposedRegion=0x9bd5a34, widget=0x994a580, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#19 0x019fad6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8cedd10, item=0x90ccf48, painter=0xbfe28984, viewTransform=0xbfe287bc, exposedRegion=0x9bd5a34, widget=0x994a580, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#20 0x019fa174 in QGraphicsScenePrivate::draw (this=0x8cedd10, item=0x90531c0, painter=0xbfe28984, viewTransform=0xbfe287bc, transformPtr=0xbfe27f40, exposedRegion=0x9bd5a34, widget=0x994a580, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#21 0x019fad6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8cedd10, item=0x90531c0, painter=0xbfe28984, viewTransform=0xbfe287bc, exposedRegion=0x9bd5a34, widget=0x994a580, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#22 0x019fa174 in QGraphicsScenePrivate::draw (this=0x8cedd10, item=0x8f32578, painter=0xbfe28984, viewTransform=0xbfe287bc, transformPtr=0xbfe28440, exposedRegion=0x9bd5a34, widget=0x994a580, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#23 0x019fad6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8cedd10, item=0x8f32578, painter=0xbfe28984, viewTransform=0xbfe287bc, exposedRegion=0x9bd5a34, widget=0x994a580, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#24 0x019fb73e in QGraphicsScenePrivate::drawItems (this=0x8cedd10, painter=0xbfe28984, viewTransform=0xbfe287bc, exposedRegion=0x9bd5a34, widget=0x994a580) at graphicsview/qgraphicsscene.cpp:4619
#25 0x01a15cab in QGraphicsView::paintEvent (this=0x9897788, event=0xbfe290a4) at graphicsview/qgraphicsview.cpp:3393
#26 0x06795d99 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#27 0x013a65d6 in QWidget::event (this=0x9897788, event=0xbfe290a4) at kernel/qwidget.cpp:8144
#28 0x017a2733 in QFrame::event (this=0x9897788, e=0xbfe290a4) at widgets/qframe.cpp:557
#29 0x0183c9b2 in QAbstractScrollArea::viewportEvent (this=0x0, e=0x24) at widgets/qabstractscrollarea.cpp:1036
#30 0x01a1212b in QGraphicsView::viewportEvent (this=0x9897788, event=0xbfe290a4) at graphicsview/qgraphicsview.cpp:2787
#31 0x0183f2a5 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9899400, o=0x994a580, e=0xbfe290a4) at widgets/qabstractscrollarea_p.h:100
#32 QAbstractScrollAreaFilter::eventFilter (this=0x9899400, o=0x994a580, e=0xbfe290a4) at widgets/qabstractscrollarea_p.h:116
#33 0x06a6be8a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8c6a728, receiver=0x994a580, event=0xbfe290a4) at kernel/qcoreapplication.cpp:819
#34 0x013483a9 in QApplicationPrivate::notify_helper (this=0x8c6a728, receiver=0x994a580, e=0xbfe290a4) at kernel/qapplication.cpp:4296
#35 0x0134f0b9 in QApplication::notify (this=0x8c64958, receiver=0x994a580, e=0xbfe290a4) at kernel/qapplication.cpp:4265
#36 0x0103b42a in KApplication::notify (this=0x8c64958, receiver=0x994a580, event=0xbfe290a4) at ../../kdeui/kernel/kapplication.cpp:302
#37 0x06a6cbeb in QCoreApplication::notifyInternal (this=0x8c64958, receiver=0x994a580, event=0xbfe290a4) at kernel/qcoreapplication.cpp:704
#38 0x013af8e6 in QCoreApplication::sendSpontaneousEvent (this=0x99bc288, pdev=0x968bb34, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x95a6688)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#39 QWidgetPrivate::drawWidget (this=0x99bc288, pdev=0x968bb34, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x95a6688) at kernel/qwidget.cpp:5339
#40 0x013b0725 in QWidgetPrivate::paintSiblingsRecursive (this=0x9bd56d0, pdev=0x968bb34, siblings=..., index=6, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x95a6688)
    at kernel/qwidget.cpp:5452
#41 0x013af635 in QWidgetPrivate::drawWidget (this=0x9bd56d0, pdev=0x968bb34, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x95a6688) at kernel/qwidget.cpp:5388
#42 0x01585f00 in QWidgetBackingStore::sync (this=0x95a6688) at painting/qbackingstore.cpp:1291
#43 0x0139fa93 in QWidgetPrivate::syncBackingStore (this=0x9bd56d0) at kernel/qwidget.cpp:1672
#44 0x013a6d96 in QWidget::event (this=0x9897788, event=0x9be6fe0) at kernel/qwidget.cpp:8291
#45 0x017a2733 in QFrame::event (this=0x9897788, e=0x9be6fe0) at widgets/qframe.cpp:557
#46 0x0183d3c7 in QAbstractScrollArea::event (this=0x9897788, e=0x9be6fe0) at widgets/qabstractscrollarea.cpp:989
#47 0x01a142d6 in QGraphicsView::event (this=0x9897788, event=0x9be6fe0) at graphicsview/qgraphicsview.cpp:2666
#48 0x06796583 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#49 0x013483cc in QApplicationPrivate::notify_helper (this=0x8c6a728, receiver=0x9be6fe0, e=0x9897788) at kernel/qapplication.cpp:4300
#50 0x0134f0b9 in QApplication::notify (this=0x8c64958, receiver=0x9897788, e=0x9be6fe0) at kernel/qapplication.cpp:4265
#51 0x0103b42a in KApplication::notify (this=0x8c64958, receiver=0x9897788, event=0x9be6fe0) at ../../kdeui/kernel/kapplication.cpp:302
#52 0x06a6cbeb in QCoreApplication::notifyInternal (this=0x8c64958, receiver=0x9897788, event=0x9be6fe0) at kernel/qcoreapplication.cpp:704
#53 0x06a6f623 in QCoreApplication::sendEvent (receiver=0x9897788, event_type=77, data=0x8c1a658) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#54 QCoreApplicationPrivate::sendPostedEvents (receiver=0x9897788, event_type=77, data=0x8c1a658) at kernel/qcoreapplication.cpp:1345
#55 0x06a6f78d in QCoreApplication::sendPostedEvents (receiver=0x9897788, event_type=77) at kernel/qcoreapplication.cpp:1238
#56 0x019f73c6 in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x8cedd10) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#57 QGraphicsScenePrivate::_q_processDirtyItems (this=0x8cedd10) at graphicsview/qgraphicsscene.cpp:509
#58 0x019f7916 in QGraphicsScene::qt_metacall (this=0x8d459c0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xa04fa88) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#59 0x0887ac6a in Plasma::Corona::qt_metacall (this=0x8d459c0, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xa04fa88) at ./corona.moc:107
#60 0x067861ad in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#61 0x06a71e5a in QMetaObject::metacall (object=0x8d459c0, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x0) at kernel/qmetaobject.cpp:237
#62 0x06a7c516 in QMetaCallEvent::placeMetaCall (this=0x9f0aa00, object=0x8d459c0) at kernel/qobject.cpp:561
#63 0x06a7d63e in QObject::event (this=0x8d459c0, e=0x9f0aa00) at kernel/qobject.cpp:1248
#64 0x019f35f4 in QGraphicsScene::event (this=0x8d459c0, event=0x9f0aa00) at graphicsview/qgraphicsscene.cpp:3500
#65 0x013483cc in QApplicationPrivate::notify_helper (this=0x8c6a728, receiver=0x8d459c0, e=0x9f0aa00) at kernel/qapplication.cpp:4300
#66 0x0134f01e in QApplication::notify (this=0x8c64958, receiver=0x8d459c0, e=0x9f0aa00) at kernel/qapplication.cpp:3704
#67 0x0103b42a in KApplication::notify (this=0x8c64958, receiver=0x8d459c0, event=0x9f0aa00) at ../../kdeui/kernel/kapplication.cpp:302
#68 0x06a6cbeb in QCoreApplication::notifyInternal (this=0x8c64958, receiver=0x8d459c0, event=0x9f0aa00) at kernel/qcoreapplication.cpp:704
#69 0x06a6f623 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8c1a658) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#70 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8c1a658) at kernel/qcoreapplication.cpp:1345
#71 0x06a6f78d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#72 0x06a98d0f in QCoreApplication::sendPostedEvents (s=0x8c6c710) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#73 postEventSourceDispatch (s=0x8c6c710) at kernel/qeventdispatcher_glib.cpp:276
#74 0x04253e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#75 0x04257730 in ?? () from /lib/libglib-2.0.so.0
#76 0x04257863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#77 0x06a98805 in QEventDispatcherGlib::processEvents (this=0x8c6a3f8, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#78 0x01407b35 in QGuiEventDispatcherGlib::processEvents (this=0x8c6a3f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#79 0x06a6b209 in QEventLoop::processEvents (this=0xbfe2a964, flags=) at kernel/qeventloop.cpp:149
#80 0x06a6b65a in QEventLoop::exec (this=0xbfe2a964, flags=...) at kernel/qeventloop.cpp:201
#81 0x06a6f84f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#82 0x01348467 in QApplication::exec () at kernel/qapplication.cpp:3579
#83 0x0678e17e in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#84 0x0804dff7 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x8c5b688 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051405 "0") at ../../kinit/kinit.cpp:717
#85 0x0804ec15 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#86 0x0804f08c in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#87 0x0804fe2f in main (argc=4, argv=0xbfe2b414, envp=0xbfe2b428) at ../../kinit/kinit.cpp:1841

This bug may be a duplicate of or related to bug 226596.

Possible duplicates by query: bug 229302, bug 228923, bug 226596.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-03-05 18:12:13 UTC

*** This bug has been marked as a duplicate of bug 226596 ***