Bug 219364 - Kwin crashes when closing a maximized Netbeans window with compositing enabled [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: Kwin crashes when closing a maximized Netbeans window with compositing enable...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-19 23:26 UTC by bugzilla
Modified: 2009-12-19 23:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2009-12-19 23:26:00 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-16-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
I can reproduce this crash with my currently installed netbeans 6.8. Other applications are not affected by this bug (as far as i know and as far as i tested). KWin crashes only if the Netbeans program window is maximized to fit the screen and compositing is enabled. Thanks

The crash can be reproduced everytime.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0x30b6c90, force=<value optimized out>) at ../../kwin/scene.cpp:485
#6  0x00007f1c8534978c in KWin::Scene::paintSimpleScreen (this=0x22d92c0, orig_mask=<value optimized out>, region=<value optimized out>) at ../../kwin/scene.cpp:237
#7  0x00007f1c853471e5 in KWin::Scene::finalPaintScreen (this=0x22d92c0, mask=0, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:176
#8  0x00007f1c8535e096 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=0, region=) at ../../kwin/effects.cpp:126
#9  0x00007f1c745ee42f in KWin::LogoutEffect::paintScreen (this=0x2421b20, mask=0, region=<value optimized out>, data=...) at ../../../kwin/effects/logout/logout.cpp:196
#10 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#11 0x00007f1c7460d610 in KWin::ShadowEffect::paintScreen (this=0x2413ff0, mask=0, region=) at ../../../kwin/effects/shadow/shadow.cpp:182
#12 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#13 0x00007f1c745f4b02 in KWin::PresentWindowsEffect::paintScreen (this=0x2416660, mask=0, region=) at ../../../kwin/effects/presentwindows/presentwindows.cpp:191
#14 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#15 0x00007f1c83b7b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#17 0x00007f1c83b7b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#18 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#19 0x00007f1c83b7b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#20 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#21 0x00007f1c83b7b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#22 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#23 0x00007f1c74636307 in KWin::FlipSwitchEffect::paintScreen (this=0x23c0bd0, mask=0, region=<value optimized out>, data=...) at ../../../kwin/effects/flipswitch/flipswitch.cpp:146
#24 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#25 0x00007f1c745da772 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:151
#26 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#27 0x00007f1c74612265 in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...) at ../../../kwin/effects/slide/slide.cpp:86
#28 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#29 0x00007f1c83b7b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#31 0x00007f1c83b7b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#33 0x00007f1c83b7b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#34 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#35 0x00007f1c7461b161 in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=0, region=) at ../../../kwin/effects/zoom/zoom.cpp:73
#36 0x00007f1c8535e12e in KWin::EffectsHandlerImpl::paintScreen (this=0x235e510, mask=0, region=) at ../../kwin/effects.cpp:122
#37 0x00007f1c853492f5 in KWin::Scene::paintScreen (this=0x22d92c0, mask=0x7fff66dfdf4c, region=0x7fff66dfe070) at ../../kwin/scene.cpp:134
#38 0x00007f1c853579c0 in KWin::SceneOpenGL::paint (this=0x22d92c0, damage=<value optimized out>, toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:747
#39 0x00007f1c85343c97 in KWin::Workspace::performCompositing (this=<value optimized out>) at ../../kwin/composite.cpp:424
#40 0x00007f1c852cf3ce in KWin::Workspace::qt_metacall (this=0x2342fa0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff66dfe220) at ./workspace.moc:535
#41 0x00007f1c80f20dc3 in QMetaObject::activate (sender=0x2343410, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x428) at kernel/qobject.cpp:3294
#42 0x00007f1c80f1da33 in QObject::event (this=0x2343410, e=0x7fff66dfe8e0) at kernel/qobject.cpp:1224
#43 0x00007f1c8165ae8c in QApplicationPrivate::notify_helper (this=0x216de20, receiver=0x2343410, e=0x7fff66dfe8e0) at kernel/qapplication.cpp:4242
#44 0x00007f1c8166148d in QApplication::notify (this=0x7fff66dfec40, receiver=0x2343410, e=0x7fff66dfe8e0) at kernel/qapplication.cpp:4125
#45 0x00007f1c84b16666 in KApplication::notify (this=0x7fff66dfec40, receiver=0x2343410, event=0x7fff66dfe8e0) at ../../kdeui/kernel/kapplication.cpp:302
#46 0x00007f1c80f0e04c in QCoreApplication::notifyInternal (this=0x7fff66dfec40, receiver=0x2343410, event=0x7fff66dfe8e0) at kernel/qcoreapplication.cpp:704
#47 0x00007f1c80f3ad52 in QCoreApplication::sendEvent (this=0x2171c50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#48 QTimerInfoList::activateTimers (this=0x2171c50) at kernel/qeventdispatcher_unix.cpp:603
#49 0x00007f1c80f37958 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#50 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#51 0x00007f1c7a45ebbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#52 0x00007f1c7a462588 in ?? () from /lib/libglib-2.0.so.0
#53 0x00007f1c7a4626b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#54 0x00007f1c80f37623 in QEventDispatcherGlib::processEvents (this=0x21544f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#55 0x00007f1c817092fe in QGuiEventDispatcherGlib::processEvents (this=0x7fff66dfc400, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#56 0x00007f1c80f0c972 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#57 0x00007f1c80f0cd4c in QEventLoop::exec (this=0x7fff66dfeb80, flags=) at kernel/qeventloop.cpp:201
#58 0x00007f1c80f10a8b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#59 0x00007f1c852e898e in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kwin/main.cpp:526
#60 0x00007f1c84f49abd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff66dff148) at libc-start.c:220
#61 0x0000000000400679 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 219255, bug 219071, bug 218851, bug 218850, bug 218761.

Reported using DrKonqi
Comment 1 Thomas Lübking 2009-12-19 23:31:27 UTC

*** This bug has been marked as a duplicate of bug 216908 ***