Bug 219071 - kwin crashes when realvnc vncviewer is used [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: kwin crashes when realvnc vncviewer is used [KWin::Scene::Window::buildQuads,...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-17 14:42 UTC by Michal Svoboda
Modified: 2009-12-17 14:45 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Svoboda 2009-12-17 14:42:48 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) (Compiled from sources)
Qt Version: 4.6.0
Operating System: Linux 2.6.31.5 x86_64

-- Information about the crash:
sometimes when i use vncviewer from realvnc, i crash kwin (see trace). the vnc viewer output is as follows:

VNC viewer for X version 4.0 - built Mar  1 2005 19:53:55
Copyright (C) 2002-2004 RealVNC Ltd.                     
See http://www.realvnc.com for information on VNC.       

Thu Dec 17 14:37:50 2009
 CConn:       connected to host 0 port 5900
 CConnection: Server supports RFB protocol version 3.8
 CConnection: Using RFB protocol version 3.8          
 TXImage:     Using default colormap and visual, TrueColor, depth 24.
 CConn:       Using pixel format depth 6 (8bpp) rgb222               
 CConn:       Using ZRLE encoding                                    
 CConn:       Throughput 20009 kbit/s - changing to hextile encoding 
 CConn:       Throughput 20009 kbit/s - changing to full colour
 CConn:       Using pixel format depth 24 (32bpp) little-endian rgb888
 CConn:       Using hextile encoding
Rect too big: 8448x401 at 448,1 exceeds 640x480
 main:        Rect too big
(this will not crash kwin, i merely find the rect too big a hinting info)
VNC viewer for X version 4.0 - built Mar  1 2005 19:53:55
Copyright (C) 2002-2004 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.

Thu Dec 17 14:37:52 2009
 CConn:       connected to host 0 port 5900
 CConnection: Server supports RFB protocol version 3.8
 CConnection: Using RFB protocol version 3.8
 TXImage:     Using default colormap and visual, TrueColor, depth 24.
 CConn:       Using pixel format depth 6 (8bpp) rgb222
 CConn:       Using ZRLE encoding
 CConn:       Throughput 10683 kbit/s - changing to hextile encoding
 CConn:       Throughput 10683 kbit/s - changing to full colour
 CConn:       Using pixel format depth 24 (32bpp) little-endian rgb888
 CConn:       Using hextile encoding
(here kwin crashes, when it restarts, i see the following 2 messages)
unknown message type 63
 main:        unknown message type


The crash can be reproduced some of the times.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0xf3e060, force=<value optimized out>) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/scene.cpp:485
#6  0x00007f526af6405a in KWin::Scene::paintSimpleScreen (this=0xa687e0, orig_mask=<value optimized out>, region=<value optimized out>)
    at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/scene.cpp:237
#7  0x00007f526af61b05 in KWin::Scene::finalPaintScreen (this=0xa687e0, mask=0, region=<value optimized out>, data=<value optimized out>)
    at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/scene.cpp:176
#8  0x00007f526af784f6 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects.cpp:126
#9  0x00007f525ce617e8 in KWin::SnowEffect::paintScreen (this=0x999bb0, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects/snow/snow.cpp:120
#10 0x00007f526af7858c in KWin::EffectsHandlerImpl::paintScreen (this=0xa2a280, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#11 0x00007f525ce14212 in KWin::PresentWindowsEffect::paintScreen (this=0x9de740, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects/presentwindows/presentwindows.cpp:191
#12 0x00007f526af7858c in KWin::EffectsHandlerImpl::paintScreen (this=0xa2a280, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#13 0x00007f526a8393c3 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=<value optimized out>)
    at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#14 0x00007f526af7858c in KWin::EffectsHandlerImpl::paintScreen (this=0xa2a280, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#15 0x00007f526a8393c3 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=<value optimized out>)
    at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#16 0x00007f526af7858c in KWin::EffectsHandlerImpl::paintScreen (this=0xa2a280, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#17 0x00007f525cdfa1a9 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=@0x7fffd4879c50)
    at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects/desktopgrid/desktopgrid.cpp:151
#18 0x00007f526af7858c in KWin::EffectsHandlerImpl::paintScreen (this=0xa2a280, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#19 0x00007f526a8393c3 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=<value optimized out>)
    at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#20 0x00007f526af7858c in KWin::EffectsHandlerImpl::paintScreen (this=0xa2a280, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#21 0x00007f526a8393c3 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=<value optimized out>)
    at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#22 0x00007f526af7858c in KWin::EffectsHandlerImpl::paintScreen (this=0xa2a280, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#23 0x00007f525ce31565 in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=@0x7fffd4879c50)
    at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects/slide/slide.cpp:86
#24 0x00007f526af7858c in KWin::EffectsHandlerImpl::paintScreen (this=0xa2a280, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#25 0x00007f525cdf8292 in KWin::BoxSwitchEffect::paintScreen (this=0x9fe060, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects/boxswitch/boxswitch.cpp:140
#26 0x00007f526af7858c in KWin::EffectsHandlerImpl::paintScreen (this=0xa2a280, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#27 0x00007f526a8393c3 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=<value optimized out>)
    at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#28 0x00007f526af7858c in KWin::EffectsHandlerImpl::paintScreen (this=0xa2a280, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#29 0x00007f525ce5b46f in KWin::MouseMarkEffect::paintScreen (this=0xa834c0, mask=0, region=<value optimized out>, data=<value optimized out>)
    at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects/mousemark/mousemark.cpp:78
#30 0x00007f526af7858c in KWin::EffectsHandlerImpl::paintScreen (this=0xa2a280, mask=0, region=) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#31 0x00007f526af63bcb in KWin::Scene::paintScreen (this=0xa687e0, mask=0x7fffd4879dcc, region=0x7fffd4879ef0) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/scene.cpp:134
#32 0x00007f526af71e6f in KWin::SceneOpenGL::paint (this=0xa687e0, damage=<value optimized out>, toplevels=<value optimized out>)
    at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/scene_opengl.cpp:747
#33 0x00007f526af5e4b4 in KWin::Workspace::performCompositing (this=<value optimized out>) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/composite.cpp:424
#34 0x00007f526aeea3ae in KWin::Workspace::qt_metacall (this=0x92c760, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd487a0a0)
    at /src/a/kde/4.4.0-b1/o/base-ws/kwin/workspace.moc:535
#35 0x00007f52681ee6a3 in QMetaObject::activate () from /opt/qt-4.6.0-b1/lib/libQtCore.so.4
#36 0x00007f52681eb313 in QObject::event () from /opt/qt-4.6.0-b1/lib/libQtCore.so.4
#37 0x00007f5268911cac in QApplicationPrivate::notify_helper () from /opt/qt-4.6.0-b1/lib/libQtGui.so.4
#38 0x00007f526891854a in QApplication::notify () from /opt/qt-4.6.0-b1/lib/libQtGui.so.4
#39 0x00007f5269f38716 in KApplication::notify (this=0x7fffd487aae0, receiver=0x92cbd0, event=0x7fffd487a770) at /src/a/kde/4.4.0-b1/kdelibs-4.3.80/kdeui/kernel/kapplication.cpp:302
#40 0x00007f52681db9fb in QCoreApplication::notifyInternal () from /opt/qt-4.6.0-b1/lib/libQtCore.so.4
#41 0x00007f526820876a in ?? () from /opt/qt-4.6.0-b1/lib/libQtCore.so.4
#42 0x00007f52682056a8 in ?? () from /opt/qt-4.6.0-b1/lib/libQtCore.so.4
#43 0x00007f526139ad4b in IA__g_main_context_dispatch (context=0x7bae20) at gmain.c:1814
#44 0x00007f526139e440 in g_main_context_iterate (context=0x7bae20, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2448
#45 0x00007f526139e5ac in IA__g_main_context_iteration (context=0x7bae20, may_block=1) at gmain.c:2511
#46 0x00007f5268205373 in QEventDispatcherGlib::processEvents () from /opt/qt-4.6.0-b1/lib/libQtCore.so.4
#47 0x00007f52689bf1ee in ?? () from /opt/qt-4.6.0-b1/lib/libQtGui.so.4
#48 0x00007f52681da352 in QEventLoop::processEvents () from /opt/qt-4.6.0-b1/lib/libQtCore.so.4
#49 0x00007f52681da72d in QEventLoop::exec () from /opt/qt-4.6.0-b1/lib/libQtCore.so.4
#50 0x00007f52681de423 in QCoreApplication::exec () from /opt/qt-4.6.0-b1/lib/libQtCore.so.4
#51 0x00007f526af033d8 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /src/a/kde/4.4.0-b1/kdebase-workspace-4.3.80/kwin/main.cpp:526
#52 0x00007f52653d09bd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffd487afe8) at libc-start.c:220
#53 0x00000000004007e9 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 218851, bug 218850, bug 218761, bug 218621, bug 218405.

Reported using DrKonqi
Comment 1 Martin Flöser 2009-12-17 14:45:39 UTC

*** This bug has been marked as a duplicate of bug 216908 ***