Bug 219255 - kwin and plasma crash as okular starts [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: kwin and plasma crash as okular starts [KWin::Scene::Window::buildQuads, KWin...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-18 23:45 UTC by Pol
Modified: 2009-12-19 00:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pol 2009-12-18 23:45:53 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-16-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
I was starting a pdf file using okular, from knode message link

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0x00e9f48a in KWin::Scene::Window::buildQuads (this=0x9e1ebe0, force=false) at ../../kwin/scene.cpp:485
#7  0x00ea05ce in KWin::Scene::paintSimpleScreen (this=0x9b010a0, orig_mask=8, region=...) at ../../kwin/scene.cpp:237
#8  0x00e9ddf9 in KWin::Scene::finalPaintScreen (this=0x9b010a0, mask=8, region=..., data=...) at ../../kwin/scene.cpp:176
#9  0x00eb765c in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:126
#10 0x02063e47 in KWin::LogoutEffect::paintScreen (this=0x9b463f8, mask=8, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:196
#11 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#12 0x0208443f in KWin::ShadowEffect::paintScreen (this=0x9b54918, mask=<value optimized out>, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:182
#13 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#14 0x0206a6ff in KWin::PresentWindowsEffect::paintScreen (this=0x9b60908, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:191
#15 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#16 0x0017ed96 in KWin::Effect::paintScreen (this=0x9bb1360, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#17 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#18 0x0017ed96 in KWin::Effect::paintScreen (this=0x9b60240, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#20 0x0017ed96 in KWin::Effect::paintScreen (this=0x9b53ee0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#21 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#22 0x0017ed96 in KWin::Effect::paintScreen (this=0x9b603e0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#23 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#24 0x0204f4a3 in KWin::DesktopGridEffect::paintScreen (this=0x9b407b0, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:151
#25 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#26 0x020898fa in KWin::SlideEffect::paintScreen (this=0x9b60ab8, mask=8, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#27 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#28 0x0017ed96 in KWin::Effect::paintScreen (this=0x9b721f0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#30 0x0017ed96 in KWin::Effect::paintScreen (this=0x9bb1988, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#32 0x02096dfc in KWin::CoverSwitchEffect::paintScreen (this=0x9b77660, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:124
#33 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#34 0x0017ed96 in KWin::Effect::paintScreen (this=0x9b47770, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#36 0x020934b3 in KWin::ZoomEffect::paintScreen (this=0x9ba6970, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:73
#37 0x00eb76e0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b11c00, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#38 0x00ea00e4 in KWin::Scene::paintScreen (this=0x9b010a0, mask=0xbffb9198, region=0xbffb9264) at ../../kwin/scene.cpp:134
#39 0x00eafe9a in KWin::SceneOpenGL::paint (this=0x9b010a0, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:747
#40 0x00e9a224 in KWin::Workspace::performCompositing (this=0x9af2278) at ../../kwin/composite.cpp:424
#41 0x00e16736 in KWin::Workspace::qt_metacall (this=0x9af2278, _c=QMetaObject::InvokeMetaMethod, _id=173, _a=0xbffb938c) at ./workspace.moc:535
#42 0x06d8011a in QMetaObject::metacall (object=0x9af2278, cl=QMetaObject::InvokeMetaMethod, idx=173, argv=0xbffb938c) at kernel/qmetaobject.cpp:237
#43 0x06d8e89b in QMetaObject::activate (sender=0x9af2500, m=0x6e8f5a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3294
#44 0x06de01c7 in QTimer::timeout (this=0x9af2500) at .moc/release-shared/moc_qtimer.cpp:134
#45 0x06d96b4e in QTimer::timerEvent (this=0x9af2500, e=0xbffb9870) at kernel/qtimer.cpp:271
#46 0x06d8b704 in QObject::event (this=0x9af2500, e=0xbffb7f8c) at kernel/qobject.cpp:1224
#47 0x0626c19c in QApplicationPrivate::notify_helper (this=0x99eee08, receiver=0x9af2500, e=0xbffb9870) at kernel/qapplication.cpp:4242
#48 0x06272df7 in QApplication::notify (this=0xbffb9be8, receiver=0x9af2500, e=0xbffb9870) at kernel/qapplication.cpp:3661
#49 0x00548f8a in KApplication::notify (this=0xbffb9be8, receiver=0x9af2500, event=0xbffb9870) at ../../kdeui/kernel/kapplication.cpp:302
#50 0x00e301ff in KWin::Application::notify (this=0xbffb9be8, o=0x9af2500, e=0xbffb9870) at ../../kwin/main.cpp:370
#51 0x06d7aeab in QCoreApplication::notifyInternal (this=0xbffb9be8, receiver=0x9af2500, event=0xbffb9870) at kernel/qcoreapplication.cpp:704
#52 0x06daa286 in QCoreApplication::sendEvent (this=0x99f1e44) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#53 QTimerInfoList::activateTimers (this=0x99f1e44) at kernel/qeventdispatcher_unix.cpp:603
#54 0x06da6f17 in timerSourceDispatch (source=0x99f1e80) at kernel/qeventdispatcher_glib.cpp:184
#55 idleTimerSourceDispatch (source=0x99f1e80) at kernel/qeventdispatcher_glib.cpp:231
#56 0x08958e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#57 0x0895c720 in ?? () from /lib/libglib-2.0.so.0
#58 0x0895c853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#59 0x06da6bd5 in QEventDispatcherGlib::processEvents (this=0x99eedc8, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#60 0x06329b75 in QGuiEventDispatcherGlib::processEvents (this=0x99eedc8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#61 0x06d794c9 in QEventLoop::processEvents (this=0xbffb9b34, flags=) at kernel/qeventloop.cpp:149
#62 0x06d7991a in QEventLoop::exec (this=0xbffb9b34, flags=...) at kernel/qeventloop.cpp:201
#63 0x06d7db0f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#64 0x0626c237 in QApplication::exec () at kernel/qapplication.cpp:3570
#65 0x00e31e10 in kdemain (argc=3, argv=0xbffb9df4) at ../../kwin/main.cpp:526
#66 0x080485cb in main (argc=3, argv=0xbffb9df4) at kwin_dummy.cpp:3

Possible duplicates by query: bug 219071, bug 218851, bug 218850, bug 218761, bug 218621.

Reported using DrKonqi
Comment 1 Thomas Lübking 2009-12-19 00:01:02 UTC

*** This bug has been marked as a duplicate of bug 216908 ***