Bug 218850 - KWin crashes when exiting smplayer's fullscreen mode [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: KWin crashes when exiting smplayer's fullscreen mode [KWin::Scene::Window::bu...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-15 23:07 UTC by Bart
Modified: 2009-12-15 23:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bart 2009-12-15 23:07:54 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) "release 197")
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) "release 197"
Qt Version: 4.6.0
Operating System: Linux 2.6.31.5-0.1-desktop i686
Distribution (Platform): openSUSE RPMs

-- Information about the crash:
Each time smplayer exits from fullscreen mode, kwin crashes. It happens only when compositing is enabled & effects are enabled.

The crash can be reproduced everytime.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0xb768fa3f in KWin::Scene::Window::buildQuads (this=0x82dbcb0, force=false) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:485
#7  0xb7690b75 in KWin::Scene::paintSimpleScreen (this=0x831dd20, orig_mask=8, region=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:237
#8  0xb768e2aa in KWin::Scene::finalPaintScreen (this=0x831dd20, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:176
#9  0xb76a85d5 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:126
#10 0xaff81732 in KWin::LogoutEffect::paintScreen (this=0x8771248, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/logout/logout.cpp:196
#11 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#12 0xaffa2a78 in KWin::ShadowEffect::paintScreen (this=0x86e6150, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/shadow/shadow.cpp:182
#13 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#14 0xaff88434 in KWin::PresentWindowsEffect::paintScreen (this=0x8273e58, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/presentwindows/presentwindows.cpp:191
#15 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#16 0xb6d145aa in KWin::Effect::paintScreen (this=0x826be78, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#17 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#18 0xb6d145aa in KWin::Effect::paintScreen (this=0x874c9d8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#19 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#20 0xb6d145aa in KWin::Effect::paintScreen (this=0x81dc908, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#21 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#22 0xb6d145aa in KWin::Effect::paintScreen (this=0x820b1f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#23 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#24 0xb6d145aa in KWin::Effect::paintScreen (this=0x8441388, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#25 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#26 0xb6d145aa in KWin::Effect::paintScreen (this=0x822e860, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#27 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#28 0xaff6c7a3 in KWin::DesktopGridEffect::paintScreen (this=0x87727d8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/desktopgrid/desktopgrid.cpp:151
#29 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#30 0xaffa8015 in KWin::SlideEffect::paintScreen (this=0x8272968, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/slide/slide.cpp:86
#31 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#32 0xb6d145aa in KWin::Effect::paintScreen (this=0x8322540, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#33 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#34 0xb6d145aa in KWin::Effect::paintScreen (this=0x87ac548, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#35 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#36 0xb6d145aa in KWin::Effect::paintScreen (this=0x81dcc30, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#37 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#38 0xaffb543a in KWin::CoverSwitchEffect::paintScreen (this=0x81a5f50, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/coverswitch/coverswitch.cpp:124
#39 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#40 0xb6d145aa in KWin::Effect::paintScreen (this=0x8440980, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#41 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#42 0xb6d145aa in KWin::Effect::paintScreen (this=0x82c96f8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#43 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#44 0xb6d145aa in KWin::Effect::paintScreen (this=0x87485c0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#45 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#46 0xaffb1caa in KWin::ZoomEffect::paintScreen (this=0x8753f60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/zoom/zoom.cpp:73
#47 0xb76a8665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81bbf60, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#48 0xb7690699 in KWin::Scene::paintScreen (this=0x831dd20, mask=0xbfab6c68, region=0xbfab6d34) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:134
#49 0xb76a0a38 in KWin::SceneOpenGL::paint (this=0x831dd20, damage=..., toplevels=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene_opengl.cpp:747
#50 0xb768a642 in KWin::Workspace::performCompositing (this=0x81c0848) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/composite.cpp:424
#51 0xb7604ba0 in KWin::Workspace::qt_metacall (this=0x81c0848, _c=InvokeMetaMethod, _id=173, _a=0xbfab6e4c) at /usr/src/debug/kdebase-workspace-4.3.80/build/kwin/workspace.moc:535
#52 0xb5bead4d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#53 0xb5bf9b76 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#54 0xb5c4d345 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#55 0xb5c01fe6 in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#56 0xb5bf6654 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#57 0xb5ead1dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#58 0xb5eb4000 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#59 0xb724f451 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#60 0xb761f1f1 in KWin::Application::notify (this=0xbfab76a8, o=0x81c0ad0, e=0xbfab7344) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/main.cpp:370
#61 0xb5be59de in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#62 0xb5c15d3e in ?? () from /usr/lib/libQtCore.so.4
#63 0xb5c129d5 in ?? () from /usr/lib/libQtCore.so.4
#64 0xb2f66622 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#65 0xb2f69ef8 in ?? () from /usr/lib/libglib-2.0.so.0
#66 0xb2f6a01e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#67 0xb5c12671 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#68 0xb5f6b8fa in ?? () from /usr/lib/libQtGui.so.4
#69 0xb5be404d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#70 0xb5be4499 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#71 0xb5be8610 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#72 0xb5ead284 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#73 0xb7620e54 in kdemain (argc=3, argv=0xbfab78a4) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/main.cpp:526
#74 0x080485fb in main (argc=3, argv=0xbfab78a4) at /usr/src/debug/kdebase-workspace-4.3.80/build/kwin/kwin_dummy.cpp:3

Possible duplicates by query: bug 218761, bug 218621, bug 218405, bug 218370, bug 218150.

Reported using DrKonqi
Comment 1 Martin Flöser 2009-12-15 23:13:05 UTC

*** This bug has been marked as a duplicate of bug 216908 ***