Bug 218851 - chrashed when triggered present windows with screen edge [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: chrashed when triggered present windows with screen edge [KWin::Scene::Window...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-15 23:22 UTC by Pascal d'Hermilly
Modified: 2009-12-15 23:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pascal d'Hermilly 2009-12-15 23:22:07 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-16-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
Kwin when I triggered the present windows effect by taking the mouse to a screen edge

The system settings dialog had frozen before I triggered the effect.

When I look at the process list I can see that TWO kwin processes are running, one of them marked Stopped

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0x232e5a0, force=<value optimized out>) at ../../kwin/scene.cpp:485
#6  0x00007f3e1f8d978c in KWin::Scene::paintSimpleScreen (this=0x144c540, orig_mask=<value optimized out>, region=<value optimized out>) at ../../kwin/scene.cpp:237
#7  0x00007f3e1f8d71e5 in KWin::Scene::finalPaintScreen (this=0x144c540, mask=8, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:176
#8  0x00007f3e1f8ee096 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=8, region=) at ../../kwin/effects.cpp:126
#9  0x00007f3e0ee55dc8 in KWin::SnowEffect::paintScreen (this=0x20cdb80, mask=8, region=) at ../../../kwin/effects/snow/snow.cpp:120
#10 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#11 0x00007f3e0ee0142f in KWin::LogoutEffect::paintScreen (this=0x14a1340, mask=8, region=<value optimized out>, data=...) at ../../../kwin/effects/logout/logout.cpp:196
#12 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#13 0x00007f3e0ee20610 in KWin::ShadowEffect::paintScreen (this=0x15480e0, mask=8, region=) at ../../../kwin/effects/shadow/shadow.cpp:182
#14 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#15 0x00007f3e1e10b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#17 0x00007f3e0ee07b02 in KWin::PresentWindowsEffect::paintScreen (this=0x19a98b0, mask=8, region=) at ../../../kwin/effects/presentwindows/presentwindows.cpp:191
#18 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#19 0x00007f3e1e10b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#20 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#21 0x00007f3e1e10b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#22 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#23 0x00007f3e0ee49307 in KWin::FlipSwitchEffect::paintScreen (this=0x1a98c20, mask=8, region=<value optimized out>, data=...) at ../../../kwin/effects/flipswitch/flipswitch.cpp:146
#24 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#25 0x00007f3e0eded772 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:151
#26 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#27 0x00007f3e1e10b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#29 0x00007f3e1e10b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#31 0x00007f3e1e10b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#33 0x00007f3e1e10b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#34 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#35 0x00007f3e1e10b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#36 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#37 0x00007f3e1e10b01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#38 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#39 0x00007f3e0ee57015 in KWin::TrackMouseEffect::paintScreen (this=0x1aa4950, mask=8, region=) at ../../../kwin/effects/trackmouse/trackmouse.cpp:71
#40 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#41 0x00007f3e0ee2e161 in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=8, region=) at ../../../kwin/effects/zoom/zoom.cpp:73
#42 0x00007f3e1f8ee12e in KWin::EffectsHandlerImpl::paintScreen (this=0x1841f80, mask=8, region=) at ../../kwin/effects.cpp:122
#43 0x00007f3e1f8d92f5 in KWin::Scene::paintScreen (this=0x144c540, mask=0x7fff87042b9c, region=0x7fff87042cc0) at ../../kwin/scene.cpp:134
#44 0x00007f3e1f8e79c0 in KWin::SceneOpenGL::paint (this=0x144c540, damage=<value optimized out>, toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:747
#45 0x00007f3e1f8d3c97 in KWin::Workspace::performCompositing (this=<value optimized out>) at ../../kwin/composite.cpp:424
#46 0x00007f3e1f85f3ce in KWin::Workspace::qt_metacall (this=0x1544fe0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff87042e70) at ./workspace.moc:535
#47 0x00007f3e1b6a8dc3 in QMetaObject::activate (sender=0x1545450, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x14c) at kernel/qobject.cpp:3294
#48 0x00007f3e1b6a5a33 in QObject::event (this=0x1545450, e=0x7fff87043530) at kernel/qobject.cpp:1224
#49 0x00007f3e1bde2e8c in QApplicationPrivate::notify_helper (this=0x13cecc0, receiver=0x1545450, e=0x7fff87043530) at kernel/qapplication.cpp:4242
#50 0x00007f3e1bde948d in QApplication::notify (this=0x7fff87043890, receiver=0x1545450, e=0x7fff87043530) at kernel/qapplication.cpp:4125
#51 0x00007f3e1f0a6666 in KApplication::notify (this=0x7fff87043890, receiver=0x1545450, event=0x7fff87043530) at ../../kdeui/kernel/kapplication.cpp:302
#52 0x00007f3e1b69604c in QCoreApplication::notifyInternal (this=0x7fff87043890, receiver=0x1545450, event=0x7fff87043530) at kernel/qcoreapplication.cpp:704
#53 0x00007f3e1b6c2d52 in QCoreApplication::sendEvent (this=0x13d2a90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#54 QTimerInfoList::activateTimers (this=0x13d2a90) at kernel/qeventdispatcher_unix.cpp:603
#55 0x00007f3e1b6bf958 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#56 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#57 0x00007f3e14c1bbbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#58 0x00007f3e14c1f588 in ?? () from /lib/libglib-2.0.so.0
#59 0x00007f3e14c1f6b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#60 0x00007f3e1b6bf623 in QEventDispatcherGlib::processEvents (this=0x13b5100, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#61 0x00007f3e1be912fe in QGuiEventDispatcherGlib::processEvents (this=0x7fff87040f90, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#62 0x00007f3e1b694972 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#63 0x00007f3e1b694d4c in QEventLoop::exec (this=0x7fff870437d0, flags=) at kernel/qeventloop.cpp:201
#64 0x00007f3e1b698a8b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#65 0x00007f3e1f87898e in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kwin/main.cpp:526
#66 0x00007f3e1f4d9abd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff87043d98) at libc-start.c:220
#67 0x0000000000400679 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 218850, bug 218761, bug 218621, bug 218405, bug 218370.

Reported using DrKonqi
Comment 1 Thomas Lübking 2009-12-15 23:40:00 UTC

*** This bug has been marked as a duplicate of bug 216908 ***