Bug 218761 - KWin crashes when clicking 'show hidden icons' on plasma panel [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: KWin crashes when clicking 'show hidden icons' on plasma panel [KWin::Scene::...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-15 07:11 UTC by Marek Śledziona
Modified: 2009-12-15 08:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Śledziona 2009-12-15 07:11:29 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) "release 197")
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) "release 197"
Qt Version: 4.6.0
Operating System: Linux 2.6.31.5-0.1-default i686
Distribution: "openSUSE 11.2 (i586)"

-- Information about the crash:
KWin crashed when showing hidden icons (with compositing enabled), but it does the same when e.g. entering a search command in yast's package manager or just starting/closing an application. First, the desktop lags, then KWin disappears and at last all desktop becomes black and nothing is visible. In some seconds after KWin starts again and works fine until next error. My KWin theme is Nitrogen.

The crash can be reproduced some of the times.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0xb76d5a3f in KWin::Scene::Window::buildQuads (this=0x8557a38, force=false) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:485
#7  0xb76d6b75 in KWin::Scene::paintSimpleScreen (this=0x81a3740, orig_mask=8, region=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:237
#8  0xb76d42aa in KWin::Scene::finalPaintScreen (this=0x81a3740, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:176
#9  0xb76ee5d5 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:126
#10 0xafa31732 in KWin::LogoutEffect::paintScreen (this=0x851eec8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/logout/logout.cpp:196
#11 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#12 0xafa52a78 in KWin::ShadowEffect::paintScreen (this=0x851ab28, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/shadow/shadow.cpp:182
#13 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#14 0xafa38434 in KWin::PresentWindowsEffect::paintScreen (this=0x8529c88, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/presentwindows/presentwindows.cpp:191
#15 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#16 0xb6d5a5aa in KWin::Effect::paintScreen (this=0x8522f38, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#17 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#18 0xb6d5a5aa in KWin::Effect::paintScreen (this=0x84d5438, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#19 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#20 0xb6d5a5aa in KWin::Effect::paintScreen (this=0x851b4b0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#21 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#22 0xb6d5a5aa in KWin::Effect::paintScreen (this=0x84f8348, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#23 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#24 0xb6d5a5aa in KWin::Effect::paintScreen (this=0x837df40, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#25 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#26 0xafa1c7a3 in KWin::DesktopGridEffect::paintScreen (this=0x852a500, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/desktopgrid/desktopgrid.cpp:151
#27 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#28 0xb6d5a5aa in KWin::Effect::paintScreen (this=0x8525150, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#29 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#30 0xafa6e958 in KWin::CubeEffect::paintScreen (this=0x84f7108, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/cube/cube.cpp:697
#31 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#32 0xafa7661f in KWin::CubeSlideEffect::paintScreen (this=0x84f4c90, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/cube/cubeslide.cpp:105
#33 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#34 0xb6d5a5aa in KWin::Effect::paintScreen (this=0x8528460, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#35 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#36 0xb6d5a5aa in KWin::Effect::paintScreen (this=0x8528058, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#37 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#38 0xafa6543a in KWin::CoverSwitchEffect::paintScreen (this=0x8384df0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/coverswitch/coverswitch.cpp:124
#39 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#40 0xb6d5a5aa in KWin::Effect::paintScreen (this=0x851fb00, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#41 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#42 0xb6d5a5aa in KWin::Effect::paintScreen (this=0x84f7cf8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#43 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#44 0xb6d5a5aa in KWin::Effect::paintScreen (this=0x852a6c8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#45 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#46 0xafa61caa in KWin::ZoomEffect::paintScreen (this=0x85285d0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/zoom/zoom.cpp:73
#47 0xb76ee665 in KWin::EffectsHandlerImpl::paintScreen (this=0x816dd80, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#48 0xb76d6699 in KWin::Scene::paintScreen (this=0x81a3740, mask=0xbfad21d8, region=0xbfad22a4) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:134
#49 0xb76e6a38 in KWin::SceneOpenGL::paint (this=0x81a3740, damage=..., toplevels=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene_opengl.cpp:747
#50 0xb76d0642 in KWin::Workspace::performCompositing (this=0x8159168) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/composite.cpp:424
#51 0xb764aba0 in KWin::Workspace::qt_metacall (this=0x8159168, _c=InvokeMetaMethod, _id=173, _a=0xbfad23bc) at /usr/src/debug/kdebase-workspace-4.3.80/build/kwin/workspace.moc:535
#52 0xb5c31d4d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#53 0xb5c40b76 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#54 0xb5c94345 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#55 0xb5c48fe6 in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#56 0xb5c3d654 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#57 0xb5ef31dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#58 0xb5efa000 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#59 0xb7295451 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#60 0xb76651f1 in KWin::Application::notify (this=0xbfad2c18, o=0x81593f0, e=0xbfad28b4) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/main.cpp:370
#61 0xb5c2c9de in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#62 0xb5c5cd3e in ?? () from /usr/lib/libQtCore.so.4
#63 0xb5c599d5 in ?? () from /usr/lib/libQtCore.so.4
#64 0xb2fad4c2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#65 0xb2fb0d98 in ?? () from /usr/lib/libglib-2.0.so.0
#66 0xb2fb0ebe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#67 0xb5c59671 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#68 0xb5fb18fa in ?? () from /usr/lib/libQtGui.so.4
#69 0xb5c2b04d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#70 0xb5c2b499 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#71 0xb5c2f610 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#72 0xb5ef3284 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#73 0xb7666e54 in kdemain (argc=3, argv=0xbfad2e14) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/main.cpp:526
#74 0x080485fb in main (argc=3, argv=0xbfad2e14) at /usr/src/debug/kdebase-workspace-4.3.80/build/kwin/kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 216908.

Possible duplicates by query: bug 218621, bug 218405, bug 218370, bug 218150, bug 217979.

Reported using DrKonqi
Comment 1 Martin Flöser 2009-12-15 08:54:53 UTC

*** This bug has been marked as a duplicate of bug 216908 ***