Bug 218621 - Kwin crashed when i printed from OpenOffice Word [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: Kwin crashed when i printed from OpenOffice Word [KWin::Scene::Window::buildQ...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-14 10:30 UTC by felix
Modified: 2009-12-14 10:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description felix 2009-12-14 10:30:54 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
Qt Version: 4.6.0
Operating System: Linux 2.6.32-7-generic x86_64
Distribution: Ubuntu lucid (development branch)

-- Information about the crash:
Kwin crashed when i printed from OpenOffice Word. Whole Plasma-Environment recovered successfully.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0x1090170, force=<value optimized out>) at ../../kwin/scene.cpp:485
#6  0x00007fb58754593c in KWin::Scene::paintSimpleScreen (this=0x8ecf80, orig_mask=<value optimized out>, region=<value optimized out>) at ../../kwin/scene.cpp:237
#7  0x00007fb587543395 in KWin::Scene::finalPaintScreen (this=0x8ecf80, mask=8, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:176
#8  0x00007fb58755a246 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=8, region=) at ../../kwin/effects.cpp:126
#9  0x00007fb57612cd58 in KWin::SnowEffect::paintScreen (this=0xa0df00, mask=8, region=) at ../../../kwin/effects/snow/snow.cpp:120
#10 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#11 0x00007fb5760d83df in KWin::LogoutEffect::paintScreen (this=0x9ee340, mask=8, region=<value optimized out>, data=...) at ../../../kwin/effects/logout/logout.cpp:196
#12 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#13 0x00007fb5760f75b0 in KWin::ShadowEffect::paintScreen (this=0x9cf6a0, mask=8, region=) at ../../../kwin/effects/shadow/shadow.cpp:182
#14 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#15 0x00007fb5760deab2 in KWin::PresentWindowsEffect::paintScreen (this=0x9e4cb0, mask=8, region=) at ../../../kwin/effects/presentwindows/presentwindows.cpp:191
#16 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#17 0x00007fb585d7901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#18 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#19 0x00007fb585d7901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#20 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#21 0x00007fb585d7901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#22 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#23 0x00007fb585d7901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#24 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#25 0x00007fb585d7901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#27 0x00007fb585d7901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#29 0x00007fb5760c4772 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:151
#30 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#31 0x00007fb585d7901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#33 0x00007fb576111052 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=8, region=) at ../../../kwin/effects/cube/cube.cpp:697
#34 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#35 0x00007fb5761183a2 in KWin::CubeSlideEffect::paintScreen (this=<value optimized out>, mask=8, region=) at ../../../kwin/effects/cube/cubeslide.cpp:105
#36 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#37 0x00007fb585d7901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#38 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#39 0x00007fb585d7901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#40 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#41 0x00007fb5761084d4 in KWin::CoverSwitchEffect::paintScreen (this=0x9feab0, mask=8, region=<value optimized out>, data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:124
#42 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#43 0x00007fb585d7901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#45 0x00007fb585d7901f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#47 0x00007fb5761032f3 in KWin::ThumbnailAsideEffect::paintScreen (this=0x9aae20, mask=8, region=<value optimized out>, data=...) at ../../../kwin/effects/thumbnailaside/thumbnailaside.cpp:56
#48 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#49 0x00007fb576105101 in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=8, region=) at ../../../kwin/effects/zoom/zoom.cpp:73
#50 0x00007fb58755a2de in KWin::EffectsHandlerImpl::paintScreen (this=0x94b9a0, mask=8, region=) at ../../kwin/effects.cpp:122
#51 0x00007fb5875454a5 in KWin::Scene::paintScreen (this=0x8ecf80, mask=0x7fff32fb7fac, region=0x7fff32fb80d0) at ../../kwin/scene.cpp:134
#52 0x00007fb587553b70 in KWin::SceneOpenGL::paint (this=0x8ecf80, damage=<value optimized out>, toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:747
#53 0x00007fb58753fe47 in KWin::Workspace::performCompositing (this=<value optimized out>) at ../../kwin/composite.cpp:424
#54 0x00007fb5874cb51e in KWin::Workspace::qt_metacall (this=0x91f510, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff32fb8280) at ./workspace.moc:535
#55 0x00007fb58311c833 in QMetaObject::activate (sender=0x91f980, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xd5) at kernel/qobject.cpp:3294
#56 0x00007fb5831194a3 in QObject::event (this=0x91f980, e=0x7fff32fb8940) at kernel/qobject.cpp:1224
#57 0x00007fb583853f2c in QApplicationPrivate::notify_helper (this=0x77b7c0, receiver=0x91f980, e=0x7fff32fb8940) at kernel/qapplication.cpp:4242
#58 0x00007fb58385a53d in QApplication::notify (this=0x7fff32fb8ca0, receiver=0x91f980, e=0x7fff32fb8940) at kernel/qapplication.cpp:4125
#59 0x00007fb586d127d6 in KApplication::notify (this=0x7fff32fb8ca0, receiver=0x91f980, event=0x7fff32fb8940) at ../../kdeui/kernel/kapplication.cpp:302
#60 0x00007fb583109abc in QCoreApplication::notifyInternal (this=0x7fff32fb8ca0, receiver=0x91f980, event=0x7fff32fb8940) at kernel/qcoreapplication.cpp:704
#61 0x00007fb5831367a2 in QCoreApplication::sendEvent (this=0x77f600) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#62 QTimerInfoList::activateTimers (this=0x77f600) at kernel/qeventdispatcher_unix.cpp:603
#63 0x00007fb583133388 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#64 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#65 0x00007fb57c1e4d4e in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#66 0x00007fb57c1e8718 in ?? () from /lib/libglib-2.0.so.0
#67 0x00007fb57c1e8840 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#68 0x00007fb583133053 in QEventDispatcherGlib::processEvents (this=0x762100, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#69 0x00007fb5839023de in QGuiEventDispatcherGlib::processEvents (this=0x7fff32fb5fb0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#70 0x00007fb5831083e2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#71 0x00007fb5831087bc in QEventLoop::exec (this=0x7fff32fb8be0, flags=) at kernel/qeventloop.cpp:201
#72 0x00007fb58310c4fb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#73 0x00007fb5874e4b0e in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kwin/main.cpp:526
#74 0x00007fb587144add in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff32fb91a8) at libc-start.c:220
#75 0x0000000000400679 in _start ()

Possible duplicates by query: bug 218405, bug 218370, bug 218150, bug 217979, bug 217945.

Reported using DrKonqi
Comment 1 Martin Flöser 2009-12-14 10:32:49 UTC

*** This bug has been marked as a duplicate of bug 216908 ***