Bug 218405 - Kwin crash when clicking "Show hidden icons" [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: Kwin crash when clicking "Show hidden icons" [KWin::Scene::Window::buildQuads...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-12 18:21 UTC by Lukas
Modified: 2009-12-12 18:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas 2009-12-12 18:21:15 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) "release 197")
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) "release 197"
Qt Version: 4.6.0
Operating System: Linux 2.6.31.5-0.1-default i686
Distribution: "openSUSE 11.2 (i586)"

-- Information about the crash:
Kwin crashed when clicking "Show hidden icons". 

As for dublicates, i found possible dublicates, but they are already closed. 
My kde setup was last updated in ~evening 09'-12-11, so if they there closed later, close this bug to (i'm currently updating to se if i could reproduce later) :)

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0xb7703a3f in KWin::Scene::Window::buildQuads (this=0x8b5baf8, force=false) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:485
#7  0xb7704b75 in KWin::Scene::paintSimpleScreen (this=0x8165bd8, orig_mask=8, region=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:237
#8  0xb77022aa in KWin::Scene::finalPaintScreen (this=0x8165bd8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:176
#9  0xb771c5d5 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:126
#10 0xb0055732 in KWin::LogoutEffect::paintScreen (this=0x82196f8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/logout/logout.cpp:196
#11 0xb771c665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#12 0xb0076a78 in KWin::ShadowEffect::paintScreen (this=0x81fd0a8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/shadow/shadow.cpp:182
#13 0xb771c665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#14 0xb005c434 in KWin::PresentWindowsEffect::paintScreen (this=0x821a8a0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/presentwindows/presentwindows.cpp:191
#15 0xb771c665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#16 0xb6d885aa in KWin::Effect::paintScreen (this=0x823fa10, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#17 0xb771c665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#18 0xb6d885aa in KWin::Effect::paintScreen (this=0x820afe0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#19 0xb771c665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#20 0xb6d885aa in KWin::Effect::paintScreen (this=0x8200bd8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#21 0xb771c665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#22 0xb6d885aa in KWin::Effect::paintScreen (this=0x815b4b8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#23 0xb771c665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#24 0xb00407a3 in KWin::DesktopGridEffect::paintScreen (this=0x820cfb8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/desktopgrid/desktopgrid.cpp:151
#25 0xb771c665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#26 0xb009a61f in KWin::CubeSlideEffect::paintScreen (this=0x8204338, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/cube/cubeslide.cpp:105
#27 0xb771c665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#28 0xb6d885aa in KWin::Effect::paintScreen (this=0x823f820, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#29 0xb771c665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#30 0xb6d885aa in KWin::Effect::paintScreen (this=0x8210d88, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#31 0xb771c665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#32 0xb6d885aa in KWin::Effect::paintScreen (this=0x823f8c0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#33 0xb771c665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#34 0xb0085caa in KWin::ZoomEffect::paintScreen (this=0x8238f88, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/zoom/zoom.cpp:73
#35 0xb771c665 in KWin::EffectsHandlerImpl::paintScreen (this=0x81aa598, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#36 0xb7704699 in KWin::Scene::paintScreen (this=0x8165bd8, mask=0xbfac0b58, region=0xbfac0c24) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:134
#37 0xb7714a38 in KWin::SceneOpenGL::paint (this=0x8165bd8, damage=..., toplevels=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene_opengl.cpp:747
#38 0xb76fe642 in KWin::Workspace::performCompositing (this=0x815a910) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/composite.cpp:424
#39 0xb7678ba0 in KWin::Workspace::qt_metacall (this=0x815a910, _c=InvokeMetaMethod, _id=173, _a=0xbfac0d3c) at /usr/src/debug/kdebase-workspace-4.3.80/build/kwin/workspace.moc:535
#40 0xb5c5ed4d in QMetaObject::metacall (object=0x815a910, cl=3062349569, idx=173, argv=0xbfac0d3c) at kernel/qmetaobject.cpp:237
#41 0xb5c6db76 in QMetaObject::activate (sender=0x815ab98, m=0xb5d705a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3294
#42 0xb5cc1345 in QTimer::timeout (this=0x815ab98) at .moc/release-shared/moc_qtimer.cpp:134
#43 0xb5c75fe6 in QTimer::timerEvent (this=0x815ab98, e=0xbfac1234) at kernel/qtimer.cpp:271
#44 0xb5c6a654 in QObject::event (this=0x815ab98, e=0x0) at kernel/qobject.cpp:1224
#45 0xb5f211dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#46 0xb5f28000 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#47 0xb72c3451 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#48 0xb76931f1 in KWin::Application::notify (this=0xbfac1598, o=0x815ab98, e=0xbfac1234) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/main.cpp:370
#49 0xb5c599de in QCoreApplication::notifyInternal (this=0xbfac1598, receiver=0x815ab98, event=0xbfac1234) at kernel/qcoreapplication.cpp:704
#50 0xb5c89d3e in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:215
#51 QTimerInfoList::activateTimers (event=<value optimized out>, receiver=<value optimized out>) at kernel/qeventdispatcher_unix.cpp:617
#52 0xb5c869d5 in timerSourceDispatch (source=0x8082fc0) at kernel/qeventdispatcher_glib.cpp:184
#53 idleTimerSourceDispatch (source=0x8082fc0) at kernel/qeventdispatcher_glib.cpp:231
#54 0xb2fda4c2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#55 0xb2fddd98 in ?? () from /usr/lib/libglib-2.0.so.0
#56 0xb2fddebe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#57 0xb5c86671 in QEventDispatcherGlib::processEvents (this=0x807feb0, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#58 0xb5fdf8fa in ?? () from /usr/lib/libQtGui.so.4
#59 0xb5c5804d in QEventLoop::processEvents (this=0xbfac14e4, flags=) at kernel/qeventloop.cpp:149
#60 0xb5c58499 in QEventLoop::exec (this=0xbfac14e4, flags=...) at kernel/qeventloop.cpp:201
#61 0xb5c5c610 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#62 0xb5f21284 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#63 0xb7694e54 in kdemain (argc=1, argv=0xbfac1794) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/main.cpp:526
#64 0x080485fb in main (argc=1, argv=0xbfac1794) at /usr/src/debug/kdebase-workspace-4.3.80/build/kwin/kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 216908, bug 216609.

Possible duplicates by query: bug 218370, bug 218150, bug 217979, bug 217945, bug 217831.

Reported using DrKonqi
Comment 1 Martin Flöser 2009-12-12 18:23:37 UTC

*** This bug has been marked as a duplicate of bug 216908 ***