Bug 209263 - Crash after Login in KDE [QX11PixmapData::toImage, QPixmap::toImage, KPixmapCache::Private::writeData]
Summary: Crash after Login in KDE [QX11PixmapData::toImage, QPixmap::toImage, KPixmapC...
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdeui (show other bugs)
Version: 4.3.1
Platform: Unlisted Binaries Linux
: NOR crash with 21 votes (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 212795 218998 220801 222155 231912 231943 232019 232322 232354 232742 233003 233296 233388 233701 234075 234130 234246 234333 234561 234576 234867 234954 235822 236091 236578 236782 236894 236969 237456 237576 239883 240373 240565 240605 241082 242004 242840 243339 244710 244888 244963 245551 246277 246616 246676 246764 246837 247579 247655 249504 249692 250148 250244 250301 250565 250954 251232 251358 251952 252183 252662 253471 253605 254903 255225 256697 257270 257876 258783 260609 260684 260945 260984 262505 262774 265784 265865 266279 267068 268820 269142 269746 276946 277629 279934 284058 285027 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-03 03:30 UTC by x545
Modified: 2016-03-06 22:05 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.5


Attachments
New crash information added by DrKonqi (3.64 KB, text/plain)
2010-03-16 17:21 UTC, Ondrej Masek
Details
New crash information added by DrKonqi (3.83 KB, text/plain)
2010-03-18 08:07 UTC, herr-schneider.m
Details
New crash information added by DrKonqi (1.92 KB, text/plain)
2010-08-18 01:32 UTC, Juan Carlos Rivera Espinoza
Details
New crash information added by DrKonqi (6.31 KB, text/plain)
2010-12-13 10:41 UTC, Georg Greve
Details
New crash information added by DrKonqi (4.95 KB, text/plain)
2011-01-29 13:25 UTC, Bruno Friedmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description x545 2009-10-03 03:30:58 UTC
Application that crashed: akonadi_googledata_resource
Version of the application: 0.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.31.1 x86_64
Distribution: Debian GNU/Linux 5.0.3 (lenny)

 -- Backtrace:
Application: Akonadi Resource (akonadi_googledata_resource), signal: Segmentation fault
[KCrash Handler]
#5  QX11PixmapData::toImage (this=<value optimized out>) at image/qpixmap_x11.cpp:1552
#6  0x0000003ec069895d in QPixmap::toImage (this=<value optimized out>) at image/qpixmap.cpp:447
#7  0x0000003ec489e251 in KPixmapCache::Private::writeData (this=<value optimized out>, key=<value optimized out>, pix=<value optimized out>) at ../../kdeui/util/kpixmapcache.cpp:1434
#8  0x0000003ec489ee34 in KPixmapCache::insert (this=<value optimized out>, key=<value optimized out>, pix=<value optimized out>) at ../../kdeui/util/kpixmapcache.cpp:1400
#9  0x0000003ec47f4f3d in KIconLoader::loadIcon (this=<value optimized out>, _name=<value optimized out>, group=<value optimized out>, size=<value optimized out>, state=<value optimized out>, 
    overlays=) at ../../kdeui/icons/kiconloader.cpp:1052
#10 0x0000003ec47f5567 in KIconLoader::loadIcon (this=<value optimized out>, _name=<value optimized out>, group=<value optimized out>, size=<value optimized out>, state=<value optimized out>, 
    overlays=) at ../../kdeui/icons/kiconloader.cpp:1177
#11 0x0000003ec47eb683 in KIconEngine::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>)
    at ../../kdeui/icons/kiconengine.cpp:119
#12 0x0000003ec0670b35 in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:713
#13 0x0000003ec065fc45 in QWidgetPrivate::setWindowIcon_sys (this=<value optimized out>, forceReset=<value optimized out>) at kernel/qwidget_x11.cpp:1347
#14 0x0000003ec0629c10 in QWidget::create (this=<value optimized out>, window=<value optimized out>, initializeWindow=<value optimized out>, destroyOldWindow=<value optimized out>)
    at kernel/qwidget.cpp:1283
#15 0x0000003ec064ccf9 in setupOwner () at kernel/qclipboard_x11.cpp:130
#16 0x0000003ec064ece9 in QClipboard (this=<value optimized out>, parent=<value optimized out>) at kernel/qclipboard_x11.cpp:452
#17 0x0000003ec05d79f4 in QApplication::clipboard () at kernel/qapplication.cpp:3045
#18 0x0000003ec482a58f in KClipboardSynchronizer::Private::setupSignals (this=<value optimized out>) at ../../kdeui/kernel/kclipboard.cpp:94
#19 0x0000003ec482a953 in KClipboardSynchronizer (this=<value optimized out>, parent=<value optimized out>) at ../../kdeui/kernel/kclipboard.cpp:84
#20 0x0000003ec482ab04 in operator-> () at ../../kdeui/kernel/kclipboard.cpp:73
#21 operator KClipboardSynchronizer* () at ../../kdeui/kernel/kclipboard.cpp:73
#22 KClipboardSynchronizer::self () at ../../kdeui/kernel/kclipboard.cpp:74
#23 0x0000003ec4826400 in KApplicationPrivate::init (this=<value optimized out>, GUIenabled=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:463
#24 0x0000003ec482788f in KApplication (this=<value optimized out>, GUIenabled=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:343
#25 0x0000000000409b47 in _start ()

Reported using DrKonqi
Comment 1 x545 2009-10-03 04:44:39 UTC
- crashes 3 times after login
- doesn't matter if I press restart or ok button
Comment 2 Dario Andres 2009-10-03 18:39:02 UTC
Mh, it could be a Qt or kdelibs issue.
- Did you got this google resource by debian packages or you manually compiled/installed it ?
Thanks
Comment 3 x545 2009-10-03 20:02:06 UTC
It is the official debian package:
Package: akonadi-kde-resource-googledata
Status: install ok installed
Priority: extra
Section: net
Installed-Size: 500
Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Architecture: amd64
Source: akonadi-googledata
Version: 1.0.1-1
Depends: kdebase-runtime (>= 4:4.3.0), kdelibs5 (>= 4:4.3.0),
kdepimlibs5 (>= 4:4.3.0), libc6 (>= 2.2.5), libgcal0, libgcc1 (>=
1:4.1.1), libqt4-dbus (>= 4:4.5.2), libqt4-svg (>= 4:4.5.2), libqtcore4
(>= 4:4.5.2), libqtgui4 (>= 4:4.5.2), libstdc++6 (>= 4.1.1)
Description: Google calendar and contacts resource for Akonadi
 It provides an easy access to Google calendars events and contacts.
 .
 This package contains the Google calendar and contacts resource for
Akonadi,
 a Personal Information Management (PIM) storage service.
Homepage: http://code.google.com/p/libgcal/

Sandro
Comment 4 Christophe Giboudeaux 2010-01-01 12:44:59 UTC
*** Bug 220801 has been marked as a duplicate of this bug. ***
Comment 5 Tobias Koenig 2010-03-16 13:01:37 UTC
*** Bug 222155 has been marked as a duplicate of this bug. ***
Comment 6 Tobias Koenig 2010-03-16 13:03:08 UTC
*** Bug 218998 has been marked as a duplicate of this bug. ***
Comment 7 Ondrej Masek 2010-03-16 17:21:04 UTC
Created attachment 41691 [details]
New crash information added by DrKonqi

Akonadi uses both CPUs at 100% for 30sec, then crashes
Comment 8 herr-schneider.m 2010-03-18 08:07:39 UTC
Created attachment 41730 [details]
New crash information added by DrKonqi

Crash on session startup.
Special circumstances were delayed initialization of encrypted home volume, no network connectivity.
Comment 9 Dario Andres 2010-03-23 21:47:36 UTC
From bug 231943:  (ksmserver crashed)
-- Information about the crash:
run automatic updates
update yum without errors
wait 30mins (i was reading :)) to reboot
reboot fine and freezed/crashed after login
Comment 10 Dario Andres 2010-03-23 21:47:45 UTC
*** Bug 231943 has been marked as a duplicate of this bug. ***
Comment 11 Dario Andres 2010-03-23 21:49:30 UTC
From bug 231912:
-- Information about the crash:
I logued out after upgrading some KDE packages (Fedora 12) and it crashed right
after I logued back in.
The login splash screen froze for a while and then the Crash Reporting
Assistant appeared.
Comment 12 Dario Andres 2010-03-23 21:49:35 UTC
*** Bug 231912 has been marked as a duplicate of this bug. ***
Comment 13 Dario Andres 2010-03-26 13:41:16 UTC
*** Bug 232019 has been marked as a duplicate of this bug. ***
Comment 14 Dario Andres 2010-03-27 23:29:22 UTC
From bug 232354:
-- Information about the crash:
I did an update, restarted, and when logging in the desktop never showed up and
I got this crash message.
Comment 15 Dario Andres 2010-03-27 23:29:24 UTC
*** Bug 232322 has been marked as a duplicate of this bug. ***
Comment 16 Dario Andres 2010-03-27 23:29:28 UTC
*** Bug 232354 has been marked as a duplicate of this bug. ***
Comment 17 Dario Andres 2010-03-27 23:41:03 UTC
As a possible workaround, you may want to try to cleanup your "/var/tmp/kdecache-USERNAME/kpc/" directory.
Comment 18 Dario Andres 2010-03-31 14:57:23 UTC
*** Bug 232742 has been marked as a duplicate of this bug. ***
Comment 19 Nicolas L. 2010-04-02 12:03:27 UTC
*** Bug 233003 has been marked as a duplicate of this bug. ***
Comment 20 Dario Andres 2010-04-03 15:08:12 UTC
*** Bug 212795 has been marked as a duplicate of this bug. ***
Comment 21 Dario Andres 2010-04-05 19:58:43 UTC
*** Bug 233388 has been marked as a duplicate of this bug. ***
Comment 22 Dario Andres 2010-04-06 02:05:17 UTC
*** Bug 233296 has been marked as a duplicate of this bug. ***
Comment 23 Dario Andres 2010-04-08 14:48:49 UTC
*** Bug 233701 has been marked as a duplicate of this bug. ***
Comment 24 Nicolas L. 2010-04-12 09:10:49 UTC
*** Bug 234130 has been marked as a duplicate of this bug. ***
Comment 25 Dario Andres 2010-04-13 14:37:00 UTC
*** Bug 234075 has been marked as a duplicate of this bug. ***
Comment 26 Dario Andres 2010-04-13 14:37:02 UTC
*** Bug 234246 has been marked as a duplicate of this bug. ***
Comment 27 Dario Andres 2010-04-16 23:26:31 UTC
*** Bug 234561 has been marked as a duplicate of this bug. ***
Comment 28 Martin Flöser 2010-04-17 08:20:10 UTC
*** Bug 234576 has been marked as a duplicate of this bug. ***
Comment 29 Christoph Feck 2010-04-20 12:55:15 UTC
*** Bug 234867 has been marked as a duplicate of this bug. ***
Comment 30 Esben Mose Hansen 2010-05-03 13:36:05 UTC
*** Bug 236091 has been marked as a duplicate of this bug. ***
Comment 31 Christoph Feck 2010-05-08 22:12:53 UTC
*** Bug 236578 has been marked as a duplicate of this bug. ***
Comment 32 Christoph Feck 2010-05-08 22:14:47 UTC
*** Bug 236894 has been marked as a duplicate of this bug. ***
Comment 33 Christoph Feck 2010-05-09 13:10:28 UTC
*** Bug 236969 has been marked as a duplicate of this bug. ***
Comment 34 Jonathan Thomas 2010-05-28 20:18:59 UTC
*** Bug 239883 has been marked as a duplicate of this bug. ***
Comment 35 Christoph Feck 2010-06-02 04:31:20 UTC
*** Bug 240373 has been marked as a duplicate of this bug. ***
Comment 36 Nicolas L. 2010-06-03 10:20:11 UTC
*** Bug 240565 has been marked as a duplicate of this bug. ***
Comment 37 Jonathan Thomas 2010-06-03 22:05:30 UTC
*** Bug 240605 has been marked as a duplicate of this bug. ***
Comment 38 Ales Seifert 2010-06-18 06:44:08 UTC
*** This bug has been confirmed by popular vote. ***
Comment 39 Nicolas L. 2010-06-18 09:50:41 UTC
*** Bug 242004 has been marked as a duplicate of this bug. ***
Comment 40 Christoph Feck 2010-06-26 13:47:15 UTC
*** Bug 242840 has been marked as a duplicate of this bug. ***
Comment 41 Christoph Feck 2010-06-26 15:41:33 UTC
*** Bug 234954 has been marked as a duplicate of this bug. ***
Comment 42 Christoph Feck 2010-06-26 15:42:12 UTC
*** Bug 236782 has been marked as a duplicate of this bug. ***
Comment 43 Christoph Feck 2010-06-26 15:42:42 UTC
*** Bug 237456 has been marked as a duplicate of this bug. ***
Comment 44 Christoph Feck 2010-06-26 15:43:16 UTC
*** Bug 234333 has been marked as a duplicate of this bug. ***
Comment 45 Christoph Feck 2010-06-26 15:43:51 UTC
*** Bug 237576 has been marked as a duplicate of this bug. ***
Comment 46 Christoph Feck 2010-06-26 15:44:17 UTC
*** Bug 235822 has been marked as a duplicate of this bug. ***
Comment 47 Christoph Feck 2010-06-26 15:44:47 UTC
*** Bug 241082 has been marked as a duplicate of this bug. ***
Comment 48 Christoph Feck 2010-06-26 16:11:01 UTC
SVN commit 1143110 by cfeck:

Make sure QClipboard is created before setting the window icon

The window icon will usually be a KIcon. Not really sure at which
stage in KApplication initialization we are ready to access icons,
but looking at how late we trigger KGlobalSettings, we should not
set the global window icon before creating the clipboard.

BUG: 209263


 M  +4 -0      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1143110
Comment 49 Christoph Feck 2010-07-17 17:01:37 UTC
*** Bug 244963 has been marked as a duplicate of this bug. ***
Comment 50 Christoph Feck 2010-07-17 17:04:10 UTC
*** Bug 244888 has been marked as a duplicate of this bug. ***
Comment 51 Christoph Feck 2010-07-17 17:04:58 UTC
*** Bug 243339 has been marked as a duplicate of this bug. ***
Comment 52 Christoph Feck 2010-07-17 17:05:24 UTC
*** Bug 244710 has been marked as a duplicate of this bug. ***
Comment 53 Christoph Feck 2010-07-18 14:50:26 UTC
*** Bug 244963 has been marked as a duplicate of this bug. ***
Comment 54 Christoph Feck 2010-07-30 16:05:07 UTC
*** Bug 246277 has been marked as a duplicate of this bug. ***
Comment 55 Christoph Feck 2010-07-30 16:10:28 UTC
*** Bug 245551 has been marked as a duplicate of this bug. ***
Comment 56 Myriam Schweingruber 2010-08-03 19:30:31 UTC
*** Bug 246616 has been marked as a duplicate of this bug. ***
Comment 57 Christoph Feck 2010-08-04 11:57:54 UTC
*** Bug 246676 has been marked as a duplicate of this bug. ***
Comment 58 Christoph Feck 2010-08-05 13:33:26 UTC
*** Bug 246764 has been marked as a duplicate of this bug. ***
Comment 59 Pino Toscano 2010-08-13 01:24:59 UTC
*** Bug 247579 has been marked as a duplicate of this bug. ***
Comment 60 Thomas Lübking 2010-08-14 23:10:57 UTC
*** Bug 247655 has been marked as a duplicate of this bug. ***
Comment 61 Juan Carlos Rivera Espinoza 2010-08-18 01:32:46 UTC
Created attachment 50672 [details]
New crash information added by DrKonqi

When logon starts, the called program crashes.
Comment 62 FiNeX 2010-08-18 13:18:57 UTC
@Juan Carlos Rivera Espinoza: please, don't attach bactkraces but paste directly in the comment. 



--- backtrace from comment #61 ---


Application: klipper (v0.9.7)
KDE Platform Version: 4.4.5 (KDE 4.4.5) (Compiled from sources)
Qt Version: 4.6.3
Operating System: Linux 2.6.33.6-147.2.4.fc13.i686 i686
Distribution: "Fedora release 13 (Goddard)"

-- Information about the crash:
When logon starts, the called program crashes.

 -- Backtrace:
Application: Klipper (klipper), signal: Aborted
[KCrash Handler]
#6  0x0053b416 in __kernel_vsyscall ()
#7  0x00b30d11 in raise () from /lib/libc.so.6
#8  0x00b325ea in abort () from /lib/libc.so.6
#9  0x003f0397 in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/libstdc++.so.6
#10 0x003ee226 in ?? () from /usr/lib/libstdc++.so.6
#11 0x003ee263 in std::terminate() () from /usr/lib/libstdc++.so.6
#12 0x003ee3a2 in __cxa_throw () from /usr/lib/libstdc++.so.6
#13 0x04bf4816 in qBadAlloc() () from /usr/lib/libQtCore.so.4
#14 0x04bffe5d in qUncompress(unsigned char const*, int) () from /usr/lib/libQtCore.so.4
#15 0x03d84bce in KPixmapCache::Private::loadData(int, QPixmap&) () from /usr/lib/libkdeui.so.5
#16 0x03d86872 in KPixmapCache::find(QString const&, QPixmap&) () from /usr/lib/libkdeui.so.5
#17 0x03cd1e2c in KIconCache::find(QString const&, QPixmap&) () from /usr/lib/libkdeui.so.5
#18 0x03cd2b51 in KIconCache::find(QString const&, QPixmap&, QString*) () from /usr/lib/libkdeui.so.5
#19 0x03cc7c87 in KIconLoader::loadIcon(QString const&, KIconLoader::Group, int, int, QStringList const&, QString*, bool) const () from /usr/lib/libkdeui.so.5
#20 0x03d35245 in KSystemTrayIcon::loadIcon(QString const&, KComponentData const&) () from /usr/lib/libkdeui.so.5
#21 0x03d35853 in KSystemTrayIcon::KSystemTrayIcon(QString const&, QWidget*) () from /usr/lib/libkdeui.so.5
#22 0x009aae58 in ?? () from /usr/lib/libkdeinit4_klipper.so
#23 0x009aa8ad in kdemain () from /usr/lib/libkdeinit4_klipper.so
#24 0x080486dc in _start ()

Possible duplicates by query: bug 237576, bug 236969, bug 236091, bug 234987, bug 234867.

Reported using DrKonqi
Comment 63 Christoph Feck 2010-08-30 14:12:51 UTC
*** Bug 249504 has been marked as a duplicate of this bug. ***
Comment 64 Christoph Feck 2010-09-01 03:39:03 UTC
*** Bug 249692 has been marked as a duplicate of this bug. ***
Comment 65 Christoph Feck 2010-09-04 12:06:22 UTC
*** Bug 250148 has been marked as a duplicate of this bug. ***
Comment 66 Christoph Feck 2010-09-08 15:37:24 UTC
*** Bug 250565 has been marked as a duplicate of this bug. ***
Comment 67 Thomas Lübking 2010-09-13 18:27:12 UTC
*** Bug 251106 has been marked as a duplicate of this bug. ***
Comment 68 Christoph Feck 2010-09-15 21:50:11 UTC
*** Bug 251358 has been marked as a duplicate of this bug. ***
Comment 69 Christoph Feck 2010-09-15 21:55:53 UTC
*** Bug 250244 has been marked as a duplicate of this bug. ***
Comment 70 Christoph Feck 2010-09-15 21:56:15 UTC
*** Bug 250301 has been marked as a duplicate of this bug. ***
Comment 71 Christoph Feck 2010-09-15 21:56:37 UTC
*** Bug 250954 has been marked as a duplicate of this bug. ***
Comment 72 Christoph Feck 2010-09-15 21:56:55 UTC
*** Bug 251232 has been marked as a duplicate of this bug. ***
Comment 73 Christoph Feck 2010-09-15 22:08:21 UTC
*** Bug 246837 has been marked as a duplicate of this bug. ***
Comment 74 Peter Penz 2010-09-22 14:37:45 UTC
*** Bug 251952 has been marked as a duplicate of this bug. ***
Comment 75 Myriam Schweingruber 2010-09-23 23:28:32 UTC
*** Bug 252183 has been marked as a duplicate of this bug. ***
Comment 76 Christoph Feck 2010-09-28 17:53:11 UTC
*** Bug 252662 has been marked as a duplicate of this bug. ***
Comment 77 thomas.hotz 2010-10-04 21:20:36 UTC
(In reply to comment #17)
> As a possible workaround, you may want to try to cleanup your
> "/var/tmp/kdecache-USERNAME/kpc/" directory.

Thanks a lot for the hint, worked for me.
Comment 78 Christoph Feck 2010-10-07 14:47:04 UTC
*** Bug 253471 has been marked as a duplicate of this bug. ***
Comment 79 Christoph Feck 2010-10-08 18:21:18 UTC
*** Bug 253605 has been marked as a duplicate of this bug. ***
Comment 80 Christoph Feck 2010-10-25 16:39:45 UTC
*** Bug 255225 has been marked as a duplicate of this bug. ***
Comment 81 Christoph Feck 2010-11-13 16:02:11 UTC
*** Bug 256697 has been marked as a duplicate of this bug. ***
Comment 82 Christoph Feck 2010-11-13 16:03:10 UTC
*** Bug 254903 has been marked as a duplicate of this bug. ***
Comment 83 Christoph Feck 2010-11-18 21:25:00 UTC
*** Bug 257270 has been marked as a duplicate of this bug. ***
Comment 84 Christoph Feck 2010-11-25 16:01:49 UTC
*** Bug 257876 has been marked as a duplicate of this bug. ***
Comment 85 Christoph Feck 2010-12-04 12:56:49 UTC
*** Bug 258783 has been marked as a duplicate of this bug. ***
Comment 86 Georg Greve 2010-12-13 10:41:25 UTC
Created attachment 54489 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.5.4 (KDE 4.5.4) using Qt 4.7.1

- What I was doing when the application crashed:

Browsing the web. So likely unrelated.

- Unusual behavior I noticed:

Computer was quite slow and unresponsive. After crash it seemed to get better.

-- Backtrace (Reduced):
#10 0x002fdc45 in __gnu_cxx::__verbose_terminate_handler () at ../../../../libstdc++-v3/libsupc++/vterminate.cc:93
#11 0x002fbb16 in __cxxabiv1::__terminate (handler=0x2fdaf0 <__gnu_cxx::__verbose_terminate_handler()>) at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:39
#12 0x002fbb53 in std::terminate () at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:49
#13 0x002fbcd2 in __cxxabiv1::__cxa_throw (obj=0xb47d3970, tinfo=0x33080c, dest=0x29f830 <std::length_error::~length_error()>) at ../../../../libstdc++-v3/libsupc++/eh_throw.cc:83
#14 0x0029fdb0 in std::__throw_length_error (__s=0x308b63 "basic_string::_S_create") at ../../../../libstdc++-v3/src/functexcept.cc:74
Comment 87 Dario Andres 2010-12-13 13:01:35 UTC
Note that the last comment (comment 86) is a Strigi (file indexer) bug unrelated to this report which was fixed in KDE SC 4.5. Please report that error to the Strigi bugtracker if you can reproduce: http://sourceforge.net/tracker/?group_id=171000&atid=856302
Thanks
Comment 88 Dario Andres 2010-12-18 14:06:02 UTC
*** Bug 260609 has been marked as a duplicate of this bug. ***
Comment 89 Dario Andres 2010-12-19 16:47:26 UTC
*** Bug 260684 has been marked as a duplicate of this bug. ***
Comment 90 Dario Andres 2010-12-22 22:25:49 UTC
*** Bug 260984 has been marked as a duplicate of this bug. ***
Comment 91 Dario Andres 2010-12-23 00:08:34 UTC
*** Bug 260945 has been marked as a duplicate of this bug. ***
Comment 92 Christoph Feck 2011-01-08 15:42:33 UTC
*** Bug 262505 has been marked as a duplicate of this bug. ***
Comment 93 Bruno Friedmann 2011-01-29 13:25:31 UTC
Created attachment 56612 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.1

- What I was doing when the application crashed: unfortunately there's a case we can crash it. 
This is how to reproduce it even wth 4.6.0
I've to explain my setup : 

/ioda/data can have to state, serve as mountpoint when I'm connected to my main nfs server, otherwise it's a symlink to my local synchronised (by unison) data pointing to /home/ioda_data

Some of my pim data, and also nepomuk indexed folders are on this place.

So this time I've start kde with the nfs mounted. and launch the syncronizing process. No trouble.
At this end of the process, I unmount the nfs share and replace it by it's symlink.
(the umount process goes well, so we can affirm at this time no files where open)
I've only konversation open at that time + konsole 

Once the symlink has been in place virtuoso-t start running at 100% cpu during 4-5minutes. In the mean times, I loose plasma control (can't change desktop by clicking on icon in systray bar. but able to change with ctrl+F# )
60 to 80 minutes after virtuoso-t running at 100% plasma-desktop start using 100% cpu too. Then crash (this backtrace) and restart properly.

After plasma-desktop restart everything works as expected.

It's pretty easy to me to reproduce it, so if dev's give me the how to get a good valgrind trace (which process must be analized) I can give that one.

-- Backtrace (Reduced):
#8  0x00007f0e95228b3d in __gnu_cxx::__verbose_terminate_handler () at ../../../../libstdc++-v3/libsupc++/vterminate.cc:93
#9  0x00007f0e95226d56 in __cxxabiv1::__terminate (handler=<value optimized out>) at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:39
#10 0x00007f0e95226d83 in std::terminate () at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:49
#11 0x00007f0e95226ed6 in __cxxabiv1::__cxa_rethrow () at ../../../../libstdc++-v3/libsupc++/eh_throw.cc:116
#12 0x00007f0e9648d373 in QEventLoop::exec (this=0x7fff9c9cc780, flags=...) at kernel/qeventloop.cpp:214
Comment 94 Dario Andres 2011-01-29 13:30:08 UTC
[Comment from a bug triager]

@Bruno: you will need to create another bug report as yours is different to the original one here (that one was fixed on KDE SC 4.5); also, your backtrace is not the same, even when the crash handler said so (that's a limitation of the crash handle)
Good enough, you provided lot of information, so I guess developers can check it.
- Can you create a new bug report against plasma-desktop, please ?

To other people: please do not add more KDE SC 4.5.0 or later reports; as this specific crash (with the backtrace including "KPixmapCache" as the title says) is fixed for KDE SC 4.5.0

THANKS
Comment 95 Bruno Friedmann 2011-01-29 13:52:17 UTC
@Dario : new bug 264738 is open now with the full details reported 

Sorry, I've been wrongly drive by drkonqi here.
Comment 96 Dario Andres 2011-01-29 13:54:05 UTC
[Comment from a bug triager]
Thank you very much!
Comment 97 Christophe Giboudeaux 2011-02-09 12:31:25 UTC
*** Bug 265865 has been marked as a duplicate of this bug. ***
Comment 98 Christophe Giboudeaux 2011-02-14 11:43:26 UTC
*** Bug 266279 has been marked as a duplicate of this bug. ***
Comment 99 Christophe Giboudeaux 2011-02-14 14:01:34 UTC
*** Bug 262774 has been marked as a duplicate of this bug. ***
Comment 100 robert Lain 2011-02-15 10:52:13 UTC
Christophe,
Sunday I installed the latest  security update for Java from Debian Squeeze 
and the Akonadi crash when launching Kmail has not shown up since.
Comment 101 Christoph Feck 2011-02-24 20:14:03 UTC
*** Bug 267068 has been marked as a duplicate of this bug. ***
Comment 102 Christoph Feck 2011-03-22 15:10:11 UTC
*** Bug 265784 has been marked as a duplicate of this bug. ***
Comment 103 Christoph Feck 2011-03-22 15:10:35 UTC
*** Bug 269142 has been marked as a duplicate of this bug. ***
Comment 104 Beat Wolf 2011-03-26 13:01:45 UTC
*** Bug 258745 has been marked as a duplicate of this bug. ***
Comment 105 Beat Wolf 2011-03-26 13:01:52 UTC
*** Bug 269249 has been marked as a duplicate of this bug. ***
Comment 106 Christoph Feck 2011-03-30 21:31:16 UTC
*** Bug 269746 has been marked as a duplicate of this bug. ***
Comment 107 Christophe Giboudeaux 2011-04-24 14:12:12 UTC
*** Bug 268820 has been marked as a duplicate of this bug. ***
Comment 108 Christophe Giboudeaux 2011-07-13 11:02:22 UTC
*** Bug 277629 has been marked as a duplicate of this bug. ***
Comment 109 Dario Andres 2011-08-07 20:23:44 UTC
*** Bug 276946 has been marked as a duplicate of this bug. ***
Comment 110 Dario Andres 2011-08-12 15:50:03 UTC
*** Bug 279934 has been marked as a duplicate of this bug. ***
Comment 111 Christophe Giboudeaux 2011-10-15 09:11:38 UTC
*** Bug 284058 has been marked as a duplicate of this bug. ***
Comment 112 Christophe Giboudeaux 2011-10-15 09:13:35 UTC
Clearing the CC list. There's no need to spam everyone for a bug fixed more than one year ago.
Comment 113 robert Lain 2011-10-18 17:55:42 UTC
Christophe
Je n'ai pas eu le bug depuis les dernières mises à jour.
Comment 114 Christoph Feck 2011-10-26 20:18:48 UTC
*** Bug 285027 has been marked as a duplicate of this bug. ***