Bug 279934 - Kmix crashed when using facebook
Summary: Kmix crashed when using facebook
Status: RESOLVED DUPLICATE of bug 209263
Alias: None
Product: kmix
Classification: Applications
Component: general (show other bugs)
Version: 3.6
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Christian Esken
Depends on:
Reported: 2011-08-12 00:52 UTC by alfasedanman
Modified: 2011-08-12 15:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description alfasedanman 2011-08-12 00:52:08 UTC
Application: kmix (3.6)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
Accessed a youtube video on a facebook page-tried to turn up the volume and Kmix crashed. Tried to restart Kmix but it continues to crash.

The crash can be reproduced every time.

 -- Backtrace:
Application: KMix (kdeinit4), signal: Aborted
[KCrash Handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb5e0e7ff in raise () from /lib/libc.so.6
#8  0xb5e10140 in abort () from /lib/libc.so.6
#9  0xb60047dd in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/libstdc++.so.6
#10 0xb6002533 in ?? () from /usr/lib/libstdc++.so.6
#11 0xb600256f in std::terminate() () from /usr/lib/libstdc++.so.6
#12 0xb60026d1 in __cxa_throw () from /usr/lib/libstdc++.so.6
#13 0xb6b3a302 in qBadAlloc() () from /usr/lib/libQtCore.so.4
#14 0xb6b44f2d in qUncompress(unsigned char const*, int) () from /usr/lib/libQtCore.so.4
#15 0xb6ea3f44 in KPixmapCache::Private::loadData(int, QPixmap&) () from /usr/lib/libkdeui.so.5
#16 0xb6ea478f in KPixmapCache::find(QString const&, QPixmap&) () from /usr/lib/libkdeui.so.5
#17 0xb6ea487b in KIconCache::find(QString const&, QPixmap&) () from /usr/lib/libkdeui.so.5
#18 0xb6f79124 in KIconCache::find(QString const&, QPixmap&, QString*) () from /usr/lib/libkdeui.so.5
#19 0xb6f797fb in KIconLoader::loadIcon(QString const&, KIconLoader::Group, int, int, QStringList const&, QString*, bool) const () from /usr/lib/libkdeui.so.5
#20 0xb6f7bea4 in ?? () from /usr/lib/libkdeui.so.5
#21 0xb6229354 in QIcon::pixmap (this=0xbfec702c, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:678
#22 0xb621a287 in QWidgetPrivate::setWindowIcon_sys (this=0x80db430, forceReset=false) at kernel/qwidget_x11.cpp:1457
#23 0xb61cd76f in QWidget::create (this=0x811df68, window=0, initializeWindow=true, destroyOldWindow=true) at kernel/qwidget.cpp:1355
#24 0xb61cd443 in QWidgetPrivate::createWinId (this=0x80db430, winid=0) at kernel/qwidget.cpp:2343
#25 0xb61cd4e6 in QWidget::createWinId (this=0x811df68) at kernel/qwidget.cpp:2359
#26 0xb6205b4c in setupOwner () at kernel/qclipboard_x11.cpp:131
#27 0xb6206544 in QClipboard::QClipboard (this=0x812c1d0, parent=0x0) at kernel/qclipboard_x11.cpp:458
#28 0xb6173f54 in QApplication::clipboard () at kernel/qapplication.cpp:3092
#29 0xb6e734fa in KClipboardSynchronizer::Private::setupSignals() () from /usr/lib/libkdeui.so.5
#30 0xb6e738ad in KClipboardSynchronizer::KClipboardSynchronizer(QObject*) () from /usr/lib/libkdeui.so.5
#31 0xb6e7396b in KClipboardSynchronizer::self() () from /usr/lib/libkdeui.so.5
#32 0xb6fe1a35 in ?? () from /usr/lib/libkdeui.so.5
#33 0xb6fe265b in KApplication::KApplication(bool, KComponentData const&) () from /usr/lib/libkdeui.so.5
#34 0xb6fe26c4 in KUniqueApplication::KUniqueApplication(bool, bool) () from /usr/lib/libkdeui.so.5
#35 0xb33c8782 in KMixApp::KMixApp (this=0x80a2130) at /usr/src/debug/kdemultimedia-4.4.4/kmix/KMixApp.cpp:32
#36 0xb339fe56 in kdemain (argc=1, argv=0x8099258) at /usr/src/debug/kdemultimedia-4.4.4/kmix/main.cpp:73
#37 0x0804e5b1 in _start ()

Possible duplicates by query: bug 243339, bug 237576, bug 236969, bug 235822, bug 234987.

Reported using DrKonqi
Comment 1 Dario Andres 2011-08-12 15:50:03 UTC
[Comment from a bug report cleaner]
This is fixed since KDE SC 4.5.0 as the KPixmapCache class was replaced with a better alternative. Similar crashes were being tracked at bug 209263.

*** This bug has been marked as a duplicate of bug 209263 ***