Bug 202918 - sudden plasma crash while using another application (RememberTheMilkPlasmoid::listChanged, RememberTheMilkPlasmoid::dataUpdated)
Summary: sudden plasma crash while using another application (RememberTheMilkPlasmoid:...
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-rememberthemilk (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 202923 245231 245600 251888 257526 264105 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-07 10:08 UTC by Martin Steigerwald
Modified: 2011-01-28 00:25 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Steigerwald 2009-08-07 10:08:26 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.29.6-tp42-toi-3.0.1-01085-gf325e4a i686
Distribution: Debian GNU/Linux 5.0.1 (lenny)

 -- Backtrace:
Application: Plasma-Arbeitsfläche (plasma-desktop), signal: Segmentation fault
[Current thread is 0 (LWP 5180)]

Thread 2 (Thread 0xa8e0ab90 (LWP 5181)):
#0  0xb7f43424 in __kernel_vsyscall ()
#1  0xb4f13fb5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/cmov/libpthread.so.0
#2  0xb7e3905d in pthread_cond_wait () from /lib/i686/cmov/libc.so.6
#3  0xb673b502 in QWaitCondition::wait (this=0x8e63608, mutex=0x8e63604, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb51c863a in QHostInfoAgent::run (this=0x8e635f8) at kernel/qhostinfo.cpp:260
#5  0xb673a522 in QThreadPrivate::start (arg=0x8e635f8) at thread/qthread_unix.cpp:188
#6  0xb4f104e5 in start_thread () from /lib/i686/cmov/libpthread.so.0
#7  0xb7e2a21e in clone () from /lib/i686/cmov/libc.so.6

Thread 1 (Thread 0xb4b84720 (LWP 5180)):
[KCrash Handler]
#6  0xa902d5fd in RememberTheMilkPlasmoid::listChanged (this=0x8d7a760, pos=<value optimized out>) at ../../../applets/rememberthemilk/rememberthemilk-plasmoid.cpp:243
#7  0xa90303b1 in RememberTheMilkPlasmoid::dataUpdated (this=0x8d7a760, name=@0xbfcaf0b8, data=@0x94e2050) at ../../../applets/rememberthemilk/rememberthemilk-plasmoid.cpp:230
#8  0xa9030d99 in RememberTheMilkPlasmoid::qt_metacall (this=0x8d7a760, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfcaf038) at ./rememberthemilk-plasmoid.moc:87
#9  0xb6840ad3 in QMetaObject::activate (sender=0x953a618, from_signal_index=4, to_signal_index=4, argv=0xbfcaf038) at kernel/qobject.cpp:3112
#10 0xb6841722 in QMetaObject::activate (sender=0x953a618, m=0xb7d3cca4, local_signal_index=0, argv=0xbfcaf038) at kernel/qobject.cpp:3186
#11 0xb7c03649 in Plasma::DataContainer::dataUpdated (this=0x953a618, _t1=@0xbfcaf0b8, _t2=@0x94e2050) at ./datacontainer.moc:93
#12 0xb7c037cd in Plasma::DataContainer::checkForUpdate (this=0x953a618) at ../../plasma/datacontainer.cpp:167
#13 0xa857eabd in ListsSource::listsChanged (this=0x953a618) at ../../../dataengines/rememberthemilk/listssource.cpp:76
#14 0xa857f1e3 in ListsSource::qt_metacall (this=0x953a618, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfcaf1c8) at ./listssource.moc:72
#15 0xb6840ad3 in QMetaObject::activate (sender=0x91ccb38, from_signal_index=9, to_signal_index=9, argv=0x0) at kernel/qobject.cpp:3112
#16 0xb6841722 in QMetaObject::activate (sender=0x91ccb38, m=0xa84ec894, local_signal_index=5, argv=0x0) at kernel/qobject.cpp:3186
#17 0xa84d49a7 in RTM::Session::listsChanged (this=0x91ccb38) at ./session.moc:150
#18 0xa84e96cb in RTM::TasksReader::read (this=0xbfcaf2c4) at ../../../libs/rtm/xmlreaders.cpp:102
#19 0xa84d6c9a in RTM::Session::qt_metacall (this=0x91ccb38, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbfcaf3ac) at ../../../libs/rtm/session_p.h:75
#20 0xb6840ad3 in QMetaObject::activate (sender=0x8e98b88, from_signal_index=9, to_signal_index=9, argv=0xbfcaf3ac) at kernel/qobject.cpp:3112
#21 0xb6841722 in QMetaObject::activate (sender=0x8e98b88, m=0xa84ec760, local_signal_index=0, argv=0xbfcaf3ac) at kernel/qobject.cpp:3186
#22 0xa84d44b3 in RTM::Request::replyReceived (this=0x8e98b88, _t1=0x8e98b88) at moc_request.cpp:93
#23 0xa84e0ace in RTM::Request::finished (this=0x8e98b88, job=0x9546bd8) at ../../../libs/rtm/request.cpp:105
#24 0xa84d4547 in RTM::Request::qt_metacall (this=0x8e98b88, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfcaf52c) at moc_request.cpp:81
#25 0xb6840ad3 in QMetaObject::activate (sender=0x9546bd8, from_signal_index=7, to_signal_index=7, argv=0xbfcaf52c) at kernel/qobject.cpp:3112
#26 0xb6841722 in QMetaObject::activate (sender=0x9546bd8, m=0xb7580fe8, local_signal_index=3, argv=0xbfcaf52c) at kernel/qobject.cpp:3186
#27 0xb7426083 in KJob::result (this=0x9546bd8, _t1=0x9546bd8) at ./kjob.moc:188
#28 0xb7426529 in KJob::emitResult (this=0x9546bd8) at ../../kdecore/jobs/kjob.cpp:304
#29 0xb64419e5 in KIO::SimpleJob::slotFinished (this=0x9546bd8) at ../../kio/kio/job.cpp:477
#30 0xb6442343 in KIO::TransferJob::slotFinished (this=0x9546bd8) at ../../kio/kio/job.cpp:948
#31 0xb643e8d3 in KIO::TransferJob::qt_metacall (this=0x9546bd8, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfcaf768) at ./jobclasses.moc:343
#32 0xb6840ad3 in QMetaObject::activate (sender=0x90df198, from_signal_index=8, to_signal_index=8, argv=0x0) at kernel/qobject.cpp:3112
#33 0xb6841722 in QMetaObject::activate (sender=0x90df198, m=0xb65e8b64, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3186
#34 0xb65076d7 in KIO::SlaveInterface::finished (this=0x90df198) at ./slaveinterface.moc:165
#35 0xb650b487 in KIO::SlaveInterface::dispatch (this=0x90df198, _cmd=104, rawdata=@0xbfcaf934) at ../../kio/kio/slaveinterface.cpp:175
#36 0xb6507bb7 in KIO::SlaveInterface::dispatch (this=0x90df198) at ../../kio/kio/slaveinterface.cpp:91
#37 0xb64f9b9d in KIO::Slave::gotInput (this=0x90df198) at ../../kio/kio/slave.cpp:322
#38 0xb64fc083 in KIO::Slave::qt_metacall (this=0x90df198, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfcafa38) at ./slave.moc:76
#39 0xb6840ad3 in QMetaObject::activate (sender=0x8f33038, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3112
#40 0xb6841722 in QMetaObject::activate (sender=0x8f33038, m=0xb65e54a0, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3186
#41 0xb6406427 in KIO::Connection::readyRead (this=0x8f33038) at ./connection.moc:86
#42 0xb6407d33 in KIO::ConnectionPrivate::dequeue (this=0x935e218) at ../../kio/kio/connection.cpp:82
#43 0xb6408116 in KIO::Connection::qt_metacall (this=0x8f33038, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x927a0d8) at ./connection.moc:73
#44 0xb683a2db in QMetaCallEvent::placeMetaCall (this=0x91e9528, object=0x8f33038) at kernel/qobject.cpp:477
#45 0xb683bdb0 in QObject::event (this=0x8f33038, e=0x91e9528) at kernel/qobject.cpp:1110
#46 0xb6ad67d4 in QApplicationPrivate::notify_helper (this=0x8728c10, receiver=0x8f33038, e=0x91e9528) at kernel/qapplication.cpp:4056
#47 0xb6ade93e in QApplication::notify (this=0x8720e30, receiver=0x8f33038, e=0x91e9528) at kernel/qapplication.cpp:3603
#48 0xb775900d in KApplication::notify (this=0x8720e30, receiver=0x8f33038, event=0x91e9528) at ../../kdeui/kernel/kapplication.cpp:302
#49 0xb682b96b in QCoreApplication::notifyInternal (this=0x8720e30, receiver=0x8f33038, event=0x91e9528) at kernel/qcoreapplication.cpp:610
#50 0xb682c5ae in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x870b890) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#51 0xb682c78d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#52 0xb6856baf in postEventSourceDispatch (s=0x872ad10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#53 0xb4f5c848 in IA__g_main_context_dispatch (context=0x872ac90) at /build/buildd-glib2.0_2.20.1-2-i386-hGzT8z/glib2.0-2.20.1/glib/gmain.c:1814
#54 0xb4f5fdab in g_main_context_iterate (context=0x872ac90, block=1, dispatch=1, self=0x87286e0) at /build/buildd-glib2.0_2.20.1-2-i386-hGzT8z/glib2.0-2.20.1/glib/gmain.c:2448
#55 0xb4f5ff28 in IA__g_main_context_iteration (context=0x872ac90, may_block=1) at /build/buildd-glib2.0_2.20.1-2-i386-hGzT8z/glib2.0-2.20.1/glib/gmain.c:2511
#56 0xb68567f8 in QEventDispatcherGlib::processEvents (this=0x870b5e0, flags={i = -1077215032}) at kernel/qeventdispatcher_glib.cpp:327
#57 0xb6b75f85 in QGuiEventDispatcherGlib::processEvents (this=0x870b5e0, flags={i = -1077214984}) at kernel/qguieventdispatcher_glib.cpp:202
#58 0xb6829fba in QEventLoop::processEvents (this=0xbfcb0170, flags={i = -1077214920}) at kernel/qeventloop.cpp:149
#59 0xb682a402 in QEventLoop::exec (this=0xbfcb0170, flags={i = -1077214856}) at kernel/qeventloop.cpp:201
#60 0xb682c859 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#61 0xb6ad6657 in QApplication::exec () at kernel/qapplication.cpp:3525
#62 0xb7ed6ee0 in kdemain (argc=1, argv=0xbfcb0324) at ../../../../plasma/shells/desktop/main.cpp:50
#63 0x080485b2 in main (argc=2317644, argv=0xb79102c8) at plasma-desktop_dummy.cpp:3

Reported using DrKonqi
Comment 1 Martin Steigerwald 2009-08-07 10:15:05 UTC
Some additional informations although I can't describe steps to reproduce it. The crash just happened while I was using another application. I have the following applets on the desktop at the moment:

- openDesktop
- Remember the Milk

I am using Debian testing/unstable packages:

shambhala:~> apt-show-versions | egrep "(kdelibs|plasma)"
kdelibs/squeeze uptodate 4:3.5.10.dfsg.1-2
kdelibs-bin/sid uptodate 4:4.3.0-1
kdelibs-data/squeeze uptodate 4:3.5.10.dfsg.1-2
kdelibs-dbg/squeeze uptodate 4:3.5.10.dfsg.1-2
kdelibs4c2a/squeeze uptodate 4:3.5.10.dfsg.1-2
kdelibs5/sid uptodate 4:4.3.0-1
kdelibs5-data/sid uptodate 4:4.3.0-1
kdelibs5-dbg/sid uptodate 4:4.3.0-1
kdelibs5-dev/sid uptodate 4:4.3.0-1
kdeplasma-addons/sid uptodate 4:4.3.0-1
kdeplasma-addons-dbg/sid uptodate 4:4.3.0-1
libplasma-applet-system-monitor4/sid uptodate 4:4.3.0-1
libplasma-geolocation-interface4/sid uptodate 4:4.3.0-1
libplasma-ruby/experimental uptodate 4:4.2.96-1
libplasma-ruby1.8/experimental uptodate 4:4.2.96-1
libplasma3/sid uptodate 4:4.3.0-1
libplasmaclock4/sid uptodate 4:4.3.0-1
libsmokeplasma2/experimental uptodate 4:4.2.96-1
plasma-dataengines-addons/sid uptodate 4:4.3.0-1
plasma-dataengines-workspace/sid uptodate 4:4.3.0-1
plasma-desktopthemes-artwork/sid upgradeable from 4:4.3.0-2 to 4:4.3.0-3
plasma-runners-addons/sid uptodate 4:4.3.0-1
plasma-scriptengine-googlegadgets/sid uptodate 4:4.3.0-1
plasma-scriptengine-javascript/sid uptodate 4:4.3.0-2
plasma-scriptengine-python/sid upgradeable from 4:4.3.0-1 to 4:4.3.0-2
plasma-scriptengine-qedje/sid uptodate 4:4.3.0-1
plasma-scriptengine-ruby/sid upgradeable from 4:4.3.0-1 to 4:4.3.0-2
plasma-scriptengine-superkaramba/sid uptodate 4:4.3.0-1
plasma-scriptengine-webkit/sid uptodate 4:4.3.0-1
plasma-scriptengines/sid upgradeable from 4:4.3.0-1 to 4:4.3.0-2
plasma-wallpapers-addons/sid uptodate 4:4.3.0-1
plasma-widget-folderview/sid uptodate 4:4.3.0-1
plasma-widget-lancelot/sid uptodate 4:4.3.0-1
plasma-widgets-addons/sid uptodate 4:4.3.0-1
plasma-widgets-workspace/sid uptodate 4:4.3.0-1

There are some upgradeable packages, but they do not appear to related to this crash for me. I will do the update nevertheless.

BTW the new DrKonqi crash assistant is really nice ;).
Comment 2 Martin Steigerwald 2009-08-07 10:51:32 UTC
I may have experienced a duplicate to this one: bug #202923, but I am not sure.

This may be related to the Remember the Milk plasmoid.
Comment 3 Dario Andres 2009-08-07 14:01:30 UTC
*** Bug 202923 has been marked as a duplicate of this bug. ***
Comment 4 Nicolas L. 2010-06-04 11:56:17 UTC
Do you still reproduce with kde 4.4 or 4.5beta ?
Comment 5 Nicolas L. 2010-07-20 16:09:41 UTC
*** Bug 245231 has been marked as a duplicate of this bug. ***
Comment 6 Jonathan Thomas 2010-07-25 02:36:41 UTC
*** Bug 245600 has been marked as a duplicate of this bug. ***
Comment 7 Beat Wolf 2010-09-21 10:25:59 UTC
*** Bug 251888 has been marked as a duplicate of this bug. ***
Comment 8 Dario Andres 2010-11-21 18:34:50 UTC
[Comment from a bug triager]
Reopening as there is a new case (bug 257526) from KDE SC 4.5.1. It was a crash on startup.

- Updated backtrace:

Thread 1 (Thread 0xb7772720 (LWP 1761)):
[KCrash Handler]
#7  0x069b0ccb in RememberTheMilkPlasmoid::listChanged (this=0x8b82038, pos=5)
at ../../../applets/rememberthemilk/rememberthemilk-plasmoid.cpp:238
#8  0x069b4214 in RememberTheMilkPlasmoid::dataUpdated (this=0x8b82038,
name=..., data=...) at
../../../applets/rememberthemilk/rememberthemilk-plasmoid.cpp:225
#9  0x069b4bfc in RememberTheMilkPlasmoid::qt_metacall (this=0x8b82038,
_c=QMetaObject::InvokeMetaMethod, _id=75, _a=0xbff09704) at
./rememberthemilk-plasmoid.moc:94
#10 0x047558ca in QMetaObject::metacall (object=0x8b82038, cl=37863412, idx=75,
argv=0xbff09704) at kernel/qmetaobject.cpp:237
#11 0x047686ad in QMetaObject::activate (sender=0x9e2eac8, m=0x3a3744,
local_signal_index=0, argv=0x6d6f6501) at kernel/qobject.cpp:3280
#12 0x001e3e69 in Plasma::DataContainer::dataUpdated (this=0x9e2eac8, _t1=...,
_t2=...) at ./datacontainer.moc:101
#13 0x001e3fe8 in Plasma::DataContainer::checkForUpdate (this=0x9e2eac8) at
../../plasma/datacontainer.cpp:169
#14 0x041714f2 in ListsSource::listsChanged (this=0x9e2eac8) at
../../../dataengines/rememberthemilk/listssource.cpp:76
#15 0x0417194b in ListsSource::qt_metacall (this=0x9e2eac8,
_c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbff0990c) at
./listssource.moc:78
#16 0x047558ca in QMetaObject::metacall (object=0x9e2eac8, cl=37863412, idx=11,
argv=0xbff0990c) at kernel/qmetaobject.cpp:237
#17 0x047686ad in QMetaObject::activate (sender=0x9147600, m=0x58b1d54,
local_signal_index=7, argv=0x6d6f6501) at kernel/qobject.cpp:3280
#18 0x0589a1b7 in RTM::Session::listsChanged (this=0x9147600) at
./session.moc:195
#19 0x058adedb in RTM::TasksReader::read (this=0xbff09a08) at
../../../libs/rtm/xmlreaders.cpp:102
#20 0x0589caf3 in listUpdate (this=0x9147600, _c=QMetaObject::InvokeMetaMethod,
_id=18, _a=0xbff09b68) at ../../../libs/rtm/session_p.h:130
#21 RTM::Session::qt_metacall (this=0x9147600,
_c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xbff09b68) at ./session.moc:132
#22 0x047558ca in QMetaObject::metacall (object=0x9147600, cl=37863412, idx=22,
argv=0xbff09b68) at kernel/qmetaobject.cpp:237
#23 0x047686ad in QMetaObject::activate (sender=0x9c34f40, m=0x58b1c20,
local_signal_index=0, argv=0x6d6f6501) at kernel/qobject.cpp:3280
#24 0x05899d03 in RTM::Request::replyReceived (this=0x9c34f40, _t1=0x9c34f40)
at moc_request.cpp:98
#25 0x058a4da4 in RTM::Request::finished (this=0x9c34f40, job=0x8a558d8) at
../../../libs/rtm/request.cpp:102
#26 0x05899e1f in RTM::Request::qt_metacall (this=0x9c34f40,
_c=QMetaObject::InvokeMetaMethod, _id=13, _a=0xbff09d18) at moc_request.cpp:86
#27 0x047558ca in QMetaObject::metacall (object=0x9c34f40, cl=37863412, idx=13,
argv=0xbff09d18) at kernel/qmetaobject.cpp:237
#28 0x047686ad in QMetaObject::activate (sender=0x8a558d8, m=0x2417b48,
local_signal_index=3, argv=0x6d6f6501) at kernel/qobject.cpp:3280
#29 0x022a48a3 in KJob::result (this=0x8a558d8, _t1=0x8a558d8) at
./kjob.moc:194
#30 0x022a4c08 in KJob::emitResult (this=0x8a558d8) at
../../kdecore/jobs/kjob.cpp:312
#31 0x0046b480 in KIO::SimpleJob::slotFinished (this=0x8a558d8) at
../../kio/kio/job.cpp:522
#32 0x0046b960 in KIO::TransferJob::slotFinished (this=0x8a558d8) at
../../kio/kio/job.cpp:1111
#33 0x00469453 in KIO::TransferJob::qt_metacall (this=0x8a558d8,
_c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbff09fbc) at
./jobclasses.moc:367
#34 0x047558ca in QMetaObject::metacall (object=0x8a558d8, cl=37863412, idx=47,
argv=0xbff09fbc) at kernel/qmetaobject.cpp:237
#35 0x047686ad in QMetaObject::activate (sender=0x91be190, m=0x61a944,
local_signal_index=4, argv=0x6d6f6501) at kernel/qobject.cpp:3280
#36 0x00523fc7 in KIO::SlaveInterface::finished (this=0x91be190) at
./slaveinterface.moc:171
#37 0x00527768 in KIO::SlaveInterface::dispatch (this=0x91be190, _cmd=104,
rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#38 0x00524483 in KIO::SlaveInterface::dispatch (this=0x91be190) at
../../kio/kio/slaveinterface.cpp:91
#39 0x00516fe8 in KIO::Slave::gotInput (this=0x91be190) at
../../kio/kio/slave.cpp:344
#40 0x005171f3 in KIO::Slave::qt_metacall (this=0x91be190,
_c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbff0a2dc) at ./slave.moc:82
#41 0x047558ca in QMetaObject::metacall (object=0x91be190, cl=37863412, idx=30,
argv=0xbff0a2dc) at kernel/qmetaobject.cpp:237
#42 0x047686ad in QMetaObject::activate (sender=0x91992d0, m=0x617500,
local_signal_index=0, argv=0x6d6f6501) at kernel/qobject.cpp:3280
#43 0x00430e17 in KIO::Connection::readyRead (this=0x91992d0) at
./connection.moc:92
#44 0x0043317e in KIO::ConnectionPrivate::dequeue (this=0x8f40648) at
../../kio/kio/connection.cpp:82
#45 0x004332ae in KIO::Connection::qt_metacall (this=0x91992d0,
_c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x90f5ed0) at ./connection.moc:79
#46 0x047558ca in QMetaObject::metacall (object=0x91992d0, cl=37863412, idx=5,
argv=0x90f5ed0) at kernel/qmetaobject.cpp:237
#47 0x04760df6 in QMetaCallEvent::placeMetaCall (this=0x9df8690,
object=0x91992d0) at kernel/qobject.cpp:534
#48 0x047626a2 in QObject::event (this=0x91992d0, e=0x98af910) at
kernel/qobject.cpp:1219
#49 0x06e47fdc in QApplicationPrivate::notify_helper (this=0x8633610,
receiver=0x91992d0, e=0x9df8690) at kernel/qapplication.cpp:4396
#50 0x06e4e04e in QApplication::notify (this=0x8625640, receiver=0x91992d0,
e=0x9df8690) at kernel/qapplication.cpp:3798
#51 0x0112c68a in KApplication::notify (this=0x8625640, receiver=0x91992d0,
event=0x9df8690) at ../../kdeui/kernel/kapplication.cpp:310
#52 0x0474fb3b in QCoreApplication::notifyInternal (this=0x8625640,
receiver=0x91992d0, event=0x9df8690) at kernel/qcoreapplication.cpp:732
#53 0x04752d8b in sendEvent (receiver=0x0, event_type=0, data=0x860f040) at
../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#54 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0,
data=0x860f040) at kernel/qcoreapplication.cpp:1373
#55 0x04752f4d in QCoreApplication::sendPostedEvents (receiver=0x0,
event_type=0) at kernel/qcoreapplication.cpp:1266
#56 0x0477ea74 in sendPostedEvents (s=0x8635978) at
../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#57 postEventSourceDispatch (s=0x8635978) at
kernel/qeventdispatcher_glib.cpp:277
#58 0x01b62855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#59 0x01b66668 in ?? () from /lib/libglib-2.0.so.0
#60 0x01b66848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#61 0x0477e565 in QEventDispatcherGlib::processEvents (this=0x860ed00,
flags=...) at kernel/qeventdispatcher_glib.cpp:415
#62 0x06f09be5 in QGuiEventDispatcherGlib::processEvents (this=0x860ed00,
flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#63 0x0474e609 in QEventLoop::processEvents (this=0xbff0ab94, flags=) at
kernel/qeventloop.cpp:149
#64 0x0474ea8a in QEventLoop::exec (this=0xbff0ab94, flags=...) at
kernel/qeventloop.cpp:201
#65 0x0475300f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#66 0x06e46e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#67 0x00c3486e in kdemain (argc=1, argv=0xbff0ada4) at
../../../../plasma/desktop/shell/main.cpp:118
#68 0x080485bb in main (argc=1, argv=0xbff0ada4) at plasma-desktop_dummy.cpp:3
Comment 9 Dario Andres 2010-11-21 18:35:27 UTC
*** Bug 257526 has been marked as a duplicate of this bug. ***
Comment 10 Aaron J. Seigo 2011-01-28 00:23:17 UTC
*** Bug 264105 has been marked as a duplicate of this bug. ***
Comment 11 Aaron J. Seigo 2011-01-28 00:24:05 UTC
SVN commit 1217584 by aseigo:

bounds check pos
BUG:202918


 M  +3 -0      rememberthemilk-plasmoid.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1217584
Comment 12 Aaron J. Seigo 2011-01-28 00:25:13 UTC
SVN commit 1217585 by aseigo:

bounds check pos
BUG:202918


 M  +3 -0      rememberthemilk-plasmoid.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1217585