Bug 245600 - Plasma crashed after restart
Summary: Plasma crashed after restart
Status: RESOLVED DUPLICATE of bug 202918
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-24 02:29 UTC by Brand
Modified: 2010-07-25 02:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brand 2010-07-24 02:29:15 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-22-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
Plasma crashed after restart and fsck from disk error, but not sure if related, plasma crashes fairly often. May be RTM applet.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d5700 (LWP 2245))]

Thread 4 (Thread 0xaa834b70 (LWP 2246)):
#0  0x00e50422 in __kernel_vsyscall ()
#1  0x00881142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x00c0524f in QWaitConditionPrivate::wait (this=0x9a720a4, mutex=0x9a720a0, time=30000) at thread/qwaitcondition_unix.cpp:85
#3  QWaitCondition::wait (this=0x9a720a4, mutex=0x9a720a0, time=30000) at thread/qwaitcondition_unix.cpp:159
#4  0x00bf932b in QThreadPoolThread::run (this=0x965a4d0) at concurrent/qthreadpool.cpp:140
#5  0x00c0436e in QThreadPrivate::start (arg=0x965a4d0) at thread/qthread_unix.cpp:248
#6  0x0087c80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0x02a6fa0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xa9effb70 (LWP 2247)):
#0  0x00e50422 in __kernel_vsyscall ()
#1  0x00880e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb6819407 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0xb6819451 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0x0087c80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x02a6fa0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xa91c8b70 (LWP 2254)):
#0  0x00e50422 in __kernel_vsyscall ()
#1  0x00881142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x00c0524f in QWaitConditionPrivate::wait (this=0x9e9039c, mutex=0x9e90398, time=30000) at thread/qwaitcondition_unix.cpp:85
#3  QWaitCondition::wait (this=0x9e9039c, mutex=0x9e90398, time=30000) at thread/qwaitcondition_unix.cpp:159
#4  0x00bf932b in QThreadPoolThread::run (this=0x9abab98) at concurrent/qthreadpool.cpp:140
#5  0x00c0436e in QThreadPrivate::start (arg=0x9abab98) at thread/qthread_unix.cpp:248
#6  0x0087c80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0x02a6fa0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb77d5700 (LWP 2245)):
[KCrash Handler]
#6  0x02620cab in ?? () from /usr/lib/kde4/plasma_applet_rtm.so
#7  0x0262418c in ?? () from /usr/lib/kde4/plasma_applet_rtm.so
#8  0x02624c4c in ?? () from /usr/lib/kde4/plasma_applet_rtm.so
#9  0x00d0be5a in QMetaObject::metacall (object=0x99b5e28, cl=12165108, idx=161177128, argv=0xbfa99e84) at kernel/qmetaobject.cpp:237
#10 0x00d1a5f5 in QMetaObject::activate (sender=0x9b99dc8, m=0x1f26d24, local_signal_index=0, argv=0xbfa9a124) at kernel/qobject.cpp:3293
#11 0x01d86329 in Plasma::DataContainer::dataUpdated (this=0x9b99dc8, _t1=..., _t2=...) at ./datacontainer.moc:101
#12 0x01d864a8 in Plasma::DataContainer::checkForUpdate (this=0x9b99dc8) at ../../plasma/datacontainer.cpp:167
#13 0x0554aab2 in ?? () from /usr/lib/kde4/plasma_engine_rtm.so
#14 0x0554af0b in ?? () from /usr/lib/kde4/plasma_engine_rtm.so
#15 0x00d0be5a in QMetaObject::metacall (object=0x9b99dc8, cl=12165108, idx=168284960, argv=0xa07d320) at kernel/qmetaobject.cpp:237
#16 0x00d1a5f5 in QMetaObject::activate (sender=0x9dd0e08, m=0x31b4d54, local_signal_index=7, argv=0x0) at kernel/qobject.cpp:3293
#17 0x0319e8a7 in RTM::Session::listsChanged() () from /usr/lib/librtm.so.4
#18 0x031b175b in RTM::TasksReader::read() () from /usr/lib/librtm.so.4
#19 0x031a0a40 in RTM::Session::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/librtm.so.4
#20 0x00d0be5a in QMetaObject::metacall (object=0x9dd0e08, cl=12165108, idx=17, argv=0xbfa9a428) at kernel/qmetaobject.cpp:237
#21 0x00d1a5f5 in QMetaObject::activate (sender=0x9a6f4f0, m=0x31b4c30, local_signal_index=0, argv=0xbfa9a538) at kernel/qobject.cpp:3293
#22 0x0319e363 in RTM::Request::replyReceived(RTM::Request*) () from /usr/lib/librtm.so.4
#23 0x031a8ad6 in RTM::Request::finished(KJob*) () from /usr/lib/librtm.so.4
#24 0x0319e491 in RTM::Request::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/librtm.so.4
#25 0x00d0be5a in QMetaObject::metacall (object=0x9a6f4f0, cl=12165108, idx=161936624, argv=0x9db8120) at kernel/qmetaobject.cpp:237
#26 0x00d1a5f5 in QMetaObject::activate (sender=0x9db8120, m=0xb95ca8, local_signal_index=3, argv=0xbfa9a6e8) at kernel/qobject.cpp:3293
#27 0x00a263c3 in KJob::result (this=0x9db8120, _t1=0x9db8120) at ./kjob.moc:194
#28 0x00a26728 in KJob::emitResult (this=0x9db8120) at ../../kdecore/jobs/kjob.cpp:312
#29 0x00309300 in KIO::SimpleJob::slotFinished (this=0x9db8120) at ../../kio/kio/job.cpp:486
#30 0x0030982d in KIO::TransferJob::slotFinished (this=0x9db8120) at ../../kio/kio/job.cpp:1058
#31 0x003079b3 in KIO::TransferJob::qt_metacall (this=0x9db8120, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbfa9a97c) at ./jobclasses.moc:367
#32 0x00d0be5a in QMetaObject::metacall (object=0x9db8120, cl=12165108, idx=47, argv=0xbfa9a97c) at kernel/qmetaobject.cpp:237
#33 0x00d1a5f5 in QMetaObject::activate (sender=0x99fafc0, m=0x4b6f44, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3293
#34 0x003d30a7 in KIO::SlaveInterface::finished (this=0x99fafc0) at ./slaveinterface.moc:171
#35 0x003d63cd in KIO::SlaveInterface::dispatch (this=0x99fafc0, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#36 0x003d3563 in KIO::SlaveInterface::dispatch (this=0x99fafc0) at ../../kio/kio/slaveinterface.cpp:91
#37 0x003c6908 in KIO::Slave::gotInput (this=0x99fafc0) at ../../kio/kio/slave.cpp:324
#38 0x003c6b13 in KIO::Slave::qt_metacall (this=0x99fafc0, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbfa9ac8c) at ./slave.moc:82
#39 0x00d0be5a in QMetaObject::metacall (object=0x99fafc0, cl=12165108, idx=30, argv=0xbfa9ac8c) at kernel/qmetaobject.cpp:237
#40 0x00d1a5f5 in QMetaObject::activate (sender=0x9d47040, m=0x4b3820, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3293
#41 0x002d1cc7 in KIO::Connection::readyRead (this=0x9d47040) at ./connection.moc:92
#42 0x002d406e in KIO::ConnectionPrivate::dequeue (this=0x9a23fc0) at ../../kio/kio/connection.cpp:82
#43 0x002d419e in KIO::Connection::qt_metacall (this=0x9d47040, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x9dfa9a8) at ./connection.moc:79
#44 0x00d0be5a in QMetaObject::metacall (object=0x9d47040, cl=12165108, idx=5, argv=0x9dfa9a8) at kernel/qmetaobject.cpp:237
#45 0x00d16516 in QMetaCallEvent::placeMetaCall (this=0x9afd080, object=0x9d47040) at kernel/qobject.cpp:561
#46 0x00d1763e in QObject::event (this=0x9d47040, e=0x9afd080) at kernel/qobject.cpp:1248
#47 0x0107f3cc in QApplicationPrivate::notify_helper (this=0x95dde28, receiver=0x9d47040, e=0x9afd080) at kernel/qapplication.cpp:4300
#48 0x0108601e in QApplication::notify (this=0x95a8ed8, receiver=0x9d47040, e=0x9afd080) at kernel/qapplication.cpp:3704
#49 0x0069f5ba in KApplication::notify (this=0x95a8ed8, receiver=0x9d47040, event=0x9afd080) at ../../kdeui/kernel/kapplication.cpp:302
#50 0x00d06beb in QCoreApplication::notifyInternal (this=0x95a8ed8, receiver=0x9d47040, event=0x9afd080) at kernel/qcoreapplication.cpp:704
#51 0x00d09623 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x95615d8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#52 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x95615d8) at kernel/qcoreapplication.cpp:1345
#53 0x00d0978d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#54 0x00d32d0f in QCoreApplication::sendPostedEvents (s=0x95dff10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#55 postEventSourceDispatch (s=0x95dff10) at kernel/qeventdispatcher_glib.cpp:276
#56 0x01a76e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#57 0x01a7a730 in ?? () from /lib/libglib-2.0.so.0
#58 0x01a7a863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#59 0x00d32805 in QEventDispatcherGlib::processEvents (this=0x95ae128, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#60 0x0113eb35 in QGuiEventDispatcherGlib::processEvents (this=0x95ae128, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#61 0x00d05209 in QEventLoop::processEvents (this=0xbfa9b544, flags=) at kernel/qeventloop.cpp:149
#62 0x00d0565a in QEventLoop::exec (this=0xbfa9b544, flags=...) at kernel/qeventloop.cpp:201
#63 0x00d0984f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#64 0x0107f467 in QApplication::exec () at kernel/qapplication.cpp:3579
#65 0x04a2706e in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#66 0x0804dff7 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x9579c80 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051425 "0") at ../../kinit/kinit.cpp:717
#67 0x0804ec15 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#68 0x0804f08c in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#69 0x0804fe47 in main (argc=2, argv=0xbfa9bff4, envp=0xbfa9c000) at ../../kinit/kinit.cpp:1845

This bug may be a duplicate of or related to bug 202918.

Possible duplicates by query: bug 245231, bug 221948, bug 219468, bug 219384.

Reported using DrKonqi
Comment 1 Jonathan Thomas 2010-07-25 02:36:41 UTC

*** This bug has been marked as a duplicate of bug 202918 ***