Bug 251888 - Plasma desktop crashed on startup
Summary: Plasma desktop crashed on startup
Status: RESOLVED DUPLICATE of bug 202918
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-21 09:10 UTC by Josef
Modified: 2010-09-21 10:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josef 2010-09-21 09:10:54 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
I saw someone mentioning the Remember the Milk widget; I'm also using this plasmoid. 

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77f5aa0 (LWP 1564))]

Thread 2 (Thread 0xab69db70 (LWP 1565)):
#0  0x01498e16 in *__GI_clock_gettime (clock_id=21614580, tp=0xab69cfb8) at ../sysdeps/unix/clock_gettime.c:100
#1  0x007da6fb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x007df825 in QTimerInfoList::updateCurrentTime (this=0xaad01034) at kernel/qeventdispatcher_unix.cpp:340
#3  0x007df86a in QTimerInfoList::timerWait (this=0xaad01034, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x007dd818 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xab69d0cc) at kernel/qeventdispatcher_glib.cpp:136
#5  0x007dd8a5 in timerSourcePrepare (source=0x0, timeout=0x149cff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x043c6aca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x043c6ee9 in ?? () from /lib/libglib-2.0.so.0
#8  0x043c74b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x007dd60f in QEventDispatcherGlib::processEvents (this=0x90a09a0, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x007b0059 in QEventLoop::processEvents (this=0xab69d290, flags=) at kernel/qeventloop.cpp:149
#11 0x007b04aa in QEventLoop::exec (this=0xab69d290, flags=...) at kernel/qeventloop.cpp:201
#12 0x006ac5a8 in QThread::exec (this=0x909ec98) at thread/qthread.cpp:487
#13 0x0078fc1b in QInotifyFileSystemWatcherEngine::run (this=0x909ec98) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x006af32e in QThreadPrivate::start (arg=0x909ec98) at thread/qthread_unix.cpp:248
#15 0x00dde96e in start_thread (arg=0xab69db70) at pthread_create.c:300
#16 0x00bc4a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb77f5aa0 (LWP 1564)):
[KCrash Handler]
#6  0x08574cab in ?? () from /usr/lib/kde4/plasma_applet_rtm.so
#7  0x0857808c in ?? () from /usr/lib/kde4/plasma_applet_rtm.so
#8  0x08578b5c in ?? () from /usr/lib/kde4/plasma_applet_rtm.so
#9  0x007b6c9a in QMetaObject::metacall (object=0x8ccba10, cl=6574068, idx=147634704, argv=0xbfee9da4) at kernel/qmetaobject.cpp:237
#10 0x007c53d5 in QMetaObject::activate (sender=0x9509970, m=0x2a83d04, local_signal_index=0, argv=0xbfeea044) at kernel/qobject.cpp:3293
#11 0x028e24d9 in Plasma::DataContainer::dataUpdated (this=0x9509970, _t1=..., _t2=...) at ./datacontainer.moc:101
#12 0x028e2658 in Plasma::DataContainer::checkForUpdate (this=0x9509970) at ../../plasma/datacontainer.cpp:167
#13 0x048ed9f2 in ?? () from /usr/lib/kde4/plasma_engine_rtm.so
#14 0x048ede4b in ?? () from /usr/lib/kde4/plasma_engine_rtm.so
#15 0x007b6c9a in QMetaObject::metacall (object=0x9509970, cl=6574068, idx=158764848, argv=0x9768f30) at kernel/qmetaobject.cpp:237
#16 0x007c53d5 in QMetaObject::activate (sender=0x9298ac0, m=0x4b76d54, local_signal_index=7, argv=0x0) at kernel/qobject.cpp:3293
#17 0x04b608c7 in RTM::Session::listsChanged() () from /usr/lib/librtm.so.4
#18 0x04b7378b in RTM::TasksReader::read() () from /usr/lib/librtm.so.4
#19 0x04b62a60 in RTM::Session::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/librtm.so.4
#20 0x007b6c9a in QMetaObject::metacall (object=0x9298ac0, cl=6574068, idx=17, argv=0xbfeea348) at kernel/qmetaobject.cpp:237
#21 0x007c53d5 in QMetaObject::activate (sender=0x9509a38, m=0x4b76c20, local_signal_index=0, argv=0xbfeea458) at kernel/qobject.cpp:3293
#22 0x04b60423 in RTM::Request::replyReceived(RTM::Request*) () from /usr/lib/librtm.so.4
#23 0x04b6aaf6 in RTM::Request::finished(KJob*) () from /usr/lib/librtm.so.4
#24 0x04b604b1 in RTM::Request::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/librtm.so.4
#25 0x007b6c9a in QMetaObject::metacall (object=0x9509a38, cl=6574068, idx=156277304, argv=0x93f5cc8) at kernel/qmetaobject.cpp:237
#26 0x007c53d5 in QMetaObject::activate (sender=0x93f5cc8, m=0x640c88, local_signal_index=3, argv=0xbfeea608) at kernel/qobject.cpp:3293
#27 0x004d21e3 in KJob::result (this=0x93f5cc8, _t1=0x93f5cc8) at ./kjob.moc:194
#28 0x004d2548 in KJob::emitResult (this=0x93f5cc8) at ../../kdecore/jobs/kjob.cpp:312
#29 0x001dac60 in KIO::SimpleJob::slotFinished (this=0x93f5cc8) at ../../kio/kio/job.cpp:517
#30 0x001db6a0 in KIO::TransferJob::slotFinished (this=0x93f5cc8) at ../../kio/kio/job.cpp:1097
#31 0x001d8ac3 in KIO::TransferJob::qt_metacall (this=0x93f5cc8, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbfeea89c) at ./jobclasses.moc:367
#32 0x007b6c9a in QMetaObject::metacall (object=0x93f5cc8, cl=6574068, idx=47, argv=0xbfeea89c) at kernel/qmetaobject.cpp:237
#33 0x007c53d5 in QMetaObject::activate (sender=0x8f9e368, m=0x389f44, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3293
#34 0x002a52a7 in KIO::SlaveInterface::finished (this=0x8f9e368) at ./slaveinterface.moc:171
#35 0x002a85cd in KIO::SlaveInterface::dispatch (this=0x8f9e368, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#36 0x002a5763 in KIO::SlaveInterface::dispatch (this=0x8f9e368) at ../../kio/kio/slaveinterface.cpp:91
#37 0x00298c28 in KIO::Slave::gotInput (this=0x8f9e368) at ../../kio/kio/slave.cpp:324
#38 0x00298e33 in KIO::Slave::qt_metacall (this=0x8f9e368, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbfeeabac) at ./slave.moc:82
#39 0x007b6c9a in QMetaObject::metacall (object=0x8f9e368, cl=6574068, idx=30, argv=0xbfeeabac) at kernel/qmetaobject.cpp:237
#40 0x007c53d5 in QMetaObject::activate (sender=0x9077ba8, m=0x386820, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3293
#41 0x001a2bd7 in KIO::Connection::readyRead (this=0x9077ba8) at ./connection.moc:92
#42 0x001a4f8e in KIO::ConnectionPrivate::dequeue (this=0x93bd178) at ../../kio/kio/connection.cpp:82
#43 0x001a50be in KIO::Connection::qt_metacall (this=0x9077ba8, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x94c6dc0) at ./connection.moc:79
#44 0x007b6c9a in QMetaObject::metacall (object=0x9077ba8, cl=6574068, idx=5, argv=0x94c6dc0) at kernel/qmetaobject.cpp:237
#45 0x007c1336 in QMetaCallEvent::placeMetaCall (this=0x977e850, object=0x9077ba8) at kernel/qobject.cpp:561
#46 0x007c23fe in QObject::event (this=0x9077ba8, e=0x977e850) at kernel/qobject.cpp:1248
#47 0x038c24dc in QApplicationPrivate::notify_helper (this=0x88ce8f8, receiver=0x9077ba8, e=0x977e850) at kernel/qapplication.cpp:4300
#48 0x038c905e in QApplication::notify (this=0x88c8760, receiver=0x9077ba8, e=0x977e850) at kernel/qapplication.cpp:3704
#49 0x011bd40a in KApplication::notify (this=0x88c8760, receiver=0x9077ba8, event=0x977e850) at ../../kdeui/kernel/kapplication.cpp:302
#50 0x007b1a3b in QCoreApplication::notifyInternal (this=0x88c8760, receiver=0x9077ba8, event=0x977e850) at kernel/qcoreapplication.cpp:704
#51 0x007b4473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8880fc8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#52 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8880fc8) at kernel/qcoreapplication.cpp:1345
#53 0x007b45dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#54 0x007ddadf in QCoreApplication::sendPostedEvents (s=0x88d10b8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#55 postEventSourceDispatch (s=0x88d10b8) at kernel/qeventdispatcher_glib.cpp:276
#56 0x043c35e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#57 0x043c72d8 in ?? () from /lib/libglib-2.0.so.0
#58 0x043c74b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#59 0x007dd5d5 in QEventDispatcherGlib::processEvents (this=0x88ce5c8, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#60 0x03982135 in QGuiEventDispatcherGlib::processEvents (this=0x88ce5c8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#61 0x007b0059 in QEventLoop::processEvents (this=0xbfeeb464, flags=) at kernel/qeventloop.cpp:149
#62 0x007b04aa in QEventLoop::exec (this=0xbfeeb464, flags=...) at kernel/qeventloop.cpp:201
#63 0x007b469f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#64 0x038c2577 in QApplication::exec () at kernel/qapplication.cpp:3579
#65 0x02c1905e in kdemain (argc=1, argv=0x88c0178) at ../../../../plasma/desktop/shell/main.cpp:112
#66 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x889efe8 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051465 "0") at ../../kinit/kinit.cpp:717
#67 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#68 0x0804f190 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#69 0x0804fe4f in main (argc=4, argv=0xbfeebf14, envp=0xbfeebf28) at ../../kinit/kinit.cpp:1845

This bug may be a duplicate of or related to bug 202918.

Possible duplicates by query: bug 248399, bug 245600, bug 245231, bug 221948, bug 219468.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-09-21 10:25:59 UTC

*** This bug has been marked as a duplicate of bug 202918 ***