Bug 245231 - Plasma-workspace crash
Summary: Plasma-workspace crash
Status: RESOLVED DUPLICATE of bug 202918
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-20 15:35 UTC by rohitece06
Modified: 2010-07-20 16:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rohitece06 2010-07-20 15:35:13 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-23-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Plasma crashed when I delayed login after restart. RTM applet wasnt login coz kwallet wasn't open. As soon as I login in kwallet and put my login info in RTM, plasma crashed. I also had virtualbox( 1 out of 3GB RAM) running in seamless mode. No unsupported plasmoids running.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77cdaa0 (LWP 1449))]

Thread 3 (Thread 0xaadb9b70 (LWP 1451)):
#0  0x0043f422 in __kernel_vsyscall ()
#1  0x0478db86 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x073c64eb in g_poll () from /lib/libglib-2.0.so.0
#3  0x073b90ac in ?? () from /lib/libglib-2.0.so.0
#4  0x073b94b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x00fa5e6f in QEventDispatcherGlib::processEvents (this=0x9a08c60, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0x00f78759 in QEventLoop::processEvents (this=0xaadb9290, flags=) at kernel/qeventloop.cpp:149
#7  0x00f78baa in QEventLoop::exec (this=0xaadb9290, flags=...) at kernel/qeventloop.cpp:201
#8  0x00e79fc9 in QThread::exec (this=0x9a08ba0) at thread/qthread.cpp:487
#9  0x00f581db in QInotifyFileSystemWatcherEngine::run (this=0x9a08ba0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00e7c97e in QThreadPrivate::start (arg=0x9a08ba0) at thread/qthread_unix.cpp:248
#11 0x003b196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0x0479ba4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xa98a5b70 (LWP 31526)):
#0  0x0043f422 in __kernel_vsyscall ()
#1  0x003b6015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x035f4a07 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x035f4a51 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0x003b196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x0479ba4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb77cdaa0 (LWP 1449)):
[KCrash Handler]
#6  0x0282acab in RememberTheMilkPlasmoid::listChanged (this=0x9874678, pos=0) at ../../../applets/rememberthemilk/rememberthemilk-plasmoid.cpp:237
#7  0x0282e08c in RememberTheMilkPlasmoid::dataUpdated (this=0x9874678, name=..., data=...) at ../../../applets/rememberthemilk/rememberthemilk-plasmoid.cpp:224
#8  0x0282eb5c in RememberTheMilkPlasmoid::qt_metacall (this=0x9874678, _c=QMetaObject::InvokeMetaMethod, _id=64, _a=0xbf9fadc4) at ./rememberthemilk-plasmoid.moc:94
#9  0x00f7f47a in QMetaObject::metacall (object=0x9874678, cl=3571700, idx=64, argv=0xbf9fadc4) at kernel/qmetaobject.cpp:237
#10 0x00f8dfbb in QMetaObject::activate (sender=0xa141518, m=0x135fd04, local_signal_index=0, argv=0xbf9fadc4) at kernel/qobject.cpp:3295
#11 0x011be4d9 in Plasma::DataContainer::dataUpdated (this=0xa141518, _t1=..., _t2=...) at ./datacontainer.moc:101
#12 0x011be658 in Plasma::DataContainer::checkForUpdate (this=0xa141518) at ../../plasma/datacontainer.cpp:167
#13 0x02a439f2 in ListsSource::listsChanged (this=0xa141518) at ../../../dataengines/rememberthemilk/listssource.cpp:76
#14 0x02a43e4b in ListsSource::qt_metacall (this=0xa141518, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbf9fafcc) at ./listssource.moc:78
#15 0x00f7f47a in QMetaObject::metacall (object=0xa141518, cl=3571700, idx=11, argv=0xbf9fafcc) at kernel/qmetaobject.cpp:237
#16 0x00f8dfbb in QMetaObject::activate (sender=0x9c9f418, m=0x2a69d54, local_signal_index=7, argv=0x0) at kernel/qobject.cpp:3295
#17 0x02a538c7 in RTM::Session::listsChanged (this=0x9c9f418) at ./session.moc:187
#18 0x02a6678b in RTM::TasksReader::read (this=0xbf9fb0c8) at ../../../libs/rtm/xmlreaders.cpp:102
#19 0x02a55a60 in RTM::SessionPrivate::taskUpdate (this=0x9c9f418, _c=QMetaObject::InvokeMetaMethod, _id=17, _a=0xbf9fb1d8) at ../../../libs/rtm/session_p.h:74
#20 RTM::Session::qt_metacall (this=0x9c9f418, _c=QMetaObject::InvokeMetaMethod, _id=17, _a=0xbf9fb1d8) at ./session.moc:126
#21 0x00f7f47a in QMetaObject::metacall (object=0x9c9f418, cl=3571700, idx=21, argv=0xbf9fb1d8) at kernel/qmetaobject.cpp:237
#22 0x00f8dfbb in QMetaObject::activate (sender=0x956f1a0, m=0x2a69c20, local_signal_index=0, argv=0xbf9fb1d8) at kernel/qobject.cpp:3295
#23 0x02a53423 in RTM::Request::replyReceived (this=0x956f1a0, _t1=0x956f1a0) at moc_request.cpp:95
#24 0x02a5daf6 in RTM::Request::finished (this=0x956f1a0, job=0xa1238b8) at ../../../libs/rtm/request.cpp:97
#25 0x02a534b1 in RTM::Request::qt_metacall (this=0x956f1a0, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbf9fb388) at moc_request.cpp:83
#26 0x00f7f47a in QMetaObject::metacall (object=0x956f1a0, cl=3571700, idx=12, argv=0xbf9fb388) at kernel/qmetaobject.cpp:237
#27 0x00f8dfbb in QMetaObject::activate (sender=0xa1238b8, m=0x363c88, local_signal_index=3, argv=0xbf9fb388) at kernel/qobject.cpp:3295
#28 0x001f51e3 in KJob::result (this=0xa1238b8, _t1=0xa1238b8) at ./kjob.moc:194
#29 0x001f5548 in KJob::emitResult (this=0xa1238b8) at ../../kdecore/jobs/kjob.cpp:312
#30 0x0073ac60 in KIO::SimpleJob::slotFinished (this=0xa1238b8) at ../../kio/kio/job.cpp:517
#31 0x0073b6a0 in KIO::TransferJob::slotFinished (this=0xa1238b8) at ../../kio/kio/job.cpp:1097
#32 0x00738ac3 in KIO::TransferJob::qt_metacall (this=0xa1238b8, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbf9fb61c) at ./jobclasses.moc:367
#33 0x00f7f47a in QMetaObject::metacall (object=0xa1238b8, cl=3571700, idx=47, argv=0xbf9fb61c) at kernel/qmetaobject.cpp:237
#34 0x00f8dfbb in QMetaObject::activate (sender=0xa122338, m=0x8e9f44, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3295
#35 0x008052a7 in KIO::SlaveInterface::finished (this=0xa122338) at ./slaveinterface.moc:171
#36 0x008085cd in KIO::SlaveInterface::dispatch (this=0xa122338, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#37 0x00805763 in KIO::SlaveInterface::dispatch (this=0xa122338) at ../../kio/kio/slaveinterface.cpp:91
#38 0x007f8c28 in KIO::Slave::gotInput (this=0xa122338) at ../../kio/kio/slave.cpp:324
#39 0x007f8e33 in KIO::Slave::qt_metacall (this=0xa122338, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbf9fb92c) at ./slave.moc:82
#40 0x00f7f47a in QMetaObject::metacall (object=0xa122338, cl=3571700, idx=30, argv=0xbf9fb92c) at kernel/qmetaobject.cpp:237
#41 0x00f8dfbb in QMetaObject::activate (sender=0x9c50c40, m=0x8e6820, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#42 0x00702bd7 in KIO::Connection::readyRead (this=0x9c50c40) at ./connection.moc:92
#43 0x00704f8e in KIO::ConnectionPrivate::dequeue (this=0xa079d50) at ../../kio/kio/connection.cpp:82
#44 0x007050be in KIO::Connection::qt_metacall (this=0x9c50c40, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x9f82028) at ./connection.moc:79
#45 0x00f7f47a in QMetaObject::metacall (object=0x9c50c40, cl=3571700, idx=5, argv=0x9f82028) at kernel/qmetaobject.cpp:237
#46 0x00f89b46 in QMetaCallEvent::placeMetaCall (this=0x9a92e88, object=0x9c50c40) at kernel/qobject.cpp:561
#47 0x00f8ac0e in QObject::event (this=0x9c50c40, e=0x9a92e88) at kernel/qobject.cpp:1248
#48 0x0185be8c in QApplicationPrivate::notify_helper (this=0x9233280, receiver=0x9c50c40, e=0x9a92e88) at kernel/qapplication.cpp:4302
#49 0x01862a0e in QApplication::notify (this=0x922ce50, receiver=0x9c50c40, e=0x9a92e88) at kernel/qapplication.cpp:3706
#50 0x00ad240a in KApplication::notify (this=0x922ce50, receiver=0x9c50c40, event=0x9a92e88) at ../../kdeui/kernel/kapplication.cpp:302
#51 0x00f7a13b in QCoreApplication::notifyInternal (this=0x922ce50, receiver=0x9c50c40, event=0x9a92e88) at kernel/qcoreapplication.cpp:726
#52 0x00f7dbfc in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x91dffc8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#53 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x91dffc8) at kernel/qcoreapplication.cpp:1367
#54 0x00f7dd7d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#55 0x00fa633f in QCoreApplication::sendPostedEvents (s=0x9235310) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#56 postEventSourceDispatch (s=0x9235310) at kernel/qeventdispatcher_glib.cpp:276
#57 0x073b55e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#58 0x073b92d8 in ?? () from /lib/libglib-2.0.so.0
#59 0x073b94b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#60 0x00fa5e35 in QEventDispatcherGlib::processEvents (this=0x9233128, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#61 0x0191be15 in QGuiEventDispatcherGlib::processEvents (this=0x9233128, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#62 0x00f78759 in QEventLoop::processEvents (this=0xbf9fc1e4, flags=) at kernel/qeventloop.cpp:149
#63 0x00f78baa in QEventLoop::exec (this=0xbf9fc1e4, flags=...) at kernel/qeventloop.cpp:201
#64 0x00f7de3f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#65 0x0185bf27 in QApplication::exec () at kernel/qapplication.cpp:3581
#66 0x0675905e in kdemain (argc=1, argv=0x92214a0) at ../../../../plasma/desktop/shell/main.cpp:112
#67 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x92036c8 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051465 "0") at ../../kinit/kinit.cpp:717
#68 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#69 0x0804f190 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#70 0x0804fe4f in main (argc=4, argv=0xbf9fcc94, envp=0xbf9fcca8) at ../../kinit/kinit.cpp:1845

This bug may be a duplicate of or related to bug 202918.

Possible duplicates by query: bug 202923, bug 202918.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-07-20 16:09:41 UTC

*** This bug has been marked as a duplicate of bug 202918 ***