Bug 264105 - Plasma crashes on KDE startup
Summary: Plasma crashes on KDE startup
Status: RESOLVED DUPLICATE of bug 202918
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-rememberthemilk (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-23 20:03 UTC by Alexey Chernov
Modified: 2011-01-28 00:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Chernov 2011-01-23 20:03:12 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.4 (KDE 4.5.4) (Compiled from sources)
Qt Version: 4.7.1
Operating System: Linux 2.6.36.1 x86_64

-- Information about the crash:
Plasma suddenly crashed on KDE startup during session restoring.

-- Backtrace:
Application: Рабочее пространство Plasma (kdeinit4), signal: Aborted
[KCrash Handler]
#6  0x00007fd8bf7c8315 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007fd8bf7c999f in *__GI_abort () at abort.c:92
#8  0x00007fd8c162d39f in qt_message_output (msgType=QtFatalMsg, buf=<value optimized out>) at global/qglobal.cpp:2282
#9  0x00007fd8c162d542 in qt_message (msgType=QtFatalMsg, msg=0x7fd8c17c80b8 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=0x7fffce07e260) at global/qglobal.cpp:2328
#10 0x00007fd8c162d6f5 in qFatal (msg=0x99b <Address 0x99b out of bounds>) at global/qglobal.cpp:2511
#11 0x00007fd898124b4f in QList<unsigned long long>::at (this=0xd25d88, i=5) at /usr/include/QtCore/qlist.h:456
#12 0x00007fd898121708 in RememberTheMilkPlasmoid::listChanged (this=0xd25d40, pos=5) at /usr/src/packages/kde4/4.5.4/kdeplasma-addons-4.5.4/applets/rememberthemilk/rememberthemilk-plasmoid.cpp:238
#13 0x00007fd898121958 in RememberTheMilkPlasmoid::dataUpdated (this=0xd25d40, name=<value optimized out>, data=<value optimized out>)
    at /usr/src/packages/kde4/4.5.4/kdeplasma-addons-4.5.4/applets/rememberthemilk/rememberthemilk-plasmoid.cpp:225
#14 0x00007fd898122246 in RememberTheMilkPlasmoid::qt_metacall (this=0xd25d40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffce07e710)
    at /usr/src/packages/kde4/4.5.4/kdeplasma-addons-4.5.4/build/applets/rememberthemilk/rememberthemilk-plasmoid.moc:94
#15 0x00007fd8c176b78f in QMetaObject::activate (sender=0x19c83f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xffffffffffffffff) at kernel/qobject.cpp:3272
#16 0x00007fd8a9d76c37 in Plasma::DataContainer::dataUpdated (this=0x99b, _t1=<value optimized out>, _t2=<value optimized out>)
    at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/build/plasma/datacontainer.moc:101
#17 0x00007fd8a9d76e7e in Plasma::DataContainer::checkForUpdate (this=0x19c83f0) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/plasma/datacontainer.cpp:169
#18 0x00007fd893d1ff57 in ListsSource::listsChanged (this=<value optimized out>) at /usr/src/packages/kde4/4.5.4/kdeplasma-addons-4.5.4/dataengines/rememberthemilk/listssource.cpp:76
#19 0x00007fd893d20224 in ListsSource::qt_metacall (this=0x19c83f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffce07e910)
    at /usr/src/packages/kde4/4.5.4/kdeplasma-addons-4.5.4/build/dataengines/rememberthemilk/listssource.moc:78
#20 0x00007fd8c176b78f in QMetaObject::activate (sender=0xf92020, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xffffffffffffffff) at kernel/qobject.cpp:3272
#21 0x00007fd893b0c935 in RTM::TasksReader::read (this=0x7fffce07ea30) at /usr/src/packages/kde4/4.5.4/kdeplasma-addons-4.5.4/libs/rtm/xmlreaders.cpp:102
#22 0x00007fd893b02b36 in RTM::SessionPrivate::taskUpdate (this=0xf916b0, reply=0xf59b80) at /usr/src/packages/kde4/4.5.4/kdeplasma-addons-4.5.4/libs/rtm/session_p.h:123
#23 0x00007fd893b020ca in RTM::Session::qt_metacall (this=0xf92020, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffce07ebc0)
    at /usr/src/packages/kde4/4.5.4/kdeplasma-addons-4.5.4/build/libs/rtm/session.moc:131
#24 0x00007fd8c176b78f in QMetaObject::activate (sender=0xf59b80, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xffffffffffffffff) at kernel/qobject.cpp:3272
#25 0x00007fd893b0066f in RTM::Request::replyReceived (this=0x99b, _t1=0xf59b80) at /usr/src/packages/kde4/4.5.4/kdeplasma-addons-4.5.4/build/libs/rtm/moc_request.cpp:98
#26 0x00007fd893b08283 in RTM::Request::finished (this=0xf59b80, job=0x12e39d0) at /usr/src/packages/kde4/4.5.4/kdeplasma-addons-4.5.4/libs/rtm/request.cpp:102
#27 0x00007fd893b0073c in RTM::Request::qt_metacall (this=0xf59b80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffce07ee30)
    at /usr/src/packages/kde4/4.5.4/kdeplasma-addons-4.5.4/build/libs/rtm/moc_request.cpp:86
#28 0x00007fd8c176b78f in QMetaObject::activate (sender=0x12e39d0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xffffffffffffffff) at kernel/qobject.cpp:3272
#29 0x00007fd8c1e4c442 in KJob::result (this=0x99b, _t1=0x12e39d0) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/build/kdecore/kjob.moc:194
#30 0x00007fd8c1e4c7a1 in KJob::emitResult (this=0x12e39d0) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kdecore/jobs/kjob.cpp:312
#31 0x00007fd8abb6878e in KIO::SimpleJob::slotFinished (this=0x12e39d0) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kio/kio/job.cpp:525
#32 0x00007fd8abb68b7d in KIO::TransferJob::slotFinished (this=0x12e39d0) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kio/kio/job.cpp:1114
#33 0x00007fd8abb6ef1d in KIO::TransferJob::qt_metacall (this=0x12e39d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffce07f250)
    at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/build/kio/jobclasses.moc:367
#34 0x00007fd8c176b78f in QMetaObject::activate (sender=0xe7cf90, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xffffffffffffffff) at kernel/qobject.cpp:3272
#35 0x00007fd8abbfca42 in KIO::SlaveInterface::dispatch (this=<value optimized out>, _cmd=104, rawdata=...) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kio/kio/slaveinterface.cpp:175
#36 0x00007fd8abbfcef6 in KIO::SlaveInterface::dispatch (this=0xe7cf90) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kio/kio/slaveinterface.cpp:91
#37 0x00007fd8abbf1831 in KIO::Slave::gotInput (this=0xe7cf90) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kio/kio/slave.cpp:347
#38 0x00007fd8abbf2a0c in KIO::Slave::qt_metacall (this=0xe7cf90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffce07f660)
    at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/build/kio/slave.moc:82
#39 0x00007fd8c176b78f in QMetaObject::activate (sender=0xe57cb0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xffffffffffffffff) at kernel/qobject.cpp:3272
#40 0x00007fd8abb3dcd1 in KIO::ConnectionPrivate::dequeue (this=0xf12ee0) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kio/kio/connection.cpp:82
#41 0x00007fd8abb3ea6d in KIO::Connection::qt_metacall (this=0xe57cb0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x1094640)
    at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/build/kio/connection.moc:79
#42 0x00007fd8c1764306 in QObject::event (this=0xe57cb0, e=0x99b) at kernel/qobject.cpp:1211
#43 0x00007fd8c04aaaf0 in QApplicationPrivate::notify_helper (this=0x8fccc0, receiver=0xe57cb0, e=0xffeab0) at kernel/qapplication.cpp:4445
#44 0x00007fd8c04b7e89 in QApplication::notify (this=0x8f2180, receiver=<value optimized out>, e=0xffeab0) at kernel/qapplication.cpp:4324
#45 0x00007fd8c274bcf1 in KApplication::notify (this=0x8f2180, receiver=0xe57cb0, event=0xffeab0) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:310
#46 0x00007fd8c174d36b in QCoreApplication::notifyInternal (this=0x8f2180, receiver=0xe57cb0, event=0xffeab0) at kernel/qcoreapplication.cpp:732
#47 0x00007fd8c1752397 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x864b00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#48 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x864b00) at kernel/qcoreapplication.cpp:1373
#49 0x00007fd8c1782543 in QCoreApplication::sendPostedEvents (s=0x9000a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#50 postEventSourceDispatch (s=0x9000a0) at kernel/qeventdispatcher_glib.cpp:277
#51 0x00007fd8bc6123fc in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#52 0x00007fd8bc612ce8 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#53 0x00007fd8bc612eac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#54 0x00007fd8c1782173 in QEventDispatcherGlib::processEvents (this=0x866d30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#55 0x00007fd8c057803e in QGuiEventDispatcherGlib::processEvents (this=0x99b, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#56 0x00007fd8c174bf62 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#57 0x00007fd8c174c345 in QEventLoop::exec (this=0x7fffce0800e0, flags=) at kernel/qeventloop.cpp:201
#58 0x00007fd8c17526ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#59 0x00007fd8a5c67d3f in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/packages/kde4/4.5.4/kdebase-workspace-4.5.4/plasma/desktop/shell/main.cpp:118
#60 0x0000000000407acd in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, 
    tty=0x0, avoid_loops=false, startup_id_str=0x40b156 "0") at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kinit/kinit.cpp:723
#61 0x000000000040875c in handle_launcher_request (sock=8, who=<value optimized out>) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kinit/kinit.cpp:1215
#62 0x0000000000408efa in handle_requests (waitForPid=<value optimized out>) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kinit/kinit.cpp:1408
#63 0x00000000004093f7 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kinit/kinit.cpp:1892

Possible duplicates by query: bug 257526, bug 245231.

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-01-28 00:23:17 UTC

*** This bug has been marked as a duplicate of bug 202918 ***