Bug 257526 - Desktop crashed after booting
Summary: Desktop crashed after booting
Status: RESOLVED DUPLICATE of bug 202918
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-rememberthemilk (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-21 16:52 UTC by Thomas Malkus
Modified: 2010-11-21 18:35 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Malkus 2010-11-21 16:52:18 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

Booting up the machine, the desktop crashed. After many restarts the desktop comes up.

-- Backtrace:
Application: Plasma-Arbeitsfläche (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7772720 (LWP 1761))]

Thread 12 (Thread 0xb0102b70 (LWP 1775)):
#0  0x009a4416 in __kernel_vsyscall ()
#1  0x008ba4dc in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x00df1dbd in __pthread_cond_wait (cond=0x1595290, mutex=0x1595278) at forward.c:139
#3  0x01491877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x15901a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x014918c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x15901a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x008b5cc9 in start_thread (arg=0xb0102b70) at pthread_create.c:304
#6  0x00de46be in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 11 (Thread 0xad7b9b70 (LWP 1780)):
#0  0x05927e36 in clock_gettime (clock_id=93503476, tp=0xad7b8f80) at ../sysdeps/unix/clock_gettime.c:100
#1  0x046a950b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x047806e5 in QTimerInfoList::updateCurrentTime (this=0x8e303bc) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0478072a in QTimerInfoList::timerWait (this=0x8e303bc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0477e7a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xad7b90ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0477e83d in timerSourcePrepare (source=0x0, timeout=0x592bff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x01b65e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x01b66279 in ?? () from /lib/libglib-2.0.so.0
#9  0x01b66848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x0477e59f in QEventDispatcherGlib::processEvents (this=0x8e30200, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x0474e609 in QEventLoop::processEvents (this=0xad7b9280, flags=) at kernel/qeventloop.cpp:149
#12 0x0474ea8a in QEventLoop::exec (this=0xad7b9280, flags=...) at kernel/qeventloop.cpp:201
#13 0x0464ab7e in QThread::exec (this=0x8e2e320) at thread/qthread.cpp:490
#14 0x0472d35b in QInotifyFileSystemWatcherEngine::run (this=0x8e2e320) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0464ddf9 in QThreadPrivate::start (arg=0x8e2e320) at thread/qthread_unix.cpp:266
#16 0x008b5cc9 in start_thread (arg=0xad7b9b70) at pthread_create.c:304
#17 0x00de46be in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 10 (Thread 0xa7d44b70 (LWP 1848)):
#0  0x009a4416 in __kernel_vsyscall ()
#1  0x008ba884 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_timedwait.S:236
#2  0x00df1e14 in __pthread_cond_timedwait (cond=0x92f6d18, mutex=0x92f6d00, abstime=0xa7d44310) at forward.c:152
#3  0x04353b3f in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 9 (Thread 0xa7138b70 (LWP 1850)):
#0  0x009a4416 in __kernel_vsyscall ()
#1  0x00ddd391 in select () at ../sysdeps/unix/syscall-template.S:82
#2  0x0437ff1c in xine_usec_sleep () from /usr/lib/libxine.so.1
#3  0x00000000 in ?? ()

Thread 8 (Thread 0xa6937b70 (LWP 1851)):
#0  0x01b663f1 in ?? () from /lib/libglib-2.0.so.0
#1  0x01b66848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#2  0x0477e59f in QEventDispatcherGlib::processEvents (this=0x91e90b8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#3  0x0474e609 in QEventLoop::processEvents (this=0xa6937270, flags=) at kernel/qeventloop.cpp:149
#4  0x0474ea8a in QEventLoop::exec (this=0xa6937270, flags=...) at kernel/qeventloop.cpp:201
#5  0x0464ab7e in QThread::exec (this=0x92034f8) at thread/qthread.cpp:490
#6  0x042a681a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#7  0x0464ddf9 in QThreadPrivate::start (arg=0x92034f8) at thread/qthread_unix.cpp:266
#8  0x008b5cc9 in start_thread (arg=0xa6937b70) at pthread_create.c:304
#9  0x00de46be in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 7 (Thread 0xa6136b70 (LWP 1852)):
#0  0x009a4416 in __kernel_vsyscall ()
#1  0x00dd5df6 in __poll (fds=0xe6dff4, nfds=2, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x01ceb562 in ?? () from /usr/lib/libpulse.so.0
#3  0x01cd7ab9 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#4  0x01cd9a73 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#5  0x01cd9b44 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#6  0x01ceb303 in ?? () from /usr/lib/libpulse.so.0
#7  0x05713bd5 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#8  0x008b5cc9 in start_thread (arg=0xa6136b70) at pthread_create.c:304
#9  0x00de46be in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 6 (Thread 0xa1934b70 (LWP 1853)):
#0  0x009a4416 in __kernel_vsyscall ()
#1  0x008ba4dc in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x00df1dbd in __pthread_cond_wait (cond=0x9713910, mutex=0x97138f8) at forward.c:139
#3  0x04365b54 in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 5 (Thread 0xa0d4ab70 (LWP 1854)):
#0  0x009a4416 in __kernel_vsyscall ()
#1  0x008ba4dc in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x00df1dbd in __pthread_cond_wait (cond=0x987428c, mutex=0x9874274) at forward.c:139
#3  0x043576c8 in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 4 (Thread 0xa037cb70 (LWP 1855)):
#0  0x009a4416 in __kernel_vsyscall ()
#1  0x008ba4dc in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x00df1dbd in __pthread_cond_wait (cond=0x9885f64, mutex=0x9885f4c) at forward.c:139
#3  0x043576c8 in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 3 (Thread 0x9fb7bb70 (LWP 1861)):
#0  0x009a4416 in __kernel_vsyscall ()
#1  0x008ba4dc in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x00df1dbd in __pthread_cond_wait (cond=0x98a39cc, mutex=0x98a39b4) at forward.c:139
#3  0x04368f3c in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0x9eb71b70 (LWP 1863)):
#0  0x009a4416 in __kernel_vsyscall ()
#1  0x008ba4dc in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x00df1dbd in __pthread_cond_wait (cond=0x3631770, mutex=0x3631758) at forward.c:139
#3  0x031293a5 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0x03129481 in ?? () from /usr/lib/libQtWebKit.so.4
#5  0x008b5cc9 in start_thread (arg=0x9eb71b70) at pthread_create.c:304
#6  0x00de46be in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb7772720 (LWP 1761)):
[KCrash Handler]
#7  0x069b0ccb in RememberTheMilkPlasmoid::listChanged (this=0x8b82038, pos=5) at ../../../applets/rememberthemilk/rememberthemilk-plasmoid.cpp:238
#8  0x069b4214 in RememberTheMilkPlasmoid::dataUpdated (this=0x8b82038, name=..., data=...) at ../../../applets/rememberthemilk/rememberthemilk-plasmoid.cpp:225
#9  0x069b4bfc in RememberTheMilkPlasmoid::qt_metacall (this=0x8b82038, _c=QMetaObject::InvokeMetaMethod, _id=75, _a=0xbff09704) at ./rememberthemilk-plasmoid.moc:94
#10 0x047558ca in QMetaObject::metacall (object=0x8b82038, cl=37863412, idx=75, argv=0xbff09704) at kernel/qmetaobject.cpp:237
#11 0x047686ad in QMetaObject::activate (sender=0x9e2eac8, m=0x3a3744, local_signal_index=0, argv=0x6d6f6501) at kernel/qobject.cpp:3280
#12 0x001e3e69 in Plasma::DataContainer::dataUpdated (this=0x9e2eac8, _t1=..., _t2=...) at ./datacontainer.moc:101
#13 0x001e3fe8 in Plasma::DataContainer::checkForUpdate (this=0x9e2eac8) at ../../plasma/datacontainer.cpp:169
#14 0x041714f2 in ListsSource::listsChanged (this=0x9e2eac8) at ../../../dataengines/rememberthemilk/listssource.cpp:76
#15 0x0417194b in ListsSource::qt_metacall (this=0x9e2eac8, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbff0990c) at ./listssource.moc:78
#16 0x047558ca in QMetaObject::metacall (object=0x9e2eac8, cl=37863412, idx=11, argv=0xbff0990c) at kernel/qmetaobject.cpp:237
#17 0x047686ad in QMetaObject::activate (sender=0x9147600, m=0x58b1d54, local_signal_index=7, argv=0x6d6f6501) at kernel/qobject.cpp:3280
#18 0x0589a1b7 in RTM::Session::listsChanged (this=0x9147600) at ./session.moc:195
#19 0x058adedb in RTM::TasksReader::read (this=0xbff09a08) at ../../../libs/rtm/xmlreaders.cpp:102
#20 0x0589caf3 in listUpdate (this=0x9147600, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xbff09b68) at ../../../libs/rtm/session_p.h:130
#21 RTM::Session::qt_metacall (this=0x9147600, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xbff09b68) at ./session.moc:132
#22 0x047558ca in QMetaObject::metacall (object=0x9147600, cl=37863412, idx=22, argv=0xbff09b68) at kernel/qmetaobject.cpp:237
#23 0x047686ad in QMetaObject::activate (sender=0x9c34f40, m=0x58b1c20, local_signal_index=0, argv=0x6d6f6501) at kernel/qobject.cpp:3280
#24 0x05899d03 in RTM::Request::replyReceived (this=0x9c34f40, _t1=0x9c34f40) at moc_request.cpp:98
#25 0x058a4da4 in RTM::Request::finished (this=0x9c34f40, job=0x8a558d8) at ../../../libs/rtm/request.cpp:102
#26 0x05899e1f in RTM::Request::qt_metacall (this=0x9c34f40, _c=QMetaObject::InvokeMetaMethod, _id=13, _a=0xbff09d18) at moc_request.cpp:86
#27 0x047558ca in QMetaObject::metacall (object=0x9c34f40, cl=37863412, idx=13, argv=0xbff09d18) at kernel/qmetaobject.cpp:237
#28 0x047686ad in QMetaObject::activate (sender=0x8a558d8, m=0x2417b48, local_signal_index=3, argv=0x6d6f6501) at kernel/qobject.cpp:3280
#29 0x022a48a3 in KJob::result (this=0x8a558d8, _t1=0x8a558d8) at ./kjob.moc:194
#30 0x022a4c08 in KJob::emitResult (this=0x8a558d8) at ../../kdecore/jobs/kjob.cpp:312
#31 0x0046b480 in KIO::SimpleJob::slotFinished (this=0x8a558d8) at ../../kio/kio/job.cpp:522
#32 0x0046b960 in KIO::TransferJob::slotFinished (this=0x8a558d8) at ../../kio/kio/job.cpp:1111
#33 0x00469453 in KIO::TransferJob::qt_metacall (this=0x8a558d8, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbff09fbc) at ./jobclasses.moc:367
#34 0x047558ca in QMetaObject::metacall (object=0x8a558d8, cl=37863412, idx=47, argv=0xbff09fbc) at kernel/qmetaobject.cpp:237
#35 0x047686ad in QMetaObject::activate (sender=0x91be190, m=0x61a944, local_signal_index=4, argv=0x6d6f6501) at kernel/qobject.cpp:3280
#36 0x00523fc7 in KIO::SlaveInterface::finished (this=0x91be190) at ./slaveinterface.moc:171
#37 0x00527768 in KIO::SlaveInterface::dispatch (this=0x91be190, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#38 0x00524483 in KIO::SlaveInterface::dispatch (this=0x91be190) at ../../kio/kio/slaveinterface.cpp:91
#39 0x00516fe8 in KIO::Slave::gotInput (this=0x91be190) at ../../kio/kio/slave.cpp:344
#40 0x005171f3 in KIO::Slave::qt_metacall (this=0x91be190, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbff0a2dc) at ./slave.moc:82
#41 0x047558ca in QMetaObject::metacall (object=0x91be190, cl=37863412, idx=30, argv=0xbff0a2dc) at kernel/qmetaobject.cpp:237
#42 0x047686ad in QMetaObject::activate (sender=0x91992d0, m=0x617500, local_signal_index=0, argv=0x6d6f6501) at kernel/qobject.cpp:3280
#43 0x00430e17 in KIO::Connection::readyRead (this=0x91992d0) at ./connection.moc:92
#44 0x0043317e in KIO::ConnectionPrivate::dequeue (this=0x8f40648) at ../../kio/kio/connection.cpp:82
#45 0x004332ae in KIO::Connection::qt_metacall (this=0x91992d0, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x90f5ed0) at ./connection.moc:79
#46 0x047558ca in QMetaObject::metacall (object=0x91992d0, cl=37863412, idx=5, argv=0x90f5ed0) at kernel/qmetaobject.cpp:237
#47 0x04760df6 in QMetaCallEvent::placeMetaCall (this=0x9df8690, object=0x91992d0) at kernel/qobject.cpp:534
#48 0x047626a2 in QObject::event (this=0x91992d0, e=0x98af910) at kernel/qobject.cpp:1219
#49 0x06e47fdc in QApplicationPrivate::notify_helper (this=0x8633610, receiver=0x91992d0, e=0x9df8690) at kernel/qapplication.cpp:4396
#50 0x06e4e04e in QApplication::notify (this=0x8625640, receiver=0x91992d0, e=0x9df8690) at kernel/qapplication.cpp:3798
#51 0x0112c68a in KApplication::notify (this=0x8625640, receiver=0x91992d0, event=0x9df8690) at ../../kdeui/kernel/kapplication.cpp:310
#52 0x0474fb3b in QCoreApplication::notifyInternal (this=0x8625640, receiver=0x91992d0, event=0x9df8690) at kernel/qcoreapplication.cpp:732
#53 0x04752d8b in sendEvent (receiver=0x0, event_type=0, data=0x860f040) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#54 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x860f040) at kernel/qcoreapplication.cpp:1373
#55 0x04752f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#56 0x0477ea74 in sendPostedEvents (s=0x8635978) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#57 postEventSourceDispatch (s=0x8635978) at kernel/qeventdispatcher_glib.cpp:277
#58 0x01b62855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#59 0x01b66668 in ?? () from /lib/libglib-2.0.so.0
#60 0x01b66848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#61 0x0477e565 in QEventDispatcherGlib::processEvents (this=0x860ed00, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#62 0x06f09be5 in QGuiEventDispatcherGlib::processEvents (this=0x860ed00, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#63 0x0474e609 in QEventLoop::processEvents (this=0xbff0ab94, flags=) at kernel/qeventloop.cpp:149
#64 0x0474ea8a in QEventLoop::exec (this=0xbff0ab94, flags=...) at kernel/qeventloop.cpp:201
#65 0x0475300f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#66 0x06e46e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#67 0x00c3486e in kdemain (argc=1, argv=0xbff0ada4) at ../../../../plasma/desktop/shell/main.cpp:118
#68 0x080485bb in main (argc=1, argv=0xbff0ada4) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 202918.

Possible duplicates by query: bug 245231.

Reported using DrKonqi
Comment 1 Thomas Malkus 2010-11-21 17:01:08 UTC
After removing the RemberTheMilk plasmoid from the desktop, the desktop is started normally. So I think the reason for this crash is the RememberTheMilk plasmoid.
Comment 2 Dario Andres 2010-11-21 18:35:27 UTC
[Comment from a bug triager]
Indeed, this is a bug in the RememberTheMilk plasmoid. The issue is being tracked at bug 202918. Merging.
Thanks

*** This bug has been marked as a duplicate of bug 202918 ***