Bug 190535 - [steps] Dolphin crashed when changing all the permissions in home/changing folder icon several times [null KDirModelNode::rowNumber, KDirModelPrivate::indexForNode, KDirModelPrivate::_k_slotNewItems]
Summary: [steps] Dolphin crashed when changing all the permissions in home/changing fo...
Status: RESOLVED WORKSFORME
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords: reproducible, testcase, triaged
: 181536 192594 198320 199556 199902 200411 200526 202164 202181 202714 204952 205852 207408 207992 209142 209228 210251 210523 210533 210538 211520 211780 211827 212655 212697 212773 213030 213310 213952 214164 214625 214626 214938 215319 215433 215442 215479 215555 215689 215920 216032 216121 216189 216228 216229 216340 216360 216565 216612 216644 216705 217518 217645 217783 217924 218311 218379 218454 218550 218704 220162 220607 220950 221955 222021 222068 222360 222374 224496 224725 224903 225226 225884 226589 227145 227700 227874 230273 230561 230698 232553 235811 237036 240941 245165 250874 262425 275102 275295 285415 295702 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-24 19:03 UTC by Ken Baldry
Modified: 2018-10-02 08:43 UTC (History)
82 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Return early on error in the KDirModelPrivate::_k_slotNewItems() (382 bytes, patch)
2009-12-07 23:12 UTC, Linus Lewandowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Baldry 2009-04-24 19:03:12 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

Application: Dolphin (dolphin), signal SIGSEGV
[?1034h(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb3ebeb90 (LWP 4113)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7700728 in ?? () from /usr/lib/libkio.so.5
#7  0xb77007d0 in ?? () from /usr/lib/libkio.so.5
#8  0xb7703f34 in ?? () from /usr/lib/libkio.so.5
#9  0xb7705195 in KDirModel::qt_metacall(QMetaObject::Call, int, void**) ()
   from /usr/lib/libkio.so.5
#10 0xb7f82580 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /usr/lib/libQtCore.so.4
#11 0xb7f83302 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#12 0xb76ed983 in KDirLister::newItems(KFileItemList const&) ()
   from /usr/lib/libkio.so.5
#13 0xb76ee90a in KDirLister::Private::emitItems() () from /usr/lib/libkio.so.5
#14 0xb76f0452 in ?? () from /usr/lib/libkio.so.5
#15 0xb76fbf71 in ?? () from /usr/lib/libkio.so.5
#16 0xb76fc702 in ?? () from /usr/lib/libkio.so.5
#17 0xb7f82580 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /usr/lib/libQtCore.so.4
#18 0xb7f83302 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#19 0xb7705c13 in OrgKdeKDirNotifyInterface::FilesChanged(QStringList const&)
    () from /usr/lib/libkio.so.5
#20 0xb7705dda in OrgKdeKDirNotifyInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#21 0xb7256e6f in ?? () from /usr/lib/libQtDBus.so.4
#22 0xb725e1f7 in ?? () from /usr/lib/libQtDBus.so.4
#23 0xb7f7d281 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#24 0xb6a678fc in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /usr/lib/libQtGui.so.4
#25 0xb6a6f75e in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libQtGui.so.4
#26 0xb7a2a41d in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdeui.so.5
#27 0xb7f6d961 in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /usr/lib/libQtCore.so.4
#28 0xb7f6e5d5 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#29 0xb7f6e7cd in QCoreApplication::sendPostedEvents(QObject*, int) ()
   from /usr/lib/libQtCore.so.4
#30 0xb7f9836f in ?? () from /usr/lib/libQtCore.so.4
#31 0xb62329a8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0xb6236063 in ?? () from /usr/lib/libglib-2.0.so.0
#33 0xb6236221 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#34 0xb7f97fb8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#35 0xb6b00785 in ?? () from /usr/lib/libQtGui.so.4
#36 0xb7f6c01a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#37 0xb7f6c1da in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib/libQtCore.so.4
#38 0xb7f6e895 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#39 0xb6a67777 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#40 0x080834df in _start ()
Comment 1 FiNeX 2009-04-25 17:05:41 UTC
Thanks Ken. Being you using a compiled from source version. You could re-compile dolphin enabling debug messages in order to provide a more useful backtrace.
Comment 2 Frank Reininghaus 2009-04-26 00:38:38 UTC
I reproduced this in 4.2.2 (Kubuntu 9.04) by right-clicking in my home dir (in the white area, not on a file), clicking "Properties", modifying the permissions and clicking OK. Not 100% reproducible, maybe it depends on files getting changed or added while the Properties dialog is open.

Probably a duplicate of bug 181536 (and quite a few more which can be found by searching crashes with "OrgKdeKDirNotifyInterface" in a comment).

Application: Dolphin (dolphin), signal SIGSEGV

Thread 1 (Thread 0xb5c12700 (LWP 6679)):
[KCrash Handler]
#6  0xb7dcf848 in KDirModelNode::rowNumber (this=0x0) at /build/buildd/kde4libs-4.2.2/kio/kio/kdirmodel.cpp:115
#7  0xb7dcf8f0 in KDirModelPrivate::indexForNode (this=0xa1d3ef8, node=0x0, rowNumber=-1) at /build/buildd/kde4libs-4.2.2/kio/kio/kdirmodel.cpp:279
#8  0xb7dd422e in KDirModelPrivate::_k_slotNewItems (this=0xa1d3ef8, directoryUrl=@0xa40e968, items=@0xa40e970) at /build/buildd/kde4libs-4.2.2/kio/kio/kdirmodel.cpp:372
#9  0xb7dd55cc in KDirModel::qt_metacall (this=0xa1de918, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfe836b8) at /build/buildd/kde4libs-4.2.2/obj-i486-linux-gnu/kio/kdirmodel.moc:78
#10 0xb6730ca8 in QMetaObject::activate (sender=0xa1de800, from_signal_index=14, to_signal_index=14, argv=0xbfe836b8) at kernel/qobject.cpp:3069
#11 0xb6731932 in QMetaObject::activate (sender=0xa1de800, m=0x80a92b0, local_signal_index=10, argv=0xbfe836b8) at kernel/qobject.cpp:3143
#12 0xb7db8ae9 in KDirLister::itemsAdded (this=0xa1de800, _t1=@0xa40e968, _t2=@0xa40e970) at /build/buildd/kde4libs-4.2.2/obj-i486-linux-gnu/kio/kdirlister.moc:268
#13 0xb7db9ce6 in KDirLister::Private::emitItems (this=0xa1de858) at /build/buildd/kde4libs-4.2.2/kio/kio/kdirlister.cpp:2274
#14 0xb7dbbcbf in KDirListerCache::emitRefreshItem (this=0xa020ee8, oldItem=@0xbfe83814, fileitem=@0xa087454) at /build/buildd/kde4libs-4.2.2/kio/kio/kdirlister.cpp:960
#15 0xb7dca0a5 in KDirListerCache::slotFilesChanged (this=0xa020ee8, fileList=@0xab49fe8) at /build/buildd/kde4libs-4.2.2/kio/kio/kdirlister.cpp:834
#16 0xb7dcacc2 in KDirListerCache::qt_metacall (this=0xa020ee8, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfe8392c) at /build/buildd/kde4libs-4.2.2/obj-i486-linux-gnu/kio/kdirlister_p.moc:93
#17 0xb6730ca8 in QMetaObject::activate (sender=0x9f3a898, from_signal_index=8, to_signal_index=8, argv=0xbfe8392c) at kernel/qobject.cpp:3069
#18 0xb6731932 in QMetaObject::activate (sender=0x9f3a898, m=0xb7f442d4, local_signal_index=3, argv=0xbfe8392c) at kernel/qobject.cpp:3143
#19 0xb7dd7073 in OrgKdeKDirNotifyInterface::FilesChanged (this=0x9f3a898, _t1=@0xab49fe8) at /build/buildd/kde4libs-4.2.2/obj-i486-linux-gnu/kio/kdirnotify.moc:118
#20 0xb7dd723a in OrgKdeKDirNotifyInterface::qt_metacall (this=0x9f3a898, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbfe83ac8)
    at /build/buildd/kde4libs-4.2.2/obj-i486-linux-gnu/kio/kdirnotify.moc:82
#21 0xb7223d7a in QDBusConnectionPrivate::deliverCall (this=0x9e5c520, object=0x9f3a898, msg=@0xa499224, metaTypes=@0xa499228, slotIdx=8) at qdbusintegrator.cpp:891
#22 0xb722c187 in QDBusCallDeliveryEvent::placeMetaCall (this=0xa4991f8, object=0x9f3a898) at qdbusintegrator_p.h:101
#23 0xb672b3a0 in QObject::event (this=0x9f3a898, e=0xa4991f8) at kernel/qobject.cpp:1118
#24 0xb6952f2c in QApplicationPrivate::notify_helper (this=0x9e645e8, receiver=0x9f3a898, e=0xa4991f8) at kernel/qapplication.cpp:4084
#25 0xb695b22e in QApplication::notify (this=0xbfe841e4, receiver=0x9f3a898, e=0xa4991f8) at kernel/qapplication.cpp:3631
#26 0xb76af94d in KApplication::notify (this=0xbfe841e4, receiver=0x9f3a898, event=0xa4991f8) at /build/buildd/kde4libs-4.2.2/kdeui/kernel/kapplication.cpp:307
#27 0xb671aa3b in QCoreApplication::notifyInternal (this=0xbfe841e4, receiver=0x9f3a898, event=0xa4991f8) at kernel/qcoreapplication.cpp:602
#28 0xb671b695 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9e45b38) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#29 0xb671b88d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1132
#30 0xb67467ef in postEventSourceDispatch (s=0x9e72cd0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#31 0xb5e98b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0xb5e9c0eb in ?? () from /usr/lib/libglib-2.0.so.0
#33 0xb5e9c268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#34 0xb6746438 in QEventDispatcherGlib::processEvents (this=0x9e498a0, flags={i = -1075298104}) at kernel/qeventdispatcher_glib.cpp:323
#35 0xb69f43f5 in QGuiEventDispatcherGlib::processEvents (this=0x9e498a0, flags={i = -1075298056}) at kernel/qguieventdispatcher_glib.cpp:202
#36 0xb671906a in QEventLoop::processEvents (this=0xbfe84170, flags={i = -1075297992}) at kernel/qeventloop.cpp:149
#37 0xb67194aa in QEventLoop::exec (this=0xbfe84170, flags={i = -1075297928}) at kernel/qeventloop.cpp:200
#38 0xb671b959 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#39 0xb6952da7 in QApplication::exec () at kernel/qapplication.cpp:3553
#40 0x080856ef in main (argc=5, argv=0xbfe84394) at /build/buildd/kdebase-4.2.2/apps/dolphin/src/main.cpp:94
Comment 3 Dario Andres 2009-05-15 17:15:28 UTC
@Frank: could bug 192770 also be related to this? (it seems to be non-reproducible on a updated trunk build) Thanks
Comment 4 Frank Reininghaus 2009-05-16 13:22:32 UTC
(In reply to comment #3)
> @Frank: could bug 192770 also be related to this?

It seems so, but right now I can't reproduce any of these issues in trunk. They never seemed 100% reproducible for me though, so I don't know if this is really fixed or if I'm just unlucky today ;-)
Comment 5 Dario Andres 2009-05-24 21:24:09 UTC
I also got this: bug 193818
Comment 6 Dario Andres 2009-05-27 19:36:53 UTC
Bug 192594 seems to be also related (save dialog on fish using KMail)
Comment 7 David Faure 2009-07-16 16:44:06 UTC
*** Bug 200411 has been marked as a duplicate of this bug. ***
Comment 8 Frank Reininghaus 2009-07-19 21:41:00 UTC
*** Bug 200526 has been marked as a duplicate of this bug. ***
Comment 9 Frank Reininghaus 2009-07-19 22:06:54 UTC
To everyone who can still reproduce this crash (I couldn't reproduce it today): there might be some output before the crash which starts with "Items emitted in directory". If you're not running the crashing application from Konsole, this output is in ~/.xsession-errors. It might help if you could paste this output here. Thanks!

[I think bug 181536, where I've once hit the Q_ASSERT(result) in KDirModelPrivate::_k_slotNewItems(), is a duplicate. Probably the segfault occurs if asserts are disabled, but the error output should be there anyway.]
Comment 10 FiNeX 2009-08-01 11:33:37 UTC
*** Bug 202181 has been marked as a duplicate of this bug. ***
Comment 11 FiNeX 2009-08-01 11:35:33 UTC
*** Bug 192594 has been marked as a duplicate of this bug. ***
Comment 12 FiNeX 2009-08-01 11:37:11 UTC
*** Bug 202164 has been marked as a duplicate of this bug. ***
Comment 13 FiNeX 2009-08-01 11:37:52 UTC
*** Bug 199556 has been marked as a duplicate of this bug. ***
Comment 14 FiNeX 2009-08-01 11:38:20 UTC
*** Bug 198320 has been marked as a duplicate of this bug. ***
Comment 15 Dario Andres 2009-09-16 03:37:19 UTC
*** Bug 207408 has been marked as a duplicate of this bug. ***
Comment 16 Dario Andres 2009-09-21 00:51:02 UTC
*** Bug 207992 has been marked as a duplicate of this bug. ***
Comment 17 David Faure 2009-09-29 11:08:42 UTC
SVN commit 1029200 by dfaure:

Don't assert if dataChanged(root, root) is emitted, e.g. when changing permissions for the current dir.
CCBUG: 190535
CCMAIL: Peter Penz <peter.penz@gmx.at>


 M  +4 -0      kfilepreviewgenerator.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1029200
Comment 18 David Faure 2009-09-29 11:40:26 UTC
My fix gets rid of the assert (or crash like in bug 193466) in KFilePreviewGenerator, but that seems unrelated to all the backtraces here mentionning _k_slotNewItems / indexForNode. I still need to find a way to reproduce that crash.
Comment 19 David Faure 2009-09-29 11:42:06 UTC
*** Bug 181536 has been marked as a duplicate of this bug. ***
Comment 20 Dario Andres 2009-10-01 00:11:44 UTC
*** Bug 204952 has been marked as a duplicate of this bug. ***
Comment 21 Dario Andres 2009-10-03 19:52:04 UTC
*** Bug 209228 has been marked as a duplicate of this bug. ***
Comment 22 Henry Pfeil 2009-10-04 18:50:39 UTC
Dario Andres wrote:
> https://bugs.kde.org/show_bug.cgi?id=190535
>
> --- Comment #21 from Dario Andres <andresbajotierra gmail com>  2009-10-03 19:52:04 ---
> - Does Dolphin crash every time you repeat the situation ?
>
> **
>   
Sorry, Sir, I've been unable to replicate the crash. There were four
similar segfaults prior to my bug report, according to the crash logs I
found. I switched to Thunar for the rest of the day. However, Fedora did
release a glibc update (glibc-2.10.1-5) the following day (2009-10-03). 
The message log is peppered with gvfs-gdu-volume segfaults in libgdu.so
with no visible effects. Don't know why I get Gnome stuff in KDE, but
that's Fedora.

These might be relevant...
http://www.kerneloops.org/submitresult.php?number=771593
http://www.kerneloops.org/submitresult.php?number=771760

I wouldn't consider this a high priority. This instance of Fedora 11 was
upgraded from 8, 9, and 10 all using yum. It's scheduled for conversion
from reiserfs to ext4 with a clean install as soon as I can find enough
room to back up my project files.
Comment 23 Ken Baldry 2009-10-04 20:12:53 UTC
Thanks for the reply. You have obviously done your best.
regards,
Ken
(who wrote an operating system in 1966)
Comment 24 Henry Pfeil 2009-10-05 21:54:33 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.30.8-64.fc11.x86_64 x86_64
Distribution: "Fedora release 11 (Leonidas)"

What I was doing when the application crashed:
<In detail, tell us what you were doing  when the application crashed.>

Simply changed directory from one to another. Caught me by surprise.
[The previous 'thread' comment was from Drkonqi starting up.]
(All I did in 1966 was write a fortran program to solve the Pythagoren Theorem for positive roots on a roll of paper tape.)

 -- Backtrace:
Application: Dolphin (dolphin), signal: Aborted
[KCrash Handler]
#5  0x0000003a6d8332f5 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x0000003a6d834b20 in *__GI_abort () at abort.c:88
#7  0x0000003a70cc35f5 in __gnu_cxx::__verbose_terminate_handler () at ../../../../libstdc++-v3/libsupc++/vterminate.cc:93
#8  0x0000003a70cc1a36 in __cxxabiv1::__terminate (handler=0xc21) at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:38
#9  0x0000003a70cc1a63 in std::terminate () at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:48
#10 0x0000003a70cc1ae6 in __cxxabiv1::__cxa_rethrow () at ../../../../libstdc++-v3/libsupc++/eh_throw.cc:116
#11 0x0000003a7853e3f5 in QEventLoop::exec (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:214
#12 0x0000003a78540439 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#13 0x0000000000437085 in _start ()
Warning: the current language does not match this frame.

Report to https://bugs.kde.org
Comment 25 Henry Pfeil 2009-10-06 16:15:24 UTC
I'm fishing for dolphin in gdb. My first guess is that my Fedora
installation is not quite right. Although dolphin is running, it started
with the following errors in the same thread:
org.freedesktop.DBus.Error.ServiceUnknown - The name
org.kde.nepomuk.services.nepomukstorage was not provided by any .service
files
  QLocalSocket::connectToServer: Invalid name

Program exited normally. -- Yet dolphin is running. It suggests
debug-install about a dozen programs, including gamin. Gamin is not in
the process tree, nor is nepomuk, which may be the source of these
recent crashes.  Perhaps you might want to close this instance of the
bug due to a corrupt Fedora 11 setup that omitted things that dolphin
occasionally requires and assumes should be already installed. IBK
Comment 26 Frank Reininghaus 2009-10-08 17:18:47 UTC
(In reply to comment #25)
> I'm fishing for dolphin in gdb.

When debugging Dolphin with gdb, it may help to close all Dolphin windows first and then start gdb with

gdb --args dolphin --nofork

Without the --nofork argument, a new process is forked off the one you're seeing in gdb, or another window is opened within an already existing process because Dolphin is a KUniqueApplication.
Comment 27 Dario Andres 2009-10-11 00:17:06 UTC
*** Bug 205852 has been marked as a duplicate of this bug. ***
Comment 28 Dario Andres 2009-10-12 00:15:08 UTC
*** Bug 209142 has been marked as a duplicate of this bug. ***
Comment 29 Dario Andres 2009-10-12 00:15:34 UTC
*** Bug 210251 has been marked as a duplicate of this bug. ***
Comment 30 Dario Andres 2009-10-12 00:16:24 UTC
*** Bug 202714 has been marked as a duplicate of this bug. ***
Comment 31 m.wege 2009-10-13 23:58:32 UTC
I have reproced the plasma crash which happened on the same occasion, described in https://bugs.kde.org/show_bug.cgi?id=209862
What I also noticed that after I had changed the icon of /home/user in Dolphin the icon does not get updated in the view. Instead of this "user" (the directory name) gets replaced by a "." That in fact everything went as expected can only be seen after the restart of Dolphin.

Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 0 (LWP 3209)]

Thread 2 (Thread 0xa7e47b90 (LWP 3211)):
#0  0xb809f430 in __kernel_vsyscall ()
#1  0xb65930e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb67732ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb7e99172 in QWaitCondition::wait (this=0x8c67680, mutex=0x8c6767c, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb77d5ac2 in QHostInfoAgent::run (this=0x8c67670) at kernel/qhostinfo.cpp:260
#5  0xb7e98132 in QThreadPrivate::start (arg=0x8c67670) at thread/qthread_unix.cpp:188
#6  0xb658f4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb676449e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb609ca20 (LWP 3209)):
[KCrash Handler]
#6  0xb79691e8 in KDirModelNode::rowNumber (this=0x0) at /build/buildd/kde4libs-4.3.2/kio/kio/kdirmodel.cpp:120
#7  0xb7969290 in KDirModelPrivate::indexForNode (this=0x8816b78, node=0x0, rowNumber=-1) at /build/buildd/kde4libs-4.3.2/kio/kio/kdirmodel.cpp:284
#8  0xb796dd6e in KDirModelPrivate::_k_slotNewItems (this=0x8816b78, directoryUrl=@0x9037e08, items=@0x9037e10) at /build/buildd/kde4libs-4.3.2/kio/kio/kdirmodel.cpp:377
#9  0xb796f10c in KDirModel::qt_metacall (this=0x87d9b68, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfef93c8) at /build/buildd/kde4libs-4.3.2/obj-i486-linux-gnu/kio/kdirmodel.moc:82
#10 0xb7fa21b8 in QMetaObject::activate (sender=0x8defe90, from_signal_index=14, to_signal_index=14, argv=0xbfef93c8) at kernel/qobject.cpp:3113
#11 0xb7fa2e42 in QMetaObject::activate (sender=0x8defe90, m=0xb7add01c, local_signal_index=10, argv=0xbfef93c8) at kernel/qobject.cpp:3187
#12 0xb7951b99 in KDirLister::itemsAdded (this=0x8defe90, _t1=@0x9037e08, _t2=@0x9037e10) at /build/buildd/kde4libs-4.3.2/obj-i486-linux-gnu/kio/kdirlister.moc:268
#13 0xb7952ab6 in KDirLister::Private::emitItems (this=0x8de4508) at /build/buildd/kde4libs-4.3.2/kio/kio/kdirlister.cpp:2303
#14 0xb7955604 in KDirListerCache::processPendingUpdates (this=0x880b330) at /build/buildd/kde4libs-4.3.2/kio/kio/kdirlister.cpp:1796
#15 0xb796466d in KDirListerCache::slotFilesChanged (this=0x880b330, fileList=@0x902b960) at /build/buildd/kde4libs-4.3.2/kio/kio/kdirlister.cpp:850
#16 0xb7965222 in KDirListerCache::qt_metacall (this=0x880b330, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfef964c) at /build/buildd/kde4libs-4.3.2/obj-i486-linux-gnu/kio/kdirlister_p.moc:93
#17 0xb7fa21b8 in QMetaObject::activate (sender=0x880b398, from_signal_index=8, to_signal_index=8, argv=0xbfef964c) at kernel/qobject.cpp:3113
#18 0xb7fa2e42 in QMetaObject::activate (sender=0x880b398, m=0xb7add274, local_signal_index=3, argv=0xbfef964c) at kernel/qobject.cpp:3187
#19 0xb7970cc3 in OrgKdeKDirNotifyInterface::FilesChanged (this=0x880b398, _t1=@0x902b960) at /build/buildd/kde4libs-4.3.2/obj-i486-linux-gnu/kio/kdirnotify.moc:118
#20 0xb7970e8a in OrgKdeKDirNotifyInterface::qt_metacall (this=0x880b398, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbfef97e8)
    at /build/buildd/kde4libs-4.3.2/obj-i486-linux-gnu/kio/kdirnotify.moc:82
#21 0xb7342e5a in QDBusConnectionPrivate::deliverCall (this=0x84da320, object=0x880b398, msg=@0x95db394, metaTypes=@0x95db398, slotIdx=8) at qdbusintegrator.cpp:891
#22 0xb734aeb7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x95db368, object=0x880b398) at qdbusintegrator_p.h:101
#23 0xb7f9d3b0 in QObject::event (this=0x880b398, e=0x95db368) at kernel/qobject.cpp:1111
#24 0xb6a48d3c in QApplicationPrivate::notify_helper (this=0x84df260, receiver=0x880b398, e=0x95db368) at kernel/qapplication.cpp:4056
#25 0xb6a5103e in QApplication::notify (this=0x84d96f8, receiver=0x880b398, e=0x95db368) at kernel/qapplication.cpp:3603
#26 0xb755949d in KApplication::notify (this=0x84d96f8, receiver=0x880b398, event=0x95db368) at /build/buildd/kde4libs-4.3.2/kdeui/kernel/kapplication.cpp:302
#27 0xb7f8cbcb in QCoreApplication::notifyInternal (this=0x84d96f8, receiver=0x880b398, event=0x95db368) at kernel/qcoreapplication.cpp:610
#28 0xb7f8d825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8473b38) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#29 0xb7f8da1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#30 0xb7fb86af in postEventSourceDispatch (s=0x84e1310) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#31 0xb65dcb88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0xb65e00eb in ?? () from /usr/lib/libglib-2.0.so.0
#33 0xb65e0268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#34 0xb7fb82f8 in QEventDispatcherGlib::processEvents (this=0x84ded30, flags={i = -1074815512}) at kernel/qeventdispatcher_glib.cpp:327
#35 0xb6aeaa75 in QGuiEventDispatcherGlib::processEvents (this=0x84ded30, flags={i = -1074815464}) at kernel/qguieventdispatcher_glib.cpp:202
#36 0xb7f8b1fa in QEventLoop::processEvents (this=0xbfef9e90, flags={i = -1074815400}) at kernel/qeventloop.cpp:149
#37 0xb7f8b642 in QEventLoop::exec (this=0xbfef9e90, flags={i = -1074815336}) at kernel/qeventloop.cpp:201
#38 0xb7f8dae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#39 0xb6a48bb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#40 0xb4bee2f0 in kdemain (argc=1, argv=0x8475cb8) at /build/buildd/kdebase-workspace-4.3.2/plasma/shells/desktop/main.cpp:50
#41 0x0804e27d in launch (argc=1, _name=0x84916c4 "/usr/bin/plasma-desktop", args=0x84916dc "", cwd=0x0, envc=0, envs=0x84916e0 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x805136d "0") at /build/buildd/kde4libs-4.3.2/kinit/kinit.cpp:677
#42 0x0804ea5d in handle_launcher_request (sock=7, who=<value optimized out>) at /build/buildd/kde4libs-4.3.2/kinit/kinit.cpp:1169
#43 0x0804efe5 in handle_requests (waitForPid=0) at /build/buildd/kde4libs-4.3.2/kinit/kinit.cpp:1362
#44 0x0804fbca in main (argc=2, argv=0xbfefa684, envp=0xbfefa690) at /build/buildd/kde4libs-4.3.2/kinit/kinit.cpp:1793
Comment 32 Frank Reininghaus 2009-10-14 12:36:53 UTC
*** Bug 210523 has been marked as a duplicate of this bug. ***
Comment 33 Dario Andres 2009-10-14 13:56:54 UTC
*** Bug 210533 has been marked as a duplicate of this bug. ***
Comment 34 Frank Reininghaus 2009-10-14 14:53:19 UTC
*** Bug 210538 has been marked as a duplicate of this bug. ***
Comment 35 Henry Pfeil 2009-10-14 17:24:49 UTC
I'm going away now. Analysis of the message log documents the gradual
degradation of my entire system caused by failed upgrade attempts. The
libdbus segfaults in hal-acl and the gvfs-gdu-volume libgdu segfaults
produced nothing noticeable in KDE at the time. (What if gnome wasn't
installed? Why does KDE invoke those gnome apps?) I had given up
upgrading Fedora fc11 to rawhide because of yum's dependency hell. I
thought perhaps that the most recent version of gcc and its associated
libraries and utilities would fix some libc problems which presented
themselves. I used that partial compiler upgrade to build a 2.6.30.3
kernel, since the Fedora developers were probably frantically preparing
for next month's fc12 rollout ... and thereby hangs a tale. I noticed
the libselinux problems when I set selinux from disabled to permissive,
then couldn't log in. I eventually booted into my 64-bit Slackware
partition, downloaded a few packages and manually installed them in
order to get login, yum, and rpm to work via chroot, then booted the
partially-repaired fc11 and fixed the rest of the problems by forcing
rpm to delete the fc12 packages and installing their fc11 versions via
yum (including rebuilding the kernel with the repaired tool chain). Much
ado over nothing. You wouldn't have been involved if it weren't for the
automatic bug reports. This verbose babbling might help someone else
with similar issues. Lesson? Keep your entire compiler toolchain and
library dependencies in a consistent state, don't do partial package
upgrades. Gcc, g++ and all which that entails has a bizarre and deep
dependency forest. For example, glibc itself has over 3500 dependencies.
It helps to have the same version used to compile each of them.

Thanks to the entire KDE team for their tireless efforts in maintaining
programming excellence throughout such a well-designed, complex user
environment. I've been using it since the late-nineties.

Colonel Panic, Probationary Kandalf Apprentice #22060.
Comment 36 Dario Andres 2009-10-23 14:37:50 UTC
*** Bug 211520 has been marked as a duplicate of this bug. ***
Comment 37 Frank Reininghaus 2009-10-25 15:44:36 UTC
*** Bug 211780 has been marked as a duplicate of this bug. ***
Comment 38 Frank Reininghaus 2009-10-25 21:11:14 UTC
*** Bug 211827 has been marked as a duplicate of this bug. ***
Comment 39 Dario Andres 2009-11-01 22:22:36 UTC
*** Bug 212655 has been marked as a duplicate of this bug. ***
Comment 40 Dario Andres 2009-11-02 14:41:19 UTC
*** Bug 212697 has been marked as a duplicate of this bug. ***
Comment 41 Dario Andres 2009-11-03 00:46:55 UTC
*** Bug 212773 has been marked as a duplicate of this bug. ***
Comment 42 Mark Kretschmann 2009-11-04 07:11:03 UTC
*** Bug 213030 has been marked as a duplicate of this bug. ***
Comment 43 Dario Andres 2009-11-05 22:30:20 UTC
*** Bug 213310 has been marked as a duplicate of this bug. ***
Comment 44 Dario Andres 2009-11-10 13:13:28 UTC
From bug 213952:
---
What I was doing when the application crashed:
1. I got the warning that disk space is low
2. I move a big file (~4.7G) from /home/$USER to another partation
3. df still says low space
4. I ringht click on my home foler and counter and calculate its size 
5. when finished, I cliked OK
6. dolphin crashed.
Comment 45 Dario Andres 2009-11-10 13:13:35 UTC
*** Bug 213952 has been marked as a duplicate of this bug. ***
Comment 46 Dario Andres 2009-11-11 21:33:09 UTC
*** Bug 214164 has been marked as a duplicate of this bug. ***
Comment 47 Dario Andres 2009-11-15 13:33:09 UTC
*** Bug 214625 has been marked as a duplicate of this bug. ***
Comment 48 Frank Reininghaus 2009-11-15 17:42:43 UTC
*** Bug 214626 has been marked as a duplicate of this bug. ***
Comment 49 Frank Reininghaus 2009-11-17 11:39:15 UTC
*** Bug 214938 has been marked as a duplicate of this bug. ***
Comment 50 Dario Andres 2009-11-20 00:30:41 UTC
*** Bug 215319 has been marked as a duplicate of this bug. ***
Comment 51 Dario Andres 2009-11-20 23:18:31 UTC
*** Bug 215479 has been marked as a duplicate of this bug. ***
Comment 52 Dario Andres 2009-11-20 23:23:40 UTC
*** Bug 215442 has been marked as a duplicate of this bug. ***
Comment 53 Dario Andres 2009-11-21 03:51:07 UTC
*** Bug 215433 has been marked as a duplicate of this bug. ***
Comment 54 Dario Andres 2009-11-21 15:35:50 UTC
*** Bug 215555 has been marked as a duplicate of this bug. ***
Comment 55 Frank Reininghaus 2009-11-22 22:54:28 UTC
*** Bug 215689 has been marked as a duplicate of this bug. ***
Comment 56 Dario Andres 2009-11-25 02:03:42 UTC
*** Bug 216032 has been marked as a duplicate of this bug. ***
Comment 57 Dario Andres 2009-11-26 13:54:53 UTC
*** Bug 216228 has been marked as a duplicate of this bug. ***
Comment 58 Dario Andres 2009-11-26 13:55:23 UTC
*** Bug 216229 has been marked as a duplicate of this bug. ***
Comment 59 Nicolas L. 2009-11-26 15:53:29 UTC
*** Bug 216189 has been marked as a duplicate of this bug. ***
Comment 60 Frank Reininghaus 2009-11-27 11:50:17 UTC
*** Bug 216340 has been marked as a duplicate of this bug. ***
Comment 61 Frank Reininghaus 2009-11-27 14:25:23 UTC
*** Bug 216360 has been marked as a duplicate of this bug. ***
Comment 62 Dario Andres 2009-11-29 19:20:16 UTC
*** Bug 216644 has been marked as a duplicate of this bug. ***
Comment 63 Dario Andres 2009-11-29 19:24:20 UTC
*** Bug 216612 has been marked as a duplicate of this bug. ***
Comment 64 Frank Reininghaus 2009-11-29 21:37:35 UTC
*** Bug 216565 has been marked as a duplicate of this bug. ***
Comment 65 Frank Reininghaus 2009-11-29 22:10:13 UTC
*** Bug 216705 has been marked as a duplicate of this bug. ***
Comment 66 Frank Reininghaus 2009-12-06 11:58:02 UTC
*** Bug 217518 has been marked as a duplicate of this bug. ***
Comment 67 Frank Reininghaus 2009-12-06 12:03:04 UTC
@David: This crash occurs mainly in two situations:

1. Open the Properties dialog, change something (icon, permissions), close it.
2. Click in action in Konqueror's context menu (like open a terminal in the current folder, run some kdesvn actions). There are no crashes for actions run from Dolphin's context menu AFAIK. Don't know if that helps...

I can reproduce the crash quite reliably using the following steps:

a. Open Dolphin, create a folder, enter the new folder
b. When inside the folder, open its Properties dialog (e.g., by pressing Alt+Return)
c. Change the icon of the folder and close the dialog.
d. If it hasn't crashed yet, go back to step b.

It usually crashes after 2 or 3 iterations.
Comment 68 Dario Andres 2009-12-06 14:24:47 UTC
@Frank: Wow, you got steps to reproduce this little monster
I can reproduce the crash using your second set of steps here:

Qt: 4.6.0 (kde-qt master commit cd8595efe9aace2afdaa5db37af7cfe82b87e4aa
        Date:   Wed Nov 18 01:33:21 2009 +0100)
KDE Development Platform: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
kdelibs svn rev. 1058633 / kdebase svn rev. 1058634
on ArchLinux i686 - Kernel 2.6.31.6

Shell output (may be useful):

dolphin(8601)/kio (KDirListerCache) KDirListerCache::processPendingUpdates: "file:///home/kde-devel/a/New%20Folder"
dolphin(8601)/kio (KDirModel): Items emitted in directory KUrl("file:///home/kde-devel/a") but that directory isn't in KDirModel! Root directory: KUrl("file:///home/kde-devel/a/New Folder")
KCrash: Application 'dolphin' crashing...
Comment 69 Frank Reininghaus 2009-12-06 23:09:27 UTC
*** Bug 217645 has been marked as a duplicate of this bug. ***
Comment 70 Linus Lewandowski 2009-12-07 23:12:34 UTC
Created attachment 38910 [details]
Return early on error in the KDirModelPrivate::_k_slotNewItems()
Comment 71 Frank Reininghaus 2009-12-09 16:02:12 UTC
*** Bug 217924 has been marked as a duplicate of this bug. ***
Comment 72 Frank Reininghaus 2009-12-09 22:23:06 UTC
*** Bug 216121 has been marked as a duplicate of this bug. ***
Comment 73 Dario Andres 2009-12-10 14:23:29 UTC
*** Bug 217783 has been marked as a duplicate of this bug. ***
Comment 74 David Faure 2009-12-11 00:54:44 UTC
Reproduced, thanks for the precise steps; one needs to change the icon twice indeed, and for the current directory.

The first icon change works but sets refreshItemWasFiltered to true in KDirLister (due to the .directory file being hidden).

And then the second icon change misbehaves because of multiple bugs; wrong directory url emitted (fixed here), in addition refreshItemWasFiltered is still true (aboutToRefreshItem not called) which makes it "add" the item under itself. Fun.
I see, KDirListerCache::aboutToRefreshItem assumes it should go up but this is not true for root items. I think the right fix is to get rid of aboutToRefreshItem altogether, now that we have oldItem+newItem.
Added to my TODO list - no more time today.

Another note to myself: debugging is easier in konqueror otherwise in dolphin there are two kdirlisters involved.
Comment 75 Dario Andres 2009-12-11 19:21:06 UTC
*** Bug 218311 has been marked as a duplicate of this bug. ***
Comment 76 David Faure 2009-12-11 23:55:48 UTC
SVN commit 1061513 by dfaure:

Fix crash when changing the icon of the current directory twice.
(for more details about what happened, see bug 190535 comment #74).
The fix was to replace the fragile aboutToRefreshItem stuff with a simple
local var based on the more recently added "oldItem".
The crash is fixed for: 4.4 beta2
CCBUG: 190535

One bug remains though: the dir becomes "." in the dolphin treeview.


 M  +8 -32     kio/kdirlister.cpp  
 M  +0 -5      kio/kdirlister_p.h  
 M  +85 -27    tests/kdirlistertest.cpp  
 M  +3 -0      tests/kdirlistertest.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1061513
Comment 77 David Faure 2009-12-12 02:09:20 UTC
SVN commit 1061529 by dfaure:

Fix the subdir being renamed to "." in the dolphin treeview when changing its icon.
 We have to let findByUrl do like slotEntries, and prefer a subdir item with a name
 over a root item with ".". The name doesn't matter for root items, but it matters
 for child items.
Fixed for: 4.4-beta2
BUG: 190535


 M  +19 -12    kio/kdirlister.cpp  
 M  +39 -9     tests/kdirlistertest.cpp  
 M  +3 -1      tests/kdirlistertest.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1061529
Comment 78 Dario Andres 2009-12-12 13:16:41 UTC
*** Bug 218379 has been marked as a duplicate of this bug. ***
Comment 79 Jonathan Thomas 2009-12-13 05:30:57 UTC
*** Bug 218454 has been marked as a duplicate of this bug. ***
Comment 80 Dario Andres 2009-12-13 23:32:52 UTC
*** Bug 218550 has been marked as a duplicate of this bug. ***
Comment 81 Frank Reininghaus 2009-12-15 12:15:52 UTC
*** Bug 218704 has been marked as a duplicate of this bug. ***
Comment 82 Peter Penz 2009-12-18 11:20:08 UTC
*** Bug 215920 has been marked as a duplicate of this bug. ***
Comment 83 Dario Andres 2009-12-30 02:52:09 UTC
*** Bug 220607 has been marked as a duplicate of this bug. ***
Comment 84 Christoph Feck 2010-01-01 17:14:54 UTC
*** Bug 220162 has been marked as a duplicate of this bug. ***
Comment 85 Christoph Feck 2010-01-01 17:16:06 UTC
Still happens in beta 2, see bug 220162.
Comment 86 Dario Andres 2010-01-02 16:04:52 UTC
I wonder if those crashes were the same backtrace but different steps to reproduce can be fixed with the same commit.. may be there are still special cases that cause the crash...
Comment 87 Dario Andres 2010-01-02 16:05:02 UTC
*** Bug 220950 has been marked as a duplicate of this bug. ***
Comment 88 Dario Andres 2010-01-09 19:24:43 UTC
*** Bug 221955 has been marked as a duplicate of this bug. ***
Comment 89 Dario Andres 2010-01-10 15:19:19 UTC
*** Bug 222021 has been marked as a duplicate of this bug. ***
Comment 90 Pino Toscano 2010-01-10 16:30:41 UTC
*** Bug 222068 has been marked as a duplicate of this bug. ***
Comment 91 Peter Soetens 2010-01-11 10:45:41 UTC
(In reply to comment #90)
> *** Bug 222068 has been marked as a duplicate of this bug. ***

What I was doing when the application crashed:
This crash happens in any KDE application with an open file dialog. For example
Okular: I click  File -> Open -> Network -> Network Services -> FTP Servers
(url bar shows zeroconf: > _ftp._tcp) -> click on a server named TSW-1(FTP) ->
it shortly shows in url bar: "ftp | tsw-1.local:21" then "ftp | tsw-1.local"
and then crashes immediately.

This looks like a new way to trigger this same bug ?
Comment 92 Dario Andres 2010-01-12 18:52:25 UTC
*** Bug 222374 has been marked as a duplicate of this bug. ***
Comment 93 Dario Andres 2010-01-12 19:34:34 UTC
*** Bug 222360 has been marked as a duplicate of this bug. ***
Comment 94 David Faure 2010-01-21 18:39:10 UTC
SVN commit 1078174 by dfaure:

Backporting all remaining fixes from 4.4 to 4.3 branch; (in fact ended up copying the files
after backporting all and checking up the remaining diff).

This backports the fixes for the bugs below to the upcoming 4.3.5 release.
Svn revisions backported: 1061529, 1062515, 1065297, 1065291, 1071530, 1061513
Fixed for: 4.3.5
CCBUG: 190535 219547


 M  +101 -89   kio/kdirlister.cpp  
 M  +16 -15    kio/kdirlister_p.h  
 M  +320 -302  tests/kdirlistertest.cpp  
 M  +60 -2     tests/kdirlistertest.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1078174
Comment 95 Dario Andres 2010-01-27 23:26:12 UTC
*** Bug 224496 has been marked as a duplicate of this bug. ***
Comment 96 Dario Andres 2010-01-30 22:33:33 UTC
*** Bug 224903 has been marked as a duplicate of this bug. ***
Comment 97 Christoph Feck 2010-02-02 05:42:39 UTC
*** Bug 225226 has been marked as a duplicate of this bug. ***
Comment 98 Dario Andres 2010-02-09 02:23:31 UTC
*** Bug 225884 has been marked as a duplicate of this bug. ***
Comment 99 Dario Andres 2010-02-12 20:16:28 UTC
*** Bug 226589 has been marked as a duplicate of this bug. ***
Comment 100 Frank Reininghaus 2010-02-16 11:25:40 UTC
*** Bug 227145 has been marked as a duplicate of this bug. ***
Comment 101 Dario Andres 2010-02-19 23:20:04 UTC
*** Bug 227700 has been marked as a duplicate of this bug. ***
Comment 102 Dario Andres 2010-02-21 02:58:13 UTC
*** Bug 227874 has been marked as a duplicate of this bug. ***
Comment 103 Dario Andres 2010-02-21 16:47:02 UTC
*** Bug 224725 has been marked as a duplicate of this bug. ***
Comment 104 Frank Reininghaus 2010-03-12 17:02:49 UTC
*** Bug 230273 has been marked as a duplicate of this bug. ***
Comment 105 Dario Andres 2010-03-13 20:02:58 UTC
*** Bug 230561 has been marked as a duplicate of this bug. ***
Comment 106 Dario Andres 2010-03-14 13:18:01 UTC
*** Bug 230698 has been marked as a duplicate of this bug. ***
Comment 107 Frank Reininghaus 2010-04-08 17:01:02 UTC
*** Bug 232553 has been marked as a duplicate of this bug. ***
Comment 108 Frank Reininghaus 2010-05-02 14:12:11 UTC
*** Bug 235811 has been marked as a duplicate of this bug. ***
Comment 109 Frank Reininghaus 2010-05-10 18:07:55 UTC
*** Bug 237036 has been marked as a duplicate of this bug. ***
Comment 110 Frank Reininghaus 2010-06-08 06:00:14 UTC
*** Bug 240941 has been marked as a duplicate of this bug. ***
Comment 111 Nicolas L. 2010-07-19 20:14:17 UTC
*** Bug 245165 has been marked as a duplicate of this bug. ***
Comment 112 Nicolas L. 2010-08-14 11:08:14 UTC
is this bug still valid under kde 4.4 or 4.5  ?
Comment 113 BRULE Herman 2010-08-14 11:54:09 UTC
Yes
Comment 114 Christoph Feck 2010-10-12 16:06:39 UTC
*** Bug 199902 has been marked as a duplicate of this bug. ***
Comment 115 Christoph Feck 2010-10-23 18:04:24 UTC
*** Bug 250874 has been marked as a duplicate of this bug. ***
Comment 116 Dawit Alemayehu 2011-06-22 03:59:53 UTC
*** Bug 262425 has been marked as a duplicate of this bug. ***
Comment 117 Dawit Alemayehu 2011-11-04 07:35:59 UTC
*** Bug 275295 has been marked as a duplicate of this bug. ***
Comment 118 Dawit Alemayehu 2011-11-04 07:37:29 UTC
*** Bug 275102 has been marked as a duplicate of this bug. ***
Comment 119 Dawit Alemayehu 2011-11-15 08:07:31 UTC
*** Bug 285415 has been marked as a duplicate of this bug. ***
Comment 120 Dominik Haumann 2012-03-10 19:04:59 UTC
*** Bug 295702 has been marked as a duplicate of this bug. ***
Comment 121 Dominik Haumann 2012-03-10 19:06:06 UTC
Bug #295702 reports this in KDE 4.8.0.
Comment 122 Dawit Alemayehu 2013-07-07 04:20:02 UTC
Can someone here please confirm if this bug is still valid for KDE 4.10 or higher?
Comment 123 Dominik Haumann 2018-02-15 06:45:19 UTC
This backtrace appeared again in bug #390288 in KDE Frameworks 5.43.
Comment 124 Andrew Crouthamel 2018-09-28 03:19:04 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!