Bug 217645 - I don't know why!
Summary: I don't know why!
Status: RESOLVED DUPLICATE of bug 190535
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-06 22:30 UTC by Julien MÊME
Modified: 2009-12-06 23:09 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien MÊME 2009-12-06 22:30:09 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-15-generic i686
Distribution: Ubuntu 9.10

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7745920 (LWP 15106))]

Thread 9 (Thread 0xb5debb70 (LWP 15181)):
#0  0x005d0422 in __kernel_vsyscall ()
#1  0x00cbe142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x08ad27e4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0x01b9f9ff in ?? () from /usr/lib/libxine.so.1
#4  0x00cb980e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x08ac57ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 8 (Thread 0xaefbdb70 (LWP 25146)):
#0  0x005d0422 in __kernel_vsyscall ()
#1  0x08abe981 in select () from /lib/tls/i686/cmov/libc.so.6
#2  0x01bc8be0 in xine_usec_sleep () from /usr/lib/libxine.so.1
#3  0x01bad011 in ?? () from /usr/lib/libxine.so.1
#4  0x00cb980e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x08ac57ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 7 (Thread 0xad9ffb70 (LWP 25147)):
#0  0x005d0422 in __kernel_vsyscall ()
#1  0x08ab7ba6 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x0612d54b in g_poll () from /lib/libglib-2.0.so.0
#3  0x0612056b in ?? () from /lib/libglib-2.0.so.0
#4  0x06120863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x05b96067 in QEventDispatcherGlib::processEvents (this=0x97c5820, flags=...) at kernel/qeventdispatcher_glib.cpp:329
#6  0x05b69c79 in QEventLoop::processEvents (this=0xad9ff2b4, flags=) at kernel/qeventloop.cpp:149
#7  0x05b6a0ca in QEventLoop::exec (this=0xad9ff2b4, flags=...) at kernel/qeventloop.cpp:201
#8  0x05a77b73 in QThread::exec (this=0xa6da070) at thread/qthread.cpp:487
#9  0x0892d20a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#10 0x05a7ae32 in QThreadPrivate::start (arg=0xa6da070) at thread/qthread_unix.cpp:188
#11 0x00cb980e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0x08ac57ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 6 (Thread 0xad1feb70 (LWP 25148)):
#0  0x005d0422 in __kernel_vsyscall ()
#1  0x08ab7ba6 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x03e46cc2 in ?? () from /usr/lib/libpulse.so.0
#3  0x03e33e09 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#4  0x03e35c23 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#5  0x03e35cf4 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#6  0x03e46bc3 in ?? () from /usr/lib/libpulse.so.0
#7  0x01f17ac2 in ?? () from /usr/lib/libpulsecommon-0.9.19.so
#8  0x00cb980e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#9  0x08ac57ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 5 (Thread 0xa89fcb70 (LWP 25149)):
#0  0x005d0422 in __kernel_vsyscall ()
#1  0x00cbde15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x08ad278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x01bb05ee in ?? () from /usr/lib/libxine.so.1
#4  0x00cb980e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x08ac57ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0xa7e12b70 (LWP 25150)):
#0  0x005d0422 in __kernel_vsyscall ()
#1  0x00cbde15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x08ad278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x01ba2fc2 in ?? () from /usr/lib/libxine.so.1
#4  0x01ba8d36 in ?? () from /usr/lib/libxine.so.1
#5  0x00cb980e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0x08ac57ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xa7444b70 (LWP 25151)):
#0  0x005d0422 in __kernel_vsyscall ()
#1  0x00cbde15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x08ad278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x01ba2fc2 in ?? () from /usr/lib/libxine.so.1
#4  0x01ba9d46 in ?? () from /usr/lib/libxine.so.1
#5  0x00cb980e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0x08ac57ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xa6c43b70 (LWP 25152)):
#0  0x005d0422 in __kernel_vsyscall ()
#1  0x00cbde15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x08ad278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x01bb351a in xine_event_wait () from /usr/lib/libxine.so.1
#4  0x01bb35a2 in ?? () from /usr/lib/libxine.so.1
#5  0x00cb980e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0x08ac57ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb7745920 (LWP 15106)):
[KCrash Handler]
#6  KDirModelNode::rowNumber (this=0x0) at ../../kio/kio/kdirmodel.cpp:120
#7  0x00870a43 in KDirModelPrivate::indexForNode (this=0x96d29f0, node=0x0, rowNumber=0) at ../../kio/kio/kdirmodel.cpp:284
#8  0x0087586b in KDirModelPrivate::_k_slotNewItems (this=0x96d29f0, directoryUrl=..., items=...) at ../../kio/kio/kdirmodel.cpp:377
#9  0x00876d77 in KDirModel::qt_metacall (this=0x9692780, _c=QMetaObject::InvokeMetaMethod, _id=22, _a=0xbf947894) at ./kdirmodel.moc:82
#10 0x05b81263 in QMetaObject::activate (sender=0x96926b0, from_signal_index=14, to_signal_index=14, argv=0xbf947894) at kernel/qobject.cpp:3113
#11 0x05b81ec2 in QMetaObject::activate (sender=0x96926b0, m=0x80b7410, local_signal_index=10, argv=0xbf947894) at kernel/qobject.cpp:3187
#12 0x00859469 in KDirLister::itemsAdded (this=0x96926b0, _t1=..., _t2=...) at ./kdirlister.moc:268
#13 0x0085a4fe in KDirLister::Private::emitItems (this=0x96926c0) at ../../kio/kio/kdirlister.cpp:2303
#14 0x008657e7 in KDirListerCache::processPendingUpdates (this=0x9664a48) at ../../kio/kio/kdirlister.cpp:1796
#15 0x008660af in KDirListerCache::slotFilesChanged (this=0x9664a48, fileList=...) at ../../kio/kio/kdirlister.cpp:850
#16 0x0086c8a5 in KDirListerCache::qt_metacall (this=0x9664a48, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbf947b98) at ./kdirlister_p.moc:93
#17 0x05b81263 in QMetaObject::activate (sender=0x966c910, from_signal_index=8, to_signal_index=8, argv=0xbf947b98) at kernel/qobject.cpp:3113
#18 0x05b81ec2 in QMetaObject::activate (sender=0x966c910, m=0x9eb294, local_signal_index=3, argv=0xbf947b98) at kernel/qobject.cpp:3187
#19 0x00878503 in OrgKdeKDirNotifyInterface::FilesChanged (this=0x966c910, _t1=...) at ./kdirnotify.moc:118
#20 0x008786d5 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x966c910, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbf947d1c) at ./kdirnotify.moc:82
#21 0x00a167b4 in QDBusConnectionPrivate::deliverCall (this=0x947b3b8, object=0x966c910, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:891
#22 0x00a1e197 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#23 0x05b7b5fe in QObject::event (this=0x966c910, e=0xe59bcb0) at kernel/qobject.cpp:1111
#24 0x01071f54 in QApplicationPrivate::notify_helper (this=0x94829e8, receiver=0x966c910, e=0xe59bcb0) at kernel/qapplication.cpp:4056
#25 0x0107967c in QApplication::notify (this=0xbf94852c, receiver=0x966c910, e=0xe59bcb0) at kernel/qapplication.cpp:3603
#26 0x003ccbfa in KApplication::notify (this=0xbf94852c, receiver=0x966c910, event=0xe59bcb0) at ../../kdeui/kernel/kapplication.cpp:302
#27 0x05b6b6cb in QCoreApplication::notifyInternal (this=0xbf94852c, receiver=0x966c910, event=0xe59bcb0) at kernel/qcoreapplication.cpp:610
#28 0x05b6c2b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9464e48) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#29 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9464e48) at kernel/qcoreapplication.cpp:1247
#30 0x05b6c47d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#31 0x05b963ff in QCoreApplication::sendPostedEvents (s=0x948bd18) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#32 postEventSourceDispatch (s=0x948bd18) at kernel/qeventdispatcher_glib.cpp:210
#33 0x0611ce88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#34 0x06120730 in ?? () from /lib/libglib-2.0.so.0
#35 0x06120863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#36 0x05b9602c in QEventDispatcherGlib::processEvents (this=0x9464a30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#37 0x01112be5 in QGuiEventDispatcherGlib::processEvents (this=0x9464a30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#38 0x05b69c79 in QEventLoop::processEvents (this=0xbf948484, flags=) at kernel/qeventloop.cpp:149
#39 0x05b6a0ca in QEventLoop::exec (this=0xbf948484, flags=...) at kernel/qeventloop.cpp:201
#40 0x05b6c53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#41 0x01071dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#42 0x0807a745 in _start ()

Reported using DrKonqi
Comment 1 FiNeX 2009-12-06 22:56:30 UTC
Please, would you like to explain what you were doing before the crash? Is the crash reproducible?
Comment 2 Frank Reininghaus 2009-12-06 23:09:27 UTC
This crash has been reported quite a few times already.

*** This bug has been marked as a duplicate of bug 190535 ***