Bug 217924 - Dolphin, permissions, folder properties
Summary: Dolphin, permissions, folder properties
Status: RESOLVED DUPLICATE of bug 190535
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-08 22:09 UTC by Ernesto P.
Modified: 2009-12-09 16:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ernesto P. 2009-12-08 22:09:50 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
config advanced permissions inside home folder

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#5  KDirModelNode::rowNumber (this=0x0) at ../../kio/kio/kdirmodel.cpp:120
#6  0x00007f02ed434e21 in KDirModelPrivate::indexForNode (this=<value optimized out>, node=<value optimized out>, rowNumber=-1) at ../../kio/kio/kdirmodel.cpp:284
#7  0x00007f02ed4397c6 in KDirModelPrivate::_k_slotNewItems (this=0x1493bb0, directoryUrl=<value optimized out>, items=...) at ../../kio/kio/kdirmodel.cpp:377
#8  0x00007f02ed43aba6 in KDirModel::qt_metacall (this=0x1436a80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff48567ec0) at ./kdirmodel.moc:82
#9  0x00007f02ea3afddc in QMetaObject::activate (sender=0x14368f0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0xffffffff) at kernel/qobject.cpp:3113
#10 0x00007f02ed41e92a in KDirLister::itemsAdded (this=0x0, _t1=<value optimized out>, _t2=<value optimized out>) at ./kdirlister.moc:268
#11 0x00007f02ed41f6da in KDirLister::Private::emitItems (this=0x1436910) at ../../kio/kio/kdirlister.cpp:2303
#12 0x00007f02ed42a158 in KDirListerCache::processPendingUpdates (this=0x1418cf0) at ../../kio/kio/kdirlister.cpp:1796
#13 0x00007f02ed42aace in KDirListerCache::slotFilesChanged (this=0x1418cf0, fileList=...) at ../../kio/kio/kdirlister.cpp:850
#14 0x00007f02ed430dd0 in KDirListerCache::qt_metacall (this=0x1418cf0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff485682b0) at ./kdirlister_p.moc:93
#15 0x00007f02ea3afddc in QMetaObject::activate (sender=0x13f2aa0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0xffffffff) at kernel/qobject.cpp:3113
#16 0x00007f02ed43c145 in OrgKdeKDirNotifyInterface::FilesChanged (this=0x0, _t1=<value optimized out>) at ./kdirnotify.moc:118
#17 0x00007f02ed43c2b0 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x13f2aa0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff48568570) at ./kdirnotify.moc:82
#18 0x00007f02eb265ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#19 0x00007f02eb26cdef in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#20 0x00007f02ea3aa0f9 in QObject::event (this=0x13f2aa0, e=0x1de2200) at kernel/qobject.cpp:1111
#21 0x00007f02ea82defc in QApplicationPrivate::notify_helper (this=0x11f54f0, receiver=0x13f2aa0, e=0x1de2200) at kernel/qapplication.cpp:4056
#22 0x00007f02ea8351ce in QApplication::notify (this=0x7fff48568f10, receiver=0x13f2aa0, e=0x1de2200) at kernel/qapplication.cpp:4021
#23 0x00007f02ebb62ab6 in KApplication::notify (this=0x7fff48568f10, receiver=0x13f2aa0, event=0x1de2200) at ../../kdeui/kernel/kapplication.cpp:302
#24 0x00007f02ea39ac2c in QCoreApplication::notifyInternal (this=0x7fff48568f10, receiver=0x13f2aa0, event=0x1de2200) at kernel/qcoreapplication.cpp:610
#25 0x00007f02ea39b80a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x11d04d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x11d04d0) at kernel/qcoreapplication.cpp:1247
#27 0x00007f02ea3c3533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#28 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#29 0x00007f02e5eb8bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#30 0x00007f02e5ebc598 in ?? () from /lib/libglib-2.0.so.0
#31 0x00007f02e5ebc6c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#32 0x00007f02ea3c31a6 in QEventDispatcherGlib::processEvents (this=0x11cfd20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#33 0x00007f02ea8c24be in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#34 0x00007f02ea399532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#35 0x00007f02ea399904 in QEventLoop::exec (this=0x7fff48568e60, flags=) at kernel/qeventloop.cpp:201
#36 0x00007f02ea39bab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#37 0x0000000000439555 in _start ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2009-12-09 16:02:12 UTC
Thanks for the bug report! This crash has been reported already.

*** This bug has been marked as a duplicate of bug 190535 ***