Bug 215433 - Dolphin crashed when closing Properties dialog
Summary: Dolphin crashed when closing Properties dialog
Status: RESOLVED DUPLICATE of bug 190535
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-20 16:23 UTC by unapiedra
Modified: 2009-11-21 03:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description unapiedra 2009-11-20 16:23:55 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I opened up the property dialog of a folder. I switched between the tabs (including "Share"), I did not perform any action within the tabs (appart from maybe clicking in empty space). 

I switchted to the Permissions-Tab. I then closed the dialog. Dolphin crashed. 

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  KDirModelNode::rowNumber (this=0x0) at ../../kio/kio/kdirmodel.cpp:120
#7  0x0020fa43 in KDirModelPrivate::indexForNode (this=0x9fa9060, node=0x0, rowNumber=0) at ../../kio/kio/kdirmodel.cpp:284
#8  0x0021486b in KDirModelPrivate::_k_slotNewItems (this=0x9fa9060, directoryUrl=..., items=...) at ../../kio/kio/kdirmodel.cpp:377
#9  0x00215d77 in KDirModel::qt_metacall (this=0x9fa8ff0, _c=QMetaObject::InvokeMetaMethod, _id=22, _a=0xbfc6ab04) at ./kdirmodel.moc:82
#10 0x05bad263 in QMetaObject::activate (sender=0x9fa8a88, from_signal_index=14, to_signal_index=14, argv=0xbfc6ab04) at kernel/qobject.cpp:3113
#11 0x05badec2 in QMetaObject::activate (sender=0x9fa8a88, m=0x80b7410, local_signal_index=10, argv=0xbfc6ab04) at kernel/qobject.cpp:3187
#12 0x001f8469 in KDirLister::itemsAdded (this=0x9fa8a88, _t1=..., _t2=...) at ./kdirlister.moc:268
#13 0x001f94fe in KDirLister::Private::emitItems (this=0x9fab0e0) at ../../kio/kio/kdirlister.cpp:2303
#14 0x002047e7 in KDirListerCache::processPendingUpdates (this=0x9f67b30) at ../../kio/kio/kdirlister.cpp:1796
#15 0x002050af in KDirListerCache::slotFilesChanged (this=0x9f67b30, fileList=...) at ../../kio/kio/kdirlister.cpp:850
#16 0x0020b8a5 in KDirListerCache::qt_metacall (this=0x9f67b30, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfc6ae08) at ./kdirlister_p.moc:93
#17 0x05bad263 in QMetaObject::activate (sender=0x9f586a0, from_signal_index=8, to_signal_index=8, argv=0xbfc6ae08) at kernel/qobject.cpp:3113
#18 0x05badec2 in QMetaObject::activate (sender=0x9f586a0, m=0x38a294, local_signal_index=3, argv=0xbfc6ae08) at kernel/qobject.cpp:3187
#19 0x00217503 in OrgKdeKDirNotifyInterface::FilesChanged (this=0x9f586a0, _t1=...) at ./kdirnotify.moc:118
#20 0x002176d5 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x9f586a0, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbfc6af8c) at ./kdirnotify.moc:82
#21 0x0078e7b4 in QDBusConnectionPrivate::deliverCall (this=0x9dd8350, object=0x9f586a0, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:891
#22 0x00796197 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#23 0x05ba75fe in QObject::event (this=0x9f586a0, e=0xa3aa298) at kernel/qobject.cpp:1111
#24 0x029e2f54 in QApplicationPrivate::notify_helper (this=0x9ddfce8, receiver=0x9f586a0, e=0xa3aa298) at kernel/qapplication.cpp:4056
#25 0x029ea67c in QApplication::notify (this=0xbfc6b79c, receiver=0x9f586a0, e=0xa3aa298) at kernel/qapplication.cpp:3603
#26 0x011adbfa in KApplication::notify (this=0xbfc6b79c, receiver=0x9f586a0, event=0xa3aa298) at ../../kdeui/kernel/kapplication.cpp:302
#27 0x05b976cb in QCoreApplication::notifyInternal (this=0xbfc6b79c, receiver=0x9f586a0, event=0xa3aa298) at kernel/qcoreapplication.cpp:610
#28 0x05b982b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9dc1e48) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#29 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9dc1e48) at kernel/qcoreapplication.cpp:1247
#30 0x05b9847d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#31 0x05bc23ff in QCoreApplication::sendPostedEvents (s=0x9de2110) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#32 postEventSourceDispatch (s=0x9de2110) at kernel/qeventdispatcher_glib.cpp:210
#33 0x03eb5e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#34 0x03eb9720 in ?? () from /lib/libglib-2.0.so.0
#35 0x03eb9853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#36 0x05bc202c in QEventDispatcherGlib::processEvents (this=0x9dc1a30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#37 0x02a83be5 in QGuiEventDispatcherGlib::processEvents (this=0x9dc1a30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#38 0x05b95c79 in QEventLoop::processEvents (this=0xbfc6b6f4, flags=) at kernel/qeventloop.cpp:149
#39 0x05b960ca in QEventLoop::exec (this=0xbfc6b6f4, flags=...) at kernel/qeventloop.cpp:201
#40 0x05b9853f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#41 0x029e2dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#42 0x0807a745 in _start ()

This bug may be a duplicate of or related to bug 210523

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-21 03:51:07 UTC
- Do you remember which folder was it ?
- Have you tried to repeat the situation to see if Dolphin crashes again ?
This kind of crashes are being tracked at bug 190535
Thans

*** This bug has been marked as a duplicate of bug 190535 ***