Bug 216705 - dolphin crashes when changing tab
Summary: dolphin crashes when changing tab
Status: RESOLVED DUPLICATE of bug 190535
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-29 19:07 UTC by Kévin PETIT
Modified: 2009-11-29 22:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kévin PETIT 2009-11-29 19:07:44 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.3
Operating System: Linux 2.6.30-gentoo-r8 i686

What I was doing when the application crashed:
all is in the title

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0xb7e885b8 in KDirModelNode::rowNumber (this=0x0) at /var/tmp/portage/kde-base/kdelibs-4.3.1-r2/work/kdelibs-4.3.1/kio/kio/kdirmodel.cpp:120
#7  0xb7e88660 in KDirModelPrivate::indexForNode (this=0x8656100, node=0x0, rowNumber=-1) at /var/tmp/portage/kde-base/kdelibs-4.3.1-r2/work/kdelibs-4.3.1/kio/kio/kdirmodel.cpp:284
#8  0xb7e8d0be in KDirModelPrivate::_k_slotNewItems (this=0x8656100, directoryUrl=@0x8739110, items=@0x8739118)
    at /var/tmp/portage/kde-base/kdelibs-4.3.1-r2/work/kdelibs-4.3.1/kio/kio/kdirmodel.cpp:377
#9  0xb7e8e3dc in KDirModel::qt_metacall (this=0x8681ce8, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfd347f8)
    at /var/tmp/portage/kde-base/kdelibs-4.3.1-r2/work/kdelibs-4.3.1_build/kio/kdirmodel.moc:82
#10 0xb71fdcc3 in QMetaObject::activate (sender=0x8681cd8, from_signal_index=<value optimized out>, to_signal_index=14, argv=0x0) at kernel/qobject.cpp:3101
#11 0xb71fe262 in QMetaObject::activate (sender=0x8681cd8, m=0x80b6410, local_signal_index=10, argv=0xbfd347f8) at kernel/qobject.cpp:3178
#12 0xb7e71279 in KDirLister::itemsAdded (this=0x8681cd8, _t1=@0x8739110, _t2=@0x8739118) at /var/tmp/portage/kde-base/kdelibs-4.3.1-r2/work/kdelibs-4.3.1_build/kio/kdirlister.moc:268
#13 0xb7e721ae in KDirLister::Private::emitItems (this=0x8656428) at /var/tmp/portage/kde-base/kdelibs-4.3.1-r2/work/kdelibs-4.3.1/kio/kio/kdirlister.cpp:2303
#14 0xb7e74c72 in KDirListerCache::processPendingUpdates (this=0x825a570) at /var/tmp/portage/kde-base/kdelibs-4.3.1-r2/work/kdelibs-4.3.1/kio/kio/kdirlister.cpp:1796
#15 0xb7e83ad5 in KDirListerCache::slotFilesChanged (this=0x825a570, fileList=@0x8725c10) at /var/tmp/portage/kde-base/kdelibs-4.3.1-r2/work/kdelibs-4.3.1/kio/kio/kdirlister.cpp:850
#16 0xb7e84682 in KDirListerCache::qt_metacall (this=0x825a570, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfd34a7c)
    at /var/tmp/portage/kde-base/kdelibs-4.3.1-r2/work/kdelibs-4.3.1_build/kio/kdirlister_p.moc:93
#17 0xb71fdcc3 in QMetaObject::activate (sender=0x81eec80, from_signal_index=<value optimized out>, to_signal_index=8, argv=0x0) at kernel/qobject.cpp:3101
#18 0xb71fe262 in QMetaObject::activate (sender=0x81eec80, m=0xb7ffb234, local_signal_index=3, argv=0xbfd34a7c) at kernel/qobject.cpp:3178
#19 0xb7e8ff03 in OrgKdeKDirNotifyInterface::FilesChanged (this=0x81eec80, _t1=@0x8725c10) at /var/tmp/portage/kde-base/kdelibs-4.3.1-r2/work/kdelibs-4.3.1_build/kio/kdirnotify.moc:118
#20 0xb7e900ca in OrgKdeKDirNotifyInterface::qt_metacall (this=0x81eec80, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbfd34b70)
    at /var/tmp/portage/kde-base/kdelibs-4.3.1-r2/work/kdelibs-4.3.1_build/kio/kdirnotify.moc:82
#21 0xb72b593f in QDBusConnectionPrivate::deliverCall (this=0x80cf1e0, object=0x81eec80, msg=@0x87631c4, metaTypes=@0x87631c8, slotIdx=8) at qdbusintegrator.cpp:891
#22 0xb72bc017 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8763198, object=0x81eec80) at qdbusintegrator_p.h:101
#23 0xb71fae30 in QObject::event (this=0x81eec80, e=0x8763198) at kernel/qobject.cpp:1099
#24 0xb69e79bc in QApplicationPrivate::notify_helper (this=0x80e0168, receiver=0x81eec80, e=0x8763198) at kernel/qapplication.cpp:4065
#25 0xb69f015e in QApplication::notify (this=0xbfd352f4, receiver=0x81eec80, e=0x8763198) at kernel/qapplication.cpp:3605
#26 0xb772bb5d in KApplication::notify (this=0xbfd352f4, receiver=0x81eec80, event=0x8763198) at /var/tmp/portage/kde-base/kdelibs-4.3.1-r2/work/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#27 0xb71eba9a in QCoreApplication::notifyInternal (this=0xbfd352f4, receiver=0x81eec80, event=0x8763198) at kernel/qcoreapplication.cpp:606
#28 0xb71ec3a3 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80b9808) at kernel/qcoreapplication.h:213
#29 0xb71ec53d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#30 0xb7212f6f in postEventSourceDispatch (s=0x80d98c0) at kernel/qcoreapplication.h:218
#31 0xb628c567 in IA__g_main_context_dispatch (context=0x80d9090) at gmain.c:1824
#32 0xb628fb23 in g_main_context_iterate (context=0x80d9090, block=1, dispatch=1, self=0x80d7180) at gmain.c:2455
#33 0xb628fca8 in IA__g_main_context_iteration (context=0x80d9090, may_block=1) at gmain.c:2518
#34 0xb7212bc8 in QEventDispatcherGlib::processEvents (this=0x80b9368, flags={i = -1076669976}) at kernel/qeventdispatcher_glib.cpp:327
#35 0xb6a74e75 in QGuiEventDispatcherGlib::processEvents (this=0x80b9368, flags={i = -1076669928}) at kernel/qguieventdispatcher_glib.cpp:202
#36 0xb71ea29a in QEventLoop::processEvents (this=0xbfd35280, flags={i = -1076669864}) at kernel/qeventloop.cpp:149
#37 0xb71ea45a in QEventLoop::exec (this=0xbfd35280, flags={i = -1076669816}) at kernel/qeventloop.cpp:197
#38 0xb71ec601 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#39 0xb69e7847 in QApplication::exec () at kernel/qapplication.cpp:3525
#40 0x0807afa3 in _start ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2009-11-29 21:51:41 UTC
Thanks for the bug report! This is bug 190535 which was reported quite a few times already, but which is not easily reproducible. Can you reproduce the crash? If yes, any details that might help us to reproduce it too might help.

Thanks!
Comment 2 Kévin PETIT 2009-11-29 22:04:30 UTC
I cannot reproduce the bug but I can give you details. There were only two tabs openned. I was switching from a tab showing a folder on a harddisk to a tab showing a folder in a usb key that had just been mounted. I don't know if it's helpful. Anyway I can't tell you more. Sorry.
Comment 3 Frank Reininghaus 2009-11-29 22:10:13 UTC
Well, the only thing that would help is a good way to reproduce this reliably, I hope we'll find one soon because it seems that this bug really causes a lot of trouble :-(

Anyway, thanks for your quick reply!

*** This bug has been marked as a duplicate of bug 190535 ***