Bug 187892 - Copying then pasting multiple (not sure if size matters) bookmarks into folder crashes bookmark manager
Summary: Copying then pasting multiple (not sure if size matters) bookmarks into folde...
Status: RESOLVED DUPLICATE of bug 287038
Alias: None
Product: keditbookmarks
Classification: Applications
Component: general (show other bugs)
Version: 1.0
Platform: Compiled Sources Linux
: NOR crash with 56 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 198746 200908 201300 204547 204687 205853 205977 208545 208805 213342 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-23 01:28 UTC by Shaun Reich
Modified: 2013-07-07 18:13 UTC (History)
18 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shaun Reich 2009-03-23 01:28:20 UTC
Version:            (using Devel)
Compiler:          gcc 4.3.2 
OS:                Linux
Installed from:    Compiled sources

This is a weird one... I'm not sure if it matters if I have multiple bookmarks or not, or how many if it does..... but I also do not know if the URL's that are pasted effect it.... ask if this is the case, I do not think it is....

It appears to happen to every-other bookmark that I drag into a folder I have created, pasting manually does this too, possibly differently, however.

It's weird because I will try to drag the following (names not what they were, for clarity).

Bookmark 1 - drag to folder = crash

Bookmark 2 - drag to folder = expected move or copy behavior

Bookmark 3 - drag to folder = crash

Bookmark 4 - like bookmark 2

It's very intriguing really...


*******************************************************


Application: Bookmark Editor (keditbookmarks), signal SIGSEGV

Thread 1 (Thread 0xb5bb96c0 (LWP 25073)):
[KCrash Handler]
#5  0xb77ae41b in QString::isNull (this=0x4000028) at ../../include/QtCore/../../src/corelib/tools/qstring.h:496
#6  0xb77aa7b2 in QDomElementPrivate::save (this=0x9d205f0, s=@0xbfd86c50, depth=5, indent=1) at dom/qdom.cpp:4603
#7  0xb779ed96 in QDomNodePrivate::save (this=0x9d205b0, s=@0xbfd86c50, depth=5, indent=1) at dom/qdom.cpp:1916
#8  0xb77aab7b in QDomElementPrivate::save (this=0x9d205b0, s=@0xbfd86c50, depth=4, indent=1) at dom/qdom.cpp:4640
#9  0xb779ed96 in QDomNodePrivate::save (this=0x9d22e58, s=@0xbfd86c50, depth=4, indent=1) at dom/qdom.cpp:1916
#10 0xb77aab7b in QDomElementPrivate::save (this=0x9d22e58, s=@0xbfd86c50, depth=3, indent=1) at dom/qdom.cpp:4640
#11 0xb779ed96 in QDomNodePrivate::save (this=0x9d1ea88, s=@0xbfd86c50, depth=3, indent=1) at dom/qdom.cpp:1916
#12 0xb77aab7b in QDomElementPrivate::save (this=0x9d1ea88, s=@0xbfd86c50, depth=2, indent=1) at dom/qdom.cpp:4640
#13 0xb779ed96 in QDomNodePrivate::save (this=0x9b97e80, s=@0xbfd86c50, depth=2, indent=1) at dom/qdom.cpp:1916
#14 0xb77aab7b in QDomElementPrivate::save (this=0x9b97e80, s=@0xbfd86c50, depth=1, indent=1) at dom/qdom.cpp:4640
#15 0xb779ed96 in QDomNodePrivate::save (this=0x9afde48, s=@0xbfd86c50, depth=1, indent=1) at dom/qdom.cpp:1916
#16 0xb77aab7b in QDomElementPrivate::save (this=0x9afde48, s=@0xbfd86c50, depth=0, indent=1) at dom/qdom.cpp:4640
#17 0xb77a5601 in QDomDocumentPrivate::saveDocument (this=0x9afef50, s=@0xbfd86c50, indent=1, encUsed=QDomNode::EncodingFromDocument) at dom/qdom.cpp:6473
#18 0xb77a57fe in QDomNode::save (this=0xbfd86cf0, str=@0xbfd86c50, indent=1, encodingPolicy=QDomNode::EncodingFromDocument) at dom/qdom.cpp:2705
#19 0xb77a5865 in QDomNode::save (this=0xbfd86cf0, str=@0xbfd86c50, indent=1) at dom/qdom.cpp:2684
#20 0xb77a58d0 in QDomDocument::toString (this=0xbfd86cf0, indent=1) at dom/qdom.cpp:6845
#21 0xb7a42126 in KBookmarkManager::saveAs (this=0x9afe368, filename=@0x9afc880, toolbarCache=true) at /home/kde-devel/kde/src/kdelibs/kio/bookmarks/kbookmarkmanager.cc:402
#22 0xb7a42318 in KBookmarkManager::save (this=0x9afe368, toolbarCache=true) at /home/kde-devel/kde/src/kdelibs/kio/bookmarks/kbookmarkmanager.cc:368
#23 0xb7a42343 in KBookmarkManager::emitChanged (this=0x9afe368, group=@0xbfd86dd4) at /home/kde-devel/kde/src/kdelibs/kio/bookmarks/kbookmarkmanager.cc:516
#24 0xb7f3aa4f in CurrentMgr::notifyManagers (this=0x9b01208, grp=@0xbfd86dd4) at /home/kde-devel/kde/src/kdebase/apps/keditbookmarks/toplevel.cpp:183
#25 0xb7f3baa1 in CmdHistory::slotCommandExecuted (this=0x9af0f58, k=0x9c34718) at /home/kde-devel/kde/src/kdebase/apps/keditbookmarks/toplevel.cpp:82
#26 0xb7f3bb7f in CmdHistory::didCommand (this=0x9af0f58, cmd=0x9c34718) at /home/kde-devel/kde/src/kdebase/apps/keditbookmarks/toplevel.cpp:93
#27 0xb7f586ec in KBookmarkModel::dropMimeData (this=0x9b016c8, data=0x9b38ec8, action=Qt::CopyAction, row=-1, column=-1, parent=@0xbfd86f20)
    at /home/kde-devel/kde/src/kdebase/apps/keditbookmarks/bookmarkmodel.cpp:306
#28 0xb6cc4546 in QAbstractItemView::dropEvent (this=0x9b009c0, event=0xbfd8784c) at itemviews/qabstractitemview.cpp:1844
#29 0xb679921a in QWidget::event (this=0x9b009c0, event=0xbfd8784c) at kernel/qwidget.cpp:7698
#30 0xb6b81b2c in QFrame::event (this=0x9b009c0, e=0xbfd8784c) at widgets/qframe.cpp:559
#31 0xb6c1e6bf in QAbstractScrollArea::viewportEvent (this=0x9b009c0, e=0xbfd8784c) at widgets/qabstractscrollarea.cpp:962
#32 0xb6cc377a in QAbstractItemView::viewportEvent (this=0x9b009c0, event=0xbfd8784c) at itemviews/qabstractitemview.cpp:1466
#33 0xb6cffba9 in QTreeView::viewportEvent (this=0x9b009c0, event=0xbfd8784c) at itemviews/qtreeview.cpp:1257
#34 0xb6c21276 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9b3ace0, event=0xbfd8784c) at widgets/qabstractscrollarea_p.h:100
#35 0xb6c212a4 in QAbstractScrollAreaFilter::eventFilter (this=0x9b317b8, o=0x9b3bfe8, e=0xbfd8784c) at widgets/qabstractscrollarea_p.h:111
#36 0xb70729bc in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9a0ef68, receiver=0x9b3bfe8, event=0xbfd8784c) at kernel/qcoreapplication.cpp:718
#37 0xb67380d0 in QApplicationPrivate::notify_helper (this=0x9a0ef68, receiver=0x9b3bfe8, e=0xbfd8784c) at kernel/qapplication.cpp:4080
#38 0xb6739f4c in QApplication::notify (this=0xbfd89be4, receiver=0x9b3bfe8, e=0xbfd8784c) at kernel/qapplication.cpp:4037
#39 0xb75c463d in KApplication::notify (this=0xbfd89be4, receiver=0x9b3bfe8, event=0xbfd8784c) at /home/kde-devel/kde/src/kdelibs/kdeui/kernel/kapplication.cpp:307
#40 0xb70745eb in QCoreApplication::notifyInternal (this=0xbfd89be4, receiver=0x9b3bfe8, event=0xbfd8784c) at kernel/qcoreapplication.cpp:598
#41 0xb7c5892d in QCoreApplication::sendEvent () from /home/kde-devel/qt-copy/lib/libQt3Support.so.4
#42 0xb67c6ff5 in QX11Data::xdndHandleDrop (this=0x9a12a40, xe=0xbfd87940, passive=false) at kernel/qdnd_x11.cpp:1163
#43 0xb67c73d6 in QDragManager::drop (this=0x9d1e8e8) at kernel/qdnd_x11.cpp:1692
#44 0xb67ca11f in QDragManager::eventFilter (this=0x9d1e8e8, o=0x9b50720, e=0xbfd87e48) at kernel/qdnd_x11.cpp:1292
#45 0xb7072ab0 in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x9a0ef68, receiver=0x9b50720, event=0xbfd87e48) at kernel/qcoreapplication.cpp:699
#46 0xb6737fa0 in QApplicationPrivate::notify_helper (this=0x9a0ef68, receiver=0x9b50720, e=0xbfd87e48) at kernel/qapplication.cpp:4059
#47 0xb6738d53 in QApplication::notify (this=0xbfd89be4, receiver=0x9b50720, e=0xbfd87e48) at kernel/qapplication.cpp:3786
#48 0xb75c463d in KApplication::notify (this=0xbfd89be4, receiver=0x9b50720, event=0xbfd87e48) at /home/kde-devel/kde/src/kdelibs/kdeui/kernel/kapplication.cpp:307
#49 0xb70745eb in QCoreApplication::notifyInternal (this=0xbfd89be4, receiver=0x9b50720, event=0xbfd87e48) at kernel/qcoreapplication.cpp:598
#50 0xb7c5898f in QCoreApplication::sendSpontaneousEvent () from /home/kde-devel/qt-copy/lib/libQt3Support.so.4
#51 0xb673cdd6 in QApplicationPrivate::sendMouseEvent (receiver=0x9b50720, event=0xbfd87e48, alienWidget=0x0, nativeWidget=0x9b50720, buttonDown=0xb6eefc80, lastMouseReceiver=@0xb6eefc84)
    at kernel/qapplication.cpp:2940
#52 0xb67ba303 in QETWidget::translateMouseEvent (this=0x9b50720, event=0xbfd8845c) at kernel/qapplication_x11.cpp:4425
#53 0xb67bb39b in QApplication::x11ProcessEvent (this=0xbfd89be4, event=0xbfd8845c) at kernel/qapplication_x11.cpp:3421
#54 0xb67e6de0 in x11EventSourceDispatch (s=0x9a11c28, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#55 0xb5fbc718 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#56 0xb5fbfdc3 in ?? () from /usr/lib/libglib-2.0.so.0
#57 0xb5fbff81 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#58 0xb70a3422 in QEventDispatcherGlib::processEvents (this=0x99f8ec0, flags={i = -1076328940}) at kernel/qeventdispatcher_glib.cpp:323
#59 0xb67e65d8 in QGuiEventDispatcherGlib::processEvents (this=0x99f8ec0, flags={i = -1076328892}) at kernel/qguieventdispatcher_glib.cpp:202
#60 0xb70715dc in QEventLoop::processEvents (this=0x9b0c990, flags={i = -1076328816}) at kernel/qeventloop.cpp:149
#61 0xb7071836 in QEventLoop::exec (this=0x9b0c990, flags={i = -1076328680}) at kernel/qeventloop.cpp:196
#62 0xb67c9db0 in QDragManager::drag (this=0x9d1e8e8, o=0x9b612c0) at kernel/qdnd_x11.cpp:1952
#63 0xb674f024 in QDrag::exec (this=0x9b612c0, supportedActions={i = -1076328396}, defaultDropAction=Qt::CopyAction) at kernel/qdrag.cpp:282
#64 0xb6cc3dc5 in QAbstractItemView::startDrag (this=0x9b009c0, supportedActions={i = -1076328136}) at itemviews/qabstractitemview.cpp:3189
#65 0xb6cc22e8 in QAbstractItemView::mouseMoveEvent (this=0x9b009c0, event=0xbfd892e8) at itemviews/qabstractitemview.cpp:1547
#66 0xb6cfc50e in QTreeView::mouseMoveEvent (this=0x9b009c0, event=0xbfd892e8) at itemviews/qtreeview.cpp:1863
#67 0xb67989a6 in QWidget::event (this=0x9b009c0, event=0xbfd892e8) at kernel/qwidget.cpp:7501
#68 0xb6b81b2c in QFrame::event (this=0x9b009c0, e=0xbfd892e8) at widgets/qframe.cpp:559
#69 0xb6c1e6bf in QAbstractScrollArea::viewportEvent (this=0x9b009c0, e=0xbfd892e8) at widgets/qabstractscrollarea.cpp:962
#70 0xb6cc377a in QAbstractItemView::viewportEvent (this=0x9b009c0, event=0xbfd892e8) at itemviews/qabstractitemview.cpp:1466
#71 0xb6cffba9 in QTreeView::viewportEvent (this=0x9b009c0, event=0xbfd892e8) at itemviews/qtreeview.cpp:1257
#72 0xb6c21276 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9b3ace0, event=0xbfd892e8) at widgets/qabstractscrollarea_p.h:100
#73 0xb6c212a4 in QAbstractScrollAreaFilter::eventFilter (this=0x9b317b8, o=0x9b3bfe8, e=0xbfd892e8) at widgets/qabstractscrollarea_p.h:111
#74 0xb70729bc in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9a0ef68, receiver=0x9b3bfe8, event=0xbfd892e8) at kernel/qcoreapplication.cpp:718
#75 0xb67380d0 in QApplicationPrivate::notify_helper (this=0x9a0ef68, receiver=0x9b3bfe8, e=0xbfd892e8) at kernel/qapplication.cpp:4080
#76 0xb6738d53 in QApplication::notify (this=0xbfd89be4, receiver=0x9b3bfe8, e=0xbfd892e8) at kernel/qapplication.cpp:3786
#77 0xb75c463d in KApplication::notify (this=0xbfd89be4, receiver=0x9b3bfe8, event=0xbfd892e8) at /home/kde-devel/kde/src/kdelibs/kdeui/kernel/kapplication.cpp:307
#78 0xb70745eb in QCoreApplication::notifyInternal (this=0xbfd89be4, receiver=0x9b3bfe8, event=0xbfd892e8) at kernel/qcoreapplication.cpp:598
#79 0xb7c5898f in QCoreApplication::sendSpontaneousEvent () from /home/kde-devel/qt-copy/lib/libQt3Support.so.4
#80 0xb673cdd6 in QApplicationPrivate::sendMouseEvent (receiver=0x9b3bfe8, event=0xbfd892e8, alienWidget=0x9b3bfe8, nativeWidget=0x9aee0c0, buttonDown=0xb6eefc80, lastMouseReceiver=@0xb6eefc84)
    at kernel/qapplication.cpp:2940
#81 0xb67ba303 in QETWidget::translateMouseEvent (this=0x9aee0c0, event=0xbfd898fc) at kernel/qapplication_x11.cpp:4425
#82 0xb67bb39b in QApplication::x11ProcessEvent (this=0xbfd89be4, event=0xbfd898fc) at kernel/qapplication_x11.cpp:3421
#83 0xb67e6de0 in x11EventSourceDispatch (s=0x9a11c28, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#84 0xb5fbc718 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#85 0xb5fbfdc3 in ?? () from /usr/lib/libglib-2.0.so.0
#86 0xb5fbff81 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#87 0xb70a3422 in QEventDispatcherGlib::processEvents (this=0x99f8ec0, flags={i = -1076323660}) at kernel/qeventdispatcher_glib.cpp:323
#88 0xb67e65d8 in QGuiEventDispatcherGlib::processEvents (this=0x99f8ec0, flags={i = -1076323612}) at kernel/qguieventdispatcher_glib.cpp:202
#89 0xb70715dc in QEventLoop::processEvents (this=0xbfd89b70, flags={i = -1076323536}) at kernel/qeventloop.cpp:149
#90 0xb7071836 in QEventLoop::exec (this=0xbfd89b70, flags={i = -1076323464}) at kernel/qeventloop.cpp:196
#91 0xb7074dc3 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#92 0xb6737e0c in QApplication::exec () at kernel/qapplication.cpp:3553
#93 0xb7f37b27 in kdemain (argc=6, argv=0xbfd89e94) at /home/kde-devel/kde/src/kdebase/apps/keditbookmarks/main.cpp:203
#94 0x08048706 in main (argc=249440, argv=0xb77cf000) at /home/kde-devel/kde/build/kdebase/apps/keditbookmarks/keditbookmarks_dummy.cpp:3
Comment 1 Shaun Reich 2009-03-23 01:29:35 UTC
Oops, sorry, I forgot to set it to Crash, just as I hit the send button too.... fixing..
Comment 2 R S 2009-04-13 09:33:02 UTC
I confirm this bug, or at least something very similar. I open the bookmark editor, then attempt to cut & paste a bookmark to another folder. Cutting causes no problem, but paste ALWAYS causes the bookmark editor to crash with this message:

A Fatal Error Occurred
The application Bookmark Editor (keditbookmarks) crashed and caused the signal 11 (SIGSEGV).
Please help us improve the software you use by filing a report at http://bugs.kde.org. Useful details include how to reproduce the error, documents that were loaded, etc.

Backtrace unfortunately just gives me this error message:

This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
Comment 3 Andrea Scarpino 2009-04-23 11:04:36 UTC
I confirm this on Arch Linux i686
KDE 4.2.2
QT 4.5
Comment 4 Peter Lewis 2009-05-07 10:23:07 UTC
Confirmed still in 4.2.71. It makes organising your bookmarks impossible.
Comment 5 Volker Wedemeier 2009-05-16 10:20:14 UTC
Confirmed for a Kubuntu 9.04 system, Konqueror Version 4.2.2 (KDE 4.2.2)
Konqueror bookmark manager is virtually unusable which is a real pitty! Otherwise, the new konqueror is really nice, but a browser without (working) bookmark management ...
Comment 6 Tommi Tervo 2009-07-03 10:28:10 UTC
*** Bug 198746 has been marked as a duplicate of this bug. ***
Comment 7 Dario Andres 2009-07-21 00:59:09 UTC
*** Bug 200908 has been marked as a duplicate of this bug. ***
Comment 8 Dario Andres 2009-07-24 02:48:45 UTC
*** Bug 201300 has been marked as a duplicate of this bug. ***
Comment 9 Tomislav Skunca 2009-07-30 18:23:53 UTC
This bug _might_ be solved by fixing the "icon name" field in the xml file that stores the bookmarks.

In my case, the bookmark manager crashed (as others mentioned above) in krusader 2.0. So I edited .kde/share/apps/krusader/krbookmarks.xml and fixed the invalid icon names by changing them from "www" to "bookmark_folder".

After that I can move and paste bookmarks and folders without crashing the manager.
Comment 10 FiNeX 2009-08-20 23:16:16 UTC
*** Bug 204547 has been marked as a duplicate of this bug. ***
Comment 11 Dario Andres 2009-08-21 20:07:07 UTC
*** Bug 204687 has been marked as a duplicate of this bug. ***
Comment 12 Dario Andres 2009-09-02 03:06:38 UTC
*** Bug 205853 has been marked as a duplicate of this bug. ***
Comment 13 Dario Andres 2009-09-02 14:27:57 UTC
*** Bug 205977 has been marked as a duplicate of this bug. ***
Comment 14 Tommi Tervo 2009-09-25 20:58:07 UTC
*** Bug 208545 has been marked as a duplicate of this bug. ***
Comment 15 Dario Andres 2009-09-29 03:40:51 UTC
*** Bug 208805 has been marked as a duplicate of this bug. ***
Comment 16 Dario Andres 2009-11-06 02:48:47 UTC
*** Bug 213342 has been marked as a duplicate of this bug. ***
Comment 17 Picobyte 2010-01-13 14:45:26 UTC
I can reproduce this crash when I use the bookmark manager to edit bookmarks in Konsole, but only with some bookmarks (always the same, but I didn't find any difference between those and other bookmarks). I use KDE SC 4.3.1 from openSUSE 11.2 packages.
Comment 18 Georg Wittenburg 2010-03-07 09:20:38 UTC
The crashes are gone in 4.4.1, but now moving multiple bookmarks from one folder to another results in breaking some of these bookmark entries. The Undo button is broken, too, possibly displays some intermediate step that might help debugging.
Comment 19 Xaver Wurzenberger 2010-03-13 13:22:58 UTC
Confirmed for Arch Linux, KDEmod 4.4.1. My backtrace is almost identical to the above.
This is a really bad bug.
Comment 20 Gavin Pryke 2011-07-14 04:52:27 UTC
Trying to stay with konqueror as my main browser after nearly 10 years, this bug is getting quite annoying though. I can confirm this has happened to me in 4.4.x and 4.6.x. If one can't manage bookmarks easily how is one supposed to get back to places from around the web? My bookmarks menu takes up full 1080p screen because I'm scared to edit them! :)

System: Gentoo Linux amd64/x86_64
KDE SC: 4.6.3

Crashed just now moving a bookmark from the main folder into one subfolder that I created. I can also confirm that when selecting a whole bunch of folders and bookmarks together and ctrl+x and then selecting destination folder and ctrl+v that bookmarks contained in folders seem to be lost, no crash there though.

If I could say my one wish about konqueror would be to sort out the bookmarks bugs and add a tagging feature like epiphany/firefox.

Backtrace follows, thanks.

Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[KCrash Handler]
#6  QDomNode::QDomNode (this=0x7fff52f7ebb0, n=...) at dom/qdom.cpp:2038
#7  0x00007f9617cf990d in KBookmark (this=<value optimized out>) at /usr/include/kbookmark.h:35
#8  TreeItem::bookmark (this=<value optimized out>) at /var/tmp/portage/kde-base/keditbookmarks-4.6.3/work/keditbookmarks-4.6.3/keditbookmarks/kbookmarkmodel/treeitem.cpp:87
#9  0x00007f9617cf7241 in KBookmarkModel::bookmarkForIndex (this=<value optimized out>, index=...) at /var/tmp/portage/kde-base/keditbookmarks-4.6.3/work/keditbookmarks-4.6.3/keditbookmarks/kbookmarkmodel/model.cpp:396
#10 0x00007f9617cf91e7 in KBookmarkModel::parent (this=0x143c690, index=...) at /var/tmp/portage/kde-base/keditbookmarks-4.6.3/work/keditbookmarks-4.6.3/keditbookmarks/kbookmarkmodel/model.cpp:263
#11 0x00007f96167a752d in parent (this=0x1a5af10, source_parent=...) at ../../include/QtCore/../../src/corelib/kernel/qabstractitemmodel.h:389
#12 QSortFilterProxyModelPrivate::can_create_mapping (this=0x1a5af10, source_parent=...) at itemviews/qsortfilterproxymodel.cpp:399
#13 0x00007f96167a8d99 in QSortFilterProxyModelPrivate::_q_sourceRowsAboutToBeInserted (this=0x7fff52f7ebb0, source_parent=..., start=1391980064, end=0) at itemviews/qsortfilterproxymodel.cpp:1271
#14 0x00007f96167afd64 in QSortFilterProxyModel::qt_metacall (this=0x1a5a540, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff52f7ed90) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:134
#15 0x00007f961580a8ef in QMetaObject::activate (sender=0x143c690, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#16 0x00007f96158556e4 in QAbstractItemModel::rowsAboutToBeInserted (this=0x7fff52f7ebb0, _t1=<value optimized out>, _t2=22, _t3=22) at .moc/release-shared/moc_qabstractitemmodel.cpp:174
#17 0x00007f96157eb2fc in QAbstractItemModel::beginInsertRows (this=0x143c690, parent=..., first=22, last=22) at kernel/qabstractitemmodel.cpp:2395
#18 0x00007f9617cf79c2 in KBookmarkModel::beginInsert (this=0x143c690, group=<value optimized out>, first=22, last=22) at /var/tmp/portage/kde-base/keditbookmarks-4.6.3/work/keditbookmarks-4.6.3/keditbookmarks/kbookmarkmodel/model.cpp:404
#19 0x00007f9617cf4189 in CreateCommand::redo (this=0x1da7ba0) at /var/tmp/portage/kde-base/keditbookmarks-4.6.3/work/keditbookmarks-4.6.3/keditbookmarks/kbookmarkmodel/commands.cpp:113
#20 0x00007f9617cf3b4b in MoveCommand::redo (this=0x191d2c0) at /var/tmp/portage/kde-base/keditbookmarks-4.6.3/work/keditbookmarks-4.6.3/keditbookmarks/kbookmarkmodel/commands.cpp:374
#21 0x00007f9616880698 in QUndoCommand::redo (this=0x1c64970) at util/qundostack.cpp:208
#22 0x00007f9616881f43 in QUndoStack::push (this=0x14314c8, cmd=0x10) at util/qundostack.cpp:541
#23 0x00007f9617cf2816 in CommandHistory::addCommand (this=0x13e8540, cmd=0x10) at /var/tmp/portage/kde-base/keditbookmarks-4.6.3/work/keditbookmarks-4.6.3/keditbookmarks/kbookmarkmodel/commandhistory.cpp:107
#24 0x00007f9617cf8795 in KBookmarkModel::dropMimeData (this=0x143c690, data=0x7fff52f7f220, action=<value optimized out>, row=<value optimized out>, column=<value optimized out>, parent=<value optimized out>) at /var/tmp/portage/kde-base/keditbookmarks-4.6.3/work/keditbookmarks-4.6.3/keditbookmarks/kbookmarkmodel/model.cpp:380
#25 0x00007f96182b62c5 in BookmarkFolderViewFilterModel::dropMimeData (this=0x1a5a540, data=0x19ffcc0, action=Qt::MoveAction, row=-1, column=<value optimized out>, parent=<value optimized out>) at /var/tmp/portage/kde-base/keditbookmarks-4.6.3/work/keditbookmarks-4.6.3/keditbookmarks/bookmarklistview.cpp:178
#26 0x00007f96167184fd in QAbstractItemView::dropEvent (this=0x1a55230, event=0x7fff52f80070) at itemviews/qabstractitemview.cpp:1990
#27 0x00007f961622a3ab in QWidget::event (this=0x1a55230, event=0x7fff52f80070) at kernel/qwidget.cpp:8449
#28 0x00007f96165ef536 in QFrame::event (this=0x1a55230, e=0x7fff52f80070) at widgets/qframe.cpp:557
#29 0x00007f961672521b in QAbstractItemView::viewportEvent (this=0x1a55230, event=0x7fff52f80070) at itemviews/qabstractitemview.cpp:1628
#30 0x00007f9616762ee5 in QTreeView::viewportEvent (this=0x1a55230, event=0x7fff52f80070) at itemviews/qtreeview.cpp:1256
#31 0x00007f96157f2456 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1a551f0, event=0x7fff52f80070) at kernel/qcoreapplication.cpp:846
#32 0x00007f96161d445c in QApplicationPrivate::notify_helper (this=0x1299930, receiver=0x1a551f0, e=0x7fff52f80070) at kernel/qapplication.cpp:4458
#33 0x00007f96161d9bc8 in QApplication::notify (this=<value optimized out>, receiver=0x1a551f0, e=0x7fff52f80070) at kernel/qapplication.cpp:4266
#34 0x00007f9616f43936 in KApplication::notify (this=0x7fff52f833f0, receiver=0x1a551f0, event=0x7fff52f80070) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#35 0x00007f96157f2c0b in QCoreApplication::notifyInternal (this=0x7fff52f833f0, receiver=0x1a551f0, event=0x7fff52f80070) at kernel/qcoreapplication.cpp:731
#36 0x00007f961626a425 in sendEvent (this=<value optimized out>, xe=<value optimized out>, passive=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#37 QX11Data::xdndHandleDrop (this=<value optimized out>, xe=<value optimized out>, passive=<value optimized out>) at kernel/qdnd_x11.cpp:1183
#38 0x00007f961626ec02 in QDragManager::drop (this=0x1843750) at kernel/qdnd_x11.cpp:1725
#39 0x00007f961626edc8 in QDragManager::eventFilter (this=0x1843750, o=<value optimized out>, e=<value optimized out>) at kernel/qdnd_x11.cpp:1312
#40 0x00007f96157f250a in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x1299930, receiver=0x16b5d80, event=0x7fff52f80a70) at kernel/qcoreapplication.cpp:827
#41 0x00007f96161d4406 in QApplicationPrivate::notify_helper (this=0x7fff52f7ebb0, receiver=0x10, e=0x7fff52f7ee20) at kernel/qapplication.cpp:4437
#42 0x00007f96161da16b in QApplication::notify (this=0x7fff52f833f0, receiver=0x16b5d80, e=0x7fff52f80a70) at kernel/qapplication.cpp:4023
#43 0x00007f9616f43936 in KApplication::notify (this=0x7fff52f833f0, receiver=0x16b5d80, event=0x7fff52f80a70) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#44 0x00007f96157f2c0b in QCoreApplication::notifyInternal (this=0x7fff52f833f0, receiver=0x16b5d80, event=0x7fff52f80a70) at kernel/qcoreapplication.cpp:731
#45 0x00007f96161d89d2 in sendEvent (receiver=0x16b5d80, event=0x7fff52f80a70, alienWidget=0x0, nativeWidget=0x16b5d80, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#46 QApplicationPrivate::sendMouseEvent (receiver=0x16b5d80, event=0x7fff52f80a70, alienWidget=0x0, nativeWidget=0x16b5d80, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at kernel/qapplication.cpp:3122
#47 0x00007f961625d9f4 in QETWidget::translateMouseEvent (this=0x16b5d80, event=<value optimized out>) at kernel/qapplication_x11.cpp:4461
#48 0x00007f961625ca90 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff52f811f0) at kernel/qapplication_x11.cpp:3587
#49 0x00007f9616287082 in x11EventSourceDispatch (s=0x129d1a0, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#50 0x00007f9611f252f1 in g_main_dispatch (context=0x129c0e0) at gmain.c:2441
#51 g_main_context_dispatch (context=0x129c0e0) at gmain.c:3014
#52 0x00007f9611f29988 in g_main_context_iterate (context=0x129c0e0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:3092
#53 0x00007f9611f29b3c in g_main_context_iteration (context=0x129c0e0, may_block=1) at gmain.c:3155
#54 0x00007f961581ecf3 in QEventDispatcherGlib::processEvents (this=0x1296780, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#55 0x00007f96162869fe in QGuiEventDispatcherGlib::processEvents (this=0x7fff52f7ebb0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#56 0x00007f96157f1962 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#57 0x00007f96157f1d44 in QEventLoop::exec (this=0x1e99930, flags=) at kernel/qeventloop.cpp:201
#58 0x00007f961626f499 in QDragManager::drag (this=0x1843750, o=<value optimized out>) at kernel/qdnd_x11.cpp:1981
#59 0x00007f96161ea5f8 in QDrag::exec (this=0x141ceb0, supportedActions=) at kernel/qdrag.cpp:284
#60 0x00007f9616722996 in QAbstractItemView::startDrag (this=0x13ce7b0, supportedActions=<value optimized out>) at itemviews/qabstractitemview.cpp:3448
#61 0x00007f96167203d6 in QAbstractItemView::mouseMoveEvent (this=0x13ce7b0, event=<value optimized out>) at itemviews/qabstractitemview.cpp:1709
#62 0x00007f961622a03a in QWidget::event (this=0x13ce7b0, event=0x7fff52f82740) at kernel/qwidget.cpp:8244
#63 0x00007f96165ef536 in QFrame::event (this=0x13ce7b0, e=0x7fff52f82740) at widgets/qframe.cpp:557
#64 0x00007f961672521b in QAbstractItemView::viewportEvent (this=0x13ce7b0, event=0x7fff52f82740) at itemviews/qabstractitemview.cpp:1628
#65 0x00007f9616762ee5 in QTreeView::viewportEvent (this=0x13ce7b0, event=0x7fff52f82740) at itemviews/qtreeview.cpp:1256
#66 0x00007f96157f2456 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x19f0f50, event=0x7fff52f82740) at kernel/qcoreapplication.cpp:846
#67 0x00007f96161d445c in QApplicationPrivate::notify_helper (this=0x1299930, receiver=0x19f0f50, e=0x7fff52f82740) at kernel/qapplication.cpp:4458
#68 0x00007f96161da16b in QApplication::notify (this=0x7fff52f833f0, receiver=0x19f0f50, e=0x7fff52f82740) at kernel/qapplication.cpp:4023
#69 0x00007f9616f43936 in KApplication::notify (this=0x7fff52f833f0, receiver=0x19f0f50, event=0x7fff52f82740) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#70 0x00007f96157f2c0b in QCoreApplication::notifyInternal (this=0x7fff52f833f0, receiver=0x19f0f50, event=0x7fff52f82740) at kernel/qcoreapplication.cpp:731
#71 0x00007f96161d89d2 in sendEvent (receiver=0x19f0f50, event=0x7fff52f82740, alienWidget=0x19f0f50, nativeWidget=0x1a6b840, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#72 QApplicationPrivate::sendMouseEvent (receiver=0x19f0f50, event=0x7fff52f82740, alienWidget=0x19f0f50, nativeWidget=0x1a6b840, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at kernel/qapplication.cpp:3122
#73 0x00007f961625d9f4 in QETWidget::translateMouseEvent (this=0x1a6b840, event=<value optimized out>) at kernel/qapplication_x11.cpp:4461
#74 0x00007f961625ca90 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff52f82ec0) at kernel/qapplication_x11.cpp:3587
#75 0x00007f9616287082 in x11EventSourceDispatch (s=0x129d1a0, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#76 0x00007f9611f252f1 in g_main_dispatch (context=0x129c0e0) at gmain.c:2441
#77 g_main_context_dispatch (context=0x129c0e0) at gmain.c:3014
#78 0x00007f9611f29988 in g_main_context_iterate (context=0x129c0e0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:3092
#79 0x00007f9611f29b3c in g_main_context_iteration (context=0x129c0e0, may_block=1) at gmain.c:3155
#80 0x00007f961581ecf3 in QEventDispatcherGlib::processEvents (this=0x1296780, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#81 0x00007f96162869fe in QGuiEventDispatcherGlib::processEvents (this=0x7fff52f7ebb0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#82 0x00007f96157f1962 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#83 0x00007f96157f1d44 in QEventLoop::exec (this=0x7fff52f831e0, flags=) at kernel/qeventloop.cpp:201
#84 0x00007f96157f5dbb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#85 0x00007f961829d3f7 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /var/tmp/portage/kde-base/keditbookmarks-4.6.3/work/keditbookmarks-4.6.3/keditbookmarks/main.cpp:212
#86 0x00007f9617f1dd2d in __libc_start_main () from /lib64/libc.so.6
#87 0x00000000004006e9 in _start ()
Comment 21 squan 2011-07-14 09:48:58 UTC
> this bug is getting quite annoying though...
While konqueror still being the most cabable and most mature KDE browser, at least this annoyance may be worked around by editing bookmarks with its (quite slowly) upcoming successor rekonq (both browsers use the same bookmarks, which was a wise decision).
Comment 22 squan 2011-07-14 10:31:07 UTC
> this annoyance may be worked around by editing bookmarks with... rekonq...
Not exactly true: While rekonq "bookmarks panel" allows basic editing, it does not support multiselection.
Comment 23 Christoph Feck 2013-07-07 18:13:08 UTC
This should be fixed with KDE 4.10.4, otherwise please reopen.

*** This bug has been marked as a duplicate of bug 287038 ***