Bug 204687 - Konqueror's Edit Bookmarks crashes at copy -> paste
Summary: Konqueror's Edit Bookmarks crashes at copy -> paste
Status: RESOLVED DUPLICATE of bug 187892
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-21 19:41 UTC by fabio de francesco
Modified: 2009-08-21 20:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fabio de francesco 2009-08-21 19:41:43 UTC
Application that crashed: keditbookmarks
Version of the application: 4.3.00 (KDE 4.3.0)
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-tuxonice-r4-090805 x86_64

What I was doing when the application crashed:
A lot of similar bugs have been reported on the same issue, but I see all of them in RESOLVED status. This is why I don't check, in DrKonqi, "this bug is similar to...".

The problem is that I cannot move/copy and then paste either any folder or single bookmark to any other folder. It crashes exactly when I select "paste".

 -- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[KCrash Handler]
#5  0x00000034b5219d96 in QDomElementPrivate::save () from /usr/lib64/qt4/libQtXml.so.4
#6  0x00000034b5212584 in QDomNodePrivate::save () from /usr/lib64/qt4/libQtXml.so.4
#7  0x00000034b5219a37 in QDomElementPrivate::save () from /usr/lib64/qt4/libQtXml.so.4
#8  0x00000034b5212584 in QDomNodePrivate::save () from /usr/lib64/qt4/libQtXml.so.4
#9  0x00000034b5219a37 in QDomElementPrivate::save () from /usr/lib64/qt4/libQtXml.so.4
#10 0x00000034b5212584 in QDomNodePrivate::save () from /usr/lib64/qt4/libQtXml.so.4
#11 0x00000034b5219a37 in QDomElementPrivate::save () from /usr/lib64/qt4/libQtXml.so.4
#12 0x00000034b5212584 in QDomNodePrivate::save () from /usr/lib64/qt4/libQtXml.so.4
#13 0x00000034b5219a37 in QDomElementPrivate::save () from /usr/lib64/qt4/libQtXml.so.4
#14 0x00000034b5212584 in QDomNodePrivate::save () from /usr/lib64/qt4/libQtXml.so.4
#15 0x00000034b5219a37 in QDomElementPrivate::save () from /usr/lib64/qt4/libQtXml.so.4
#16 0x00000034b521ebd5 in QDomDocumentPrivate::saveDocument () from /usr/lib64/qt4/libQtXml.so.4
#17 0x00000034b521f197 in QDomDocument::toString () from /usr/lib64/qt4/libQtXml.so.4
#18 0x00000034b81d22db in KBookmarkManager::saveAs () from /usr/lib64/libkio.so.5
#19 0x00000034b81d2783 in KBookmarkManager::emitChanged () from /usr/lib64/libkio.so.5
#20 0x00000034b9a23369 in CmdHistory::slotCommandExecuted () from /usr/lib64/libkdeinit4_keditbookmarks.so
#21 0x00000034b9a2658b in ActionsImpl::slotPaste () from /usr/lib64/libkdeinit4_keditbookmarks.so
#22 0x00000034b9a271ed in ActionsImpl::qt_metacall () from /usr/lib64/libkdeinit4_keditbookmarks.so
#23 0x00000034b4d41dfd in QMetaObject::activate () from /usr/lib64/qt4/libQtCore.so.4
#24 0x00000034b6599da7 in QAction::triggered () from /usr/lib64/qt4/libQtGui.so.4
#25 0x00000034b659b040 in QAction::activate () from /usr/lib64/qt4/libQtGui.so.4
#26 0x00000034b693ff2c in QMenuPrivate::activateCausedStack () from /usr/lib64/qt4/libQtGui.so.4
#27 0x00000034b6945cab in QMenuPrivate::activateAction () from /usr/lib64/qt4/libQtGui.so.4
#28 0x00000034b72ed631 in KMenu::mouseReleaseEvent () from /usr/lib64/libkdeui.so.5
#29 0x00000034b65ec860 in QWidget::event () from /usr/lib64/qt4/libQtGui.so.4
#30 0x00000034b694732b in QMenu::event () from /usr/lib64/qt4/libQtGui.so.4
#31 0x00000034b659f21d in QApplicationPrivate::notify_helper () from /usr/lib64/qt4/libQtGui.so.4
#32 0x00000034b65a73ab in QApplication::notify () from /usr/lib64/qt4/libQtGui.so.4
#33 0x00000034b721c5fb in KApplication::notify () from /usr/lib64/libkdeui.so.5
#34 0x00000034b4d2fcfb in QCoreApplication::notifyInternal () from /usr/lib64/qt4/libQtCore.so.4
#35 0x00000034b65a88c8 in QApplicationPrivate::sendMouseEvent () from /usr/lib64/qt4/libQtGui.so.4
#36 0x00000034b66024fb in QETWidget::translateMouseEvent () from /usr/lib64/qt4/libQtGui.so.4
#37 0x00000034b6600e85 in QApplication::x11ProcessEvent () from /usr/lib64/qt4/libQtGui.so.4
#38 0x00000034b6626a2c in x11EventSourceDispatch () from /usr/lib64/qt4/libQtGui.so.4
#39 0x0000003076839dd9 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#40 0x000000307683d528 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#41 0x000000307683d6ec in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#42 0x00000034b4d54e9f in QEventDispatcherGlib::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#43 0x00000034b66262ef in QGuiEventDispatcherGlib::processEvents () from /usr/lib64/qt4/libQtGui.so.4
#44 0x00000034b4d2e6a2 in QEventLoop::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#45 0x00000034b4d2e83c in QEventLoop::exec () from /usr/lib64/qt4/libQtCore.so.4
#46 0x00000034b4d308dc in QCoreApplication::exec () from /usr/lib64/qt4/libQtCore.so.4
#47 0x00000034b9a1f5b0 in kdemain () from /usr/lib64/libkdeinit4_keditbookmarks.so
#48 0x00000038ea41ea26 in __libc_start_main () from /lib/libc.so.6
#49 0x0000000000400899 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-08-21 20:07:07 UTC
Merging with bug 187892. Thanks

*** This bug has been marked as a duplicate of bug 187892 ***