Bug 205853 - bookmark editor crashes when moving bookmarks
Summary: bookmark editor crashes when moving bookmarks
Status: RESOLVED DUPLICATE of bug 187892
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-01 00:29 UTC by Rodrigo Fresneda
Modified: 2009-09-02 03:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigo Fresneda 2009-09-01 00:29:09 UTC
Application that crashed: keditbookmarks
Version of the application: 4.3.00 (KDE 4.3.0)
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30.5 x86_64
Distribution: Debian GNU/Linux unstable (sid)

What I was doing when the application crashed:
The bookmark editor crashes when attempting to move any bookmark to different folder:
1)Add bookmark
2)Create folder using bookmark editor
3)Move bookmark to folder 1)
Crash!

 -- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[KCrash Handler]
#6  0xf7a030e0 in QDomElementPrivate::save (this=0x9e4e098, s=..., depth=6, indent=1) at dom/qdom.cpp:4603
#7  0xf79f67e2 in QDomNodePrivate::save (this=0x9e4e040, s=..., depth=6, indent=1) at dom/qdom.cpp:1916
#8  0xf7a02d37 in QDomElementPrivate::save (this=0x9e4e040, s=..., depth=5, indent=1) at dom/qdom.cpp:4640
#9  0xf79f67e2 in QDomNodePrivate::save (this=0x9e7cf40, s=..., depth=5, indent=1) at dom/qdom.cpp:1916
#10 0xf7a02d37 in QDomElementPrivate::save (this=0x9e7cf40, s=..., depth=4, indent=1) at dom/qdom.cpp:4640
#11 0xf79f67e2 in QDomNodePrivate::save (this=0x9e4d398, s=..., depth=4, indent=1) at dom/qdom.cpp:1916
#12 0xf7a02d37 in QDomElementPrivate::save (this=0x9e4d398, s=..., depth=3, indent=1) at dom/qdom.cpp:4640
#13 0xf79f67e2 in QDomNodePrivate::save (this=0x9e02730, s=..., depth=3, indent=1) at dom/qdom.cpp:1916
#14 0xf7a02d37 in QDomElementPrivate::save (this=0x9e02730, s=..., depth=2, indent=1) at dom/qdom.cpp:4640
#15 0xf79f67e2 in QDomNodePrivate::save (this=0x9c27cb8, s=..., depth=2, indent=1) at dom/qdom.cpp:1916
#16 0xf7a02d37 in QDomElementPrivate::save (this=0x9c27cb8, s=..., depth=1, indent=1) at dom/qdom.cpp:4640
#17 0xf79f67e2 in QDomNodePrivate::save (this=0x9c278d8, s=..., depth=1, indent=1) at dom/qdom.cpp:1916
#18 0xf7a02d37 in QDomElementPrivate::save (this=0x9c278d8, s=..., depth=0, indent=1) at dom/qdom.cpp:4640
#19 0xf7a076b6 in QDomDocumentPrivate::saveDocument (this=0x9bc7298, s=..., indent=1, encUsed=QDomNode::EncodingFromDocument) at dom/qdom.cpp:6473
#20 0xf7a07d43 in QDomNode::save (this=0xffc58e50, str=..., indent=1) at dom/qdom.cpp:2684
#21 0xf7a07dae in QDomDocument::toString (this=0xffc58e50, indent=1) at dom/qdom.cpp:6845
#22 0xf7be0b0c in KBookmarkManager::saveAs (this=0x9c3c3f0, filename=..., toolbarCache=true) at ../../kio/bookmarks/kbookmarkmanager.cc:402
#23 0xf7be0fff in KBookmarkManager::save (this=0x9c3c3f0, toolbarCache=<value optimized out>) at ../../kio/bookmarks/kbookmarkmanager.cc:368
#24 0xf7be1040 in KBookmarkManager::emitChanged (this=0x9c3c3f0, group=...) at ../../kio/bookmarks/kbookmarkmanager.cc:516
#25 0xf7f3afbb in CurrentMgr::notifyManagers (this=0x9bf3fa0, grp=...) at ../../../apps/keditbookmarks/toplevel.cpp:183
#26 0xf7f3e621 in CmdHistory::slotCommandExecuted (this=0x9bc7468, k=0x9e6e2f8) at ../../../apps/keditbookmarks/toplevel.cpp:82
#27 0xf7f5e070 in KBookmarkModel::dropMimeData (this=0x9c2d708, data=0x9e83450, action=Qt::CopyAction, row=-1, column=-1, parent=...) at ../../../apps/keditbookmarks/bookmarkmodel.cpp:306
#28 0xf6e3daf1 in QAbstractItemView::dropEvent (this=0x9c261e0, event=0xffc59830) at itemviews/qabstractitemview.cpp:1849
#29 0xf6953359 in QWidget::event (this=0x9c261e0, event=0xffc59830) at kernel/qwidget.cpp:7731
#30 0xf6cf9f53 in QFrame::event (this=0x9c261e0, e=0xffc59830) at widgets/qframe.cpp:559
#31 0xf6d98f6f in QAbstractScrollArea::viewportEvent (this=0x9c261e0, e=0xf73b0f08) at widgets/qabstractscrollarea.cpp:962
#32 0xf6e4a127 in QAbstractItemView::viewportEvent (this=0x9c261e0, event=0xffc59830) at itemviews/qabstractitemview.cpp:1476
#33 0xf6e84f26 in QTreeView::viewportEvent (this=0x9c261e0, event=0xffc59830) at itemviews/qtreeview.cpp:1266
#34 0xf6d9b545 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9c3c260, o=0x9c266f0, e=0xffc59830) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x9c3c260, o=0x9c266f0, e=0xffc59830) at widgets/qabstractscrollarea_p.h:111
#36 0xf72bcbfa in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9b5ccc0, receiver=0x9c266f0, event=0xffc59830) at kernel/qcoreapplication.cpp:726
#37 0xf68fd7ec in QApplicationPrivate::notify_helper (this=0x9b5ccc0, receiver=0x9c266f0, e=0xffc59830) at kernel/qapplication.cpp:4052
#38 0xf6905f81 in QApplication::notify (this=0xffc5dc8c, receiver=0x9c266f0, e=0xffc59830) at kernel/qapplication.cpp:4009
#39 0xf783100d in KApplication::notify (this=0xffc5dc8c, receiver=0x9c266f0, event=0xffc59830) at ../../kdeui/kernel/kapplication.cpp:302
#40 0xf72bd9cb in QCoreApplication::notifyInternal (this=0xffc5dc8c, receiver=0x9c266f0, event=0xffc59830) at kernel/qcoreapplication.cpp:610
#41 0xf698191f in QCoreApplication::sendEvent (this=0x9b60ae8, xe=0xffc5991c, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#42 QX11Data::xdndHandleDrop (this=0x9b60ae8, xe=0xffc5991c, passive=false) at kernel/qdnd_x11.cpp:1173
#43 0xf69862d8 in QDragManager::drop (this=0x9e15340) at kernel/qdnd_x11.cpp:1709
#44 0xf698648e in QDragManager::eventFilter (this=0x9e15340, o=0x9e6e590, e=0xffc59e7c) at kernel/qdnd_x11.cpp:1302
#45 0xf72bccbc in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x9b5ccc0, receiver=0x9e6e590, event=0xffc59e7c) at kernel/qcoreapplication.cpp:707
#46 0xf68fd793 in QApplicationPrivate::notify_helper (this=0x9b5ccc0, receiver=0x9e6e590, e=0xffc59e7c) at kernel/qapplication.cpp:4031
#47 0xf69062e1 in QApplication::notify (this=0xffc5dc8c, receiver=0x9e6e590, e=0xffc59e7c) at kernel/qapplication.cpp:3758
#48 0xf783100d in KApplication::notify (this=0xffc5dc8c, receiver=0x9e6e590, event=0xffc59e7c) at ../../kdeui/kernel/kapplication.cpp:302
#49 0xf72bd9cb in QCoreApplication::notifyInternal (this=0xffc5dc8c, receiver=0x9e6e590, event=0xffc59e7c) at kernel/qcoreapplication.cpp:610
#50 0xf690536e in QCoreApplication::sendSpontaneousEvent (receiver=0x9e6e590, event=0xffc59e7c, alienWidget=0x0, nativeWidget=0x9e6e590, buttonDown=0xf7173aa0, lastMouseReceiver=...)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#51 QApplicationPrivate::sendMouseEvent (receiver=0x9e6e590, event=0xffc59e7c, alienWidget=0x0, nativeWidget=0x9e6e590, buttonDown=0xf7173aa0, lastMouseReceiver=...) at kernel/qapplication.cpp:2924
#52 0xf6973ea5 in QETWidget::translateMouseEvent (this=0x9e6e590, event=0xffc5b42c) at kernel/qapplication_x11.cpp:4409
#53 0xf6973386 in QApplication::x11ProcessEvent (this=0xffc5dc8c, event=0xffc5b42c) at kernel/qapplication_x11.cpp:3428
#54 0xf699d892 in x11EventSourceDispatch (s=0x9b5f7b0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#55 0xf5f12368 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#56 0xf5f158c3 in ?? () from /usr/lib/libglib-2.0.so.0
#57 0xf5f15a48 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#58 0xf72e8858 in QEventDispatcherGlib::processEvents (this=0x9b5cca0, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#59 0xf699cfd5 in QGuiEventDispatcherGlib::processEvents (this=0x9b5cca0, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#60 0xf72bc01a in QEventLoop::processEvents (this=0x9bdbce0, flags=...) at kernel/qeventloop.cpp:149
#61 0xf72bc462 in QEventLoop::exec (this=0x9bdbce0, flags=...) at kernel/qeventloop.cpp:201
#62 0xf6985d06 in QDragManager::drag (this=0x9e15340, o=0x9b9bbe0) at kernel/qdnd_x11.cpp:1969
#63 0xf6910c4a in QDrag::exec (this=0x9b9bbe0, supportedActions=..., defaultDropAction=Qt::CopyAction) at kernel/qdrag.cpp:282
#64 0xf6e4865c in QAbstractItemView::startDrag (this=0x9c261e0, supportedActions=...) at itemviews/qabstractitemview.cpp:3205
#65 0xf6e45605 in QAbstractItemView::mouseMoveEvent (this=0x9c261e0, event=0xffc5c22c) at itemviews/qabstractitemview.cpp:1552
#66 0xf6e84d24 in QTreeView::mouseMoveEvent (this=0x9c261e0, event=0xffc5c22c) at itemviews/qtreeview.cpp:1872
#67 0xf69535e5 in QWidget::event (this=0x9c261e0, event=0xffc5c22c) at kernel/qwidget.cpp:7534
#68 0xf6cf9f53 in QFrame::event (this=0x9c261e0, e=0xffc5c22c) at widgets/qframe.cpp:559
#69 0xf6d98f6f in QAbstractScrollArea::viewportEvent (this=0x9c261e0, e=0xf73b0f08) at widgets/qabstractscrollarea.cpp:962
#70 0xf6e4a127 in QAbstractItemView::viewportEvent (this=0x9c261e0, event=0xffc5c22c) at itemviews/qabstractitemview.cpp:1476
#71 0xf6e84f26 in QTreeView::viewportEvent (this=0x9c261e0, event=0xffc5c22c) at itemviews/qtreeview.cpp:1266
#72 0xf6d9b545 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9c3c260, o=0x9c266f0, e=0xffc5c22c) at widgets/qabstractscrollarea_p.h:100
#73 QAbstractScrollAreaFilter::eventFilter (this=0x9c3c260, o=0x9c266f0, e=0xffc5c22c) at widgets/qabstractscrollarea_p.h:111
#74 0xf72bcbfa in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9b5ccc0, receiver=0x9c266f0, event=0xffc5c22c) at kernel/qcoreapplication.cpp:726
#75 0xf68fd7ec in QApplicationPrivate::notify_helper (this=0x9b5ccc0, receiver=0x9c266f0, e=0xffc5c22c) at kernel/qapplication.cpp:4052
#76 0xf69062e1 in QApplication::notify (this=0xffc5dc8c, receiver=0x9c266f0, e=0xffc5c22c) at kernel/qapplication.cpp:3758
#77 0xf783100d in KApplication::notify (this=0xffc5dc8c, receiver=0x9c266f0, event=0xffc5c22c) at ../../kdeui/kernel/kapplication.cpp:302
#78 0xf72bd9cb in QCoreApplication::notifyInternal (this=0xffc5dc8c, receiver=0x9c266f0, event=0xffc5c22c) at kernel/qcoreapplication.cpp:610
#79 0xf690536e in QCoreApplication::sendSpontaneousEvent (receiver=0x9c266f0, event=0xffc5c22c, alienWidget=0x9c266f0, nativeWidget=0x9b88ce8, buttonDown=0xf7173aa0, lastMouseReceiver=...)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#80 QApplicationPrivate::sendMouseEvent (receiver=0x9c266f0, event=0xffc5c22c, alienWidget=0x9c266f0, nativeWidget=0x9b88ce8, buttonDown=0xf7173aa0, lastMouseReceiver=...)
    at kernel/qapplication.cpp:2924
#81 0xf6973ea5 in QETWidget::translateMouseEvent (this=0x9b88ce8, event=0xffc5d7dc) at kernel/qapplication_x11.cpp:4409
#82 0xf6973386 in QApplication::x11ProcessEvent (this=0xffc5dc8c, event=0xffc5d7dc) at kernel/qapplication_x11.cpp:3428
#83 0xf699d892 in x11EventSourceDispatch (s=0x9b5f7b0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#84 0xf5f12368 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#85 0xf5f158c3 in ?? () from /usr/lib/libglib-2.0.so.0
#86 0xf5f15a48 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#87 0xf72e8858 in QEventDispatcherGlib::processEvents (this=0x9b5cca0, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#88 0xf699cfd5 in QGuiEventDispatcherGlib::processEvents (this=0x9b5cca0, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#89 0xf72bc01a in QEventLoop::processEvents (this=0xffc5da40, flags=...) at kernel/qeventloop.cpp:149
#90 0xf72bc462 in QEventLoop::exec (this=0xffc5da40, flags=...) at kernel/qeventloop.cpp:201
#91 0xf72be8b9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#92 0xf68fd697 in QApplication::exec () at kernel/qapplication.cpp:3525
#93 0xf7f3a0e9 in kdemain (argc=6, argv=0xffc5dfe4) at ../../../apps/keditbookmarks/main.cpp:203
#94 0x080485b2 in main (argc=1, argv=0x9e75130) at keditbookmarks_dummy.cpp:3

Reported using DrKonqi
Comment 1 Dario Andres 2009-09-02 03:06:38 UTC
Related to bug 187892 / bug 160679. Thanks

*** This bug has been marked as a duplicate of bug 187892 ***