Bug 200908 - bookmark editor crash by move a bookmark in an other directory
Summary: bookmark editor crash by move a bookmark in an other directory
Status: RESOLVED DUPLICATE of bug 187892
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-20 18:47 UTC by Fabian B.
Modified: 2009-07-21 00:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian B. 2009-07-20 18:47:50 UTC
Application that crashed: keditbookmarks
Version of the application: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2))
KDE Version: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2))
Qt Version: 4.5.2
Operating System: Linux 2.6.31-3-generic i686
Distribution: Ubuntu karmic (development branch)

What I was doing when the application crashed:
Same here: if i drag and drop a bookmark (with favicon), the bookmarkeditor crashes

 -- Backtrace:
Application: Lesezeichen-Editor (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x010ceeed in QDomElementPrivate::save (this=0x96cbbd0, s=..., depth=5, indent=1) at dom/qdom.cpp:4603
#7  0x010c1ad2 in QDomNodePrivate::save (this=0x96d88a0, s=..., depth=5, indent=1) at dom/qdom.cpp:1916
#8  0x010ceb54 in QDomElementPrivate::save (this=0x96d88a0, s=..., depth=4, indent=1) at dom/qdom.cpp:4640
#9  0x010c1ad2 in QDomNodePrivate::save (this=0x96d7ca8, s=..., depth=4, indent=1) at dom/qdom.cpp:1916
#10 0x010ceb54 in QDomElementPrivate::save (this=0x96d7ca8, s=..., depth=3, indent=1) at dom/qdom.cpp:4640
#11 0x010c1ad2 in QDomNodePrivate::save (this=0x9683fd8, s=..., depth=3, indent=1) at dom/qdom.cpp:1916
#12 0x010ceb54 in QDomElementPrivate::save (this=0x9683fd8, s=..., depth=2, indent=1) at dom/qdom.cpp:4640
#13 0x010c1ad2 in QDomNodePrivate::save (this=0x962a830, s=..., depth=2, indent=1) at dom/qdom.cpp:1916
#14 0x010ceb54 in QDomElementPrivate::save (this=0x962a830, s=..., depth=1, indent=1) at dom/qdom.cpp:4640
#15 0x010c1ad2 in QDomNodePrivate::save (this=0x9610bb8, s=..., depth=1, indent=1) at dom/qdom.cpp:1916
#16 0x010ceb54 in QDomElementPrivate::save (this=0x9610bb8, s=..., depth=0, indent=1) at dom/qdom.cpp:4640
#17 0x010d2ed3 in QDomDocumentPrivate::saveDocument (this=0x9570e40, s=..., indent=1, encUsed=QDomNode::EncodingFromDocument) at dom/qdom.cpp:6473
#18 0x010d3423 in QDomNode::save (this=0xbf97c2a4, str=..., indent=1) at dom/qdom.cpp:2684
#19 0x010d348e in QDomDocument::toString (this=0xbf97c2a4, indent=1) at dom/qdom.cpp:6845
#20 0x00bdc185 in KBookmarkManager::saveAs (this=0x96216e0, filename=..., toolbarCache=true) at ../../kio/bookmarks/kbookmarkmanager.cc:402
#21 0x00bdc69f in KBookmarkManager::save (this=0x96216e0, toolbarCache=<value optimized out>) at ../../kio/bookmarks/kbookmarkmanager.cc:368
#22 0x00bdc6e0 in KBookmarkManager::emitChanged (this=0x96216e0, group=...) at ../../kio/bookmarks/kbookmarkmanager.cc:516
#23 0x0454a26b in CurrentMgr::notifyManagers (this=0x956c220, grp=...) at ../../../apps/keditbookmarks/toplevel.cpp:183
#24 0x0454dbe3 in CmdHistory::slotCommandExecuted (this=0x95732f0, k=0x96d69e8) at ../../../apps/keditbookmarks/toplevel.cpp:82
#25 0x0456e02f in KBookmarkModel::dropMimeData (this=0x9597250, data=0x96cd230, action=Qt::CopyAction, row=-1, column=-1, parent=...) at ../../../apps/keditbookmarks/bookmarkmodel.cpp:306
#26 0x031221c3 in QAbstractItemView::dropEvent (this=0x960a9b8, event=0xbf97cce0) at itemviews/qabstractitemview.cpp:1849
#27 0x02c2d858 in QWidget::event (this=0x960a9b8, event=0xbf97cce0) at kernel/qwidget.cpp:7731
#28 0x02fdcdc3 in QFrame::event (this=0x960a9b8, e=0xbf97cce0) at widgets/qframe.cpp:559
#29 0x0307bc14 in QAbstractScrollArea::viewportEvent (this=0x9648750, e=0x80532c8) at widgets/qabstractscrollarea.cpp:962
#30 0x0312f7e7 in QAbstractItemView::viewportEvent (this=0x960a9b8, event=0xbf97cce0) at itemviews/qabstractitemview.cpp:1476
#31 0x0316ab74 in QTreeView::viewportEvent (this=0x960a9b8, event=0xbf97cce0) at itemviews/qtreeview.cpp:1266
#32 0x0307e215 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9619360, o=0x962d228, e=0xbf97cce0) at widgets/qabstractscrollarea_p.h:100
#33 QAbstractScrollAreaFilter::eventFilter (this=0x9619360, o=0x962d228, e=0xbf97cce0) at widgets/qabstractscrollarea_p.h:111
#34 0x008d291a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x95114e0, receiver=0x962d228, event=0xbf97cce0) at kernel/qcoreapplication.cpp:726
#35 0x02bd8c0c in QApplicationPrivate::notify_helper (this=0x95114e0, receiver=0x962d228, e=0xbf97cce0) at kernel/qapplication.cpp:4052
#36 0x02be088c in QApplication::notify (this=0xbf9811d4, receiver=0x962d228, e=0xbf97cce0) at kernel/qapplication.cpp:4009
#37 0x00ea9aaa in KApplication::notify (this=0xbf9811d4, receiver=0x962d228, event=0xbf97cce0) at ../../kdeui/kernel/kapplication.cpp:302
#38 0x008d37ab in QCoreApplication::notifyInternal (this=0xbf9811d4, receiver=0x962d228, event=0xbf97cce0) at kernel/qcoreapplication.cpp:610
#39 0x02c5d165 in QCoreApplication::sendEvent (this=0x9514b80, xe=0xbf97cdfc, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#40 QX11Data::xdndHandleDrop (this=0x9514b80, xe=0xbf97cdfc, passive=false) at kernel/qdnd_x11.cpp:1173
#41 0x02c621f4 in QDragManager::drop (this=0x96d8638) at kernel/qdnd_x11.cpp:1709
#42 0x02c623ea in QDragManager::eventFilter (this=0x96d8638, o=0x96cdbb8, e=0xbf97d280) at kernel/qdnd_x11.cpp:1302
#43 0x008d29dc in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x95114e0, receiver=0x96cdbb8, event=0xbf97d280) at kernel/qcoreapplication.cpp:707
#44 0x02bd8bb3 in QApplicationPrivate::notify_helper (this=0x95114e0, receiver=0x96cdbb8, e=0xbf97d280) at kernel/qapplication.cpp:4031
#45 0x02be0d13 in QApplication::notify (this=0xbf9811d4, receiver=0x96cdbb8, e=0xbf97d280) at kernel/qapplication.cpp:3758
#46 0x00ea9aaa in KApplication::notify (this=0xbf9811d4, receiver=0x96cdbb8, event=0xbf97d280) at ../../kdeui/kernel/kapplication.cpp:302
#47 0x008d37ab in QCoreApplication::notifyInternal (this=0xbf9811d4, receiver=0x96cdbb8, event=0xbf97d280) at kernel/qcoreapplication.cpp:610
#48 0x02bdfc4e in QCoreApplication::sendSpontaneousEvent (receiver=0x96cdbb8, event=0xbf97d280, alienWidget=0x0, nativeWidget=0x96cdbb8, buttonDown=0x3452aa0, lastMouseReceiver=...)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#49 QApplicationPrivate::sendMouseEvent (receiver=0x96cdbb8, event=0xbf97d280, alienWidget=0x0, nativeWidget=0x96cdbb8, buttonDown=0x3452aa0, lastMouseReceiver=...) at kernel/qapplication.cpp:2924
#50 0x02c4e3c0 in QETWidget::translateMouseEvent (this=0x96cdbb8, event=0xbf97e8cc) at kernel/qapplication_x11.cpp:4409
#51 0x02c4d84b in QApplication::x11ProcessEvent (this=0xbf9811d4, event=0xbf97e8cc) at kernel/qapplication_x11.cpp:3428
#52 0x02c7a0c2 in x11EventSourceDispatch (s=0x95142a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#53 0x004dabc8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#54 0x004de470 in ?? () from /usr/lib/libglib-2.0.so.0
#55 0x004de5a3 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#56 0x008fe10c in QEventDispatcherGlib::processEvents (this=0x94fcd20, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#57 0x02c797a5 in QGuiEventDispatcherGlib::processEvents (this=0x94fcd20, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#58 0x008d1d59 in QEventLoop::processEvents (this=0x95b9820, flags=) at kernel/qeventloop.cpp:149
#59 0x008d21aa in QEventLoop::exec (this=0x95b9820, flags=...) at kernel/qeventloop.cpp:201
#60 0x02c61d58 in QDragManager::drag (this=0x96d8638, o=0x95c1b70) at kernel/qdnd_x11.cpp:1969
#61 0x02bec0de in QDrag::exec (this=0x95c1b70, supportedActions=..., defaultDropAction=Qt::CopyAction) at kernel/qdrag.cpp:282
#62 0x0312d8b1 in QAbstractItemView::startDrag (this=0x960a9b8, supportedActions=...) at itemviews/qabstractitemview.cpp:3205
#63 0x0312a452 in QAbstractItemView::mouseMoveEvent (this=0x960a9b8, event=0xbf97f6c0) at itemviews/qabstractitemview.cpp:1552
#64 0x0316a944 in QTreeView::mouseMoveEvent (this=0x960a9b8, event=0xbf97f6c0) at itemviews/qtreeview.cpp:1872
#65 0x02c2dac3 in QWidget::event (this=0x960a9b8, event=0xbf97f6c0) at kernel/qwidget.cpp:7534
#66 0x02fdcdc3 in QFrame::event (this=0x960a9b8, e=0xbf97f6c0) at widgets/qframe.cpp:559
#67 0x0307bc14 in QAbstractScrollArea::viewportEvent (this=0x9648750, e=0x80532c8) at widgets/qabstractscrollarea.cpp:962
#68 0x0312f7e7 in QAbstractItemView::viewportEvent (this=0x960a9b8, event=0xbf97f6c0) at itemviews/qabstractitemview.cpp:1476
#69 0x0316ab74 in QTreeView::viewportEvent (this=0x960a9b8, event=0xbf97f6c0) at itemviews/qtreeview.cpp:1266
#70 0x0307e215 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9619360, o=0x962d228, e=0xbf97f6c0) at widgets/qabstractscrollarea_p.h:100
#71 QAbstractScrollAreaFilter::eventFilter (this=0x9619360, o=0x962d228, e=0xbf97f6c0) at widgets/qabstractscrollarea_p.h:111
#72 0x008d291a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x95114e0, receiver=0x962d228, event=0xbf97f6c0) at kernel/qcoreapplication.cpp:726
#73 0x02bd8c0c in QApplicationPrivate::notify_helper (this=0x95114e0, receiver=0x962d228, e=0xbf97f6c0) at kernel/qapplication.cpp:4052
#74 0x02be0d13 in QApplication::notify (this=0xbf9811d4, receiver=0x962d228, e=0xbf97f6c0) at kernel/qapplication.cpp:3758
#75 0x00ea9aaa in KApplication::notify (this=0xbf9811d4, receiver=0x962d228, event=0xbf97f6c0) at ../../kdeui/kernel/kapplication.cpp:302
#76 0x008d37ab in QCoreApplication::notifyInternal (this=0xbf9811d4, receiver=0x962d228, event=0xbf97f6c0) at kernel/qcoreapplication.cpp:610
#77 0x02bdfc4e in QCoreApplication::sendSpontaneousEvent (receiver=0x962d228, event=0xbf97f6c0, alienWidget=0x962d228, nativeWidget=0x958c298, buttonDown=0x3452aa0, lastMouseReceiver=...)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#78 QApplicationPrivate::sendMouseEvent (receiver=0x962d228, event=0xbf97f6c0, alienWidget=0x962d228, nativeWidget=0x958c298, buttonDown=0x3452aa0, lastMouseReceiver=...)
    at kernel/qapplication.cpp:2924
#79 0x02c4e3c0 in QETWidget::translateMouseEvent (this=0x958c298, event=0xbf980d0c) at kernel/qapplication_x11.cpp:4409
#80 0x02c4d84b in QApplication::x11ProcessEvent (this=0xbf9811d4, event=0xbf980d0c) at kernel/qapplication_x11.cpp:3428
#81 0x02c7a0c2 in x11EventSourceDispatch (s=0x95142a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#82 0x004dabc8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#83 0x004de470 in ?? () from /usr/lib/libglib-2.0.so.0
#84 0x004de5a3 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#85 0x008fe10c in QEventDispatcherGlib::processEvents (this=0x94fcd20, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#86 0x02c797a5 in QGuiEventDispatcherGlib::processEvents (this=0x94fcd20, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#87 0x008d1d59 in QEventLoop::processEvents (this=0xbf981004, flags=) at kernel/qeventloop.cpp:149
#88 0x008d21aa in QEventLoop::exec (this=0xbf981004, flags=...) at kernel/qeventloop.cpp:201
#89 0x008d461f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#90 0x02bd8ab7 in QApplication::exec () at kernel/qapplication.cpp:3525
#91 0x04549389 in kdemain (argc=1, argv=0x94efbe8) at ../../../apps/keditbookmarks/main.cpp:203
#92 0x0804de01 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=1, envs=0x94fbf98 "DISPLAY=:0.0", reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x8051249 "0") at ../../kinit/kinit.cpp:676
#93 0x0804ea55 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1168
#94 0x0804efe3 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1361
#95 0x0804fc2f in main (argc=1, argv=0xbf981bb4, envp=0xbf981bbc) at ../../kinit/kinit.cpp:1788

This bug may be a duplicate of or related to bug 197829

Reported using DrKonqi
Comment 1 Dario Andres 2009-07-21 00:59:09 UTC
Merging with bug 187892. Thanks

*** This bug has been marked as a duplicate of bug 187892 ***