Bug 204547 - keditbookmarks crash when I move bookmarks
Summary: keditbookmarks crash when I move bookmarks
Status: RESOLVED DUPLICATE of bug 187892
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-20 18:02 UTC by jajaX
Modified: 2009-08-20 23:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jajaX 2009-08-20 18:02:43 UTC
Application that crashed: keditbookmarks
Version of the application: 4.3.00 (KDE 4.3.0)
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-15-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
Hi !

keditbookmarks crash when I want move a bookmark in other folder

 -- Backtrace:
Application: Éditeur de signet (keditbookmarks), signal: Segmentation fault
[KCrash Handler]
#6  0xb77d4a50 in QDomElementPrivate::save (this=0x96151b8, s=@0xbfe46010, depth=4, indent=1) at dom/qdom.cpp:4603
#7  0xb77c7e92 in QDomNodePrivate::save (this=0x9615160, s=@0xbfe46010, depth=4, indent=1) at dom/qdom.cpp:1916
#8  0xb77d4677 in QDomElementPrivate::save (this=0x9615160, s=@0xbfe46010, depth=3, indent=1) at dom/qdom.cpp:4640
#9  0xb77c7e92 in QDomNodePrivate::save (this=0x92bf110, s=@0xbfe46010, depth=3, indent=1) at dom/qdom.cpp:1916
#10 0xb77d4677 in QDomElementPrivate::save (this=0x92bf110, s=@0xbfe46010, depth=2, indent=1) at dom/qdom.cpp:4640
#11 0xb77c7e92 in QDomNodePrivate::save (this=0x93ae750, s=@0xbfe46010, depth=2, indent=1) at dom/qdom.cpp:1916
#12 0xb77d4677 in QDomElementPrivate::save (this=0x93ae750, s=@0xbfe46010, depth=1, indent=1) at dom/qdom.cpp:4640
#13 0xb77c7e92 in QDomNodePrivate::save (this=0x93ad7a8, s=@0xbfe46010, depth=1, indent=1) at dom/qdom.cpp:1916
#14 0xb77d4677 in QDomElementPrivate::save (this=0x93ad7a8, s=@0xbfe46010, depth=0, indent=1) at dom/qdom.cpp:4640
#15 0xb77d90c6 in QDomDocumentPrivate::saveDocument (this=0x933f2d8, s=@0xbfe46010, indent=1, encUsed=QDomNode::EncodingFromDocument) at dom/qdom.cpp:6473
#16 0xb77d9763 in QDomNode::save (this=0xbfe460d0, str=@0xbfe46010, indent=1) at dom/qdom.cpp:2684
#17 0xb77d97ce in QDomDocument::toString (this=0xbfe460d0, indent=1) at dom/qdom.cpp:6845
#18 0xb7ac4e9c in KBookmarkManager::saveAs (this=0x93c21a0, filename=@0x938f060, toolbarCache=true) at /build/buildd/kde4libs-4.3.0/kio/bookmarks/kbookmarkmanager.cc:402
#19 0xb7ac53bf in KBookmarkManager::save (this=0x93c21a0, toolbarCache=<value optimized out>) at /build/buildd/kde4libs-4.3.0/kio/bookmarks/kbookmarkmanager.cc:368
#20 0xb7ac5400 in KBookmarkManager::emitChanged (this=0x93c21a0, group=@0xbfe461b0) at /build/buildd/kde4libs-4.3.0/kio/bookmarks/kbookmarkmanager.cc:516
#21 0xb7fdefdb in CurrentMgr::notifyManagers (this=0x938f3a0, grp=@0xbfe461b0) at /build/buildd/kdebase-4.3.0/apps/keditbookmarks/toplevel.cpp:183
#22 0xb7fe26a1 in CmdHistory::slotCommandExecuted (this=0x933f4a8, k=0x9615310) at /build/buildd/kdebase-4.3.0/apps/keditbookmarks/toplevel.cpp:82
#23 0xb80020d0 in KBookmarkModel::dropMimeData (this=0x933b4b0, data=0x9541a18, action=Qt::CopyAction, row=-1, column=-1, parent=@0xbfe462d0)
    at /build/buildd/kdebase-4.3.0/apps/keditbookmarks/bookmarkmodel.cpp:306
#24 0xb800427f in BookmarkFolderViewFilterModel::dropMimeData (this=0x93aabf0, data=0x9541a18, action=Qt::CopyAction, row=-1, column=-1, parent=@0xbfe46354)
    at /build/buildd/kdebase-4.3.0/apps/keditbookmarks/bookmarklistview.cpp:184
#25 0xb6bd0e31 in QAbstractItemView::dropEvent (this=0x93c63d8, event=0xbfe46b2c) at itemviews/qabstractitemview.cpp:1849
#26 0xb66d9551 in QWidget::event (this=0x93c63d8, event=0xbfe46b2c) at kernel/qwidget.cpp:7731
#27 0xb6a8aa53 in QFrame::event (this=0x93c63d8, e=0xbfe46b2c) at widgets/qframe.cpp:559
#28 0xb6b2ac2f in QAbstractScrollArea::viewportEvent (this=0x93c63d8, e=0xb713e448) at widgets/qabstractscrollarea.cpp:962
#29 0xb6bdd4a7 in QAbstractItemView::viewportEvent (this=0x93c63d8, event=0xbfe46b2c) at itemviews/qabstractitemview.cpp:1476
#30 0xb6c17ff6 in QTreeView::viewportEvent (this=0x93c63d8, event=0xbfe46b2c) at itemviews/qtreeview.cpp:1266
#31 0xb6b2d235 in QAbstractScrollAreaFilter::eventFilter (this=0x93c62c0, o=0x9296910, e=0xbfe46b2c) at widgets/qabstractscrollarea_p.h:100
#32 0xb7049dea in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9235f00, receiver=0x9296910, event=0xbfe46b2c) at kernel/qcoreapplication.cpp:726
#33 0xb6682d1a in QApplicationPrivate::notify_helper (this=0x9235f00, receiver=0x9296910, e=0xbfe46b2c) at kernel/qapplication.cpp:4052
#34 0xb668b651 in QApplication::notify (this=0xbfe4afdc, receiver=0x9296910, e=0xbfe46b2c) at kernel/qapplication.cpp:4009
#35 0xb75ff5cd in KApplication::notify (this=0xbfe4afdc, receiver=0x9296910, event=0xbfe46b2c) at /build/buildd/kde4libs-4.3.0/kdeui/kernel/kapplication.cpp:302
#36 0xb704abcb in QCoreApplication::notifyInternal (this=0xbfe4afdc, receiver=0x9296910, event=0xbfe46b2c) at kernel/qcoreapplication.cpp:610
#37 0xb67089cd in QX11Data::xdndHandleDrop (this=0x9239b48, xe=0xbfe46c28, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#38 0xb670d693 in QDragManager::drop (this=0x95ae0e0) at kernel/qdnd_x11.cpp:1709
#39 0xb670d856 in QDragManager::eventFilter (this=0x95ae0e0, o=0x9615378, e=0xbfe470c8) at kernel/qdnd_x11.cpp:1302
#40 0xb7049eac in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x9235f00, receiver=0x9615378, event=0xbfe470c8) at kernel/qcoreapplication.cpp:707
#41 0xb6682cb3 in QApplicationPrivate::notify_helper (this=0x9235f00, receiver=0x9615378, e=0xbfe470c8) at kernel/qapplication.cpp:4031
#42 0xb668b9b1 in QApplication::notify (this=0xbfe4afdc, receiver=0x9615378, e=0xbfe470c8) at kernel/qapplication.cpp:3758
#43 0xb75ff5cd in KApplication::notify (this=0xbfe4afdc, receiver=0x9615378, event=0xbfe470c8) at /build/buildd/kde4libs-4.3.0/kdeui/kernel/kapplication.cpp:302
#44 0xb704abcb in QCoreApplication::notifyInternal (this=0xbfe4afdc, receiver=0x9615378, event=0xbfe470c8) at kernel/qcoreapplication.cpp:610
#45 0xb668aa1e in QApplicationPrivate::sendMouseEvent (receiver=0x9615378, event=0xbfe470c8, alienWidget=0x0, nativeWidget=0x9615378, buttonDown=0xb6f04aa0, lastMouseReceiver=@0xb6f04aa4)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#46 0xb66facce in QETWidget::translateMouseEvent (this=0x9615378, event=0xbfe4875c) at kernel/qapplication_x11.cpp:4409
#47 0xb66fa085 in QApplication::x11ProcessEvent (this=0xbfe4afdc, event=0xbfe4875c) at kernel/qapplication_x11.cpp:3428
#48 0xb672537a in x11EventSourceDispatch (s=0x9238ea8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#49 0xb5e96b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#50 0xb5e9a0eb in ?? () from /usr/lib/libglib-2.0.so.0
#51 0xb5e9a268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#52 0xb70762f8 in QEventDispatcherGlib::processEvents (this=0x921fd10, flags={i = -1075541736}) at kernel/qeventdispatcher_glib.cpp:327
#53 0xb6724a75 in QGuiEventDispatcherGlib::processEvents (this=0x921fd10, flags={i = -1075541688}) at kernel/qguieventdispatcher_glib.cpp:202
#54 0xb70491fa in QEventLoop::processEvents (this=0x9613e50, flags={i = -1075541624}) at kernel/qeventloop.cpp:149
#55 0xb7049642 in QEventLoop::exec (this=0x9613e50, flags={i = -1075541512}) at kernel/qeventloop.cpp:201
#56 0xb670d05b in QDragManager::drag (this=0x95ae0e0, o=0x95434f8) at kernel/qdnd_x11.cpp:1969
#57 0xb66963da in QDrag::exec (this=0x95434f8, supportedActions={i = -1075541260}, defaultDropAction=Qt::CopyAction) at kernel/qdrag.cpp:282
#58 0xb6bdb9fc in QAbstractItemView::startDrag (this=0x93aceb0, supportedActions={i = -1075541004}) at itemviews/qabstractitemview.cpp:3205
#59 0xb6bd890d in QAbstractItemView::mouseMoveEvent (this=0x93aceb0, event=0xbfe49498) at itemviews/qabstractitemview.cpp:1552
#60 0xb6c17df4 in QTreeView::mouseMoveEvent (this=0x93aceb0, event=0xbfe49498) at itemviews/qtreeview.cpp:1872
#61 0xb66d97dd in QWidget::event (this=0x93aceb0, event=0xbfe49498) at kernel/qwidget.cpp:7534
#62 0xb6a8aa53 in QFrame::event (this=0x93aceb0, e=0xbfe49498) at widgets/qframe.cpp:559
#63 0xb6b2ac2f in QAbstractScrollArea::viewportEvent (this=0x93aceb0, e=0xb713e448) at widgets/qabstractscrollarea.cpp:962
#64 0xb6bdd4a7 in QAbstractItemView::viewportEvent (this=0x93aceb0, event=0xbfe49498) at itemviews/qabstractitemview.cpp:1476
#65 0xb6c17ff6 in QTreeView::viewportEvent (this=0x93aceb0, event=0xbfe49498) at itemviews/qtreeview.cpp:1266
#66 0xb6b2d235 in QAbstractScrollAreaFilter::eventFilter (this=0x93f4848, o=0x93ad3c0, e=0xbfe49498) at widgets/qabstractscrollarea_p.h:100
#67 0xb7049dea in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9235f00, receiver=0x93ad3c0, event=0xbfe49498) at kernel/qcoreapplication.cpp:726
#68 0xb6682d1a in QApplicationPrivate::notify_helper (this=0x9235f00, receiver=0x93ad3c0, e=0xbfe49498) at kernel/qapplication.cpp:4052
#69 0xb668b9b1 in QApplication::notify (this=0xbfe4afdc, receiver=0x93ad3c0, e=0xbfe49498) at kernel/qapplication.cpp:3758
#70 0xb75ff5cd in KApplication::notify (this=0xbfe4afdc, receiver=0x93ad3c0, event=0xbfe49498) at /build/buildd/kde4libs-4.3.0/kdeui/kernel/kapplication.cpp:302
#71 0xb704abcb in QCoreApplication::notifyInternal (this=0xbfe4afdc, receiver=0x93ad3c0, event=0xbfe49498) at kernel/qcoreapplication.cpp:610
#72 0xb668aa1e in QApplicationPrivate::sendMouseEvent (receiver=0x93ad3c0, event=0xbfe49498, alienWidget=0x93ad3c0, nativeWidget=0x933f700, buttonDown=0xb6f04aa0, lastMouseReceiver=@0xb6f04aa4)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#73 0xb66facce in QETWidget::translateMouseEvent (this=0x933f700, event=0xbfe4ab2c) at kernel/qapplication_x11.cpp:4409
#74 0xb66fa085 in QApplication::x11ProcessEvent (this=0xbfe4afdc, event=0xbfe4ab2c) at kernel/qapplication_x11.cpp:3428
#75 0xb672537a in x11EventSourceDispatch (s=0x9238ea8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#76 0xb5e96b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#77 0xb5e9a0eb in ?? () from /usr/lib/libglib-2.0.so.0
#78 0xb5e9a268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#79 0xb70762f8 in QEventDispatcherGlib::processEvents (this=0x921fd10, flags={i = -1075532568}) at kernel/qeventdispatcher_glib.cpp:327
#80 0xb6724a75 in QGuiEventDispatcherGlib::processEvents (this=0x921fd10, flags={i = -1075532520}) at kernel/qguieventdispatcher_glib.cpp:202
#81 0xb70491fa in QEventLoop::processEvents (this=0xbfe4ad90, flags={i = -1075532456}) at kernel/qeventloop.cpp:149
#82 0xb7049642 in QEventLoop::exec (this=0xbfe4ad90, flags={i = -1075532392}) at kernel/qeventloop.cpp:201
#83 0xb704bae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#84 0xb6682bb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#85 0xb7fde109 in kdemain (argc=6, argv=0xbfe4b334) at /build/buildd/kdebase-4.3.0/apps/keditbookmarks/main.cpp:203
#86 0x080486a2 in main (argc=1, argv=0x9615d60) at /build/buildd/kdebase-4.3.0/obj-i486-linux-gnu/apps/keditbookmarks/keditbookmarks_dummy.cpp:3

Reported using DrKonqi
Comment 1 FiNeX 2009-08-20 23:16:16 UTC

*** This bug has been marked as a duplicate of bug 187892 ***