Bug 198746 - Crashed while moving bookmarks
Summary: Crashed while moving bookmarks
Status: RESOLVED DUPLICATE of bug 187892
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-03 09:40 UTC by Javier García
Modified: 2009-07-03 10:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Javier García 2009-07-03 09:40:38 UTC
Application that crashed: keditbookmarks
Version of the application: 4.2.95 (KDE 4.2.95 (KDE 4.3 RC1))
KDE Version: 4.2.95 (KDE 4.2.95 (KDE 4.3 RC1))
Qt Version: 4.5.0
Operating System: Linux 2.6.28-13-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
After updating to KDE 4.3.0 RC1 I keep getting crashes when moving bookmarks of KRDC, changing order or moving from history to bookmark folders

 -- Backtrace:
Application: Editor de marcadores (keditbookmarks), signal: Segmentation fault
[KCrash Handler]
#6  0xb76a8450 in QDomElementPrivate::save (this=0xa1fe0d0, s=@0xbf925850, depth=5, indent=1) at dom/qdom.cpp:4603
#7  0xb769b892 in QDomNodePrivate::save (this=0xa1f5600, s=@0xbf925850, depth=5, indent=1) at dom/qdom.cpp:1916
#8  0xb76a8077 in QDomElementPrivate::save (this=0xa1f5600, s=@0xbf925850, depth=4, indent=1) at dom/qdom.cpp:4640
#9  0xb769b892 in QDomNodePrivate::save (this=0xa1f3b18, s=@0xbf925850, depth=4, indent=1) at dom/qdom.cpp:1916
#10 0xb76a8077 in QDomElementPrivate::save (this=0xa1f3b18, s=@0xbf925850, depth=3, indent=1) at dom/qdom.cpp:4640
#11 0xb769b892 in QDomNodePrivate::save (this=0xa1ee708, s=@0xbf925850, depth=3, indent=1) at dom/qdom.cpp:1916
#12 0xb76a8077 in QDomElementPrivate::save (this=0xa1ee708, s=@0xbf925850, depth=2, indent=1) at dom/qdom.cpp:4640
#13 0xb769b892 in QDomNodePrivate::save (this=0x9fe4e78, s=@0xbf925850, depth=2, indent=1) at dom/qdom.cpp:1916
#14 0xb76a8077 in QDomElementPrivate::save (this=0x9fe4e78, s=@0xbf925850, depth=1, indent=1) at dom/qdom.cpp:4640
#15 0xb769b892 in QDomNodePrivate::save (this=0x9fe4a98, s=@0xbf925850, depth=1, indent=1) at dom/qdom.cpp:1916
#16 0xb76a8077 in QDomElementPrivate::save (this=0x9fe4a98, s=@0xbf925850, depth=0, indent=1) at dom/qdom.cpp:4640
#17 0xb76acac6 in QDomDocumentPrivate::saveDocument (this=0x9fe2bc0, s=@0xbf925850, indent=1, encUsed=QDomNode::EncodingFromDocument) at dom/qdom.cpp:6473
#18 0xb76ad163 in QDomNode::save (this=0xbf925910, str=@0xbf925850, indent=1) at dom/qdom.cpp:2684
#19 0xb76ad1ce in QDomDocument::toString (this=0xbf925910, indent=1) at dom/qdom.cpp:6845
#20 0xb799a4fc in KBookmarkManager::saveAs (this=0x9f9fec8, filename=@0x9f7cd80, toolbarCache=true) at /build/buildd/kde4libs-4.2.95/kio/bookmarks/kbookmarkmanager.cc:402
#21 0xb799aa1f in KBookmarkManager::save (this=0x9f9fec8, toolbarCache=<value optimized out>) at /build/buildd/kde4libs-4.2.95/kio/bookmarks/kbookmarkmanager.cc:368
#22 0xb799aa60 in KBookmarkManager::emitChanged (this=0x9f9fec8, group=@0xbf9259f0) at /build/buildd/kde4libs-4.2.95/kio/bookmarks/kbookmarkmanager.cc:516
#23 0xb7ec2fdb in ?? () from /usr/lib/libkdeinit4_keditbookmarks.so
#24 0xb7ec66a1 in ?? () from /usr/lib/libkdeinit4_keditbookmarks.so
#25 0xb7ee60d0 in ?? () from /usr/lib/libkdeinit4_keditbookmarks.so
#26 0xb7ee827f in ?? () from /usr/lib/libkdeinit4_keditbookmarks.so
#27 0xb6a9c0f1 in QAbstractItemView::dropEvent (this=0xbf9259f4, event=0xbf92636c) at itemviews/qabstractitemview.cpp:1844
#28 0xb657c721 in QWidget::event (this=0x9f19a30, event=0xbf92636c) at kernel/qwidget.cpp:7698
#29 0xb6956993 in QFrame::event (this=0x9f19a30, e=0xbf92636c) at widgets/qframe.cpp:559
#30 0xb69f694f in QAbstractScrollArea::viewportEvent (this=0x9f19a30, e=0xb7012a48) at widgets/qabstractscrollarea.cpp:962
#31 0xb6aa8647 in QAbstractItemView::viewportEvent (this=0x9f19a30, event=0xbf92636c) at itemviews/qabstractitemview.cpp:1466
#32 0xb6ae30c4 in QTreeView::viewportEvent (this=0x9f19a30, event=0xbf92636c) at itemviews/qtreeview.cpp:1257
#33 0xb69f8f55 in QAbstractScrollAreaFilter::eventFilter (this=0x9fdef80, o=0x9f18e20, e=0xbf92636c) at widgets/qabstractscrollarea_p.h:100
#34 0xb6f1cc5a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9e81e68, receiver=0x9f18e20, event=0xbf92636c) at kernel/qcoreapplication.cpp:718
#35 0xb6525e7a in QApplicationPrivate::notify_helper (this=0x9e81e68, receiver=0x9f18e20, e=0xbf92636c) at kernel/qapplication.cpp:4080
#36 0xb652e7b1 in QApplication::notify (this=0xbf92877c, receiver=0x9f18e20, e=0xbf92636c) at kernel/qapplication.cpp:4037
#37 0xb74d23dd in KApplication::notify (this=0xbf92877c, receiver=0x9f18e20, event=0xbf92636c) at /build/buildd/kde4libs-4.2.95/kdeui/kernel/kapplication.cpp:302
#38 0xb6f1da3b in QCoreApplication::notifyInternal (this=0xbf92877c, receiver=0x9f18e20, event=0xbf92636c) at kernel/qcoreapplication.cpp:602
#39 0xb65ab51d in QX11Data::xdndHandleDrop (this=0x9e856f8, xe=0xbf926468, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#40 0xb65b01a3 in QDragManager::drop (this=0xa1fd7a0) at kernel/qdnd_x11.cpp:1692
#41 0xb65b0366 in QDragManager::eventFilter (this=0xa1fd7a0, o=0xa1fea30, e=0xbf926908) at kernel/qdnd_x11.cpp:1292
#42 0xb6f1cd1c in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x9e81e68, receiver=0xa1fea30, event=0xbf926908) at kernel/qcoreapplication.cpp:699
#43 0xb6525e13 in QApplicationPrivate::notify_helper (this=0x9e81e68, receiver=0xa1fea30, e=0xbf926908) at kernel/qapplication.cpp:4059
#44 0xb652eb11 in QApplication::notify (this=0xbf92877c, receiver=0xa1fea30, e=0xbf926908) at kernel/qapplication.cpp:3786
#45 0xb74d23dd in KApplication::notify (this=0xbf92877c, receiver=0xa1fea30, event=0xbf926908) at /build/buildd/kde4libs-4.2.95/kdeui/kernel/kapplication.cpp:302
#46 0xb6f1da3b in QCoreApplication::notifyInternal (this=0xbf92877c, receiver=0xa1fea30, event=0xbf926908) at kernel/qcoreapplication.cpp:602
#47 0xb652db7e in QApplicationPrivate::sendMouseEvent (receiver=0xa1fea30, event=0xbf926908, alienWidget=0x0, nativeWidget=0xa1fea30, buttonDown=0xb6dd0200, lastMouseReceiver=@0xb6dd0204)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#48 0xb659d97e in QETWidget::translateMouseEvent (this=0xa1fea30, event=0xbf926f4c) at kernel/qapplication_x11.cpp:4425
#49 0xb659cca7 in QApplication::x11ProcessEvent (this=0xbf92877c, event=0xbf926f4c) at kernel/qapplication_x11.cpp:3421
#50 0xb65c7c6a in x11EventSourceDispatch (s=0x9e84d70, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#51 0xb5d18b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#52 0xb5d1c0eb in ?? () from /usr/lib/libglib-2.0.so.0
#53 0xb5d1c268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#54 0xb6f49438 in QEventDispatcherGlib::processEvents (this=0x9e81e48, flags={i = -1080921848}) at kernel/qeventdispatcher_glib.cpp:323
#55 0xb65c7365 in QGuiEventDispatcherGlib::processEvents (this=0x9e81e48, flags={i = -1080921800}) at kernel/qguieventdispatcher_glib.cpp:202
#56 0xb6f1c06a in QEventLoop::processEvents (this=0xa1b3820, flags={i = -1080921736}) at kernel/qeventloop.cpp:149
#57 0xb6f1c4aa in QEventLoop::exec (this=0xa1b3820, flags={i = -1080921624}) at kernel/qeventloop.cpp:200
#58 0xb65ae310 in QDragManager::drag (this=0xa1fd7a0, o=0xa126438) at kernel/qdnd_x11.cpp:1952
#59 0xb653953a in QDrag::exec (this=0xa126438, supportedActions={i = -1080921372}, defaultDropAction=Qt::CopyAction) at kernel/qdrag.cpp:282
#60 0xb6aa6b9c in QAbstractItemView::startDrag (this=0x9fc9be0, supportedActions={i = -1080921116}) at itemviews/qabstractitemview.cpp:3189
#61 0xb6aa3b5d in QAbstractItemView::mouseMoveEvent (this=0x9fc9be0, event=0xbf927c88) at itemviews/qabstractitemview.cpp:1547
#62 0xb6ae2e84 in QTreeView::mouseMoveEvent (this=0x9fc9be0, event=0xbf927c88) at itemviews/qtreeview.cpp:1863
#63 0xb657c9ad in QWidget::event (this=0x9fc9be0, event=0xbf927c88) at kernel/qwidget.cpp:7501
#64 0xb6956993 in QFrame::event (this=0x9fc9be0, e=0xbf927c88) at widgets/qframe.cpp:559
#65 0xb69f694f in QAbstractScrollArea::viewportEvent (this=0x9fc9be0, e=0xb7012a48) at widgets/qabstractscrollarea.cpp:962
#66 0xb6aa8647 in QAbstractItemView::viewportEvent (this=0x9fc9be0, event=0xbf927c88) at itemviews/qabstractitemview.cpp:1466
#67 0xb6ae30c4 in QTreeView::viewportEvent (this=0x9fc9be0, event=0xbf927c88) at itemviews/qtreeview.cpp:1257
#68 0xb69f8f55 in QAbstractScrollAreaFilter::eventFilter (this=0x9fe3c58, o=0xa0215a8, e=0xbf927c88) at widgets/qabstractscrollarea_p.h:100
#69 0xb6f1cc5a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9e81e68, receiver=0xa0215a8, event=0xbf927c88) at kernel/qcoreapplication.cpp:718
#70 0xb6525e7a in QApplicationPrivate::notify_helper (this=0x9e81e68, receiver=0xa0215a8, e=0xbf927c88) at kernel/qapplication.cpp:4080
#71 0xb652eb11 in QApplication::notify (this=0xbf92877c, receiver=0xa0215a8, e=0xbf927c88) at kernel/qapplication.cpp:3786
#72 0xb74d23dd in KApplication::notify (this=0xbf92877c, receiver=0xa0215a8, event=0xbf927c88) at /build/buildd/kde4libs-4.2.95/kdeui/kernel/kapplication.cpp:302
#73 0xb6f1da3b in QCoreApplication::notifyInternal (this=0xbf92877c, receiver=0xa0215a8, event=0xbf927c88) at kernel/qcoreapplication.cpp:602
#74 0xb652db7e in QApplicationPrivate::sendMouseEvent (receiver=0xa0215a8, event=0xbf927c88, alienWidget=0xa0215a8, nativeWidget=0x9f843a0, buttonDown=0xb6dd0200, lastMouseReceiver=@0xb6dd0204)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#75 0xb659d97e in QETWidget::translateMouseEvent (this=0x9f843a0, event=0xbf9282cc) at kernel/qapplication_x11.cpp:4425
#76 0xb659cca7 in QApplication::x11ProcessEvent (this=0xbf92877c, event=0xbf9282cc) at kernel/qapplication_x11.cpp:3421
#77 0xb65c7c6a in x11EventSourceDispatch (s=0x9e84d70, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#78 0xb5d18b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#79 0xb5d1c0eb in ?? () from /usr/lib/libglib-2.0.so.0
#80 0xb5d1c268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#81 0xb6f49438 in QEventDispatcherGlib::processEvents (this=0x9e81e48, flags={i = -1080916856}) at kernel/qeventdispatcher_glib.cpp:323
#82 0xb65c7365 in QGuiEventDispatcherGlib::processEvents (this=0x9e81e48, flags={i = -1080916808}) at kernel/qguieventdispatcher_glib.cpp:202
#83 0xb6f1c06a in QEventLoop::processEvents (this=0xbf928530, flags={i = -1080916744}) at kernel/qeventloop.cpp:149
#84 0xb6f1c4aa in QEventLoop::exec (this=0xbf928530, flags={i = -1080916680}) at kernel/qeventloop.cpp:200
#85 0xb6f1e959 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#86 0xb6525d17 in QApplication::exec () at kernel/qapplication.cpp:3553
#87 0xb7ec2109 in kdemain () from /usr/lib/libkdeinit4_keditbookmarks.so
#88 0x080486a2 in _start ()

Reported using DrKonqi
Comment 1 Tommi Tervo 2009-07-03 10:28:10 UTC

*** This bug has been marked as a duplicate of bug 187892 ***