Bug 168914 - no mount options anywhere for external drives, e.g. vfat shortname
Summary: no mount options anywhere for external drives, e.g. vfat shortname
Status: RESOLVED UNMAINTAINED
Alias: None
Product: solid
Classification: Unclassified
Component: libsolid (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 612 votes (vote)
Target Milestone: ---
Assignee: Lukáš Tinkl
URL:
Keywords:
: 170636 181942 188310 209267 216985 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-11 15:44 UTC by Alex Lennon
Modified: 2018-09-04 15:48 UTC (History)
29 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
mount-shortname-mixed.patch (565 bytes, patch)
2009-01-03 14:29 UTC, kujub
Details
sample fdi file (571 bytes, application/octet-stream)
2010-01-22 22:39 UTC, Michael Kopp
Details
proposed patch (594 bytes, patch)
2010-01-22 22:39 UTC, Michael Kopp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Lennon 2008-08-11 15:44:31 UTC
Version:            (using KDE 4.1.0)
Installed from:    Unlisted Binary Package
Compiler:          gcc 4.3.1 
OS:                Linux

After upgrading to KDE4 I have not been able to find a way of passing mount options for external devices, in particular a usb fat32 drive. The default automount behaviour in dolphin doesn't use mixed case for shortnames. After a lot of web searching and browsing the KDE 'systemsettings' GUI and dolphin etc., I haven't come across a way of setting this from within KDE. 

This ability seems to have been dropped since KDE 3.5.9---device icons on the desktop had an option within the properties link to control some mount options, such as the filename case.

A workaround for now is to use 'pmount' from the terminal which has my preferred default behaviour. 

Thanks,
Alex
Comment 1 Victor Suarez 2008-08-23 20:08:49 UTC
I think this is the same that bug #161588.
Comment 2 Victor Suarez 2008-10-03 20:31:47 UTC
Forget my previous comment, it is not the same bug. 

This one is very important for interoperability between Java developers: without mixed case for shortnames, WEB-INF and META-INF directories are converted to lowercase, disabling web apps or servers installations.
Comment 3 Jason Voegele 2008-10-29 01:28:40 UTC
It is also very important for iPods and other media players.  Consider, for instance, if you use rsync to push music files to your iPod.  Under KDE 4, "U2" shows up as "u2" on the iPod, and when I use rsync I end up with two copies of every U2 track.
Comment 4 Christoph Tavan 2008-10-31 12:35:40 UTC
This issue is so annoying and makes using KDE 4 a much less comfortable than it could be. I would love to see an options dialog again. Or to have KDE at least respect HAL-Policies....
Comment 5 Per Ångström 2008-11-03 22:33:44 UTC
I'm missing the ability to choose a mount point other than the default. My workaround is to use Konqueror from KDE 3, which has this functionality. In my opinion, the lack of such functionality in KDE 4 is a regression.
Comment 6 kujub 2008-12-26 20:15:25 UTC
Mount options would be good to have,
 but I think shortname=mixed should be used as default on vfat anyway. All other shortname settings lead to confusing weird results IMHO.
Comment 7 kujub 2008-12-26 20:16:25 UTC
*** This bug has been confirmed by popular vote. ***
Comment 8 kujub 2009-01-03 14:29:32 UTC
Created attachment 29861 [details]
mount-shortname-mixed.patch
Comment 9 kujub 2009-01-03 14:32:14 UTC
I created a simple patch to get shortname=mixed as default option. Tested here with 4.1.3. Should work with trunk too.
Comment 10 David Faure 2009-01-30 14:52:05 UTC
Kevin, can you review the patch for Solid?
Thanks. (see also bug 181942 which explains why this is necessary)
Comment 11 Kevin Ottens 2009-01-30 17:56:07 UTC
*** Bug 181942 has been marked as a duplicate of this bug. ***
Comment 12 Kevin Ottens 2009-01-30 17:56:43 UTC
Looks good to me, please commit.

Regards.
Comment 13 kujub 2009-01-30 19:49:57 UTC
I also applied the patch here on KDE 4.2.0 on my ArchLinux box meanwhile.
Works good too. :)
Comment 14 David Faure 2009-01-31 04:15:40 UTC
Patch committed in 918779, no idea why CCBUG didn't work.

Does this resolve this report, or was it a more general request for user configuration of options?
Comment 15 Per Ångström 2009-01-31 09:23:47 UTC
If the patch only addresses the mixed-case case and does not offer a way to set other options, it does not belong to this case. I'm not so happy about duping bug 181942 to this one; they have very different scope.

I saw this bug as a request for user configuration of options, something like we had in KDE3. Even Gnome has a GUI for this.
Comment 16 Serguei Miridonov 2009-02-10 07:25:03 UTC
(In reply to comment #15)
> If the patch only addresses the mixed-case case and does not offer a way to set
> other options, it does not belong to this case. I'm not so happy about duping
> bug 181942 to this one; they have very different scope.
> 
> I saw this bug as a request for user configuration of options, something like
> we had in KDE3. Even Gnome has a GUI for this.
> 

+1. 

The possibility to set both default (for majority of mounted devices) and specific mount options seems very important. Consider the following situations:

1. You prefer to use shortname=mixed to have full compatibility with win32 file names. But sometimes you need to mount a vfat volume for use with some legacy application which expects shortname=lower setting.

2. You need to copy something from very sensitive storage which you don't want to destroy by accident. Solution: mount read-only, just once.

3. You may want to add specific pre- and post- actions for both mount/umount... For example, sdparm --command=stop scsi-emulated drives like external hard disks after umount.

More examples?
Comment 17 Orion Poplawski 2009-03-24 18:07:14 UTC
I need to be able to set permission options, e.g. gid= and umask= as well.  This needs to be available for a large set of options.  Perhaps some could be set via a gui, but an area to enter text option would be desired as well.
Comment 18 Serguei Miridonov 2009-03-24 22:44:12 UTC
Is anybody taking care of this? People from KDE development team, could you please be so kind, at least, to return the functionality which existed in KDE 3.x? Please, this is really important!
Comment 19 Adam Spiers 2009-03-29 23:38:26 UTC
Wow, another big regression from KDE3 :-(  Have voted for this one.  I agree with many of the comments in this bug, especially #15 and #16.
Comment 20 krienke 2009-07-17 11:57:17 UTC
I run kde 4.2.4 on a openSuSE 11.1 box. last wekk I did another update to get the latest sub-version of 4.2.4. Since then I suddenly get all my files on my flash cards (with vfat) in upper case. Seems the patch from above reached the stable tree. However for me this horror. I take photos. All of my photo files up to now were in lower case. The sorting is done by filename. Suddenly the files are in upper case which destroys sorting them. Besides this upper case names simply look ugly to me and I like to have them in lower case.

Is there a way to get back to the old behaviour using shortname-lower as an mount option?

I think from what I read here its a really important lack of functionality that options like the mount option shortname are hardcoded in the source and not adjustable for the end user.

Or is there such a way I do not know of by now?

Thanks
Rainer
Comment 21 Michael Kopp 2010-01-22 20:38:17 UTC
I found 4 other tickets about the same thing, is somebody working on this?
Comment 22 Michael Kopp 2010-01-22 22:35:42 UTC
I built a small patch for my own purposes. it basically revives the hal mount option feature with kde

I added the attached fdi file to my hal config and patch kde with the attached patch.

result is that I can configure my mount options via hal and obviously per filesystem. Maybe it can be integrated, otherwise it is for those of you who have a source distro like me
Comment 23 Michael Kopp 2010-01-22 22:39:11 UTC
Created attachment 40135 [details]
sample fdi file
Comment 24 Michael Kopp 2010-01-22 22:39:47 UTC
Created attachment 40136 [details]
proposed patch
Comment 25 Peter Penz 2010-01-25 10:22:09 UTC
*** Bug 170636 has been marked as a duplicate of this bug. ***
Comment 26 Kevin Ottens 2010-01-25 18:26:31 UTC
I'm uneasy with this patch as it relies on some HAL trick which is frowned upon by its developers. They push to use /etc/fstab instead, isn't it enough for you to provide those options via fstab?
(Not talking about the general case, which would require a UI, but only Michael Kopp's needs)
Comment 27 Michael Kopp 2010-01-25 19:13:07 UTC
1 it's no trick, just accessing a property that is user defined. 
2 fstab does not allow to specify options globally but only per specific device
    Still it is an option but not a really satisfying one.
I agree the patch is not a solution but a workaround and I understand if it's not added.
I much rather have a ui myself or even a a kde config file.
Comment 28 H.H. 2010-02-14 16:50:16 UTC
I just found a workaround described here

http://www.linuxforen.de/forums/showpost.php?p=1741457&postcount=13

it's german and for opensuse-11.2. it rescues me, until this is fixed in kde.

my use case is to have data on a vfat partition and need to have write access for other users than me.
Comment 29 KOPRajs 2010-05-27 13:31:05 UTC
Hi,
why not include the Michael Kopp's patch? It's small, clean, it doesn't break anything and it gives users a way to specify any mount option for a specific device or for group of devices with common attribute. It's what the hal mount option policy is for.
In my case I can't mount my VFAT disk because I need to specify iocharset=utf8 for it to get accents working.
Comment 30 krienke 2010-08-04 11:06:30 UTC
Is there anything new about this problem? 

In between I am working with openSuSE 11.3 and the kernel used in 11.3 (2.6.34) changed the default for vfat mounts from shortname=lower to shortname=mixed. This results in upper case filenames on some USB vfat devices (my SD-card from my digital camera)  and others display lower case (a regular USB stick). 

The workarounds that are based on changing hal rules do no longer work since at least openSuSE 11.3 now uses udisks as far as I can see and no longer hal for this purpose. So changing hal rules has no longer any effect on attached USB mass storage devices. At the moment eg when copying  photos from my cameras SD-card I  have to manually rename all of the files to lower case afterwards. 

There is no way to to have them displayed lower case except if I mount the device manually using shortname=lower or manually create  fstab entries suitable for each device in question. But this does not really make sense.

So a general solution for this problem by letting the user specify the extra vfat mounts options he want is really needed.
Comment 31 Björn Ruberg 2010-09-11 21:02:12 UTC
*** Bug 188310 has been marked as a duplicate of this bug. ***
Comment 32 Kevin Ottens 2010-10-02 15:48:39 UTC
*** Bug 209267 has been marked as a duplicate of this bug. ***
Comment 33 Sergey Burladyan 2010-11-05 00:50:30 UTC
Is there anything new about this problem? 

Is there any chance that this will be implemented?
Comment 34 Orion Poplawski 2010-11-10 20:01:24 UTC
Moving forward (KDE 4.6) we should be using udisks and can pass options to FilesystemMount().  KDE will need a UI to store and manage options though.
Comment 35 Joker-jar 2011-01-28 11:56:24 UTC
Yes, KDE needs something like this. Possibility to set up individual mount options for each filesystem
Comment 36 Kevin Ottens 2011-04-15 11:02:29 UTC
Moving at the right place.
Comment 37 Lamarque V. Souza 2011-09-01 19:55:36 UTC
*** Bug 216985 has been marked as a duplicate of this bug. ***
Comment 38 Sérgio Basto 2012-04-22 22:44:49 UTC
now with udisks, we got the problem again 
see bug #273792 please
Comment 39 rlk 2013-06-23 19:47:29 UTC
Using KDE 4.10.4, OpenSUSE 12.3.

Another vote for this: I would like to mount all filesystems noatime.
Comment 40 aditsu 2013-07-05 01:17:30 UTC
I also want noatime for every mount
Comment 41 Volker Kuhlmann 2013-12-03 01:49:07 UTC
We need a general mechanism for providing additional mount options for removable devices. Devices need to be identified by hardware if possible, or filesystem UUID in a crunch. It is not good that something like this still isn' t available in KDE4 (it was in KDE 3).

It is not an acceptable solution to hard-code options into udisks2 (or whatever the current flavour of the month), in fact that is not a solution at all. Some want noatime, some want flush, and I want tz=UTC for vfat. 

Android runs vfat with UTC, as does anyone with a digital camera and any sense.  KDE can't handle this, which is very annoying. "Workarounds" with /etc/fstab cause brain injuries. Missing UTC stamps turn rsync into custard, for example. More use cases have been listed earlier; they have in common that it is impossible to predict the precise mount option(s) needed.

Because it'd be easy to compromise a system with the wrong option requiring root to set these might be a good idea. I'd also almost always like them set per external storage device (or per Linux system), not per user. No need to re-do the same thing for every user.

Having a config file with device properties and their mount options would be a good start, as long as they get used by the KDE device notifier.

Otherwise the only functional alternative is the command line, which negates the advantages of a user friendly desktop system.
Comment 42 rlk 2013-12-03 02:07:19 UTC
Exactly.  *As it happens*, I want to use noatime (at least for most devices), but that's just my personal preference/use case.  There is no one set of mount options that will work for every user, device type, and individual device.

This bug (and I feel justified in calling it that, since it's a regression from KDE3 and even GNOME does it) has been around for 5 years.  It really needs to be given higher priority.
Comment 43 Jonathan Riddell 2015-03-11 19:03:45 UTC
This bug is reported on libsolid which is the kdelibs4 version of the solid library.  It is now in maintenance mode.  If you think it should still be fixed in the KDE Frameworks 5 version of solid please move it to or report a bug on frameworks-solid.
Comment 44 rlk 2016-07-01 04:48:38 UTC
I just filed bug 364955 - no mount options anywhere for external drives, e.g. vfat shortname.  This is getting ridiculous.  Right now I have some data I urgently need to migrate to an external drive, but the shortname=mixed is causing me a lot of problems (on my Linux system the files are lower case; shortname=mixed on files coming out of a camera results in all upper case filenames).
Comment 45 Andrew Crouthamel 2018-09-04 15:42:26 UTC
Hello! Sorry to be the bearer of bad news, but this project has been unmaintained for many years so I am closing this bug. Please try again with the latest version and submit a new bug to frameworks-solid if your issue persists. Thank you!
Comment 46 rlk 2018-09-04 15:47:35 UTC
Bug already exists against frameworks-solid, 364955.  You may wish to duplicate this bug to that one.