Bug 181942 - copy of some content of UPPERCASE directories to usb fat32 fails
Summary: copy of some content of UPPERCASE directories to usb fat32 fails
Status: RESOLVED DUPLICATE of bug 168914
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: SVN
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-26 00:49 UTC by Marco Menardi
Modified: 2009-02-03 01:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Menardi 2009-01-26 00:49:54 UTC
Version:            (using KDE 4.1.96)
OS:                Linux
Installed from:    Debian testing/unstable Packages

In your hard disk create the following directory structure (case and directory name are important!)
directory:
UPPERCASE
with 2 subdirs, MAPPE and MAPPEZ
and inside them create mydocument_03.txt file.
So you will have:
UPPERCASE
..MAPPE
....mydocument_03.txt
..MAPPZ
....mydocument_03.txt

Then insert a usb pen drive, fat32 formatted, and open it in Dophin. With split window or another dolphin instance go to "UPPERCASE" dir and copy/paste to the USB pen drive.
"Could not write to /media/KINGSTON/UPPERCASE/MAPPE/mydocument_03.txt" appears. If you press "AutoSkip" you will end with a pen with:
UPPERCASE
..mappe
..mappz
(no file copied, subdirs in lowercase).
This bug has been confirmed by a friend of mine in IRC chat (he has compiled RC1 from source).
Comment 1 kujub 2009-01-29 16:36:16 UTC
I can confirm this on KDE 4.2.0 ArchLinux 686.

I think this happens because KDE does not mount VFAT with option shortname=mixed (as pmount does)

Related bug report: https://bugs.kde.org/show_bug.cgi?id=168914
Patch for this:     https://bugs.kde.org/attachment.cgi?id=29861
Comment 2 Kevin Ottens 2009-01-30 17:56:07 UTC
Looks like a duplicate, well or at least a symptom of 168914.

*** This bug has been marked as a duplicate of bug 168914 ***
Comment 3 Marco Menardi 2009-01-30 19:05:11 UTC
Well, maybe is a duplicate, but if so I'm shocked that the "original" 168914 is still open, and flagged as Priority Normal, Severity: wishlist!
Don't you think that removable devices are often used to exchange data between GNU/Linux and M$Crap OS? And so they are mainly formatted with fat32 for interoperability reasons? And then copy file to them is currently badly BROKEN, putting me in a big embarass when I tried to show a firend of mine how good GNU/Linux is?
I had to use cp from command line (so how can it be a mount parameter problem, if I can do the copy from bash?), but can't force my old father to do the same (yes, he is using GNU/Linux + KDE 4.2 on his laptop!).
Comment 4 David Faure 2009-01-30 19:40:24 UTC
"severity wishlist" is wrong, but apart from that, calm down please! and let us merge bug reports when they have indeed the same cause.

Do you think we introduce bugs on purpose in our free time, or what? We have a HUGE amount of work and if you're not happy with it you can only blame yourself for not helping us - who (for the most part) are doing this on our free time.

Calling us names doesn't make anything better.
Comment 5 David Faure 2009-01-30 19:44:01 UTC
SVN commit 918779 by dfaure:

Mount vfat devices with shortname=mixed otherwise copying uppercase dirs to them breaks (181942); patch is from 168914, approved by Kevin.
CCBUG: 181942, 168914


 M  +2 -0      halstorageaccess.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=918779
Comment 6 Marco Menardi 2009-01-31 18:09:17 UTC
@David Faure.
a) "calling us names" was absolutely not my intention (seems I've not done, but if you have percieved so, I apologise). I was nervous because I discovered this bug when rc1 was available to my distro, and was very sad discovering that the day after 4.2 was released with the bug. When I saw that the "original" bug is of some months ago, I had the impression was not cosidered as important as I think it is, so I was a bit upset mainly with myself for the late discovery. Being upset with what happened is really far from blame / insult / understimate KDE developers value and work. I'm sure you are doing your best. Of course in my message you don't read how much I like KDE and apreciate your work, but belive me :)
b) I help only testing KDE and reporting bugs/discussing in IRC. Next step would be helping in "real programming", but I'm still far from it, sigh, shame on me.
c) thanks for the patch :)
Comment 7 David Faure 2009-02-03 01:16:52 UTC
A bug opened "a few months ago" and not fixed yet doesn't mean we don't care, it only means we didn't have time yet.
Heck, in December I was fixing bugs from 2003 and 2004...
I don't think people realize just how many bug reports we have to handle.