Bug 170636 - Add 'mount options' for removable media
Summary: Add 'mount options' for removable media
Status: RESOLVED DUPLICATE of bug 168914
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: OpenSUSE Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-07 19:03 UTC by Pavel Zheltobryukhov
Modified: 2010-01-25 10:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
proposed patch (594 bytes, text/plain)
2010-01-22 22:36 UTC, Michael Kopp
Details
sample fdi file (571 bytes, text/plain)
2010-01-22 22:37 UTC, Michael Kopp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Zheltobryukhov 2008-09-07 19:03:40 UTC
Version:            (using KDE 4.1.1)
OS:                Linux
Installed from:    SuSE RPMs

When I plug USB stick, it mounting in KDE4 as (for example)

/dev/sdb1 on /media/disk type vfat (rw,nosuid,nodev,uid=1001)

As you can see, 'utf8' option losed, the names of files and folders with national symbols (Cyrillic, or German umlauts, for example) will be displaed incorrectly.

Then, mount the same USB stick in KDE3 on the same machine:

/dev/sdb1 on /media/disk type vfat (rw,nosuid,nodev,noatime,flush,uid=1001,utf8,shortname=lower)

the 'utf8' appear and national symbols displayed properly. Reboot and login into KDE4 session - this mounting options persist:

/dev/sdb1 on /media/disk type vfat (rw,nosuid,nodev,noatime,flush,uid=1001,utf8,shortname=lower)

Does KDE4 still use ~/.kde/share/config/mediamanagerrc file? (because I found changes in this file and this changes, maden in KDE3, reflecting in KDE4 session after re-login). 

Conclusion: need a GUI tool to make changes in mounting options for removable medias.
Comment 1 Pavel Zheltobryukhov 2008-09-19 15:42:37 UTC

*** This bug has been marked as a duplicate of bug 161673 ***
Comment 2 Michael Kopp 2010-01-22 20:36:50 UTC
Duplicate of 168914
Comment 3 Michael Kopp 2010-01-22 22:36:37 UTC
Created attachment 40133 [details]
proposed patch
Comment 4 Michael Kopp 2010-01-22 22:37:18 UTC
Created attachment 40134 [details]
sample fdi file
Comment 5 Peter Penz 2010-01-25 10:22:09 UTC

*** This bug has been marked as a duplicate of bug 168914 ***