Bug 149477 - All memory used, probably by many kio_file and kio_pop3 processes
Summary: All memory used, probably by many kio_file and kio_pop3 processes
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: enterprise
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 149334 149432 149492 149500 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-09-02 15:06 UTC by sts
Modified: 2008-01-26 18:57 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
ps aux (6.77 KB, text/plain)
2007-09-02 15:07 UTC, sts
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sts 2007-09-02 15:06:18 UTC
Version:           1.9.6 (enterprise 0.20070831.706792) (using KDE 3.5.7 "release 74.1" , openSUSE )
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.18.8-0.5-default

After last update I have some problems with kontact. I use 2 kde sessions and very often kde eats all of my memory / swap.

see attachment for process output
Comment 1 sts 2007-09-02 15:07:26 UTC
Created attachment 21531 [details]
ps aux
Comment 2 sts 2007-09-02 15:09:42 UTC
If I check my GMX mails again.. kontact means another session is already running? hmh.. :(
Comment 3 Thomas McGuire 2007-09-03 19:25:59 UTC
This is not a crash.
I guess this is either the folder size calculation at startup (bug 149414), which starts many kio_file processes, or the POP3 bug, which starts many kio_pop3 processes (bug 149432).

Can you rule out that the problem is one of the above? You might want to try a normal KMail version, instead of the unsupported enterprise versions.
Comment 4 Thomas McGuire 2007-09-03 19:35:28 UTC
I guess all the following bugs are related, and are recently introduced in the enterprise and 3.5 branch:
bug 149413
bug 149477
bug 149492
bug 149493
bug 149500
Comment 5 Thomas McGuire 2007-09-05 15:19:15 UTC
*** Bug 149500 has been marked as a duplicate of this bug. ***
Comment 6 Thomas McGuire 2007-09-05 15:20:15 UTC
*** Bug 149492 has been marked as a duplicate of this bug. ***
Comment 7 Thomas McGuire 2007-09-05 15:22:03 UTC
This should be fixed in the enterprise and in the 3.5 branch. Please reopen if you can still reproduce the problem with the newest version.
Comment 8 Thomas McGuire 2007-09-05 15:26:28 UTC
*** Bug 149432 has been marked as a duplicate of this bug. ***
Comment 9 Thomas McGuire 2007-09-05 16:03:20 UTC
*** Bug 149334 has been marked as a duplicate of this bug. ***
Comment 10 Tristan Miller 2007-09-28 00:25:55 UTC
Bug still occurs with the latest SUSE package (kdepim3-3.5.7.enterprise.0.20070904.708012-5.2.i586.rpm) which I am told was released specifically to fix this bug.  So provided SUSE actually incorporated the bugfixes they said they did, then yes, the problem is still reproducible.
Comment 11 Pacho Ramos 2007-10-11 14:19:10 UTC
Same here with Mandriva, please REOPEN

Thanks
Comment 12 Tommi Tervo 2007-10-11 14:32:40 UTC
Reopened, two users claims that this is not fixed.
Comment 13 Pacho Ramos 2007-10-11 14:36:08 UTC
Mandriva bug report is:
http://qa.mandriva.com/show_bug.cgi?id=27440

And original reporter says:

> hello,
>
> with libkdebase4-3.5.7-38mdv2008.0, problem is still there.
> After 2 days of uptime, kio_pop3 (used by korn) is taking 100 MB instead
> of approx 40 MB when started.
> So the leak is still there.
Comment 14 Pacho Ramos 2007-10-11 15:44:53 UTC
Seems that mandriva problem is different

sorry for the inconvenience 
Comment 15 Thomas McGuire 2008-01-26 18:57:34 UTC
Is there anyone in this bug report who still has the problem with many kio_pop3 processes and has a recent KMail version of the enterprise branch? If so, I'll reopen.

The problem with many kio_file processes is different, see bug 149414.