Bug 149334 - Manual and automatical POP3 jobs get in conflict; automatical job requests the password each turn
Summary: Manual and automatical POP3 jobs get in conflict; automatical job requests th...
Status: RESOLVED DUPLICATE of bug 149477
Alias: None
Product: kmail
Classification: Applications
Component: pop3 (show other bugs)
Version: enterprise
Platform: Ubuntu Linux
: NOR normal with 21 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-29 15:09 UTC by Richard Johnson
Modified: 2007-09-05 16:03 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Johnson 2007-08-29 15:09:43 UTC
Version:           1.9.6 (enterprise 0.20070824.704228) (using KDE KDE 3.5.7)
Installed from:    Ubuntu Packages
OS:                Linux

Application: Kontact/KMail 
Version: 1.9.6 (enterprise 0.20070824.704228) 
Distro: Kubuntu Gutsy (7.04 w/ the latest updates) 
Distro Bug Report: https://bugs.launchpad.net/ubuntu/+source/kdepim/+bug/135446
............

After Kontact/KMail is up and running, when I do a manual mail check, I receive the following error:

............
Could not login to mail.mymailhost.com. The password may be wrong.
The server said: "[IN-USE] account busy (locked by another POP3 process)"
............

This only occurs after Kontact/KMail is up and running and I do a manual mail check.
Comment 1 Richard Johnson 2007-08-30 18:23:55 UTC
This bug is only specific to the Enterprise branch. 1.9.7 on Debian works fine.
Comment 2 Friedrich W. H. Kossebau 2007-09-01 17:21:37 UTC
I see this problem, too, with latest openSUSE packages kdepim3-3.5.7.enterprise.0.20070831.706868-15.2 

Changed the summary to what I think is the problem.
Comment 3 Friedrich W. H. Kossebau 2007-09-01 21:13:18 UTC
This bug is even worse. After a few hours I found that there were no new emails in any folder, even if the progressbar some times showed "Download of xx finished". Just looked by the web interface of my email account, found relief, since the start of this KMail instance no emails were moved, all still on the server. Instead there are a bunch of kio_pop3 processes hanging around on my system, "ps x | grep pop3" showed:

 7064 ?        S      0:00 kio_pop3 [kdeinit] pop3 /tmp/ksocket-kossebau/klauncherNpjWIb.s
 7139 ?        S      0:00 kio_pop3 [kdeinit] pop3 /tmp/ksocket-kossebau/klauncherNpjWIb.s
 7140 ?        S      0:00 kio_pop3 [kdeinit] pop3 /tmp/ksocket-kossebau/klauncherNpjWIb.s
[some 90 or so of these more]

They vanished after I closed KMail. So KMail looses control somewhere of the kio_pop3 job?
Comment 4 Stephan Johach 2007-09-02 12:37:18 UTC
I have this too after an svn update from stable svn. Sometimes no new pop3 mails come in. Furthermore I now experience random crashes when fetching mails by hand. And I get a strange message, that my gmx server does not support the APOP protocol. There's something really broken. :(
Comment 5 Stephan Johach 2007-09-02 12:58:48 UTC
A backtrace when requesting pop messages:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1250944736 (LWP 4128)]
[New Thread -1280808016 (LWP 4132)]
[New Thread -1272415312 (LWP 4131)]
[New Thread -1264022608 (LWP 4130)]
[New Thread -1255629904 (LWP 4129)]
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb57b4431 in *__GI_raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0xb57b5bab in *__GI_abort () at ../sysdeps/generic/abort.c:88
#9  0xb57ad805 in *__GI___assert_fail (
    assertion=0x6 <Address 0x6 out of bounds>, 
    file=0x6 <Address 0x6 out of bounds>, line=6, 
    function=0xb7715020 "DwString::DwString(const char*, size_t)")
    at assert.c:83
#10 0xb7709499 in DwString (this=0xbf9278b0, aBuf=0x0, aLen=0)
    at dwstring.cpp:356
#11 0xb7b1f25d in KMMessage::fromByteArray () at /opt/qt/include/qglist.h:149
#12 0xb7cb74aa in KMail::PopAccount::slotMsgRetrieved ()
    at /opt/qt/include/qstringlist.h:58
#13 0xb7cbd80a in KMail::PopAccount::qt_invoke ()
    at /opt/qt/include/qstringlist.h:58
#14 0xb5f66619 in QObject::activate_signal ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#15 0xb6b11e3f in KIO::Job::infoMessage () from /opt/kde-3.5/lib/libkio.so.4
#16 0xb6b11e98 in KIO::SimpleJob::slotInfoMessage ()
   from /opt/kde-3.5/lib/libkio.so.4
#17 0xb6b16b90 in KIO::SimpleJob::qt_invoke ()
   from /opt/kde-3.5/lib/libkio.so.4
#18 0xb6b16c23 in KIO::TransferJob::qt_invoke ()
   from /opt/kde-3.5/lib/libkio.so.4
#19 0xb5f66619 in QObject::activate_signal ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#20 0xb5f66f11 in QObject::activate_signal ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#21 0xb6b02bd3 in KIO::SlaveInterface::infoMessage ()
   from /opt/kde-3.5/lib/libkio.so.4
#22 0xb6b05310 in KIO::SlaveInterface::dispatch ()
   from /opt/kde-3.5/lib/libkio.so.4
#23 0xb6b03cb7 in KIO::SlaveInterface::dispatch ()
   from /opt/kde-3.5/lib/libkio.so.4
#24 0xb6b00e3b in KIO::Slave::gotInput () from /opt/kde-3.5/lib/libkio.so.4
#25 0xb6b00feb in KIO::Slave::qt_invoke () from /opt/kde-3.5/lib/libkio.so.4
#26 0xb5f66619 in QObject::activate_signal ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#27 0xb5f66be1 in QObject::activate_signal ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#28 0xb62a3050 in QSocketNotifier::activated ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#29 0xb5f856c0 in QSocketNotifier::event ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#30 0xb5f06d81 in QApplication::internalNotify ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#31 0xb5f07669 in QApplication::notify () from /opt/qt-3.3.7/lib/libqt-mt.so.3
#32 0xb654a79e in KApplication::notify () from /opt/kde-3.5/lib/libkdecore.so.4
#33 0xb5efacad in QEventLoop::activateSocketNotifiers ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#34 0xb5eb5a68 in QEventLoop::processEvents ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#35 0xb5f1d9e3 in QEventLoop::enterLoop () from /opt/qt-3.3.7/lib/libqt-mt.so.3
#36 0xb5f066ff in QApplication::enter_loop ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#37 0xb60f098e in QDialog::exec () from /opt/qt-3.3.7/lib/libqt-mt.so.3
#38 0xb68de347 in KMessageBox::createKMessageBox ()
   from /opt/kde-3.5/lib/libkdeui.so.4
#39 0xb68deaee in KMessageBox::createKMessageBox ()
   from /opt/kde-3.5/lib/libkdeui.so.4
#40 0xb68df00e in KMessageBox::errorListWId ()
   from /opt/kde-3.5/lib/libkdeui.so.4
#41 0xb68e04c3 in KMessageBox::error () from /opt/kde-3.5/lib/libkdeui.so.4
#42 0xb7cb6296 in KMail::PopAccount::slotSlaveError ()
    at /opt/qt/include/qstringlist.h:58
#43 0xb7cbd8af in KMail::PopAccount::qt_invoke ()
    at /opt/qt/include/qstringlist.h:58
#44 0xb5f6657c in QObject::activate_signal ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#45 0xb6b0847b in KIO::Scheduler::slaveError ()
   from /opt/kde-3.5/lib/libkio.so.4
#46 0xb6b08505 in KIO::Scheduler::slotSlaveError ()
   from /opt/kde-3.5/lib/libkio.so.4
#47 0xb6b0c7a0 in KIO::Scheduler::qt_invoke ()
   from /opt/kde-3.5/lib/libkio.so.4
#48 0xb5f66619 in QObject::activate_signal ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#49 0xb6b0301f in KIO::SlaveInterface::error ()
   from /opt/kde-3.5/lib/libkio.so.4
#50 0xb6b056c0 in KIO::SlaveInterface::dispatch ()
   from /opt/kde-3.5/lib/libkio.so.4
#51 0xb6b03cb7 in KIO::SlaveInterface::dispatch ()
   from /opt/kde-3.5/lib/libkio.so.4
#52 0xb6b00e3b in KIO::Slave::gotInput () from /opt/kde-3.5/lib/libkio.so.4
#53 0xb6b00feb in KIO::Slave::qt_invoke () from /opt/kde-3.5/lib/libkio.so.4
#54 0xb5f66619 in QObject::activate_signal ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#55 0xb5f66be1 in QObject::activate_signal ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#56 0xb62a3050 in QSocketNotifier::activated ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#57 0xb5f856c0 in QSocketNotifier::event ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#58 0xb5f06d81 in QApplication::internalNotify ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#59 0xb5f07669 in QApplication::notify () from /opt/qt-3.3.7/lib/libqt-mt.so.3
#60 0xb654a79e in KApplication::notify () from /opt/kde-3.5/lib/libkdecore.so.4
#61 0xb5efacad in QEventLoop::activateSocketNotifiers ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#62 0xb5eb5a68 in QEventLoop::processEvents ()
   from /opt/qt-3.3.7/lib/libqt-mt.so.3
#63 0xb5f1d9c9 in QEventLoop::enterLoop () from /opt/qt-3.3.7/lib/libqt-mt.so.3
#64 0xb5f1d8c6 in QEventLoop::exec () from /opt/qt-3.3.7/lib/libqt-mt.so.3
#65 0xb5f066cf in QApplication::exec () from /opt/qt-3.3.7/lib/libqt-mt.so.3
#66 0x0804a458 in main ()
Comment 6 Stephan Johach 2007-09-02 13:07:01 UTC
Perhaps more interesting for the developers. I get this on the konsole window:

hunsum@leviathan:~/svn/kdepim$ kmail &
[1] 4127
hunsum@leviathan:~/svn/kdepim$ WeaverThreadLogger: thread (ID: 1) suspended.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "move_message_to_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "copy_message_to_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "jump_to_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "jump_to_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "cancel"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "inc_current_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "dec_current_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "select_current_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "inc_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "dec_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "select_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "delete"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "edit"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "use_template"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x82f62a0 ): KAccel object already contains an action name "display_message"
WeaverThreadLogger: thread (ID: 4) suspended.
WeaverThreadLogger: thread (ID: 3) suspended.
WeaverThreadLogger: thread (ID: 2) suspended.
QObject::disconnect: No such slot KMComposeWin::slotContinueAutoSave(bool)
QObject::disconnect:  (sender name:   'kmail-composer#1')
QObject::disconnect:  (receiver name: 'kmail-composer#1')
QObject::disconnect: No such slot KMComposeWin::slotContinueAutoSave(bool)
QObject::disconnect:  (sender name:   'kmail-composer#1')
QObject::disconnect:  (receiver name: 'kmail-composer#1')
ASSERT: "!mMailCheckProgressItem" in popaccount.cpp (403)
ASSERT: "!mMailCheckProgressItem" in popaccount.cpp (403)
ASSERT: "!mMailCheckProgressItem" in popaccount.cpp (403)
ASSERT: "!mMailCheckProgressItem" in popaccount.cpp (403)
kmail: dwstring.cpp:356: DwString::DwString(const char*, size_t): Zusicherung »aBuf != 0« nicht erfüllt.
*** KMail got signal 6 (Crashing)
KCrash: Application 'kmail' crashing...
 
Comment 7 Ismail Donmez 2007-09-03 04:08:29 UTC
This is also happening with 3.5 branch now due to enterprise merge.
Comment 8 S. Burmeister 2007-09-03 08:17:06 UTC
Another issue is that kmail shows "LIST operation could not be terminated.", which it never did for that account before.
Comment 9 Will Stephenson 2007-09-03 10:25:26 UTC
I've checked commits 700060 and 705225, which touched kmail's pop, neither of them do anything obviously wrong, going to check the rest of the enterprise merge commits recently now.
Comment 10 Martín Lucas Golini 2007-09-03 20:10:48 UTC
Have the same problem here. And i receive the new mails in bad format, example:

No Subject:

 Date: 
 From: 
 To: 
 
1 GmailId114c9a0cf5bdb29a
And the date is 1969-12-31 20:59

I receive all new mails with this format, my KMail version is 1.9.6 enterprise.0.20070831.70692 on openSUSE 10.2
Comment 11 Thomas McGuire 2007-09-03 20:13:47 UTC
I guess all the following bugs are related, and are recently introduced in the enterprise and 3.5 branch: 
bug 149334
bug 149413 
bug 149477 
bug 149492 
bug 149493 
bug 149500 
 
Comment 12 Tristan Miller 2007-09-03 23:22:39 UTC
I expect my Bug 149525 is related as well.
Comment 13 G. Landini 2007-09-04 11:16:27 UTC
This bug was introduced in opensuse linux with:

kdepim3 3.5.7.enterprise.0.20070831.706868-15.2@i586
the update I tried today:
kdepim3 3.5.7.enterprise.0.20070831.706868-18.1@i586
still has this bug.

It happens in manual and automatic checks.

Interestingly I only get the problem when downloading from only one of my mail accounts (a sun computer), but not from other ISPs (no idea what servers they use).

The only solution to read my mail is to log into that server machine, then run pine (which opens the mailbox as read only and gives the pid of the process), get out of pine, kill the process, then the account is unlocked and I can access it again (with pine).
Comment 14 Thomas McGuire 2007-09-04 23:17:00 UTC
Please try 3.5.7.enterprise.0.20070904.708281-3.1 or higher, it should be fixed there.
Comment 15 Luka Renko 2007-09-05 09:18:24 UTC
In Kubuntu Gutsy, try kdepim 3.5.7enterprise20070904-0ubuntu1 which should fix the problem.
Comment 16 Thomas McGuire 2007-09-05 16:03:17 UTC
This should be fixed now in the enterprise branch and the 3.5 branch. If you can still reproduce with the newest versions, please reopen.

*** This bug has been marked as a duplicate of 149477 ***