Bug 149413 - Fetching emails with POP3 is a noop
Summary: Fetching emails with POP3 is a noop
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: pop3 (show other bugs)
Version: enterprise
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-31 11:35 UTC by Friedrich W. H. Kossebau
Modified: 2008-07-17 17:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Friedrich W. H. Kossebau 2007-08-31 11:35:44 UTC
Version:           enterprise (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs

Commanding KMail to look for new emails (from my POP3 accounts) results in no reaction. Before upgrading from an older (>1 month) openSUSE package things worked alright. In the status bar is a new symbol with the tooltip "The desktop is offline" even if KNetworkManager shows a different state. I have no problem sending by SMTP at the same time.

See also my blogmoaning http://frinring.wordpress.com/2007/08/30/wanted-older-packages-of-kdepim-357-for-opensuse-102/
Comment 1 Thomas McGuire 2007-08-31 17:15:58 UTC
This is probably a broken Suse modification for KMail related to networkmanager. I don't think it happens with the normal KMail. Added Will to the CC list, maybe he knows more.
Comment 2 Will Stephenson 2007-08-31 18:30:18 UTC
POP3 works fine here. Make sure you have the _next_ set of build service RPMs (the ones i have just submitted, so be patient for them to build)

Make sure all your kdelibs3 and kdepim3 packages are correctly installed (rpm -V them) and make sure you logged out and back in after upgrading your KDE. 

If there are no problems there, what is the output of 'dcop kded networkstatus status'?  

If that is 6, are you online using dialup when this happens?  If so try stopping knetworkmanager when you go online using dialup or setting kinternet to control network status on connect.

Comment 3 Will Stephenson 2007-09-01 13:47:28 UTC
Updated packages are in the KDE:KDE3 repo now.
Comment 4 Friedrich W. H. Kossebau 2007-09-01 15:08:10 UTC
Just installed all of the new packages, no change.
$rpm -V kdelibs3
$rpm -V kdepim3
$rpm -q kdelibs3
kdelibs3-3.5.7-74.1
$rpm -q kdepim3
kdepim3-3.5.7.enterprise.0.20070831.706868-15.2

Output of "dcop kded networkstatus status" is
  Not enough arguments (expected 0, got 0).
Did you mean "dcop kded networkstatus status localhost"? That delivers 8.
I am on a LAN behind a DSL router. Both Konqueror and KMail keep on showing the offline symbol. KNetworkManager works fine.
Tried with KInternet with the older packages, did not change anything. What else could I try?
Comment 5 Friedrich W. H. Kossebau 2007-09-01 16:58:39 UTC
"dcop kmail ConnectionManager slotStatusChanged 8" tricked KMail to feel online, at least. The same works with the konquerors instances. Strange enough they don't get triggered if I unplug and replug the network cable. I could monitor by "dcop kded networkstatus status something" that the demon knows about the state, going to 6, then 7 and finally 8 again. But both KMail and the Konqueror instances ignore that.

Looking at connectionmanager.cpp in both 3.5 and enterprise branch I also see ConnectionManager::updateStatus() is a noop. And

NetworkStatus::EnumStatus ConnectionManager::status( const QString & host )
{
        if ( d->m_state == Inactive )
                return NetworkStatus::NoNetworks;
        else
                return NetworkStatus::Offline;
}

looks strange to me, too. Should the last line not query the networkstatus demon?

Then there is still the detail that "status" asked for arguments. Bille said on IRC that "kdelibs3-3.5.7-64.1 (10.2)" doesn't do that, like it is supposed to do. Perhaps kdelibs is borked in recent versions? See also the number 0 in the message "Not enough arguments (expected 0, got 0)"!
Comment 6 Thomas McGuire 2007-09-03 19:35:20 UTC
I guess all the following bugs are related, and are recently introduced in the enterprise and 3.5 branch:
bug 149413
bug 149477
bug 149492
bug 149493
bug 149500
Comment 7 René Krell 2007-09-04 14:23:32 UTC
I can confirm that bug for the SuSE Factory 10.3 (upcoming Beta3). With the update to the following packages
- kdelibs3-3.5.7-56
- kdebase3-3.5.7-66
I switched on fetching mails on startup. On trying to fetch mails manually I get a messagebox:
  Could not login to _server_. The password may be wrong.
  The Server said: "Mailbox '_username_' is busy".
Within a few minutes I got 55 processes kio_pop3, which grows further. This slows down system extremeley and makes it unusable. New mails are only fetched after startup, after that POP3 fetching is locked up.
Furthermore, Kontact with KMail crashes now quite regularly and makes other weird things like marking existing messages with a valid subject in the message list panel temporarily as 'No subject', says something about a locked archive by a second instance on shutdown and similar things.

Comment 8 Will Stephenson 2007-09-05 10:59:20 UTC
Fixed in the buildservice packages
Comment 9 linux 2008-07-14 17:32:12 UTC
in opensuse 11.0 kmail 1.9.9 using KDE 3.5.9 release 49.1

The same as in the first comment here occurs to me.
Nevertheless under root and a only one user it doesn't occur.
For the main user and newly created users (for testing purposes), it is simply impossible to get the Emails (pop).
SMTP is OK.
Under Yast networkmanager is not set but well ifup. Nevertheless changing that setting changes nothing.
The problem came when upgrading from opensuse 10.2 to 11.0.
Guess it is an user configuration file problem but which ? Tried to compare files between main user and the one which works correctly but hopeless.
And getting the mails under root is not really secure nor optimal, ... and changing from user to root and vice-versa every ten minutes is very lastening.
Nota : the user which works and the one main which doesn't both have multi-pop accounts.
Comment 10 linux 2008-07-17 17:18:56 UTC
Could You please reopen for opensuse 11.0, kmail 1.9.9 KDE 3.5.9