Bug 149432 - consume too much hard disc
Summary: consume too much hard disc
Status: RESOLVED DUPLICATE of bug 149477
Alias: None
Product: kmail
Classification: Applications
Component: pop3 (show other bugs)
Version: 1.9.6
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-31 17:56 UTC by Manuel Kaufmann
Modified: 2007-09-05 15:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Konsole output of kio_pop3 processes (315.90 KB, image/jpeg)
2007-09-04 15:08 UTC, vonbirn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Kaufmann 2007-08-31 17:56:36 UTC
Version:           1.9.6 (using KDE KDE 3.5.7)
Installed from:    Ubuntu Packages

When I start Kmail it consume all hard disc and not allow me use pc. It open too much "kio_pop3" process.
Comment 1 Thomas McGuire 2007-09-01 16:20:59 UTC
Please explain a bit more.

What exact KMail version are you using (from the Help->About KMail menu)?

>When I start Kmail it consume all hard disc
What do you mean? Does KMail fill the hard disk with files?

>It open too much "kio_pop3" process.
How many POP3 accounts do you have?
Comment 2 vonbirn 2007-09-04 11:47:31 UTC
I have the same issue. KMail opens up new kio_pop3 processes but doesn't close the old ones. That consumes all the RAM (1 GB) and all the swap space (500 MB). I have 6 accounts and I'm using KMail 1.9.6 Enterprise version.

When I quit KMail all kio_pop3 processes are terminated, too. And that frees a lot of RAM/Swap. But the issue returns when I start KMail again.

Killing kio_pop3 processes manually helps , too, but is not a real alternative.
Comment 3 Manuel Kaufmann 2007-09-04 14:03:44 UTC
>Please explain a bit more.
I don't speak english

>What exact KMail version are you using (from the Help->About KMail menu)?
1.9.6

>>When I start Kmail it consume all hard disc
>What do you mean? Does KMail fill the hard disk with files?
No, the red light blink (hard disk).

>>It open too much "kio_pop3" process.
>How many POP3 accounts do you have? 
Only one
Comment 4 René Krell 2007-09-04 14:29:38 UTC
I can confirm that bug for the SuSE Factory 10.3 (upcoming Beta3). With the update to the following packages 
 - kdelibs3-3.5.7-56 
 - kdebase3-3.5.7-66 
the problem was introduced on my system, too.
 I switched on fetching mails on startup. On trying to fetch mails manually I get a messagebox: 
   Could not login to _server_. The password may be wrong. 
   The Server said: "Mailbox '_username_' is busy". 
 Within a few minutes I got 55 processes kio_pop3, which grows further. This slows down system extremeley and makes it unusable. New mails are only fetched after startup, after that POP3 fetching is locked up. 
 Furthermore, Kontact with KMail crashes now quite regularly and makes other weird things like marking existing messages with a valid subject in the message list panel temporarily as 'No subject', says something about a locked archive by a second instance on shutdown and similar things.
Comment 5 vonbirn 2007-09-04 15:08:09 UTC
Created attachment 21547 [details]
Konsole output of kio_pop3 processes
Comment 6 vonbirn 2007-09-04 15:10:40 UTC
I forgot to mention, that I use OpenSuSE 10.1, KDE 3.5.7 Release 74.2. 
Comment 7 Thomas McGuire 2007-09-05 15:26:26 UTC
This should be fixed in the enterprise and in the 3.5 branch. If this still happens with the newest version, please reopen.

*** This bug has been marked as a duplicate of 149477 ***