Bug 149493 - pop lock busy; impossible fetching mails from popserver
Summary: pop lock busy; impossible fetching mails from popserver
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-02 21:05 UTC by Helga Fischer
Modified: 2007-09-05 12:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
crashreport for kmail until fetching mails (3.79 KB, text/plain)
2007-09-03 12:11 UTC, Helga Fischer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Helga Fischer 2007-09-02 21:05:30 UTC
Version:           kmail 1.9.6 (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs
Compiler:          4.1.2 20061115 (prerelease) (SUSE Linux) 
OS:                Linux

Hello Developers,

It's impossible to fetch mails from a few of my popservers - important: my account at gmx. Sometimes it works, for example after a 'shutdown' of KDE via ctrl-alt-backspace. The Server says »Servermeldung: "[IN-USE] /var/mail/.username.pop lock busy! Is another session active? (11)"«. I am sure, that my configuration is OK, I didn't change it, they work for a long time without errors.
I fetch my mail not automaticly.
The problem appeared after the last complete update of kde this weekend from a install-source for opensuse-rpms (10.2).
kmail runs standalone.
I can reproduce the errors by a next try to fetch my mails.
Shutdown and start again KDE seems to repair the problems for one session of fetching mails.
Not all popservers are affected. I cannot repeat this effect for every run to fetch mails.


Helga Fischer
Comment 1 Helga Fischer 2007-09-03 12:11:29 UTC
Created attachment 21537 [details]
crashreport for kmail until fetching mails

Hello Developers,

Unfortunatly there are no rules for missing success fetching the mails. Killing
all kio_pops has no effect.

Fetching mails from an arcor.de-Account is successful for every time. For
eschkitai.de (hosteurope.de) and gmx.de there does it not work. Exceptionally
the first one after the system was rebootet.

The problem is discussed in the opensuse-de-mailinglist. Other users have no
problems with fetching their mail from a gmx-account.


Helga
Comment 2 Helga Fischer 2007-09-03 14:39:36 UTC
I forgot: If it can help - I'm able to get the logs of two mailserver, from which kmail cannot fetch the mails.


hfischer
Comment 3 Harald Huthmann 2007-09-03 18:11:38 UTC
1. Kmail is running an the error "[IN-USE] Unable to lock maildrop" appears:

ps -ef | grep kmail
harald    4994     1  0 17:26 ?        00:00:02 kmail -caption KMail -icon kmail -miniicon kmail
ps -ef | grep kio_pop3
harald    5009  4246  0 17:26 ?        00:00:00 kio_pop3 [kdeinit] pop3 /home/harald/.kde/
[... a lot mohre kio_pop3 proceses]
lsof -i
kio_pop3 5321 harald    6u  IPv4  19804       TCP p50824C9D.dip.t-dialin.net:panja-axbnet->194.25.134.24:pop3 (ESTABLISHED)

2. I terminate kamil

ps -ef | grep kmail
harald    4994     1  0 17:26 ?        00:00:02 kmail -caption KMail -icon kmail -miniicon kmail
lso -i
kio_pop3 5321 harald    6u  IPv4  19804       TCP p50824C9D.dip.t-dialin.net:panja-axbnet->194.25.134.24:pop3 (ESTABLISHED)
harald    5009  4246  0 17:26 ?        00:00:00 kio_pop3 [kdeinit] pop3 /home/harald/.kde/socket-k
(...same list as above)

killall kmail
lsof -i
/*nothing*/
after three minuts
ps -ef | grep kio_pop3
/*nothing*/
Then i restart Kmail an it works again for a while...
Comment 4 Thomas McGuire 2007-09-03 19:35:48 UTC
I guess all the following bugs are related, and are recently introduced in the enterprise and 3.5 branch:
bug 149413
bug 149477
bug 149492
bug 149493
bug 149500
Comment 5 Helga Fischer 2007-09-05 12:53:02 UTC
Since the last update (the second on thuesday, 09.03.) kmail now works fine.

Thank You for the quick update,
Helga Fischer