Bug 149492 - Kmail crashes frequently and fails to download mail from server. It takes also ages to contact the server.
Summary: Kmail crashes frequently and fails to download mail from server. It takes als...
Status: RESOLVED DUPLICATE of bug 149477
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-02 20:36 UTC by Derk
Modified: 2007-09-05 15:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Derk 2007-09-02 20:36:58 UTC
Version:           Kmail 1.9.6 (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs
OS:                Linux

As I said above: since I upgraded KDE on sept.1 , Kmail crashes frequently and fails to download mail from the server. I can see there's mail, but it's just not downloaded. Furthermore, when I close Kmail and restart, no password is asked!

Derk
Comment 1 Bram Schoenmakers 2007-09-02 20:58:07 UTC
Please post a backtrace of the crashes. Read http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports for more info.
Comment 2 Derk 2007-09-03 10:52:39 UTC
Error:
"Het proces voor het protocol pop3://mail.etc stopte onverwacht".

Bugreport kmail:

Systeemconfiguratie opstartcontrole uitgeschakeld.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1249761056 (LWP 19920)]
[New Thread -1279886448 (LWP 19983)]
[New Thread -1271493744 (LWP 19982)]
[New Thread -1263101040 (LWP 19981)]
[New Thread -1254708336 (LWP 19980)]
[KCrash handler]
#9  0xb753b599 in QString::QString () from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0xb6229b1e in KIO::Scheduler::_assignJobToSlave ()
   from /opt/kde3/lib/libkio.so.4
#11 0xb7c80592 in KMail::PopAccount::connectJob ()
   from /opt/kde3/lib/libkmailprivate.so
#12 0xb7c84c7f in KMail::PopAccount::slotJobFinished ()
   from /opt/kde3/lib/libkmailprivate.so
#13 0xb7c86b49 in KMail::PopAccount::slotResult ()
   from /opt/kde3/lib/libkmailprivate.so
#14 0xb7c86e06 in KMail::PopAccount::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#15 0xb7269bad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0xb61eeefe in KIO::Job::result () from /opt/kde3/lib/libkio.so.4
#17 0xb622d75d in KIO::Job::emitResult () from /opt/kde3/lib/libkio.so.4
#18 0xb624c45e in KIO::SimpleJob::slotFinished ()
   from /opt/kde3/lib/libkio.so.4
#19 0xb624cb7d in KIO::TransferJob::slotFinished ()
   from /opt/kde3/lib/libkio.so.4
#20 0xb622d38a in KIO::TransferJob::qt_invoke () from /opt/kde3/lib/libkio.so.4
#21 0xb7269bad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb726a7ed in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0xb61e76dc in KIO::SlaveInterface::finished ()
   from /opt/kde3/lib/libkio.so.4
#24 0xb6257440 in KIO::SlaveInterface::dispatch ()
   from /opt/kde3/lib/libkio.so.4
#25 0xb624245a in KIO::SlaveInterface::dispatch ()
   from /opt/kde3/lib/libkio.so.4
#26 0xb61fb51c in KIO::Slave::gotInput () from /opt/kde3/lib/libkio.so.4
#27 0xb6239f90 in KIO::Slave::qt_invoke () from /opt/kde3/lib/libkio.so.4
#28 0xb7269bad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb726a6f2 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb75a5540 in QSocketNotifier::activated ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb7287de0 in QSocketNotifier::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0xb720a657 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb720b421 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb78b85a2 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#35 0xb71ff001 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb71b9424 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0xb7221480 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0xb720a17f in QApplication::enter_loop ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#39 0xb73f0a45 in QDialog::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0xb6028139 in KMessageBox::createKMessageBox ()
   from /opt/kde3/lib/libkdeui.so.4
#41 0xb6028887 in KMessageBox::createKMessageBox ()
   from /opt/kde3/lib/libkdeui.so.4
#42 0xb602aa32 in KMessageBox::errorListWId () from /opt/kde3/lib/libkdeui.so.4
#43 0xb602abf3 in KMessageBox::error () from /opt/kde3/lib/libkdeui.so.4
#44 0xb7c816f6 in KMail::PopAccount::slotSlaveError ()
   from /opt/kde3/lib/libkmailprivate.so
#45 0xb7c86e6f in KMail::PopAccount::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#46 0xb7269b11 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#47 0xb61efaeb in KIO::Scheduler::slaveError () from /opt/kde3/lib/libkio.so.4
#48 0xb61efb96 in KIO::Scheduler::slotSlaveError ()
   from /opt/kde3/lib/libkio.so.4
#49 0xb624e640 in KIO::Scheduler::qt_invoke () from /opt/kde3/lib/libkio.so.4
#50 0xb7269bad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#51 0xb61f0990 in KIO::SlaveInterface::error () from /opt/kde3/lib/libkio.so.4
#52 0xb61fbaa5 in KIO::Slave::timeout () from /opt/kde3/lib/libkio.so.4
#53 0xb6239f9f in KIO::Slave::qt_invoke () from /opt/kde3/lib/libkio.so.4
#54 0xb7269bad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#55 0xb75a476e in QSignal::signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#56 0xb7285c87 in QSignal::activate () from /usr/lib/qt3/lib/libqt-mt.so.3
#57 0xb728d013 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#58 0xb720a657 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#59 0xb720b421 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#60 0xb78b85a2 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#61 0xb71ff863 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#62 0xb71b94f0 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#63 0xb7221480 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#64 0xb7221316 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#65 0xb720a20f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#66 0x0804a0fb in main ()


And I get SIGGEGV11 Errors.........
Comment 3 Thomas McGuire 2007-09-03 19:31:03 UTC
Are you talking about POP3 or IMAP?
What is the exact version of KMail? Are you using "enterprise" packages?
Comment 4 Thomas McGuire 2007-09-03 19:35:35 UTC
I guess all the following bugs are related, and are recently introduced in the enterprise and 3.5 branch:
bug 149413
bug 149477
bug 149492
bug 149493
bug 149500
Comment 5 Thomas McGuire 2007-09-05 15:20:13 UTC
This should be fixed with newer enterprise packages. Please reopen if you can still reproduce with the newest version.

*** This bug has been marked as a duplicate of 149477 ***