Bug 136232 - Global shortcut for last.fm (skip/love/ban)
Summary: Global shortcut for last.fm (skip/love/ban)
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 1.4.5
Platform: Ubuntu Packages Linux
: NOR wishlist with 80 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 134659 138322 178017 179536 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-24 13:56 UTC by Krisztian Vida
Modified: 2009-10-01 23:49 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Krisztian Vida 2006-10-24 13:56:36 UTC
Version:           1.4.3 (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages
OS:                Linux

Would it be possible to add global shortcut possibilities for last.fm features (skip/love/ban track?)
Comment 1 Bram Schoenmakers 2006-12-05 11:54:24 UTC
*** Bug 138322 has been marked as a duplicate of this bug. ***
Comment 2 Alexandre Oliveira 2007-01-10 22:27:06 UTC
*** Bug 134659 has been marked as a duplicate of this bug. ***
Comment 3 Kevin Funk 2007-02-17 15:08:07 UTC
Seconding this, too.
Comment 4 Chris Peikert 2007-02-25 02:25:45 UTC
Thirding!  Would be a very nice feature.
Comment 5 Sebastian Krämer 2007-03-07 01:56:13 UTC
This is probably closely related to bug #138591 (which proposed a dcop call for the same thing).
Comment 6 Bogdan Gribincea 2007-05-16 15:32:19 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Seb Ruiz 2008-09-08 06:46:55 UTC
Amarok 2 has a global shortcut for loving to last.fm: Love: Meta+L. We haven't added shortcuts for skip and ban, but perhaps we will in the future (so far we decided against it).

Closing bug since it's fixed from our perspective - skip/ban shortcuts are a wontfix currently.
Comment 8 David Nolden 2008-10-18 20:00:24 UTC
Shortcuts for Ban/Skip would be great. What is the objection against it?

If you're worried about too many shortcuts, maybe it would make sense to merge this with the general "rating" system. WIN+5 could equal "loving", WIN+0 could equal banning, WIN+1 would equal skipping or something like that.
Comment 9 Dario Andres 2009-05-17 01:05:07 UTC
*** Bug 178017 has been marked as a duplicate of this bug. ***
Comment 10 Jochen Bauer 2009-08-20 18:09:04 UTC
Whats the Staus here atm? Is there a specific reason why not to implement that? I wonder why, guess it wont be so much amount of work to give that Button a shortcut. Greets
Comment 11 Myriam Schweingruber 2009-08-20 18:17:11 UTC
Jochen, you are welcome to submit a patch, then, but I think we really have so many more important things to implement.
Comment 12 Kevin Funk 2009-10-01 23:16:36 UTC
commit 871dc03e95a6b5d4bb91588b5b9ea3b45e7ad7e7                                                                        
Author: Kevin Funk <krf@electrostorm.net>                                                                              
Date:   Thu Oct 1 23:12:20 2009 +0200                                                                                  

    Make Love/Skip/Ban available in shortcuts configuration dialog.
    BUG: 136232
Comment 13 Kevin Funk 2009-10-01 23:49:22 UTC
*** Bug 179536 has been marked as a duplicate of this bug. ***