Bug 115611 - Merge all folder options into one Properties dialog
Summary: Merge all folder options into one Properties dialog
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: commands and actions (show other bugs)
Version: Git (master)
Platform: Compiled Sources Linux
: NOR wishlist with 76 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 109170 114893 116470 298894 305373 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-11-03 14:28 UTC by Thiago Macieira
Modified: 2013-01-20 17:30 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thiago Macieira 2005-11-03 14:28:22 UTC
Currently KMail folder options are set in several different dialogs, accessed 
by different menus. I'd like to see them merged into one dialog, possibly with 
tabs for the different settings and some Advanced buttons or such. 
 
They are: 
* Properties (RMB -> Properties, Folder -> Properties) 
* Mailing list management (Folder -> Mailing list) 
* Expiry settings (RMB -> Expire) 
* Shortcut (Folder -> Associate shortcut, RMB -> Associate shortcut) 
 
The dialog could also contain the following settings, which should not be 
removed from the Folder menu: 
* Display HTML 
* Load external references 
* Sort messages by thread 
* Thread messages by subject 
 
The reason I ask for this is because every time a folder has to be configured, 
one must go to 3 or 4 different dialogs to accomplish that. With KMail losing 
those settings after a crash, it's really annoying and time-consuming to do so 
for 50 folders every two weeks. 
 
Also, please don't make the Ok button for this new dialog trigger an "Expire 
now" action.
Comment 1 Reinhold Kainhofer 2005-11-03 15:18:36 UTC
Also, for consistency, the "Delete folder" should be re-added to the RMB menu in the folder tree. Everywhere else the delete action is in the RMB menu, just kmail's folder tree doesn't have it. 

Reinhold
Comment 2 Thiago Macieira 2005-11-16 11:17:16 UTC
*** Bug 116470 has been marked as a duplicate of this bug. ***
Comment 3 Carsten Burghardt 2005-12-13 19:57:11 UTC
That sounds a lot like the old properties dialog which we splitted because of 
input from the usability team...
Comment 4 Thiago Macieira 2005-12-14 03:02:48 UTC
It might have made the Properties dialog simpler, but it's made it a lot worse for someone trying to configure the properties on a folder.

As I said, I have now to go to 3 or 4 different dialogs. It gets especially annoying since KMail loses the folder settings after a crash... 3 * 50 folders is a LOT of dialogs to go through.
Comment 5 George Staikos 2005-12-14 03:10:17 UTC
I agree, the new system is horribly confusing.
Comment 6 Marco Gusy 2006-11-16 09:33:29 UTC
I tried to report this on the usability mailing-list:
http://comments.gmane.org/gmane.comp.kde.usability/14947

This is their attitude on the subject
"To be blunt, this is really just noise.  You're not going to get behavior 
reverted that was agreed on by the developers and the usability team by 
bringing it up here.

-Scott"
Comment 7 Thiago Macieira 2006-11-16 09:47:26 UTC
But it has happened before, like the Delete folder entry in the RMB menu, as mentioned in comment #1
Comment 8 Jonathan Marten 2006-11-22 17:45:46 UTC
*** Bug 114893 has been marked as a duplicate of this bug. ***
Comment 9 Thomas McGuire 2007-05-07 17:24:08 UTC
*** Bug 109170 has been marked as a duplicate of this bug. ***
Comment 10 Marco Gusy 2007-09-28 10:27:04 UTC
Looks like Openusability closed the Kmail project (what a pity!). Maybe it's time to make a REAL usability study of the app, and make it work again as it should.
Any volounteers? I lift up my hand!
Comment 11 Maciej Pilichowski 2008-06-28 20:25:57 UTC
For full dialog I opt to merge them into folder properties (as tab) and to _remove_ them from the folder menu, but for single options (see folder menu) I opt to group them in the properties dialog but also to keep them in this menu --> because it is faster to just switch one single option (like assign shortcut, or load external references) and continue working.
Comment 12 Jonathan Marten 2009-02-09 15:29:55 UTC
See http://lists.kde.org/?t=123368147700003&r=1&w=2
and http://reviewboard.kde.org/r/48/

This is still a contentious usability issue, so please comment/vote further on this bug if you would like to see any further action...
Comment 13 Jonathan Marten 2009-02-18 17:56:03 UTC
SVN commit 927964 by marten:

Add a "Maintenance" tab to the folder properties dialogue.  This gives some
information about the folder, its file and index locations and sizes, and the
content and messages.

For mbox folders, the compaction state and a button to do it is here (still
also in the folder context menu).  A folder can be compacted (at the user's
own risk) even if it was previously marked "unsafe".

Other dangerous operations ("Rebuild Index" and "Rebuild IMAP Cache") have
been moved from the context/menubar menus to here.

Moved the "mark_all_as_read" action back to the top of the folder popup menu,
as suggested by aseigo.

Added some hooks (KMFolderDialog::setPage() and KMMainWidget::PropsPage enum)
to embed the other folder properties into this dialogue, if there can ever be
agreement on the usability of this.  So it's not a fix for bug 115611, but it's
a start...

CCBUG:115611


 M  +1 -2      folderdialogacltab.cpp  
 M  +0 -1      folderdialogacltab.h  
 M  +2 -3      folderdialogquotatab.cpp  
 M  +0 -1      folderdialogquotatab.h  
 M  +10 -0     folderstorage.cpp  
 M  +6 -0      folderstorage.h  
 M  +7 -30     folderview.cpp  
 M  +0 -6      folderview.h  
 M  +1 -1      identitydialog.cpp  
 M  +2 -5      kmail_part.rc  
 M  +302 -16   kmfolderdialog.cpp  
 M  +56 -4     kmfolderdialog.h  
 M  +20 -10    kmmainwidget.cpp  
 M  +14 -1     kmmainwidget.h  
 M  +2 -5      kmmainwin.rc  


WebSVN link: http://websvn.kde.org/?view=rev&revision=927964
Comment 14 Jonathan Marten 2012-04-27 12:06:41 UTC
*** Bug 298894 has been marked as a duplicate of this bug. ***
Comment 15 Graeme Hewson 2012-04-27 12:26:01 UTC
I would like to see Expiry Properties merged into Folder Properties, as I explained in duplicate bug 298894. Having it separate is confusing, which *reduces* usability.
Comment 16 Myriam Schweingruber 2012-08-18 08:06:08 UTC
Thank you for your feature request. Kmail1 is currently unmaintained so we are closing all wishes. Please feel free to reopen a feature request for Kmail2 if it has not already been implemented.
Thank you for your understanding.
Comment 17 Jonathan Marten 2012-08-18 13:38:22 UTC
Reopening because still relevant to KMail2.
Product and version updated.
Comment 18 Jonathan Marten 2012-09-27 10:51:40 UTC
*** Bug 305373 has been marked as a duplicate of this bug. ***
Comment 19 Jonathan Marten 2012-11-21 16:49:24 UTC
Git commit d651859dbd410da40d2dd53d6156fa721839af0b by Jonathan Marten.
Committed on 21/11/2012 at 17:10.
Pushed by marten into branch 'master'.

Embed "Mailing List Management" into "Folder Properties"

The original action (in the "Folder" menu bar menu) remains
present, it opens the "Folder Properties" dialogue at the
appropriate tab.

This requires commit ea9a9a132e09d2ac1bd359bcccf68cdde3b3c566
to kdepimlibs.
REVIEW:107341

M  +1    -1    kmail/CMakeLists.txt
R  +108  -130  kmail/collectionmailinglistpage.cpp [from: kmail/mailinglistpropertiesdialog.cpp - 058% similarity]
A  +91   -0    kmail/collectionmailinglistpage.h     [License: GPL (v2)]
M  +23   -8    kmail/kmmainwidget.cpp
M  +2    -0    kmail/kmmainwidget.h
D  +0    -86   kmail/mailinglistpropertiesdialog.h

http://commits.kde.org/kdepim/d651859dbd410da40d2dd53d6156fa721839af0b
Comment 20 Jonathan Marten 2013-01-18 14:28:45 UTC
Git commit e1d9e4cde408fdcf7387b9f980c068d4d9e1e724 by Jonathan Marten.
Committed on 18/01/2013 at 15:27.
Pushed by marten into branch 'master'.

Embed "Assign Shortcut" into "Folder Properties"

The original actions (in the "Folder" menu bar menu and folder
list popup) remain present, they open the "Folder Properties"
dialogue at the appropriate tab.
REVIEW:108447

M  +1    -1    kmail/CMakeLists.txt
A  +108  -0    kmail/collectionshortcutpage.cpp     [License: GPL (v2)]
A  +55   -0    kmail/collectionshortcutpage.h     [License: GPL (v2)]
D  +0    -100  kmail/foldershortcutdialog.cpp
D  +0    -77   kmail/foldershortcutdialog.h
M  +4    -7    kmail/kmmainwidget.cpp

http://commits.kde.org/kdepim/e1d9e4cde408fdcf7387b9f980c068d4d9e1e724
Comment 21 Allen Winter 2013-01-18 17:36:07 UTC
Jonathan, can we resolve this one now?
Comment 22 Jonathan Marten 2013-01-18 19:34:40 UTC
One more dialogue to embed (expiry).  Will do that very soon, then the bug can be closed...
Comment 23 Jonathan Marten 2013-01-19 17:39:09 UTC
Git commit 8ad83768ca26a6cbded59d5f7714bd0d3e1d0b26 by Jonathan Marten.
Committed on 19/01/2013 at 18:30.
Pushed by marten into branch 'master'.

Embed "Expiry" into "Folder Properties"

The original "Expire" actions (in the "Folder" menu bar menu and
folder list popup) remain present, they open the "Folder Properties"
dialogue at the appropriate tab.

As noted in comments in KMMainWidget::setupActions(), there is
still inconstency between the wording of the action and what it does.

Hooray, a seven year old wish finally implemented!
REVIEW:108485

M  +5    -6    kmail/kmmainwidget.cpp
M  +1    -1    mailcommon/CMakeLists.txt
A  +275  -0    mailcommon/collectionexpirypage.cpp     [License: GPL (v2)]
A  +81   -0    mailcommon/collectionexpirypage.h     [License: GPL (v2)]
D  +0    -244  mailcommon/expirypropertiesdialog.cpp
D  +0    -47   mailcommon/expirypropertiesdialog.h

http://commits.kde.org/kdepim/8ad83768ca26a6cbded59d5f7714bd0d3e1d0b26
Comment 24 Graeme Hewson 2013-01-19 17:59:17 UTC
> Hooray, a seven year old wish finally implemented!

Congratulations!

Are you considering removing the old menu items in a future release? It might be confusing having duplicate items. I think I'd be confused.
Comment 25 Laurent Montel 2013-01-20 16:41:53 UTC
(In reply to comment #24)
> > Hooray, a seven year old wish finally implemented!
> 
> Congratulations!
> 
> Are you considering removing the old menu items in a future release? It
> might be confusing having duplicate items. I think I'd be confused.

No we will not remove them.
Regards
Comment 26 Jonathan Marten 2013-01-20 17:20:50 UTC
You could remove them per-user or locally, though, by editing the rc file - and we could maybe convert the context menu to an XMLGUI container so that it can be modified in the same way.
Comment 27 Jonathan Marten 2013-01-20 17:30:35 UTC
Correction - it already is.  So just edit the kmmainwin.rc file.