Bug 330054

Summary: Actualizacion de software
Product: muon Reporter: Esteban Sánchez <steskings>
Component: discoverAssignee: Jonathan Thomas <echidnaman>
Status: RESOLVED DUPLICATE    
Severity: crash CC: aleixpol, sitter
Priority: NOR Keywords: drkonqi
Version: 2.1.2   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Esteban Sánchez 2014-01-17 00:17:41 UTC
Application: muon-discover (2.1.2)
KDE Platform Version: 4.11.3
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed: Realizando la actualizacion del software instalado, ha ocurrido dos veces.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Muon Discover (muon-discover), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6da3bb97c0 (LWP 6816))]

Thread 5 (Thread 0x7f6d88fc4700 (LWP 6817)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f6d9d3a506b in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f6d9d3a50a9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f6d99568f6e in start_thread (arg=0x7f6d88fc4700) at pthread_create.c:311
#4  0x00007f6da088d9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7f6d07bb1700 (LWP 6818)):
#0  0x00007f6da0880f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6d990906a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6d990907ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6da1006a76 in QEventDispatcherGlib::processEvents (this=0x7f6d000008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f6da0fd85ef in QEventLoop::processEvents (this=this@entry=0x7f6d07bb0d70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6da0fd88e5 in QEventLoop::exec (this=this@entry=0x7f6d07bb0d70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f6da0ed788f in QThread::exec (this=this@entry=0x21c6b30) at thread/qthread.cpp:542
#7  0x00007f6da0fb9d13 in QInotifyFileSystemWatcherEngine::run (this=0x21c6b30) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f6da0ed9f2f in QThreadPrivate::start (arg=0x21c6b30) at thread/qthread_unix.cpp:338
#9  0x00007f6d99568f6e in start_thread (arg=0x7f6d07bb1700) at pthread_create.c:311
#10 0x00007f6da088d9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f6d064a2700 (LWP 6819)):
#0  0x00007f6da0880f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6d990906a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6d990907ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6da1006a76 in QEventDispatcherGlib::processEvents (this=0x7f6cf40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f6da0fd85ef in QEventLoop::processEvents (this=this@entry=0x7f6d064a1db0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6da0fd88e5 in QEventLoop::exec (this=this@entry=0x7f6d064a1db0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f6da0ed788f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007f6da0ed9f2f in QThreadPrivate::start (arg=0x2255070) at thread/qthread_unix.cpp:338
#8  0x00007f6d99568f6e in start_thread (arg=0x7f6d064a2700) at pthread_create.c:311
#9  0x00007f6da088d9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f6d04fea700 (LWP 6820)):
#0  0x00007f6da0880f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6d990906a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6d990907ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6da1006a76 in QEventDispatcherGlib::processEvents (this=0x7f6cec0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f6da0fd85ef in QEventLoop::processEvents (this=this@entry=0x7f6d04fe9db0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6da0fd88e5 in QEventLoop::exec (this=this@entry=0x7f6d04fe9db0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f6da0ed788f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007f6da0ed9f2f in QThreadPrivate::start (arg=0x25e49f0) at thread/qthread_unix.cpp:338
#8  0x00007f6d99568f6e in start_thread (arg=0x7f6d04fea700) at pthread_create.c:311
#9  0x00007f6da088d9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f6da3bb97c0 (LWP 6816)):
[KCrash Handler]
#6  0x00007f6da07c9f77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007f6da07cd5e8 in __GI_abort () at abort.c:90
#8  0x00007f6da0ecf912 in qt_message_output (msgType=msgType@entry=QtFatalMsg, buf=0x51bc5c8 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 469") at global/qglobal.cpp:2347
#9  0x00007f6da0ecfc79 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0x7f6da103aaa8 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=ap@entry=0x7fff7d25cff8) at global/qglobal.cpp:2393
#10 0x00007f6da0ed0484 in qFatal (msg=msg@entry=0x7f6da103aaa8 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2576
#11 0x00007f6da0ed04ea in qt_assert_x (where=where@entry=0x7f6cfa3690ac "QList<T>::at", what=what@entry=0x7f6cfa36908a "index out of range", file=file@entry=0x7f6cfa368f70 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2029
#12 0x00007f6cfa33805a in at (i=67204, this=0x2d1b328) at /usr/include/qt4/QtCore/qlist.h:469
#13 QApt::Backend::stateChanges (this=<optimized out>, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
#14 0x00007f6cf879efb4 in ApplicationUpdates::calculateUpdates (this=this@entry=0x2d1b2f0) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:448
#15 0x00007f6cf879f608 in ApplicationUpdates::fetchingChanged (this=0x2d1b2f0) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:441
#16 0x00007f6da0feda58 in QMetaObject::activate (sender=sender@entry=0x2d0ec50, m=m@entry=0x7f6da39e5180 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#17 0x00007f6da37bf040 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0x2d0ec50) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#18 0x00007f6cf8790e33 in ApplicationBackend::setFetching (this=0x2d0ec50, f=<optimized out>) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:642
#19 0x00007f6cf8793463 in ApplicationBackend::reload (this=0x2d0ec50) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#20 0x00007f6cf879e0f4 in ApplicationUpdates::transactionFinished (this=0x2d1b2f0) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#21 0x00007f6da0feda58 in QMetaObject::activate (sender=0x26f5aa0, m=m@entry=0x7f6cfa57a9c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7fff7d25d540) at kernel/qobject.cpp:3539
#22 0x00007f6cfa365441 in QApt::Transaction::finished (this=<optimized out>, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:338
#23 0x00007f6cfa3581af in QApt::Transaction::updateProperty (this=0x26f5aa0, type=6816, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#24 0x00007f6cfa365974 in QApt::Transaction::qt_static_metacall (_o=0x26f5aa0, _c=<optimized out>, _id=<optimized out>, _a=0x7fff7d25d760) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#25 0x00007f6da0feda58 in QMetaObject::activate (sender=sender@entry=0x2b4f9e0, m=m@entry=0x7f6cfa57aaa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff7d25d760) at kernel/qobject.cpp:3539
#26 0x00007f6cfa3663d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x2b4f9e0, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#27 0x00007f6cfa36677c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x2b4f9e0, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7fff7d25da20) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#28 0x00007f6cfa3670f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x2b4f9e0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff7d25da20) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#29 0x00007f6d9fd88e36 in QDBusConnectionPrivate::deliverCall (this=0x2b54940, object=0x2b4f9e0, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#30 0x00007f6da0ff1dce in QObject::event (this=0x2b4f9e0, e=<optimized out>) at kernel/qobject.cpp:1194
#31 0x00007f6da19cadfc in QApplicationPrivate::notify_helper (this=this@entry=0x20a5810, receiver=receiver@entry=0x2b4f9e0, e=e@entry=0x3cec3a0) at kernel/qapplication.cpp:4567
#32 0x00007f6da19d1470 in QApplication::notify (this=this@entry=0x7fff7d25e1c0, receiver=receiver@entry=0x2b4f9e0, e=e@entry=0x3cec3a0) at kernel/qapplication.cpp:4353
#33 0x00007f6da26d4a6a in KApplication::notify (this=0x7fff7d25e1c0, receiver=0x2b4f9e0, event=0x3cec3a0) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x00007f6da0fd98bd in QCoreApplication::notifyInternal (this=0x7fff7d25e1c0, receiver=receiver@entry=0x2b4f9e0, event=event@entry=0x3cec3a0) at kernel/qcoreapplication.cpp:946
#35 0x00007f6da0fdce1f in sendEvent (event=0x3cec3a0, receiver=0x2b4f9e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x205a1f0) at kernel/qcoreapplication.cpp:1570
#37 0x00007f6da0fdd2c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#38 0x00007f6da1007073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 postEventSourceDispatch (s=0x20a6ca0) at kernel/qeventdispatcher_glib.cpp:279
#40 0x00007f6d990903b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f6d99090708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007f6d990907ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007f6da1006a55 in QEventDispatcherGlib::processEvents (this=0x205bad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0x00007f6da1a6c9d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007f6da0fd85ef in QEventLoop::processEvents (this=this@entry=0x7fff7d25e0d0, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007f6da0fd88e5 in QEventLoop::exec (this=this@entry=0x7fff7d25e0d0, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007f6da0fdde5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#48 0x00007f6da19c934c in QApplication::exec () at kernel/qapplication.cpp:3828
#49 0x000000000040b4dc in main (argc=1, argv=0x7fff7d25e318) at /build/buildd/muon-2.1.2/discover/main.cpp:86

Possible duplicates by query: bug 329935, bug 329528, bug 328995, bug 328347, bug 327912.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-17 01:53:47 UTC

*** This bug has been marked as a duplicate of bug 325109 ***