Bug 291443

Summary: Deleting a folder on nfs-volume
Product: [Frameworks and Libraries] kio Reporter: matalla <matalla>
Component: generalAssignee: Peter Penz <peter.penz19>
Status: RESOLVED DUPLICATE    
Severity: crash CC: frank78ac
Priority: NOR    
Version: 4.6   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description matalla 2012-01-13 13:28:55 UTC
Application: dolphin (1.6)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.9-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I deleted a folder on a nfs-volume. Few minutes later, while writing a e-mail, dolphin crashed.

-- Backtrace:
Application: Dolphin (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe0d928d760 (LWP 3684))]

Thread 2 (Thread 0x7fe0bf98d700 (LWP 3686)):
#0  0xffffffffff600177 in ?? ()
#1  0x00007fff38a317a1 in ?? ()
#2  0x00007fe0d3aaf2b3 in clock_gettime () from /lib64/librt.so.1
#3  0x00007fe0d7ebd2b2 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007fe0d7f8031d in QTimerInfoList::updateCurrentTime (this=0x8b73a0) at kernel/qeventdispatcher_unix.cpp:339
#6  0x00007fe0d7f80695 in QTimerInfoList::timerWait (this=0x8b73a0, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#7  0x00007fe0d7f7f15c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7fe0bf98cb8c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007fe0d7f7f205 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007fe0d37fe087 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#10 0x00007fe0d37fefa9 in ?? () from /lib64/libglib-2.0.so.0
#11 0x00007fe0d37ff650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#12 0x00007fe0d7f7f956 in QEventDispatcherGlib::processEvents (this=0x801bd0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#13 0x00007fe0d7f54032 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007fe0d7f54245 in QEventLoop::exec (this=0x7fe0bf98cd20, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007fe0d7e691e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#16 0x00007fe0d7f35948 in QInotifyFileSystemWatcherEngine::run (this=0x8d30e0) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007fe0d7e6ba5e in QThreadPrivate::start (arg=0x8d30e0) at thread/qthread_unix.cpp:285
#18 0x00007fe0cb3ba2da in ?? () from /usr/X11R6/lib64/libGL.so.1
#19 0x00007fe0d7bdca3f in start_thread () from /lib64/libpthread.so.0
#20 0x00007fe0d699766d in sysctl () from /lib64/libc.so.6
#21 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe0d928d760 (LWP 3684)):
[KCrash Handler]
#7  0x00007fe0d13d0413 in KFileItem::isDir (this=0x9b1840) at /usr/src/debug/kdelibs-4.6.0/kio/kio/kfileitem.cpp:1008
#8  0x00007fe0d148fdf2 in KDirModelPrivate::removeFromNodeHash (this=0x9b1f90, node=<value optimized out>, url=...) at /usr/src/debug/kdelibs-4.6.0/kio/kio/kdirmodel.cpp:204
#9  0x00007fe0d149090d in KDirModelPrivate::_k_slotDeleteItems (this=0x9b1f90, items=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kio/kio/kdirmodel.cpp:494
#10 0x00007fe0d1490ec2 in KDirModel::qt_metacall (this=0x7d8b90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff38a21ab0) at /usr/src/debug/kdelibs-4.6.0/build/kio/kdirmodel.moc:91
#11 0x00007fe0c5c68c60 in DolphinModel::qt_metacall (this=0x7d8b90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff38a21ab0) at /usr/src/debug/kdebase-4.6.0/build/apps/dolphin/src/moc_dolphinmodel.cpp:68
#12 0x00007fe0d7f69dcf in QMetaObject::activate (sender=0x9b1d40, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff38a21ab0) at kernel/qobject.cpp:3272
#13 0x00007fe0d13ce3f5 in KDirLister::itemsDeleted (this=<value optimized out>, _t1=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/build/kio/kdirlister.moc:295
#14 0x00007fe0d144611c in KDirLister::Private::emitItemsDeleted (this=0x9b1e00, _items=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kio/kio/kdirlister.cpp:2438
#15 0x00007fe0d1488c36 in KDirListerCache::itemsDeleted (this=0x8c4610, listers=<value optimized out>, deletedItems=...) at /usr/src/debug/kdelibs-4.6.0/kio/kio/kdirlister.cpp:1786
#16 0x00007fe0d148b292 in KDirListerCache::slotFilesRemoved (this=<value optimized out>, fileList=...) at /usr/src/debug/kdelibs-4.6.0/kio/kio/kdirlister.cpp:837
#17 0x00007fe0d148b594 in KDirListerCache::slotFilesRemoved (this=0x8c4610, fileList=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kio/kio/kdirlister.cpp:792
#18 0x00007fe0d149a3e0 in KDirListerCache::qt_metacall (this=0x8c4610, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff38a21ea0) at /usr/src/debug/kdelibs-4.6.0/build/kio/kdirlister_p.moc:98
#19 0x00007fe0d7f69dcf in QMetaObject::activate (sender=0x7d0410, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff38a21ea0) at kernel/qobject.cpp:3272
#20 0x00007fe0d13ced25 in OrgKdeKDirNotifyInterface::FilesRemoved (this=<value optimized out>, _t1=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/build/kio/kdirnotify.moc:131
#21 0x00007fe0d13cee30 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x7d0410, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff38a22080) at /usr/src/debug/kdelibs-4.6.0/build/kio/kdirnotify.moc:89
#22 0x00007fe0d4da8b68 in QDBusConnectionPrivate::deliverCall (this=0x6dda90, object=0x7d0410, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:919
#23 0x00007fe0d4db3c1f in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#24 0x00007fe0d7f68a4a in QObject::event (this=0x7d0410, e=<value optimized out>) at kernel/qobject.cpp:1211
#25 0x00007fe0d7103d14 in QApplicationPrivate::notify_helper (this=0x6e7140, receiver=0x7d0410, e=0x128c640) at kernel/qapplication.cpp:4445
#26 0x00007fe0d710c22a in QApplication::notify (this=<value optimized out>, receiver=0x7d0410, e=0x128c640) at kernel/qapplication.cpp:4324
#27 0x00007fe0d8bf89e6 in KApplication::notify (this=0x7fff38a22b70, receiver=0x7d0410, event=0x128c640) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#28 0x00007fe0d7f54bdc in QCoreApplication::notifyInternal (this=0x7fff38a22b70, receiver=0x7d0410, event=0x128c640) at kernel/qcoreapplication.cpp:732
#29 0x00007fe0d7f583d5 in sendEvent (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.h:215
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.cpp:1373
#31 0x00007fe0d7f7f763 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#32 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#33 0x00007fe0d37febd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#34 0x00007fe0d37ff3b0 in ?? () from /lib64/libglib-2.0.so.0
#35 0x00007fe0d37ff650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#36 0x00007fe0d7f7f8ff in QEventDispatcherGlib::processEvents (this=0x617ca0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#37 0x00007fe0d71a8d8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#38 0x00007fe0d7f54032 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#39 0x00007fe0d7f54245 in QEventLoop::exec (this=0x7fff38a22ab0, flags=...) at kernel/qeventloop.cpp:201
#40 0x00007fe0d7f5868b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#41 0x00007fe0c661aae5 in kdemain (argc=950152128, argv=0x7fff38a22bb0) at /usr/src/debug/kdebase-4.6.0/apps/dolphin/src/main.cpp:98
#42 0x00000000004075e9 in _start ()

This bug may be a duplicate of or related to bug 226338.

Possible duplicates by query: bug 252261, bug 242155, bug 239929, bug 232710, bug 227848.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2012-01-18 22:20:30 UTC
Thanks for the bug report! This is fixed in KDE 4.6.4 and later.

*** This bug has been marked as a duplicate of bug 196695 ***