Bug 270414

Summary: Rename any file using folderview causes an error message.
Product: [Plasma] plasma4 Reporter: tony <lorefice2>
Component: widget-folderviewAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED FIXED    
Severity: normal CC: adaptee, alessandro.ufms, antares-metal, balcaen.john, brice.brice, chgonzalezg, deckoff, e.lex, giovanni, gsmanuel, h.reindl, housegregory299, kamikazow, kokoko3k, linuxfever, lydia, mail, mattjohn0169, n.schnelle, nitanovidiu, spaz16, vamp898, vprea, wanzeo
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Archlinux   
OS: Linux   
Latest Commit: Version Fixed In:

Description tony 2011-04-08 08:56:38 UTC
Version:           unspecified (using KDE 4.6.2) 
OS:                Linux

When i rename a file using folderview, the file is renamed, but an error is triggered.

Reproducible: Always

Steps to Reproduce:
-place a folderview widget on the desktop
-rename a file from 'oldname' to 'newname'


Actual Results:  
- see the error message: "The file or folder oldname does not exist."
- see that the file has been renamed to 'newname'


Expected Results:  
Don't throw an unuseful error message, it is clear that 'oldname' does not exists anymore.
Comment 1 Nikos Papas 2011-04-09 18:22:21 UTC
I cannot reproduce the error. Using KDE 4.6.2, 64bit, Kubuntu packages.
Comment 2 Vamp898 2011-04-11 13:56:27 UTC
Maybe this one? Bug #218180
Comment 3 tony 2011-04-11 19:25:23 UTC
Seems that some archlinux guys can reproduce it, but i don't think it is a packaging issue.
https://bbs.archlinux.org/viewtopic.php?id=116683
Comment 4 José Manuel 2011-04-14 20:04:10 UTC
I also have this problem in Fedora 14, I don know in which moment it started, but I realized about it after installing KDE 4.6.2. I downgraded to KDE 4.5 but the problem persists.
Comment 5 Sebastian H. 2011-04-15 20:15:43 UTC
I can reproduce this on opensuse 11.4, kde 4.6.2, too
Comment 6 alexander 2011-04-19 17:49:44 UTC
(In reply to comment #5)
> I can reproduce this on opensuse 11.4, kde 4.6.2, too

So can I.
Comment 7 GiorgioP 2011-04-19 22:15:51 UTC
I have this problem on Chakra linux MS5 KDE, 4.6.2
Comment 8 brice rebsamen 2011-05-04 04:53:02 UTC
I am having this problem too
Debian wheezy
KDE 4.4.5
folderview widget version 1.0
Comment 9 Alessandro Nakamuta 2011-05-08 05:57:23 UTC
This is happening to me too.
Comment 10 alexander 2011-05-08 12:23:45 UTC
Kde4.6.3 doesn't fix this bug.
Please fix it!
Comment 11 Nikos Papas 2011-05-11 17:20:33 UTC
I can confirm that this bug now appears to me too, using Kubuntu 11.04, KDE 4.6.3 64-bit.
Comment 12 Alessandro Nakamuta 2011-05-25 19:36:46 UTC
Still reproduce on 4.7 beta 1.
Comment 13 Georg Wittenburg 2011-05-27 12:20:23 UTC
*** This bug has been confirmed by popular vote. ***
Comment 14 Ovidiu D. Niţan 2011-06-12 22:29:22 UTC
Still reproduce on KDE 4.7 beta 1, on Arch Linux
Comment 15 Nikola Schnelle 2011-06-17 23:50:42 UTC
Bug is present in Kubuntu 11.04 KDE 4.6.4
Comment 16 Víctor Prea 2011-07-05 15:57:30 UTC
Same here. Kubuntu 11.04 KDE 4.6.2
Comment 17 alexander 2011-07-05 16:21:51 UTC
openSUSE 11.4, KDE 4.6.5: this bug is not fixed.
Comment 18 Antonio Orefice 2011-07-07 15:51:01 UTC
Just installed 4.6.5 and the issue persists in archlinux too.
Comment 19 Matt 2011-07-15 18:16:03 UTC
I seem to have this bug (running 4.6.5 on Arch Linux).

However, I see two different boxes, with no noticeable pattern as to which appears.

The first, which seems to be what the others on this report experience:
http://i.imgur.com/COIHG.png

And the second:
http://i.imgur.com/4aJE5.png

Notice the different paths to the same file... Or am I barking up the wrong tree?

(This is my first bug report, so if I've violated etiquette please let me know.)
Comment 20 Matt 2011-07-15 19:26:57 UTC
(In reply to comment #19)
> I seem to have this bug (running 4.6.5 on Arch Linux).
> 
> However, I see two different boxes, with no noticeable pattern as to which
> appears.
> ...

Ok, I'm an idiot. I've been unable to reproduce the 2nd dialogue box, so I'll assume I just got myself confused whilst repeatedly renaming files and tried to overwrite another unrelated file.
Sorry for the spam!
Comment 21 Christoph Feck 2011-07-19 14:23:45 UTC
*** Bug 262325 has been marked as a duplicate of this bug. ***
Comment 22 Christoph Feck 2011-07-19 14:25:27 UTC
*** Bug 277188 has been marked as a duplicate of this bug. ***
Comment 23 Matt 2011-07-19 14:43:28 UTC
Turns out I'm not crazy :)
I deleted all the non-hidden files in my desktop folder so I knew I wasn't
overwriting an existing one and voila:
http://i.imgur.com/BbqGX.jpg

I note that there's a hidden file called '.directory', whose contents are as
follows:
http://pastebin.com/Fmsb9D11

If there's anything more useful I can do, please let me know.
Comment 24 Reindl Harald 2011-07-19 14:47:48 UTC
pff 4 major releases and nothing happens :-(
Comment 25 deckoff 2011-07-31 20:08:51 UTC
I can confirm this bug, both 4.6.x and 4.6 , Kubuntu 11.04
Comment 26 alexander 2011-08-01 02:01:41 UTC
openSUSE 11.4, KDE 4.7.0 (stable): this bug is not fixed.
Comment 27 Reindl Harald 2011-08-01 04:38:27 UTC
this is a bug of the catehory "did who wrote it using his piece of code ever?"
i did not imagine that a bugreport would be ncessesary because i get this idiotic message multiple times every day since months and it inditaces a hughe programming error if after the whole operation a access to the old name happens
Comment 28 Reindl Harald 2011-08-21 14:04:56 UTC
KDE 4.7 does not fix this (Fedora 15 kde47-Repo from Rex Dieter)

Can anybody explain what takes half a year to fix such things instead breaking usability permanently with changes like "we do not want a popup by rename because it is more beautiful to have it inline and force users permanently using the cursor keys while rename a longer fiel name and have no way to look at the old name before confirm)
Comment 29 Jekyll Wu 2011-08-21 16:57:31 UTC
Yeah, this problem is easy to reproduce and very annoying. It makes the renaming functionality practically un-usable.

Could some plasma developer take a look at this?
Comment 30 Víctor Prea 2011-08-22 15:03:00 UTC
(In reply to comment #29)
> Yeah, this problem is easy to reproduce and very annoying. It makes the
> renaming functionality practically un-usable.
> 
> Could some plasma developer take a look at this?

Yes, and it gives very poor image about Linux Desktop... I started to getting tired about silly bugs like this one, or loosing desktop effects when change number of monitors; and others not so silly, like my system getting completely slow without reason so I need to restart it.
My idea of running Linux as a desktop was to have a fast, usable and stable system, but I think it has lost that essence.
I have tested Window$7 Pro 64 bit, and it's really stable, and as fast as a Kubuntu 11.04 distro. I have the license on my laptop, but I refuse to use it. I really support free software, but as far as it is don't get me into trouble...
Comment 31 Nikos Papas 2011-08-22 15:38:02 UTC
In reply to comment 30:

I couldn't agree more. I really like KDE and have been my DE choice for many years now, but have to say that sometimes I am really put down by bugs like this. 

I understand how difficult it is to create a DE and I believe we all appreciate the effort of the developers they put into it. Nonetheless, I think it is more important to try and correct/debug whatever is wrong with the current features, rather than developing new ones. In fact, KDE 3.5 had half the features and I would still be quite happy with it today.
Comment 32 wanzeo 2011-09-01 23:27:10 UTC
Me too on this bug. (KDE 4.7.0 with Archlinux)

This is the ONLY thing that is keeping me from switching from GNOME 2 to KDE 4 on my workstation. I simply cannot deal with this annoyance everyday.
Comment 33 Christoph Feck 2011-09-09 10:49:36 UTC
*** Bug 281679 has been marked as a duplicate of this bug. ***
Comment 34 Christoph Feck 2011-09-09 10:52:25 UTC
*** Bug 275492 has been marked as a duplicate of this bug. ***
Comment 35 Christoph Feck 2011-09-09 10:54:38 UTC
*** Bug 281643 has been marked as a duplicate of this bug. ***
Comment 36 Reindl Harald 2011-09-20 19:56:20 UTC
unbelieveable - this f**ing bug is not fixed even in 4.7.1
what the hell is so complicated in renaming a file???????
Comment 37 Jekyll Wu 2011-09-21 08:41:43 UTC
If any plasma develper is watching this bug, I would suggest raising the priority of this bug.

The reason is simple: this apprarent bug damages the reputation of KDE badly, because IIRC several distros put this folderview widget on desktop by default. It is easy to imagine how a new KDE user would think of KDE when he plays around this widget and encounters this annoying and apparent bug.
Comment 38 Antonio Orefice 2011-09-21 08:43:30 UTC
(In reply to comment #37)
> this apprarent bug damages the reputation of KDE badly,
> because IIRC several distros put this folderview widget on desktop by default.
> It is easy to imagine how a new KDE user would think of KDE when he plays
> around this widget and encounters this annoying and apparent bug.

I strongly agree!
Comment 39 Nikos Papas 2011-09-21 08:48:29 UTC
Would a KDE developer perhaps care to comment on what is so difficult about fixing this bug?
Comment 40 Giovanni Venturi 2011-09-21 10:17:34 UTC
Still happen with ArchLinux KDE 4.7.1. I love KDE.
Comment 41 Matt 2011-09-21 11:11:07 UTC
There's a bug report on Launchpad that links to this report, but there's no link back there as far as I can see. I'll paste the URL below.

https://bugs.launchpad.net/kde-baseapps/+bug/792148

It seems that all that is happening as that the widget is responding twice to the pressing of the Enter key- once to confirm the file name change, and once to activate the icon (which presumably happens just after the renaming, causing the 'file not found' error to appear).

If you just click in some blank space in the widget rather than hitting Enter, the renaming works fine.

As such, the description here isn't really accurate. I don't know how to change it though.
Comment 42 alexander 2011-09-21 13:00:27 UTC
> It seems that all that is happening as that the widget is responding twice to
> the pressing of the Enter key- once to confirm the file name change, and once
> to activate the icon (which presumably happens just after the renaming, causing
> the 'file not found' error to appear).
> 
> If you just click in some blank space in the widget rather than hitting Enter,
> the renaming works fine.

Yes, I can confirm.
Comment 43 Aaron J. Seigo 2011-09-21 13:01:12 UTC
Git commit 1a284bb79e547f0789f02b202fa309823e6198b5 by Aaron Seigo.
Committed on 21/09/2011 at 15:00.
Pushed by aseigo into branch 'KDE/4.7'.

only try to change the name once

BUG:270414

M  +2    -3    plasma/applets/folderview/iconview.cpp
M  +12   -5    plasma/applets/folderview/itemeditor.cpp
M  +1    -0    plasma/applets/folderview/itemeditor.h

http://commits.kde.org/kde-baseapps/1a284bb79e547f0789f02b202fa309823e6198b5
Comment 44 Aaron J. Seigo 2011-09-21 13:01:14 UTC
Git commit e36f73c7fc3eca7beb0ebb16664b4c855cdf513e by Aaron Seigo.
Committed on 21/09/2011 at 15:00.
Pushed by aseigo into branch 'master'.

only try to change the name once

BUG:270414

M  +2    -3    plasma/applets/folderview/iconview.cpp
M  +12   -5    plasma/applets/folderview/itemeditor.cpp
M  +1    -0    plasma/applets/folderview/itemeditor.h

http://commits.kde.org/kde-baseapps/e36f73c7fc3eca7beb0ebb16664b4c855cdf513e
Comment 45 Aaron J. Seigo 2011-09-21 13:20:30 UTC
i am glad KDE has so many supportive and constructive users so that the kind of non-constructive rubbish this report eventually inspired is the exception rather than the rule. this unfortunately does not magically undo the damage, intentional or not, that comes from the type of behaviour some chose to engage in here. i urge those people (and i'm sure you know who you are) to think about how they chose to interact with others in the KDE community and consider how to be forces for positive change in the future.

i also invite those who decided to respond non-constructively to send your apologies to the appropriate people. those who volunteer time from their life to work on something that you get in all freedom simply do not need nor deserve that kind of experience. it also does nothing to improve the software itself; instead it makes it even harder to find people willing to work on these things due to the poisonous environment it creates.

now, i fixed this issue so that i could make the above statement without it being derailed by defensive "but this isn't fixed!" retores. i believe everyone deserves at least one chance / warning, but i will not reward similar non-constructive behaviour on other reports.

and, since someone asked: i don't personally use folderview to rename files. furthermore, there isn't anyone who is doing  Q/A bug triage for this component.  we don't have any spare human resources to throw at that either. you are welcome to take on that role, and i'd be happy to help anyone who would like to start contributing in this manner to start doing so in a constructive fashion.

note that i made this fix even though it doesn't do anything for my own enjoyment of the software and even though some of you chose to make my working environment less pleasant. but i care, despite what some of you evidently think, about both the software and our community. and i'm not alone in that. consider that in future, please, before drafting hasty emails that will end up cached indefinitely in our mailing archives with your name on them.
Comment 46 Reindl Harald 2011-09-21 13:30:17 UTC
well i understand that ranting on the mailing-list is not nice

but please try to understand also that from 2011-04-08 on users
are frustrated and even open hundret bugreports widget-folderview
whould not have changed anything since the code was orphaned

orphaned code is dangerous for security and stability and maybe
there should be some automatism to detected maintainers with
no commits for months to have a chance that somebody looks
if and what bugs are open for them 

from one point of view i am sorry about my bad words, from the
other point of view it as right to register on the mailing-list
to prevent frustrating users with 4.7.2, 4.7.3, 4.8.x with the
same old problems
Comment 47 Nikos Papas 2011-09-21 13:32:53 UTC
Thank you Aaron for fixing this. As I said in my previous comment, I am sure we all appreciate the effort of all KDE developers; a few non-constructive comments by some users, I believe, are due to their disappointment of not having their DE as bug-free as possible, and not due to wanting to insult or discourage the developers.
Comment 48 Aaron J. Seigo 2011-09-21 15:06:13 UTC
Git commit 62c198cf9493d6bd686765fb841dc4fdfc87df55 by Aaron Seigo.
Committed on 21/09/2011 at 17:04.
Pushed by aseigo into branch 'KDE/4.7'.

apparently this fix does not belong in the stable branch.

if unsure why, you can ask Reindl Harald <h.reindl@thelounge.net>.

CCBUG:270414

M  +5    -12   plasma/applets/folderview/itemeditor.cpp
M  +0    -1    plasma/applets/folderview/itemeditor.h

http://commits.kde.org/kde-baseapps/62c198cf9493d6bd686765fb841dc4fdfc87df55
Comment 49 Reindl Harald 2011-09-21 15:10:56 UTC
are you really sure that plaing such games is the right way while you on the other side demand a polite tone from frustrated people? take a deep breath and consider if your childish "he did not exactly what i wanted from him and so i revert a long outstanding bugfix" is the right way......
Comment 50 Reindl Harald 2011-09-21 17:29:33 UTC
well, because it helps not that everybody writes mails now 
here the reason: i was not amused about the first reply from 
the mailing-list "why haven't you fixed it"  from Brad Hards
and after his stoopid reply and some not polite one from
me not willing tk kneel in front of aaron seigo enough and
so he decided to fuck the community for personal reasons

-------- Original-Nachricht --------
Betreff: Re: why are bugs ignored over months?
Datum: Wed, 21 Sep 2011 20:17:57 +1000
Von: Brad Hards <bradh@frogmouth.net>
Antwort an: kde-devel@kde.org
An: kde-devel@kde.org

On Wed, 21 Sep 2011 08:11:43 PM Reindl Harald wrote:
> https://bugs.kde.org/show_bug.cgi?id=270414
> 
> why in the world does nobody care about bugs like
> basic-operations (and rename a file is really one
> since many years) for half a year?
I see lots of comments, so many people care. However there are a lot of 
negative comments, so working on such a bug is pretty disheartening for a 
developer. 

When I read stuff that is nasty, mean or abusive, I often find something else to 
do. Remember that this is a hobby for almost all developers.

Another way to look at this is "why haven't you fixed it in the last six 
months". If you don't know how, why haven't you learned?
Comment 51 Lydia Pintscher 2011-09-21 17:37:00 UTC
And this ends here. I'll ask to have bugzilla access removed for anyone else who feels the need to continue here. We've already had the fun of setting the mailing list on moderation thanks to this.
Comment 52 Reindl Harald 2011-09-21 17:44:47 UTC
well, before i kneel in front of Aaron Seigo it would be time for "Brad Hards" to apologize for his answer to my first mail on teh kde-list ever "why haven't you fixed it in the last six months". If you don't know how, why haven't you learned?"
and the rest of the mailing-list-thread was the direct result of this answer!

so if you think this is how the kde-community  acts with bug-reporters PLEASE delete my account because it is useless, i need no bugtracker-access to let me spit in the face
Comment 53 tony 2011-09-21 22:22:33 UTC
I do not intend to follow the thread, but as Seigo wrote:

>[..] i am glad KDE has so many supportive and constructive users[..]

Since i'm the bug reporter and one of the many "polite" kde users out there, can i kindly ask you, Aaron, to revert your fix back again, please?
I do not think that we all -nor kde- deserve this.

Thanks.
Comment 54 Vamp898 2011-09-22 06:15:19 UTC
I think both sides are right.

Aaron is right that Harald could ask some more... let me say "nice".

But anyway, this bug is opened since KDE 4.3 and it was fixed in less than 24 hours in case that Harald showed his anger.

For sure this is not the right way, but it is sad to see that it works.

It seems like this bug exists since 2 years.

2 Years nothing done and than inside of 24 hours it was fixed.

I can understand Aaron´s anger in every point, but anyway it helped that this bug was fixed in 24 hours after 2 years of waiting.
Comment 55 Sebastian Sauer 2011-09-22 10:01:00 UTC
@Vamp898

Yay. Your comment makes it even worse cause it nails down why Aaron's decision is correct and why we all should support him in this :-/

The problem is that after "Harald showed his anger." we not only got a patch but also lot of side-effects. Kicking contributors in the nuts like that means next time it will take 4 years or longer till its fixed rather then 2.

Remember that the top-priority for most of us is *NOT* to fix bugs but to keep the contributors happy so they continue to contribute also tomorrow.

Just to make this very clear; The patch *IS* in 4.8. What we are discussing here is the decision to not backport to 4.7. You should know that there is a difference cause backporting a patch to a stable branch means that those who contributes the patch and maintains the code-base (both Aaron) needs to spend probably significant more time on making sure there are no new regressions introduced. It is completely up to those who contributed the gift if he/she likes to invest that additional time and likes to take that risk.
Comment 56 Scott Kitterman 2011-09-22 19:10:38 UTC
FYI, I've pulled this patch into the Kubuntu packages for the next release (we wouldn't have had this either way since we're releasing with 4.7.1, so this is not an excuse to start arguing about that - just updated status).
Comment 57 DrHouse 2012-02-02 14:54:00 UTC
I applied these patches to kde-4.7.4 on my Gentoo system, but it's not fixed this bug
Comment 58 Antonio Orefice 2012-02-02 15:15:57 UTC
4.8.0 and it is fixed