Bug 218180 - folderview-panel not correctly refreshed if a folder is renamed from another application
Summary: folderview-panel not correctly refreshed if a folder is renamed from another ...
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 4.3.4
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 202017 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-10 21:41 UTC by H.H.
Modified: 2011-12-21 04:08 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.H. 2009-12-10 21:41:51 UTC
Version:           4.3.4 (KDE 4.3.4) "release 2" (using 4.3.4 (KDE 4.3.4) "release 2", KDE:43 / openSUSE_11.2)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.31.5-0.1-desktop

I browse my external usb-disk on /media/disk/...
I rename a folder there on konsole. konqueror refreshes its main file-view, but the folder-view on the left is not refreshed. after diving into the renamed folder in the main-file-list, it appears additionally(!) on the folder panel. even when clicking on the no-more-existent folder, konqueror displays a message "folder does not exist anymore", but still not removes it from its view.
Comment 1 Dario Andres 2009-12-10 22:01:03 UTC
Probably related to bug 207361. Thanks

*** This bug has been marked as a duplicate of bug 207361 ***
Comment 2 H.H. 2010-01-04 22:54:38 UTC
why does dolphin not have such problems?
Comment 3 Dario Andres 2010-01-04 23:00:21 UTC
Because it implements the file browsing stuff with some small differences. In any case this is fixed in KDE SC 4.4 (for all the applications). Thanks
Comment 4 H.H. 2010-01-17 04:47:44 UTC
I have to reopen this bug, because it is not fixed in konqueror in kde 4.3.90. it is only in konqueror left side folderview, not in dolphin. often folders appear twice, or deleted folders are still displayed.
Comment 5 Jérôme Borme 2010-06-27 13:54:28 UTC
I live with this bug since KDE 4.0 RC and I can tell it is still there as of SC 4.4.4.
Comment 6 Vamp898 2011-04-11 13:57:35 UTC
There seems to be an duplicate in Bug 270414
Comment 7 brice rebsamen 2011-09-13 02:39:19 UTC
I am using KDE 4.6.2 in Natty. If I delete a folder that is in my folder view (by selecting it and pressing DEL), it is effectively deleted, but does not disappear from the view. Attempting to delete again yields an error message saying that it does not exist anymore. Refreshing with F5 removes the folder from the view. Bad!
Comment 8 Dawit Alemayehu 2011-12-20 00:07:27 UTC
Git commit 13c832b06843a30a8d290cde17e960f87b721971 by Dawit Alemayehu.
Committed on 20/12/2011 at 01:05.
Pushed by adawit into branch 'master'.

Call the correct lookupItems function when deleting an item from the directory tree.

BUG: 218180
FIXED-IN: 4.8.0

M  +1    -1    konqueror/sidebar/trees/dirtree_module/dirtree_module.cpp

http://commits.kde.org/kde-baseapps/13c832b06843a30a8d290cde17e960f87b721971
Comment 9 Dawit Alemayehu 2011-12-21 04:08:02 UTC
*** Bug 202017 has been marked as a duplicate of this bug. ***