Bug 222470

Summary: Switch to temporarily disable all notifications ("Do not disturb" mode)
Product: plasmashell Reporter: Tilman Klaeger <kde>
Component: NotificationsAssignee: Kai Uwe Broulik <kde>
Status: RESOLVED FIXED    
Severity: wishlist CC: augustin.trancart, bugseforuns, jarlgjessing, jat255, Karsten.Fleischer, kdelibs-bugs, matejm98mthw, mte90net, nate, nortexoid, plasma-bugs
Priority: NOR Keywords: usability
Version: master   
Target Milestone: 1.0   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In: 5.16.0

Description Tilman Klaeger 2010-01-12 23:40:27 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

Could you make a switch, maybe a global shortcut or something similiar, to shut off all notifications by knotify? Something like a "Do Not Disturb"-Feature? 
Some programs (like Kopete or KMail) do have their own symbol in the tray for important stuff (incoming message, ...). When trying to concentrate on some other jobs, the knotify messages are just a little big and an off-switch would just be awesome.
Comment 1 Daniele Scasciafratte 2018-11-19 10:45:48 UTC
I started a reddit thread about it https://www.reddit.com/r/kde/comments/9xwg84/disable_temporary_notifications_in_kde/
Now I discover that there was already a ticket about it...
Other DE like Gnome have this kind of flag and seems that in KDE the only thing possible is to mute them but this will not block them to appear.
Comment 2 Nate Graham 2018-11-19 14:48:08 UTC
*** Bug 395949 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2018-11-19 14:48:15 UTC
*** Bug 399158 has been marked as a duplicate of this bug. ***
Comment 4 jat255 2019-03-15 18:51:30 UTC
Anyone have an idea on how to go about implementing something like this? Would it need a big change on the notification backend, or is there a flag somewhere that could be changed with a nice little checkbox? As Daniele mentioned, nearly every other DE (windows and mac included) have something like this, and this is a serious usability issue for Plasma.
Comment 5 Karsten.Fleischer 2019-04-15 22:16:33 UTC
I'm not sure if it does exactly what you want in all cases, but there is a button to disable notifications. At least I have one in Opensuse Tumbleweed running plasma 5.14.4. Found it recently when I looked into a related issue of shutting up new mail sounds during presentations. 

To find it: 
1) Left click on the triangle in the systray
2) Right Click on the "Notifications" entry
3) Select "Configure Notifications"

I get a settings window then were I can uncheck "Show application and system notifications". It might not do all you want as some apps start showing there own notification window now, as I assume they check if plasma accepts notification and if not draw them themselves, so it might only be a partial fix.

It didn't help my issue as while it suppressed the notification icon/message it didn't shut up the sound, presumably as that was generated by kmail directly and not affected by the notification settings. 

Arguably it could be easier to find ;-)
Comment 6 Kai Uwe Broulik 2019-05-09 09:33:08 UTC
Git commit 3c52fc3bc05e0f351d4998ad54edae1a4e21a043 by Kai Uwe Broulik.
Committed on 09/05/2019 at 09:29.
Pushed by broulik into branch 'master'.

Merge branch 'broulik/libnotificationmanager'

This includes:
libnotificationmanager https://phabricator.kde.org/D20265
New notification plasmoid: https://phabricator.kde.org/D20266
as well as dataengine compat: https://phabricator.kde.org/D20490 and https://phabricator.kde.org/D20491
Related: bug 402144, bug 405570, bug 391646, bug 401819, bug 400811, bug 392669, bug 390143, bug 390864, bug 374099, bug 360990, bug 346458, bug 398926, bug 390152, bug 342355, bug 402391, bug 399697, bug 400871, bug 398580
FIXED-IN: 5.16.0


https://commits.kde.org/plasma-workspace/3c52fc3bc05e0f351d4998ad54edae1a4e21a043