Bug 398926 - X11 primary selection does not work in plasma notifications
Summary: X11 primary selection does not work in plasma notifications
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Notifications (show other bugs)
Version: 5.13.4
Platform: Fedora RPMs Linux
: NOR normal
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords:
: 401571 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-09-21 17:14 UTC by Alexander Potashev
Modified: 2019-05-09 09:47 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.16.0


Attachments
screenshot (35.29 KB, image/png)
2018-09-21 17:15 UTC, Alexander Potashev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Potashev 2018-09-21 17:14:30 UTC
1. Get a notification in the notifications popup in Plasma tray
2. Select portion of text from the notification
3. Middle click in another window as an attempt to paste the selection

Actual:
A former primary selection is pasted.

Expected:
The selected text from the notifications popup should be pasted.


Also, the notification popup does not support selecting words with double clicks :(
Comment 1 Alexander Potashev 2018-09-21 17:15:48 UTC
Created attachment 115150 [details]
screenshot
Comment 2 Patrick Silva 2018-11-05 19:00:18 UTC
Same thing here.

Operating System: Arch Linux 
KDE Plasma Version: 5.14.2
Qt Version: 5.12.0
KDE Frameworks Version: 5.51.0
Kernel Version: 4.18.16-arch1-1-ARCH
Comment 3 Patrick Silva 2019-01-22 20:20:50 UTC
*** Bug 401571 has been marked as a duplicate of this bug. ***
Comment 4 Kai Uwe Broulik 2019-05-09 09:47:10 UTC
Git commit 3c52fc3bc05e0f351d4998ad54edae1a4e21a043 by Kai Uwe Broulik.
Committed on 09/05/2019 at 09:29.
Pushed by broulik into branch 'master'.

Merge branch 'broulik/libnotificationmanager'

This includes:
libnotificationmanager https://phabricator.kde.org/D20265
New notification plasmoid: https://phabricator.kde.org/D20266
as well as dataengine compat: https://phabricator.kde.org/D20490 and https://phabricator.kde.org/D20491
Related: bug 222470, bug 402144, bug 405570, bug 391646, bug 401819, bug 400811, bug 392669, bug 390143, bug 390864, bug 374099, bug 360990, bug 346458, bug 390152, bug 342355, bug 402391, bug 399697, bug 400871, bug 398580
FIXED-IN: 5.16.0


https://commits.kde.org/plasma-workspace/3c52fc3bc05e0f351d4998ad54edae1a4e21a043