Bug 399697 - Progress notification is misleading
Summary: Progress notification is misleading
Status: RESOLVED DUPLICATE of bug 394165
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Notifications (show other bugs)
Version: 5.14.0
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-12 09:23 UTC by Christian Muehlhaeuser
Modified: 2019-05-09 09:47 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Muehlhaeuser 2018-10-12 09:23:18 UTC
While copying/moving files, the progress circle in the system tray is slightly misleading:

During the transfer, the circle gets a visual filling, not unlike a regular progress bar does. However, it's not actually starting to fill up visually, until about 15% of the transfer has already been finished. Similarly, it looks to be completely full when the transfer has only reached about 85%.
Comment 1 Kai Uwe Broulik 2018-10-12 09:24:24 UTC
I wish we could get the pie-style filling back we had in Plasma 4.
Comment 2 avlas 2018-11-20 15:21:17 UTC
> I wish we could get the pie-style filling back we had in Plasma 4.

I was about to report this issue myself. Filling should be angular (clockwise) rather than longitudinal (left to right, which does not work at all for circles). I guess this is what you meant about pie-style, isn't it?

Is this difficult to implement because of a technical issue of some sort?

Alternatively for a change, why not to make the notification a square instead of a circle?
Comment 3 Kai Uwe Broulik 2019-03-31 10:19:16 UTC

*** This bug has been marked as a duplicate of bug 394165 ***
Comment 4 Kai Uwe Broulik 2019-05-09 09:47:07 UTC
Git commit 3c52fc3bc05e0f351d4998ad54edae1a4e21a043 by Kai Uwe Broulik.
Committed on 09/05/2019 at 09:29.
Pushed by broulik into branch 'master'.

Merge branch 'broulik/libnotificationmanager'

This includes:
libnotificationmanager https://phabricator.kde.org/D20265
New notification plasmoid: https://phabricator.kde.org/D20266
as well as dataengine compat: https://phabricator.kde.org/D20490 and https://phabricator.kde.org/D20491
Related: bug 222470, bug 402144, bug 405570, bug 391646, bug 401819, bug 400811, bug 392669, bug 390143, bug 390864, bug 374099, bug 360990, bug 346458, bug 398926, bug 390152, bug 342355, bug 402391, bug 400871, bug 398580
FIXED-IN: 5.16.0


https://commits.kde.org/plasma-workspace/3c52fc3bc05e0f351d4998ad54edae1a4e21a043