Bug 390143 - Persistent notification popups time out
Summary: Persistent notification popups time out
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Notifications (show other bugs)
Version: 5.12.0
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords:
: 392786 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-09 12:23 UTC by Fabian Vogt
Modified: 2019-05-09 13:21 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.16.0
kde: Usability?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Vogt 2018-02-09 12:23:58 UTC
Persistent notifications exist for one reason: Get noticed by the user.

As even persistent notifications' popups time out, this is not guaranteed anymore. For instance, the updater applet shows a notification which asks the user to log out/reboot the system.
Now this gets hidden in the tray next to the "Updates installed" notification, where it is very easy to be missed.
Comment 1 Kai Uwe Broulik 2018-02-09 12:25:55 UTC
This was done on purpose back in the days but I agree that persistent notifications should keep their popup on screen until the user dismisses them. It often happened to me with e.g. PIN prompt or Bluetooth pairing request that the notification disappeared in the history even though the pairing process was still active and waiting for my confirmation. Usability, what do you think?
Comment 2 David Edmundson 2018-02-09 12:26:19 UTC
The balance we have to deal with is that some apps (kdeconnect for example) randomly set persistent notifications on everything.

If they stayed open forever it would be really annoying
Comment 3 Fabian Vogt 2018-02-09 12:31:43 UTC
(In reply to David Edmundson from comment #2)
> The balance we have to deal with is that some apps (kdeconnect for example)
> randomly set persistent notifications on everything.

That's something that needs to be fixed in kdeconnect then.
While it's important that plasma doesn't break existing applications, this must only be done when it's reasonable to. Not providing the option for persistent popups at all is IMO not a good option.
Comment 4 David Edmundson 2018-02-09 13:45:52 UTC
That was one example, we can't control every app.
Comment 5 Kai Uwe Broulik 2019-03-31 10:23:59 UTC
*** Bug 392786 has been marked as a duplicate of this bug. ***
Comment 6 Kai Uwe Broulik 2019-05-09 09:33:07 UTC
Git commit 3c52fc3bc05e0f351d4998ad54edae1a4e21a043 by Kai Uwe Broulik.
Committed on 09/05/2019 at 09:29.
Pushed by broulik into branch 'master'.

Merge branch 'broulik/libnotificationmanager'

This includes:
libnotificationmanager https://phabricator.kde.org/D20265
New notification plasmoid: https://phabricator.kde.org/D20266
as well as dataengine compat: https://phabricator.kde.org/D20490 and https://phabricator.kde.org/D20491
Related: bug 222470, bug 402144, bug 405570, bug 391646, bug 401819, bug 400811, bug 392669, bug 390864, bug 374099, bug 360990, bug 346458, bug 398926, bug 390152, bug 342355, bug 402391, bug 399697, bug 400871, bug 398580
FIXED-IN: 5.16.0


https://commits.kde.org/plasma-workspace/3c52fc3bc05e0f351d4998ad54edae1a4e21a043